SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-29-2008, 01:55 AM
Xytrix Xytrix is offline
New Member
 
Join Date: Nov 2008
Posts: 2
Question service only accepting connections from localhost?

Hi,

I recently installed the 6.4.8 trial of SageTV Media Center on this PC, and 6.4.8 trial of SageTV Client on my laptop. The two computers are within the same local network and I've disabled the firewall for now, but I'm having problems getting the SageTV service to accept connections from the laptop. If I disable the service and just run SageTV.exe, then the laptop can connect just fine.

So far I've kept the "SageTV Server" option set to Enabled in the 'Detail Setup' menu and I've tried switching the service's user from LocalSystem to an administrator to no avail. If I start the service while SageTV.exe is closed, I can see that it is listening on ports 7818, 31099, and 42024. If I telnet to 42024 from the local machine, it'll connect, but from the laptop it won't respond. I can see on this machine that the laptop's connection request packets are coming through though.

The service will handle scheduled recordings in the background, so it seems to be working fine otherwise. Could there be something I missed in the setup?
Reply With Quote
  #2  
Old 11-29-2008, 10:53 AM
Xytrix Xytrix is offline
New Member
 
Join Date: Nov 2008
Posts: 2
Red face

Hmm, well boy is my face red. I disabled my personal firewall, but since this is a new server, forgot about the default Windows firewall. Looks like SageTV creates itself an exception in the Windows firewall exception list, but not for the service.

Hope no one wasted time on this one :x
Reply With Quote
Reply

Tags
client, connections, firewall, server, service


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching to service mode question Beefcake550 SageTV Software 1 11-24-2008 11:01 PM
Moving from Sage Client to Sage Service DSSavant SageTV Software 1 09-20-2008 04:49 PM
Service Mode under Vista 64 GStiles SageTV Software 4 12-19-2007 01:06 PM
Sage Server as a service in Win2003 drive mapping eguy SageTV Software 9 07-27-2007 01:10 PM
Service mode help needed please kkeller20 SageTV Software 2 01-20-2006 02:43 PM


All times are GMT -6. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.