SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Media Extender

Notices

SageTV Media Extender Discussion related to any SageTV Media Extender used directly by SageTV. Questions, issues, problems, suggestions, etc. relating to a SageTV supported media extender should be posted here. Use the SageTV HD Theater - Media Player forum for issues related to using an HD Theater while not connected to a SageTV server.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-11-2021, 01:29 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Crash goes the extender(s)

I probably should bring this up to Schedules Direct, but I'm having an issue with a specific program in the EPG which crashes multiple extenders in my home and also whenever one of my extenders accesses one of 2 different servers and tries to do anything with this EPG entry.

This Friday at 9pm (Eastern) a new show "Game of Talents" airs on Fox. Whenever I try to do anything at all with this listing, i.e. mark it as don't like, try to see future airings, call up the description, etc. It will lock up the extender which will shut off after a few seconds. Turn the extender back on via the power button on the remote and everything is find again unless I try to do anything with that specific EPG listing.
The exact same thing happened with this show last week(Premier episode), but at the time I just chalked it up to possibly a corrupt EPG entry.

Can someone access this entry and see if the same thing is happening to them? Maybe it is just my specific lineup. (I have both an Xfinity and OTA lineup for this channel)
__________________
Wayne Dunham
Reply With Quote
  #2  
Old 03-11-2021, 01:49 PM
KeithAbbott KeithAbbott is online now
Sage Icon
 
Join Date: Oct 2009
Location: Southeastern Michigan
Posts: 1,220
Same behavior on an HD300. Although my airing is showing on Saturday evening, not Friday evening.
__________________
Server: MSI Z270 SLI Plus ATX Motherboard, Intel i7-7700T CPU, 32GB Memory, unRAID 6.9.2, SageTV (java11) & OpenDCT Dockers
Tuners: 2 x SiliconDust HDHomeRun Prime Cable TV Tuners, SiliconDust HDHomeRun CONNECT 4K OTA Tuner
Clients: Multiple HD300 Extenders, Multiple Fire TV Stick 4K w/MiniClient
Miscellaneous: Multiple Sony RM-VLZ620 Universal Remote Controls
Reply With Quote
  #3  
Old 03-11-2021, 02:54 PM
wayner wayner is online now
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 7,199
I wonder if there are some weird characters in the description.

I am checking this out, first in Placeshifter. For me it shows up as Saturday at 9pm on Fox from Buffalo as well and I can click on the name to see the program details. So it works ok in Placeshifter. When I try it on the extender I get a crash. Nothing looks too weird in the description on the Placeshifter. I wonder if there are some invisible characters causing the crash?
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #4  
Old 03-11-2021, 04:50 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Post the log file after you crash it. There's likely an exception there.
__________________
Windows Installer
Reply With Quote
  #5  
Old 03-11-2021, 06:41 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wnjj View Post
Post the log file after you crash it. There's likely an exception there.
My error, yes it was Saturday and not Friday.

What and where might this log file be? I looked in the clients folder where the extender info is and no log files there.

In the SageTV folder I see the regular SageTV log files and SageTVclient log files, but all the client log files have dates from well over 6 months ago.

Just to note for clarity, it isn't crashing SageTV itself, just the extender. SageTV is happily chugging along while the extender is crashed. During one of these incidents of crashing the extender SageTV was recording something and there were no gaps or glitches in the recording.
__________________
Wayne Dunham

Last edited by waynedunham; 03-11-2021 at 06:54 PM.
Reply With Quote
  #6  
Old 03-11-2021, 08:12 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
There may still be an indication of what was being processed in the main sagetv_0.txt log file. The extenders run their own software but all of the UI and command processing is on the server.
__________________
Windows Installer
Reply With Quote
  #7  
Old 03-14-2021, 07:09 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wnjj View Post
There may still be an indication of what was being processed in the main sagetv_0.txt log file. The extenders run their own software but all of the UI and command processing is on the server.
I'll give it a go tomorrow and see if anything pops up in the sagetv0.txt file.(on a fresh restart so the file won't be so massive)
__________________
Wayne Dunham
Reply With Quote
  #8  
Old 03-15-2021, 12:46 AM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Quote:
Originally Posted by waynedunham View Post
I'll give it a go tomorrow and see if anything pops up in the sagetv0.txt file.(on a fresh restart so the file won't be so massive)
You can always prune it down to around the relevant times.
__________________
Windows Installer
Reply With Quote
  #9  
Old 03-15-2021, 08:59 AM
wayner wayner is online now
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 7,199
I tried this again and have collected the log. Hopefully I have the relevant piece of the log. This may be related to rendering an image.

FYI the extender that crashed in this instance is context/MAC 0023a5000654.
Attached Files
File Type: zip extender_crash.zip (6.3 KB, 61 views)
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #10  
Old 03-15-2021, 09:16 AM
wayner wayner is online now
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 7,199
I have had other issues in the past with images causing SageTV to crash in the past, that is why I am suspecting that this may be an issue here.
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #11  
Old 03-15-2021, 12:05 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wayner View Post
I have had other issues in the past with images causing SageTV to crash in the past, that is why I am suspecting that this may be an issue here.
I too have had issues like this before. One I specifically recall was with the logo for the Centric channel when it first came out. Whenever I was looking through the EPG and that channel happened upon the screen it would lock up. Can't recall now whether it was SageTV itself, or just the extender.

At that time my solution was to copy a working station logo and put it in place of the "real" Centric logo.
__________________
Wayne Dunham
Reply With Quote
  #12  
Old 03-15-2021, 12:10 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wayner View Post
I tried this again and have collected the log. Hopefully I have the relevant piece of the log. This may be related to rendering an image.

FYI the extender that crashed in this instance is context/MAC 0023a5000654.
And here's mine just captured this afternoon. I grabbed this right after restarting SageTV as soon as the extender could see SageTV.
Attached Files
File Type: zip Extender Crash.zip (104.9 KB, 68 views)
__________________
Wayne Dunham
Reply With Quote
  #13  
Old 03-15-2021, 05:18 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Try setting ui/disable_native_image_loader=true in sage.properties. The last thing in your log file before the crash is gated by that option. I'm not totally sure of the conquence of turning off the native image loader, likely performance but you can try it and see if the crash persists. That would provide some insight.
__________________
Windows Installer
Reply With Quote
  #14  
Old 03-17-2021, 05:39 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wnjj View Post
Try setting ui/disable_native_image_loader=true in sage.properties. The last thing in your log file before the crash is gated by that option. I'm not totally sure of the conquence of turning off the native image loader, likely performance but you can try it and see if the crash persists. That would provide some insight.
Nope. Checked and it crashed, changed that setting in sage.properties and restarted SageTV. Still crashes the extender.
__________________
Wayne Dunham
Reply With Quote
  #15  
Old 03-22-2021, 12:45 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Found another one just now.

I was going through custom menus/premieres..... and came upon the show "Elliot From Earth" on Toon 3/29 9am. Just moving the cursor to that program for more than a split second had the same effect as the program noted previously. I repeated it a couple times just to make sure it was indeed that program.

Oh, and as I was scrolling through I also came upon the next airing of "Game of Talents" the one we first discovered this issue on, and it is still locking up the extender.

It has to be something in the data and/or the show graphic for these two (at least) shows that is causing the issue. Hopefully as we find more shows with this issue we can discover the reason and include a fix in future releases of SageTV.
Although, since it is locking up the extender and ot SageTV itself I wonder if the issue might be in the HD300 firmware.
__________________
Wayne Dunham
Reply With Quote
  #16  
Old 03-22-2021, 01:12 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Quote:
Originally Posted by waynedunham View Post
Found another one just now.

I was going through custom menus/premieres..... and came upon the show "Elliot From Earth" on Toon 3/29 9am. Just moving the cursor to that program for more than a split second had the same effect as the program noted previously. I repeated it a couple times just to make sure it was indeed that program.

Oh, and as I was scrolling through I also came upon the next airing of "Game of Talents" the one we first discovered this issue on, and it is still locking up the extender.

It has to be something in the data and/or the show graphic for these two (at least) shows that is causing the issue. Hopefully as we find more shows with this issue we can discover the reason and include a fix in future releases of SageTV.
Although, since it is locking up the extender and ot SageTV itself I wonder if the issue might be in the HD300 firmware.
It's likely in the extender but if we could figure out what is causing it, the server could potentially reconvert or skip sending whatever is crashing it.
__________________
Windows Installer
Reply With Quote
  #17  
Old 03-22-2021, 01:13 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Do the extenders keep log files or at least crash dumps on them?

EDIT: It looks like there is a 'messages' log file that the extender creates: https://forms.sagetv.com/forums/showthread.php?p=375671

Crash the extender and then grab that message file.
__________________
Windows Installer

Last edited by wnjj; 03-22-2021 at 01:29 PM.
Reply With Quote
  #18  
Old 03-24-2021, 09:04 AM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wnjj View Post
Do the extenders keep log files or at least crash dumps on them?

EDIT: It looks like there is a 'messages' log file that the extender creates: https://forms.sagetv.com/forums/showthread.php?p=375671

Crash the extender and then grab that message file.
I'll take those steps as soon as I have a chance.
__________________
Wayne Dunham
Reply With Quote
  #19  
Old 03-25-2021, 06:18 AM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,460
Quote:
Originally Posted by wnjj View Post
Do the extenders keep log files or at least crash dumps on them?

EDIT: It looks like there is a 'messages' log file that the extender creates: https://forms.sagetv.com/forums/showthread.php?p=375671

Crash the extender and then grab that message file.
I'm not having any luck. None of my computers (mix of Win8 and Win10 all on wired network) can see either of my extenders even though I have file sharing and debug logging turned on in the extenders.

EDIT: Oh, and discovery is turned on in the network setting for all of the PCs. No difference.
__________________
Wayne Dunham
Reply With Quote
  #20  
Old 03-25-2021, 11:00 AM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,442
Quote:
Originally Posted by waynedunham View Post
I'm not having any luck. None of my computers (mix of Win8 and Win10 all on wired network) can see either of my extenders even though I have file sharing and debug logging turned on in the extenders.

EDIT: Oh, and discovery is turned on in the network setting for all of the PCs. No difference.
Do they respond to ping? Are you trying to use telnet in the command prompt? Are you sure you have the right IP address? I confirm by looking in the sagetv_0.txt file after using the extender. You can find a line in there with the IP of the server and the client.
__________________
Windows Installer
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VFS Crash Course wrems Phoenix 2 06-21-2011 03:30 PM
Crash. keodark SageTV Software 2 04-03-2009 10:56 AM
MVP UI Crash mayamaniac SageTV Media Extender 0 03-02-2007 08:57 AM
HDD Crash!! kayoti General Discussion 3 05-24-2005 08:03 AM
PVR 350 MP3 crash Crowdx42 SageTV Beta Test Software 2 04-30-2004 10:10 PM


All times are GMT -6. The time now is 08:47 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.