SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-09-2021, 07:16 PM
jt4242 jt4242 is offline
Sage Advanced User
 
Join Date: Dec 2009
Location: Montreal, Canada
Posts: 178
IMDB read failed

I just started having problems looking things up in IMDB. I get the list of titles but when I try to open one, I get the following error:

IMDB read failed:
reading Title:All Rise(2019) (TV Series)
net.sf.sageplugins.sageimdb.DbFailureException: Failed to find content in Title reference Page https://www.imdb.com/title/tt10183798/reference
at: net.sf.sageplugins.sageimdb.ImdbWebGetTitle.get:492


Is anyone else having problems?
Reply With Quote
  #2  
Old 03-09-2021, 09:26 PM
Striker:WG Striker:WG is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 398
I can confirm that I am getting the same error
Reply With Quote
  #3  
Old 03-10-2021, 07:40 AM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,965
Quote:
Originally Posted by Striker:WG View Post
I can confirm that I am getting the same error
+1, I noticed it stopped working yesterday.
__________________
Server: Ryzen 2400G with integrated graphics, ASRock X470 Taichi Motherboard, HDMI output to Vizio 1080p LCD, Win10-64Bit (Professional), 16GB RAM
Capture Devices (7 tuners): Colossus (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast/Xfinity X1 Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250, HD-PVR
Reply With Quote
  #4  
Old 03-10-2021, 08:47 AM
jt4242 jt4242 is offline
Sage Advanced User
 
Join Date: Dec 2009
Location: Montreal, Canada
Posts: 178
Quote:
Originally Posted by Tiki View Post
+1, I noticed it stopped working yesterday.
I wonder if it is a temporary hiccup? I use it all the time to fill in missing metadata and just to satisfy my curiosity during a show when I see someone and know I've seen them before but can't remember when and in what - so handy!

I've PMed JREkiwi who fixed the plugin in 2019 to see if he can suss out what has gone wrong but I don't know if he is still active.
Reply With Quote
  #5  
Old 03-10-2021, 04:45 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,448
+1 here as well. As Tiki mentioned, it stopped working yesterday.
I use it quite often as well. "where have I seen that actor/actress before?" Is usually my reason for the query.
__________________
Wayne Dunham
Reply With Quote
  #6  
Old 03-10-2021, 04:56 PM
jt4242 jt4242 is offline
Sage Advanced User
 
Join Date: Dec 2009
Location: Montreal, Canada
Posts: 178
Quote:
Originally Posted by waynedunham View Post
+1 here as well. As Tiki mentioned, it stopped working yesterday.
I use it quite often as well. "where have I seen that actor/actress before?" Is usually my reason for the query.
exactly! I'd really miss having that.
Reply With Quote
  #7  
Old 03-11-2021, 01:35 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,448
Quote:
Originally Posted by jt4242 View Post
exactly! I'd really miss having that.
I'd suspect that IMDB changed something in either the way information is requested, or how or the content of what is delivered causing the plugin to fail. That has happened multiple times in the past, but back then all the plugin developers were still around and quick to fix the issue.

Sadly I think we're circling ever closer to the drain.
__________________
Wayne Dunham
Reply With Quote
  #8  
Old 03-11-2021, 09:55 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,115
Quote:
Originally Posted by jt4242 View Post
I've PMed JREkiwi who fixed the plugin in 2019 to see if he can suss out what has gone wrong but I don't know if he is still active.
Not sure if I could every be described as active

I'll have a look over the weekend

John
Reply With Quote
  #9  
Old 03-12-2021, 12:34 AM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,115
A quick mod to get it back to it's previous broken state (No Backstage Info)

Unzip this file
Shut down SageTV and replace the JARS\nielm_sageimdb.jar with this one

John

Last edited by JREkiwi; 03-12-2021 at 06:04 PM. Reason: Removed outdated file
Reply With Quote
  #10  
Old 03-12-2021, 06:08 AM
jt4242 jt4242 is offline
Sage Advanced User
 
Join Date: Dec 2009
Location: Montreal, Canada
Posts: 178
Quote:
Originally Posted by JREkiwi View Post
A quick mod to get it back to it's previous broken state (No Backstage Info)

Unzip this file
Shut down SageTV and replace the JARS\nielm_sageimdb.jar with this one

John
It works!!! Thank you SO much.
Reply With Quote
  #11  
Old 03-12-2021, 12:15 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,448
Downloaded the file and heading over to the SageServer machine to install it.

Thanks so much for fixing this!!

Now, who do we message to get the web and mobile web interface fixed to work with Java 8? Some features are broken under Java 8. Yeah, I know, give them and inch....
__________________
Wayne Dunham
Reply With Quote
  #12  
Old 03-12-2021, 01:17 PM
egeller egeller is offline
Sage Aficionado
 
Join Date: Feb 2006
Location: Drexel Hill, PA
Posts: 275
A note on the JAR file. Don't forget to install it on Windows Clients as well as the server, if you have both.

Quote:
Originally Posted by waynedunham View Post
Now, who do we message to get the web and mobile web interface fixed to work with Java 8? Some features are broken under Java 8. Yeah, I know, give them and inch....
Web interface has a pretty easy workaround. I do not use the mobile, but maybe someone can figure it out based on what I have here.

To get the Web Interface running, easily, with Java 8:
  • Create folder ../sagetv/server/jetty/static/
  • In that folder, populate it with, at least, 1 file, named index.html. In its simplest form, it only needs to contain the links you want to access.
  • Access your server with the URL http://yourserver_name_or_ip:8080/. Jetty defaults to the web page named index.html.

A sample index.html is attached. Link references are relative, not absolute, so it won't work until it's installed.

Feel free to correct / change it. You can make it whatever you want and add links to it. The attached version is edited and mine contains a dozen or so links to various things I have on my network.
Attached Files
File Type: zip index.zip (552 Bytes, 30 views)
__________________
Server:UnRaid;2x Intel Xeon E5; SuperMicro moboard;Also:BM3000 w/ WMC; 2x Ceton ETH 6; OpenDCT
SageTV Extender:3x HD200 1x HD300
Sage TV: 9.2.1, Standard STVi, Comskip Playback, Web Interface, 24 Hour Clock, SRE, YouTube2015, Playon
All in lovely Drexel Hill, PA
Reply With Quote
  #13  
Old 03-12-2021, 06:12 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,115
I've added the latest file which also fixes the backstage issue to the V9 repository so should prompt for a CMT update that will also update this JAR. The V7 repository no longer allows submissions, so I've added the latest JAR here if for some obscure reason anyone is still running V7. (Upgrade to V9 )

Manual process for V7
Unzip this file
Shut down SageTV and replace the JARS\nielm_sageimdb.jar with this one.
If you are running SageTV Clients, you will also need to replace this file on them too.

John
Attached Files
File Type: zip nielm_sageimdb.zip (57.3 KB, 38 views)
Reply With Quote
  #14  
Old 03-13-2021, 07:32 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
How long does it usually take the plugin manager to prompt for an update?
Reply With Quote
  #15  
Old 03-13-2021, 07:51 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,115
It's usually within a day, but it still hasn't been merged. It's a automated process and I'm not even sure who's looking after it now.

John
Reply With Quote
  #16  
Old 03-13-2021, 08:59 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
I'm too impatient so I just manually replaced the JAR instead. Works great again!

Apart from Comskip, I think I use this plugin more than any other SageTV plugin.

Thanks for keeping it working for us
Reply With Quote
  #17  
Old 03-14-2021, 01:47 AM
elcid elcid is offline
Sage User
 
Join Date: Mar 2021
Posts: 7
Quote:
Originally Posted by JREkiwi View Post
A quick mod to get it back to it's previous broken state (No Backstage Info)

Unzip this file
Shut down SageTV and replace the JARS\nielm_sageimdb.jar with this one

John
Hi.

Where is this file?

Thanks
Reply With Quote
  #18  
Old 03-14-2021, 07:06 AM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,200
Quote:
Originally Posted by JREkiwi View Post
It's usually within a day, but it still hasn't been merged. It's a automated process and I'm not even sure who's looking after it now.

John
It seems nobody is looking after it now but I saw the request and merged it. We may need a volunteer to do these merges in the future
Reply With Quote
  #19  
Old 03-14-2021, 06:44 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,448
Quote:
Originally Posted by JREkiwi View Post
It's usually within a day, but it still hasn't been merged. It's a automated process and I'm not even sure who's looking after it now.

John
As of Sunday 3/14 late afternoon at least the updates are in the repository and show as updates for the related plugins. At least that's when they showed up in my "Setup/System Messages" area of the main menu.
__________________
Wayne Dunham
Reply With Quote
  #20  
Old 03-14-2021, 07:06 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,448
Quote:
Originally Posted by egeller View Post
A note on the JAR file. Don't forget to install it on Windows Clients as well as the server, if you have both.



Web interface has a pretty easy workaround. I do not use the mobile, but maybe someone can figure it out based on what I have here.

To get the Web Interface running, easily, with Java 8:
  • Create folder ../sagetv/server/jetty/static/
  • In that folder, populate it with, at least, 1 file, named index.html. In its simplest form, it only needs to contain the links you want to access.
  • Access your server with the URL http://yourserver_name_or_ip:8080/. Jetty defaults to the web page named index.html.

A sample index.html is attached. Link references are relative, not absolute, so it won't work until it's installed.

Feel free to correct / change it. You can make it whatever you want and add links to it. The attached version is edited and mine contains a dozen or so links to various things I have on my network.
Getting access to the original webserver and mobile webserver aren't really the issue for me. I have the links for them saved in my bookmarks. I can access them locally or on the road using my DynDNS connection.

I don't want to hijack this thread, but wanted to say that at least for me the old webserver works for searching the EPG, but doesn't work 100% when searching Recordings since going to Java 8. The newer mobile webserver tosses up an Error message "Error
Message: PWC6033: Unable to compile class for JSP PWC6199: Generated servlet error: The import java.util.Arrays cannot be resolved PWC6197:
An error occurred at line: 14 in the jsp file: /WEB-INF/tags/sage/functions/collections/ArrayToList.tag PWC6199: Generated servlet error: Arrays
cannot be resolved"

It throws up that same error message whether trying to Searh EPG or Search Recordings. This only happened after moving to Java 8.
Odd that the Search EPG works fine in the much older original webserver, but not in the newer Mobile Webserver.
In the original Webserver searching recordings gets some mixed results. It hs trouble finding current recordings, but seems to see past and future airings just fine.
__________________
Wayne Dunham
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Metadata Failed (Code 10100) IMDB: Failed to parse providerDataUrl: mkanet Batch Metadata Tools 2 10-12-2010 03:22 PM
BMT: Read this if you don't see any BMT topics Opus4 SageTV Customizations 0 04-25-2010 09:17 PM
Failed IMDB search spook SageMC Custom Interface 12 12-04-2008 02:51 PM
forum posts not marked read when read? xlr8shun The SageTV Community 2 05-04-2004 01:49 AM


All times are GMT -6. The time now is 04:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.