SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Clients Development

Notices

SageTV Clients Development This forum is for discussions relating to SageTV Open Source Clients Development.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-04-2016, 07:48 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Android MiniClient - ExoPlayer

Some time ago, I updated to ExoPlayer 2x. I don't use ExoPlayer myself, because it requires 100% hardware decoding for audio and video formats, and it uses audio passthrough (and I can't see a way to turn it off). Audio pass-through is great if your TV can decode ac3 or if you are going through a receiver that decodes it, but otherwise, you get video without audio.

ExoPlayer 2x introduced "extensions" and one of the extensions was ffmpeg extension for audio. So I build ExoPlayer with the ffmpeg extension (enabling ac3) and now I get audio/video using ExoPlayer.

The problem of course, is that this likely disables audio-passthrough, so I won't be releasing it until I can figure out a solution to enable both (via configuration most likely).

I haven't spent much time with ExoPlayer, but, now that I can use it more reliably, I'll start using it, and see what other issues I encounter.
Reply With Quote
  #2  
Old 12-04-2016, 12:18 PM
cculpepp cculpepp is offline
Sage User
 
Join Date: Mar 2016
Location: GA
Posts: 24
I'm new to all of this so this may have already been discussed, but the problem that I'm having with mini-client using Exoplayer on the Sheild is that live tv is very choppy and stuttery. Local files (mostly in mkv form) play fine, live tv is the issue. Does Exoplayer have a problem with mpeg2 or is it something else causing this problem on the Nvidia Shield. Everything plays fine with the default (ijk) player with no pass through (obviously).
Reply With Quote
  #3  
Old 12-04-2016, 12:33 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by cculpepp View Post
I'm new to all of this so this may have already been discussed, but the problem that I'm having with mini-client using Exoplayer on the Sheild is that live tv is very choppy and stuttery. Local files (mostly in mkv form) play fine, live tv is the issue. Does Exoplayer have a problem with mpeg2 or is it something else causing this problem on the Nvidia Shield. Everything plays fine with the default (ijk) player with no pass through (obviously).
I don't really have any mpeg2 content (other than for testing)... but I haven't noticed any issues myself. Both ExoPlayer and IJKPlayer would use the hardware decoding for mpeg2... the difference is that with IJKPlayer it will software decode the audio if it's ac3. So maybe it's the audio that is causing the issue with ExoPlayer.
Reply With Quote
  #4  
Old 12-04-2016, 01:16 PM
cculpepp cculpepp is offline
Sage User
 
Join Date: Mar 2016
Location: GA
Posts: 24
Quote:
Originally Posted by stuckless View Post
I don't really have any mpeg2 content (other than for testing)... but I haven't noticed any issues myself. Both ExoPlayer and IJKPlayer would use the hardware decoding for mpeg2... the difference is that with IJKPlayer it will software decode the audio if it's ac3. So maybe it's the audio that is causing the issue with ExoPlayer.
My Shield is connected to an Onkyo TXNR-616 via HDMI. Hmmm.....probably is something with the audio. I'm using the HDHomerun Connect as my tuner, and when I watch live tv on the Shield with the Live Channels or the HDHomerun View apps, ac3 passes through without issue. I wonder why it's choking on the mini-client with Exoplayer.
Reply With Quote
  #5  
Old 12-04-2016, 01:38 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by cculpepp View Post
My Shield is connected to an Onkyo TXNR-616 via HDMI. Hmmm.....probably is something with the audio. I'm using the HDHomerun Connect as my tuner, and when I watch live tv on the Shield with the Live Channels or the HDHomerun View apps, ac3 passes through without issue. I wonder why it's choking on the mini-client with Exoplayer.
You can probably test that theory with the next MiniClient update (updated today)... There is a configuration setting to disable audio-passthrough. Try disabling it, and seeing if you still have stuttering issues.

I did look on the ExoPlayer issue list to see if there were issues related to mpeg2 playback... There has been some stuttering issues reported... but none are open (ie, they are all hardware specific or fixed).
Reply With Quote
  #6  
Old 12-04-2016, 02:02 PM
cculpepp cculpepp is offline
Sage User
 
Join Date: Mar 2016
Location: GA
Posts: 24
Quote:
Originally Posted by stuckless View Post
You can probably test that theory with the next MiniClient update (updated today)... There is a configuration setting to disable audio-passthrough. Try disabling it, and seeing if you still have stuttering issues.

I did look on the ExoPlayer issue list to see if there were issues related to mpeg2 playback... There has been some stuttering issues reported... but none are open (ie, they are all hardware specific or fixed).
Ok. I updated to today's version of the mini-client. I enabled Exoplayer and disabled audio pass-through. Same results....very choppy video and no sound.
Reply With Quote
  #7  
Old 12-04-2016, 02:11 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by cculpepp View Post
Ok. I updated to today's version of the mini-client. I enabled Exoplayer and disabled audio pass-through. Same results....very choppy video and no sound.
At least you know it has nothing to do with Audio... It may be something in the mpeg2 stream that ExoPlayer is having issues with.
Reply With Quote
  #8  
Old 12-04-2016, 04:37 PM
panteragstk's Avatar
panteragstk panteragstk is offline
SageTVaholic
 
Join Date: Oct 2008
Location: New Braunfels, TX
Posts: 3,311
Quote:
Originally Posted by stuckless View Post
At least you know it has nothing to do with Audio... It may be something in the mpeg2 stream that ExoPlayer is having issues with.
I would say it is an issue with mpeg2 and exoplayer. Everything else plays fine, but as soon as I try to play an mpeg2 file (HDHR) it fails to play properly.
__________________
SageTV Server: unRAID Docker v9, S2600CPJ, Norco 24 hot swap bay case, 2x Xeon 2670, 64 GB DDR3, 3x Colossus for DirecTV, HDHR for OTA
Living room: nVidia Shield TV, Sage Mini Client, 65" Panasonic VT60
Bedroom: Xiomi Mi Box, Sage Mini Client, 42" Panasonic PZ800u
Theater: nVidia Shield TV, mini client, Plex for movies, 120" screen. Mitsubishi HC4000. Denon X4300H. 7.4.4 speaker setup.
Reply With Quote
  #9  
Old 12-05-2016, 01:36 AM
mlcarson mlcarson is offline
Sage Advanced User
 
Join Date: Aug 2016
Location: Lompoc, CA
Posts: 79
The new version is working great with Exoplayer on my Nvidia Shield and Comcast MPEG2 channels. Is there any advantage in using Exoplayer over ijkplayer?
Reply With Quote
  #10  
Old 12-05-2016, 05:34 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,508
Audio passthrough appears to be the only big one that comes to mind. Also it's nice to have options; which is another reason why ExoPlayer is there.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #11  
Old 12-05-2016, 06:45 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by mlcarson View Post
The new version is working great with Exoplayer on my Nvidia Shield and Comcast MPEG2 channels. Is there any advantage in using Exoplayer over ijkplayer?
Quote:
Originally Posted by EnterNoEscape View Post
Audio passthrough appears to be the only big one that comes to mind. Also it's nice to have options; which is another reason why ExoPlayer is there.
Initially I chose IJKPlayer because it's a ffmpeg based player and it could software decode formats if the hardware didn't have hardware decoders (more useful on a phone/tablet, since those generally are lacking on the hardware decoding side).

Narflex later suggested that I look at ExoPlayer, and so I did. Initially it didn't support mpeg2-ps, so Narflex added that to ExoPlayer... but I also would run into some issues on some files, and so I tended to stick with IJKPlayer. I the 2.xx release of ExoPlayer is pretty stable, and as of the release I did on on the weekend, I'm going to try to use ExoPlayer as the default player (in my setup), to see other issues I encounter. I've watched about 10 shows with it so far, and I haven't found any issues, yet.

ExoPlayer is a pure java player with no native parts (makes it easy to build and work with). The exception is that with the release I did on the weekend, it can use ffmpeg to software decode ac3 audio if you don't have an audio-passthrough setup (which I don't).
Reply With Quote
  #12  
Old 12-05-2016, 08:45 AM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
i know so little, but barely reading the forums

is there a chance using dcadec in ffmpeg would allow dts decoding as well as ac3?
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders
Reply With Quote
  #13  
Old 12-05-2016, 08:55 AM
cncb cncb is offline
Sage Icon
 
Join Date: Jul 2006
Posts: 1,240
I just tried the new version using ExoPlayer with my MPEG-2 recordings on my Shield TV and unfortunately it still has a lot of problems. With my Sage recordings, it seems to stick on the first frame of video and not play at all or in a strange fast-forward fashion. It plays .ts recordings from another program OK but skipping around is still an issue where the timeline jumps to the end of the recording unexpectedly (even though this was fixed in Plex with the last firmware update). I might be able to upload some samples if you have any time or desire to take a look.
__________________
-Craig
Reply With Quote
  #14  
Old 12-05-2016, 09:15 AM
KarylFStein KarylFStein is offline
Sage Fanatic
 
Join Date: Apr 2006
Location: Westland, Michigan, USA
Posts: 999
It seems like (for me) it has trouble with 720p@60 MPEG2-TS (CableCard) and skipping. Eventually it will just skip all the way to the end. I tried a couple 1080i@29.97 MPEG2-TS files (CableCard and OTA) and skipping was fine with those.

Also, a couple times I exited the app and no longer had audio and had to reboot to get it back. In those cases if you pressed the volume on the controller instead of giving you the volume bar it said something about being in surround mode and to use the receiver volume control.
__________________
Home Network: https://karylstein.com/technology.html

Last edited by KarylFStein; 12-05-2016 at 09:37 AM.
Reply With Quote
  #15  
Old 12-05-2016, 09:33 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by jptheripper View Post
i know so little, but barely reading the forums

is there a chance using dcadec in ffmpeg would allow dts decoding as well as ac3?
Yeah, I think that's possible. I just added "ac3" but if there's a "dcadec" codec that can be enabled, then I can enable that as well. (I don't have anything to test though, since I don't have any dcadec media files.
Reply With Quote
  #16  
Old 12-05-2016, 10:12 AM
jm9843 jm9843 is offline
Sage Aficionado
 
Join Date: Oct 2003
Posts: 286
Quote:
Originally Posted by cncb View Post
It plays .ts recordings from another program OK but skipping around is still an issue where the timeline jumps to the end of the recording unexpectedly (even though this was fixed in Plex with the last firmware update).
Were you using audio passthrough when the jump to the end happened? ExoPlayer issue 1522 had to do with this but has been marked closed since it was device specific to the Nvidia Shield and should have been fixed in the last firmware update.

For the curious, do you have a link to the discussion about this being fixed in Plex? Maybe they had to do something on the software side in combination with Nvidia's fix.
Reply With Quote
  #17  
Old 12-05-2016, 10:23 AM
Daweeze Daweeze is offline
Sage User
 
Join Date: Aug 2010
Location: CA
Posts: 39
Hey Stuckless,

Any idea when MiniClient 1.1.0 will hit the Amazon App Store or are you waiting to fork that version before deploying the next release there?

-Travis
Reply With Quote
  #18  
Old 12-05-2016, 10:29 AM
cculpepp cculpepp is offline
Sage User
 
Join Date: Mar 2016
Location: GA
Posts: 24
Quote:
Originally Posted by mlcarson View Post
The new version is working great with Exoplayer on my Nvidia Shield and Comcast MPEG2 channels. Is there any advantage in using Exoplayer over ijkplayer?
I'm completely stumped. Anytime I try to play OTA mpeg2 channels with ExoPlayer, it's very choppy with no sound. Is your Shield connected to an AVR then to your TV, or directly to your TV?
Reply With Quote
  #19  
Old 12-05-2016, 11:00 AM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
Quote:
Originally Posted by stuckless View Post
Yeah, I think that's possible. I just added "ac3" but if there's a "dcadec" codec that can be enabled, then I can enable that as well. (I don't have anything to test though, since I don't have any dcadec media files.
https://ffmpeg.zeranoe.com/forum/viewtopic.php?t=2385

awesome test file site (once you click the link, click the video in the middle of all the ads
http://www.demo-world.eu/2d-demo-trailers-hd/

Look for something about halfway down with DTS-HD MA 7.1
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders

Last edited by jptheripper; 12-05-2016 at 11:08 AM.
Reply With Quote
  #20  
Old 12-05-2016, 11:17 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by Daweeze View Post
Hey Stuckless,

Any idea when MiniClient 1.1.0 will hit the Amazon App Store or are you waiting to fork that version before deploying the next release there?

-Travis
I could push 1.1.0 to the Amazon App Store... I just ignored it... since EvilPenguin had a separate fork with Amazon's version of ExoPlayer. If people want, I can publish 1.1.0 to the Amazon store.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Android Miniclient and UK TV rickgillyon SageTV Clients Development 6 12-01-2016 05:58 PM
Android MiniClient 1.0.5 - Released stuckless SageTV Clients Development 11 11-16-2016 01:32 PM
Android MiniClient 1.0.7 - released stuckless SageTV Clients Development 11 10-15-2016 10:45 AM
[Android MiniClient] Now in BETA stuckless SageTV Clients Development 487 07-03-2016 03:55 PM
[HELP]MPEG-PS Stream Reader for ExoPlayer (Android MiniClient) stuckless SageTV Clients Development 2 04-01-2016 02:22 PM


All times are GMT -6. The time now is 06:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.