SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-28-2018, 08:48 AM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,108
Wiz.bin not updated for 6 days - What is Wiz.bin.tmp?

What is Wiz.bin.tmp?

Today is 7/28/2018 and it looks like Wiz.bin hasn't been updated for 6 days.

Wiz.bin.tmp 7/22/2018 3:00 pm
Wiz.bak 7/22/2018 3:00 pm
Wiz.bin 7/22/2018 3:00 pm

Do not have a sagetv_##.txt file that goes back to then.
Latest I have is 7/26/2018 1:08am

What could cause Wiz.bin not to update?
Would restarting Sage cause any "updates" (Flag status i.e. watched/archived ; scheduled recordings ; etc.) since 7/22/2018 to be lost?

I collected info on watched/archived status for past week and what is currently scheduled.

Performed reboot of SageTV PC
Attached the sagetv_0.txt file from startup in case that shows any clues.
Attached Files
File Type: zip sagetv_0 - 20180728.zip (384.9 KB, 9 views)

Last edited by graywolf; 07-28-2018 at 09:25 AM.
Reply With Quote
  #2  
Old 08-03-2018, 02:54 PM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,108
Happened again - NullPointerException

This time 8/2/2018 20:23

Any help would be appreciated. WAF taking a hit.

Log fiile attached.

snippet where the error occurred
Code:
Thu 8/2 20:23:36.140 [EPG@a386b8] Wizard writing out table info for SeriesInfo
Thu 8/2 20:23:36.478 [EPG@a386b8] Exception during Maintenance:java.lang.NullPointerException
Thu 8/2 20:23:36.478 [EPG@a386b8] java.lang.NullPointerException
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.SeriesInfo.write(SeriesInfo.java:201)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.Wizard.saveDBFile(Wizard.java:7930)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.Wizard.maintenance(Wizard.java:2369)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.EPG.run(EPG.java:645)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at java.lang.Thread.run(Unknown Source)
Thu 8/2 20:23:36.479 [EPG@a386b8] sage.epg.sd.SDRipper@1f6b7c6 needs an update in 16:33:26
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG needs an update in 993 minutes
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG's works is done. Waiting...
Attached Files
File Type: zip sagetv_7.zip (366.0 KB, 8 views)
Reply With Quote
  #3  
Old 08-03-2018, 06:19 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,012
I'm seeing the same problem on a semi regular basis with an exception following "Wizard writing out table info for SeriesInfo"

A restart of SageTV restores the wiz.bin from wiz.bak and then it will be fine again for a while.

Haven't been able to identify a pattern, but it's certainly been a problem for me over the last few builds.

John
Reply With Quote
  #4  
Old 08-03-2018, 09:13 PM
wnjj wnjj is offline
Sage Expert
 
Join Date: Jan 2009
Posts: 638
Quote:
Originally Posted by graywolf View Post
This time 8/2/2018 20:23

Any help would be appreciated. WAF taking a hit.

Log fiile attached.

snippet where the error occurred
Code:
Thu 8/2 20:23:36.140 [EPG@a386b8] Wizard writing out table info for SeriesInfo
Thu 8/2 20:23:36.478 [EPG@a386b8] Exception during Maintenance:java.lang.NullPointerException
Thu 8/2 20:23:36.478 [EPG@a386b8] java.lang.NullPointerException
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.SeriesInfo.write(SeriesInfo.java:201)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.Wizard.saveDBFile(Wizard.java:7930)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.Wizard.maintenance(Wizard.java:2369)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at sage.EPG.run(EPG.java:645)
Thu 8/2 20:23:36.479 [EPG@a386b8] 	at java.lang.Thread.run(Unknown Source)
Thu 8/2 20:23:36.479 [EPG@a386b8] sage.epg.sd.SDRipper@1f6b7c6 needs an update in 16:33:26
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG needs an update in 993 minutes
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG's works is done. Waiting...
The line thatís crashing is attempting to access an array of people associated with the series and one of them is null. Tracing back, the person object it can be null if the name has 0 length. I wonder if SD has some funky data and the EPG code isnít filtering it?
Reply With Quote
  #5  
Old 08-04-2018, 11:21 AM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,108
Quote:
Originally Posted by JREkiwi View Post
I'm seeing the same problem on a semi regular basis with an exception following "Wizard writing out table info for SeriesInfo"

A restart of SageTV restores the wiz.bin from wiz.bak and then it will be fine again for a while.

Haven't been able to identify a pattern, but it's certainly been a problem for me over the last few builds.

John
Yes. Restart of Sage does fix it temporarily but then again, you lose stuff between when it "locks/freezes" and you do the restart.
i.e. Flag settings, manual Scheduled Recordings that you have set, etc.

While Recordings do occur, any after the "lock/freeze" of wiz.bin updates and the restart of Sage all become Archived so have to try to remember what they were so as to Unarchive them

Also Glad/Sad that I'm not the only one.
Glad that it isn't my setup per se
Sad others also afflicted

Last edited by graywolf; 08-04-2018 at 11:35 AM.
Reply With Quote
  #6  
Old 08-04-2018, 01:05 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,012
Quote:
Originally Posted by wnjj View Post
The line thatís crashing is attempting to access an array of people associated with the series and one of them is null. Tracing back, the person object it can be null if the name has 0 length. I wonder if SD has some funky data and the EPG code isnít filtering it?
I'm getting the same issue with XMLTV EPG, so it's not SD specific. I feel it's more likely to be associated with data that BMT is pulling in for shows and the wiz.bin writing code should handle it rather than crashing.

John
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SD in the UK - how many days? syrel SageTV EPG Service 6 06-12-2018 05:04 AM
600 days... Trepidati0n SageTV Software 1 09-27-2010 11:47 AM
Help...My HD PVR dead after only three days... phlucas Hardware Support 6 02-13-2009 01:40 AM
Five days of Bliss jphhughes SageTV Software 32 08-28-2004 12:51 AM


All times are GMT -6. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.