SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 11-10-2010, 08:22 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Quote:
Originally Posted by jreichen View Post
I don't think so. A Quad Core 2.66GHz Q9450 can't do HD-PVR recordings.

If you have AirVideo, try out your recordings there and that should give you a pretty good idea of what it can handle.
Although I haven't tried this another user (PeterH) said he could do h.264 on a q6600 quad processor without any issues on the iphone.

I have the same processor in my server and am hoping to test this weekend.
Reply With Quote
  #42  
Old 11-10-2010, 03:11 PM
Fonceur's Avatar
Fonceur Fonceur is offline
Sage Icon
 
Join Date: Jan 2008
Location: DDO, QC
Posts: 1,915
As far as streaming other files, generic mpeg files seems fine, but downloaded TV shows in avi format tend to hang the process...
__________________
SageTCPServer (2.3.5): Open source TCP interface to the SageTV API
MLSageTV (3.1.8)/Sage Media Server (1.13): SageTV plugin for MainLobby/CQC
TaSageTV (2.58)/TaSTVRemote (1.14): Monitor/control SageTV with an Android device
TbSageTV (1.02)/STVRemote (1.11): Monitor/control SageTV with a PlayBook 2
TiSageTV (1.64)/TiSTVRemote (1.09): Monitor/control SageTV with an iPhone/iPod/iPad
Reply With Quote
  #43  
Old 11-10-2010, 04:46 PM
Chriscic Chriscic is offline
Sage Expert
 
Join Date: Apr 2008
Posts: 729
Quote:
Originally Posted by jreichen View Post
I don't think so. A Quad Core 2.66GHz Q9450 can't do HD-PVR recordings.

If you have AirVideo, try out your recordings there and that should give you a pretty good idea of what it can handle.
Using Air Video I play live-converted HD-PVR recordings no problem; using a WHS core 2 duo 2.4ghz. Note they are 720p and I haven't tried 1080i.

I'd be surprised though if a quad couldn't do 1080i; something else must be wrong or just having trouble with the file format.
Reply With Quote
  #44  
Old 11-10-2010, 05:29 PM
Fonceur's Avatar
Fonceur Fonceur is offline
Sage Icon
 
Join Date: Jan 2008
Location: DDO, QC
Posts: 1,915
And for the curious, it doesn't stream mp3 in its current form either...
__________________
SageTCPServer (2.3.5): Open source TCP interface to the SageTV API
MLSageTV (3.1.8)/Sage Media Server (1.13): SageTV plugin for MainLobby/CQC
TaSageTV (2.58)/TaSTVRemote (1.14): Monitor/control SageTV with an Android device
TbSageTV (1.02)/STVRemote (1.11): Monitor/control SageTV with a PlayBook 2
TiSageTV (1.64)/TiSTVRemote (1.09): Monitor/control SageTV with an iPhone/iPod/iPad
Reply With Quote
  #45  
Old 11-10-2010, 05:46 PM
macsupergeek macsupergeek is offline
Sage Advanced User
 
Join Date: Sep 2008
Location: NJ
Posts: 161
I have it working on my desktop iMac, safari 5.02. what makes it work ultimately is quicktime x, so while you can install safari 5.02 onto windows, its quicktime is only 7.6.8 and quicktime x is what implements live streaming so my guess is when and if apple ever releases a quicktime x -- safari in windows would work too.
__________________
SERVER: Dual Core Xeon 3.0GHz 5160, 8gb RAM, Win7 x64, SageTV 9.0.13.536 w/ BMT, WebUI, OpenDCT, Java 1.70_79
TUNERS: 2 x Ceton PCIe InfinitiTV - FIOS
STORAGE: UNRAID - 8tb for archived shows, DVDs, pictures and music
CLIENTS: 2 x HD200s, 2 x HD300
Reply With Quote
  #46  
Old 11-10-2010, 07:05 PM
jreichen's Avatar
jreichen jreichen is offline
Sage Icon
 
Join Date: Jul 2004
Posts: 1,192
Quote:
Originally Posted by Fonceur View Post
As far as streaming other files, generic mpeg files seems fine, but downloaded TV shows in avi format tend to hang the process...
If you want me to troubleshoot then please follow the instructions in the first post of this thread so I can see the log.
__________________
Server: Intel Core i5 760 Quad, Gigabyte GA-H57M-USB3, 4GB RAM, Gigabyte GeForce 210, 120GB SSD (OS), 1TB SATA, HD HomeRun.
Extender: STP-HD300, Harmony 550 Remote,
Netgear MCA1001 Ethernet over Coax.
SageTV: SageTV Server 7.1.8 on Ubuntu Linux 11.04, SageTV Placeshifter for Mac 6.6.2, SageTV Client 7.0.15 for Windows, Linux Placeshifter 7.1.8 on Server and Client
, Java 1.6.
Plugins: Jetty, Nielm's Web Server, Mobile Web Interface.

Reply With Quote
  #47  
Old 11-10-2010, 07:06 PM
jreichen's Avatar
jreichen jreichen is offline
Sage Icon
 
Join Date: Jul 2004
Posts: 1,192
Quote:
Originally Posted by macsupergeek View Post
I have it working on my desktop iMac, safari 5.02. what makes it work ultimately is quicktime x, so while you can install safari 5.02 onto windows, its quicktime is only 7.6.8 and quicktime x is what implements live streaming so my guess is when and if apple ever releases a quicktime x -- safari in windows would work too.
Excellent info. Thanks for posting. I'll add it to the FAQ.
__________________
Server: Intel Core i5 760 Quad, Gigabyte GA-H57M-USB3, 4GB RAM, Gigabyte GeForce 210, 120GB SSD (OS), 1TB SATA, HD HomeRun.
Extender: STP-HD300, Harmony 550 Remote,
Netgear MCA1001 Ethernet over Coax.
SageTV: SageTV Server 7.1.8 on Ubuntu Linux 11.04, SageTV Placeshifter for Mac 6.6.2, SageTV Client 7.0.15 for Windows, Linux Placeshifter 7.1.8 on Server and Client
, Java 1.6.
Plugins: Jetty, Nielm's Web Server, Mobile Web Interface.

Reply With Quote
  #48  
Old 11-10-2010, 08:15 PM
Fonceur's Avatar
Fonceur Fonceur is offline
Sage Icon
 
Join Date: Jan 2008
Location: DDO, QC
Posts: 1,915
Quote:
Originally Posted by jreichen View Post
If you want me to troubleshoot then please follow the instructions in the first post of this thread so I can see the log.
Here's an example of trying a wmv, which eventually gives up and switch back to the file I streamed a few hours and restart ago...
Attached Files
File Type: zip sagetv_0.zip (17.1 KB, 256 views)
__________________
SageTCPServer (2.3.5): Open source TCP interface to the SageTV API
MLSageTV (3.1.8)/Sage Media Server (1.13): SageTV plugin for MainLobby/CQC
TaSageTV (2.58)/TaSTVRemote (1.14): Monitor/control SageTV with an Android device
TbSageTV (1.02)/STVRemote (1.11): Monitor/control SageTV with a PlayBook 2
TiSageTV (1.64)/TiSTVRemote (1.09): Monitor/control SageTV with an iPhone/iPod/iPad
Reply With Quote
  #49  
Old 11-10-2010, 09:56 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,505
If anyone's interested, I was suprised that 1080i HD-PVR content on the Great setting was able to stream over 3G when I testing this out earlier. It did require a good amount of buffering initially, but I felt the PQ was very good. I have a Q9300 (2.5GHz) quad core.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #50  
Old 11-10-2010, 10:04 PM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 6,578
Quote:
Originally Posted by EnterNoEscape View Post
If anyone's interested, I was suprised that 1080i HD-PVR content on the Great setting was able to stream over 3G when I testing this out earlier. It did require a good amount of buffering initially, but I felt the PQ was very good. I have a Q9300 (2.5GHz) quad core.
Isn't your upload speed generally going to be the bottleneck in the equation. I can generally get more than 1 Mbps downloads on my 3G iPad however my upload speed is only 800 kbps from my ISP and most cable or DSL ISPs don't give you any more than 1 Mbps, or do they?
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #51  
Old 11-10-2010, 10:29 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,505
I would figure that as well, but I was accounting for saying my computer had enough power to do it and the latency on the 3G connection was acceptable. My ISP gives me a verfied 15 up.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #52  
Old 11-10-2010, 10:51 PM
Peter_h Peter_h is offline
Sage Fanatic
 
Join Date: May 2008
Location: Kailua, HI
Posts: 798
Quote:
Originally Posted by PLUCKYHD View Post
Although I haven't tried this another user (PeterH) said he could do h.264 on a q6600 quad processor without any issues on the iphone.

I have the same processor in my server and am hoping to test this weekend.

Yep, tested this a few days ago. Was able to stream h.264 over wifi at work from my q6600 server at home. It worked without any issue. It did take quite a bit of time to buffer.

I also did a brief test of h.264 over 3g and it also seemed to work but I merely checked to see if it would play. I didn't really have time to watch more than a couple of minutes.
Reply With Quote
  #53  
Old 11-11-2010, 10:27 AM
Chriscic Chriscic is offline
Sage Expert
 
Join Date: Apr 2008
Posts: 729
By the way, I tried streaming a 1080i HD-PVR file (recorded at max quality) over Air Video and it works perfectly. Again, my sever is 2.4ghz Core 2 Duo, for those trying to figure out what might be "enough."

I still haven't tried the Sage plugin as I'm waiting for final release of v.7 to upgrade.

Also, the discussion on whether you can stream h.264 over 3G as opposed to wifi seems a bit misguided since the conversion is being done on your PC; you're sending the same thing over the airwaves whether you've converted a h.264 or an MPEG2 file as far as I know.

Last edited by Chriscic; 11-11-2010 at 11:12 AM.
Reply With Quote
  #54  
Old 11-11-2010, 10:49 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,505
Quote:
Originally Posted by Chriscic View Post
By the way, I tried streaming a 1080i HD-PVR file (recorded at max quality) over Air Video and it works perfectly. Again, my sever is 2.4ghz Core 2 Duo, for those trying to figure out what might be "enough."

What operating system are you running on your server?
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #55  
Old 11-11-2010, 11:12 AM
Chriscic Chriscic is offline
Sage Expert
 
Join Date: Apr 2008
Posts: 729
WHS
Reply With Quote
  #56  
Old 11-12-2010, 05:53 PM
wbarber69's Avatar
wbarber69 wbarber69 is offline
Sage Expert
 
Join Date: Oct 2004
Location: Hammond, La.
Posts: 511
Send a message via ICQ to wbarber69 Send a message via AIM to wbarber69 Send a message via MSN to wbarber69 Send a message via Yahoo to wbarber69 Send a message via Skype™ to wbarber69
I am able to watch anything that is recorded as is but I am unable to watch anything transcoded to avi or mkv like it can't transcode again what's been transcoded already also some shows (I'm trying to figure out the similarity) are only streaming audio but there is no commonality between them (at least nothing I'm seeing at this moment)
Reply With Quote
  #57  
Old 11-12-2010, 06:22 PM
jreichen's Avatar
jreichen jreichen is offline
Sage Icon
 
Join Date: Jul 2004
Posts: 1,192
On the first post I have instructions for capturing debug logging and posting the log here. If you want to have me look at it please follow those instructions. I'm curious why it won't decode those videos.
__________________
Server: Intel Core i5 760 Quad, Gigabyte GA-H57M-USB3, 4GB RAM, Gigabyte GeForce 210, 120GB SSD (OS), 1TB SATA, HD HomeRun.
Extender: STP-HD300, Harmony 550 Remote,
Netgear MCA1001 Ethernet over Coax.
SageTV: SageTV Server 7.1.8 on Ubuntu Linux 11.04, SageTV Placeshifter for Mac 6.6.2, SageTV Client 7.0.15 for Windows, Linux Placeshifter 7.1.8 on Server and Client
, Java 1.6.
Plugins: Jetty, Nielm's Web Server, Mobile Web Interface.

Reply With Quote
  #58  
Old 11-13-2010, 08:40 AM
wbarber69's Avatar
wbarber69 wbarber69 is offline
Sage Expert
 
Join Date: Oct 2004
Location: Hammond, La.
Posts: 511
Send a message via ICQ to wbarber69 Send a message via AIM to wbarber69 Send a message via MSN to wbarber69 Send a message via Yahoo to wbarber69 Send a message via Skype™ to wbarber69
as am I since you would think an avi would stream easier than an mpeg
Reply With Quote
  #59  
Old 11-23-2010, 09:56 PM
pawn's Avatar
pawn pawn is offline
Sage Expert
 
Join Date: May 2003
Posts: 516
Hmmm...this is so close to being a perfect solution for me. Mostly, I love how the iPhone streaming is true streaming and doesn't have a problem with files currently being recorded.

That said, like others in this thread, I use Airvideo on the same machine and it converts and streams h264 files no problem (too bad it's useless for live recordings). Something is obviously being done differently with the streaming and/or conversion method you're using and I don't think it has anything to do with CPU horsepower (or else I couldn't use Airvideo to do the same thing without problems).

Not being critical, I'm really excited about this, just trying to help.
Reply With Quote
  #60  
Old 12-29-2010, 03:34 PM
gamehendge2000 gamehendge2000 is offline
New Member
 
Join Date: Feb 2010
Location: Boston
Posts: 3
So after a little testing of the streaming...

I have a Core Duo 2,2ghz, trying to stream HD-PVR .ts files at the 'Great' encoding setting. I know this may be sub-optimal, just trying to get the config right at the moment.

- When logged in to my network via VPN, the mobile interface works fine (over 8080, jetty non-ssl) - but the streaming will not work. I get the video play button in the crossed-out circle icon on iPhone (4.01) and a blank black box on the iPad (4.2.1). I understand it will not worked directly over SSL, but would have thought that VPN might have worked...

- When opening the 8080 port and connecting publicly, everything seemed to work fine on the 4.01 iPhone (3GS) the first time. Subsequent times, the video never finishes buffering/loading in the video player.

- streaming does not work on the iPad (4.2.1). I get the play video button..when clicked, it greys out for a moment, but then returns to the white video icon, and does not launch the iPad video player.

Any thoughts? Logs attached

Specs:
CPU Core Duo 2.2ghz
SageTV OS: Win XP SP3 32 bit
Connect iPad/iPhone to server via Wifi G
Devices:
- iPhone 3GS, jailbroken. 4.01
- iPad 4.2.1
Attached Files
File Type: txt sagetv_0.txt (164.0 KB, 221 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugin: Mobile Web Interface Version 2 jreichen SageTV v7 Customizations 383 04-23-2018 09:12 AM
Plugin: Mobile Web Interface 1.2 jreichen SageTV Customizations 281 06-17-2011 02:20 PM
FAQ: Mobile Web Interface V2 iOS Streaming jreichen SageTV v7 Customizations 3 11-07-2010 08:28 PM
Wanted: Developer for Web Interface Mobile Brent SageTV Customizations 249 02-09-2009 11:21 PM
Web User Interface + Secure = Broken Streaming Function jmoney579 SageTV Customizations 1 05-28-2008 01:51 AM


All times are GMT -6. The time now is 05:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.