SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Clients Development

Notices

SageTV Clients Development This forum is for discussions relating to SageTV Open Source Clients Development.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-23-2016, 05:31 PM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
Android Miniclient and UK TV

I'm trying out the Miniclient on a cheap Android box. It's working really well generally. Plays HD imported video better then the Windows clients, plays recorded SDTV just fine.

The problem is with recorded HDTV. I've tried stuff from C4 (see attached) and BBC. I get the picture just fine but no sound. I can select the audio stream, 2 available, but both are silent. I've tried both players and all 3 streaming modes.

Any ideas? Anything I can provide for debugging? Files are pretty big but I'm happy to upload to my FTP. Thanks.
Attached Images
File Type: png humans.PNG (355.9 KB, 75 views)
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #2  
Old 11-23-2016, 05:53 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
Quote:
Originally Posted by rickgillyon View Post
I'm trying out the Miniclient on a cheap Android box. It's working really well generally. Plays HD imported video better then the Windows clients, plays recorded SDTV just fine.

The problem is with recorded HDTV. I've tried stuff from C4 (see attached) and BBC. I get the picture just fine but no sound. I can select the audio stream, 2 available, but both are silent. I've tried both players and all 3 streaming modes.

Any ideas? Anything I can provide for debugging? Files are pretty big but I'm happy to upload to my FTP. Thanks.
Are all the non working recordings HE-AAC audio?
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #3  
Old 11-23-2016, 05:57 PM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
Quote:
Originally Posted by Fuzzy View Post
Are all the non working recordings HE-AAC audio?
Yes, all the freeview HD recordings I have are HE-AAC, MPEG2-PS H.264 1080i.
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #4  
Old 11-24-2016, 11:05 AM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
I've put a small(ish) example file here for download, if someone is able to help...

https://drive.google.com/open?id=0B-...U5lci1JLXZsMTA
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #5  
Old 12-01-2016, 02:31 PM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
No ideas? Is it likely just a limitation of the client or the box?
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #6  
Old 12-01-2016, 05:32 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
Sage Icon
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,491
Quote:
Originally Posted by rickgillyon View Post
No ideas? Is it likely just a limitation of the client or the box?
While I can see that there should be an audio track in that video, I only have a few programs that can play it back with the audio working.

The problem as I see it is that the file is an MPEG-PS file and that container doesn't support H.264 which the video definitely is. The container is also very confusing for FFmpeg to decipher. It was unable to use it to remux the file to MPEG-TS which is a much more appropriate container. Also, the fact that bit-rate of the audio in your screen shot from SageTV is unlikely is a good tell that something is not right. I was able to determine that it's 128Kbps after using VLC to remux the file to MPEG-TS with partial success.

What I would do is change the setting in Sage.properties for that capture device to capture using the MPEG-TS container instead of MPEG-PS. The line you're looking for will look like the line below. All you need to do is stop the SageTV service, then change the value from true to false, then start the SageTV service back up.

Code:
mmc/encoders/<id>/100/0/encode_digital_tv_as_program_stream=true
I don't know how this normally works in SageTV because I've never had it try to record H.264 content using any of it's built in capture device support, but ideally it should change container formats automatically if the codecs are incompatible instead of pushing on. Like I said though, I don't know if it was supposed to handle that or not.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 8x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.3.0-rc6 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #7  
Old 12-01-2016, 05:58 PM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
Wow, thanks for the effort there, that's cracked it.

I had no idea that the files were strange, as they have always played in our PC clients... Now they play everywhere.

Thanks again.
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Android MiniClient - Subtitle + CC support stuckless SageTV Clients Development 42 01-01-2018 08:17 AM
Android MiniClient and Audio Passthrough stuckless SageTV Clients Development 10 11-30-2016 10:39 AM
Android MiniClient 1.0.5 - Released stuckless SageTV Clients Development 11 11-16-2016 01:32 PM
Android MiniClient 1.0.7 - released stuckless SageTV Clients Development 11 10-15-2016 10:45 AM
[Android MiniClient] Now in BETA stuckless SageTV Clients Development 487 07-03-2016 03:55 PM


All times are GMT -6. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.