SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-06-2021, 08:49 AM
brianrent brianrent is offline
Sage Advanced User
 
Join Date: Jan 2010
Location: KY
Posts: 84
Exclamation MKVs with too many subtitles wont play

Ive had this problem for years. I get error "problem with video portion of playback" or something to that effect. But if I remove subtitles from the mkv and make no other changes it plays fine. Not sure how many is too many but 1 or 2 work but i download files that have many and I have to remove them to get these files to play. This is on a computer client. Not sure about extenders. Is there a way to turn off subtitles in the registry maybe?
Reply With Quote
  #2  
Old 08-10-2021, 12:07 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,093
Quote:
Originally Posted by brianrent View Post
Ive had this problem for years. I get error "problem with video portion of playback" or something to that effect. But if I remove subtitles from the mkv and make no other changes it plays fine. Not sure how many is too many but 1 or 2 work but i download files that have many and I have to remove them to get these files to play. This is on a computer client. Not sure about extenders. Is there a way to turn off subtitles in the registry maybe?
I've noticed this too, when there are a gazillion SRT's in the MKV.

While the HDx00's extenders have a problem with this (they tend to lock up in my experience) the Android Mini Client seems to fair better. I've since learned to not even try to use SageTV with these. I use Plex for playback instead when I have one of these multiple diverse language media files on hand. I imagine it's an edge case that the SageTV client code never thought it would have to handle.
Reply With Quote
  #3  
Old 08-10-2021, 02:42 PM
nyplayer nyplayer is online now
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,653
I noticed this also happens if the MKV has embedded subtitles and you also have an srt file alongside it.

I create MKV out of SageTV recordings with embeeded subtitles but I had to delete the srt left behind in order for them to play.
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
  #4  
Old 08-11-2021, 05:35 AM
graywolf's Avatar
graywolf graywolf is online now
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,337
I've seen this with HD200 & HD300 also.
I end up using MakeMKV to strip out the undesired languages and have had no issue playing them afterwards on the HD200 & HD300
Reply With Quote
  #5  
Old 08-20-2021, 11:21 PM
brianrent brianrent is offline
Sage Advanced User
 
Join Date: Jan 2010
Location: KY
Posts: 84
Quote:
Originally Posted by graywolf View Post
I've seen this with HD200 & HD300 also.
I end up using MakeMKV to strip out the undesired languages and have had no issue playing them afterwards on the HD200 & HD300
Yes. I use MKV toolnix and batch do this for multiple files at once. I have it set to automatically include only audio, video and english subs. Works fairly well but would rather it was fixed so I don't have to do this.
Thanks everyone who still works on sage. It is the perfect setup for my family.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help - Can't Get MKVs to Play in SageTV Win Client SteveW SageTV Software 18 10-05-2020 06:26 PM
MKVs and subtitles pjpjpjpj General Discussion 9 03-27-2014 09:19 PM
Play all MKVs through MPC? ChaOConnor SageTV Software 3 08-30-2011 09:55 AM
Any way to get subtitles for MKVs through directshow? mkanet SageTV v7 Customizations 1 08-22-2011 09:00 PM
subtitles wont work when play an iso dvd tanquef SageTV Software 8 01-28-2011 07:27 AM


All times are GMT -6. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.