SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV EPG Service

Notices

SageTV EPG Service Discussion related to the SageTV EPG Service used within SageTV. Questions about service area coverage, channel lineups, EPG listings, XMLTV, or anything else related to the service or programming guide data for SageTV should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 10-05-2022, 10:19 PM
robogeek robogeek is offline
Sage Expert
 
Join Date: Apr 2003
Location: Appleton, WI USA
Posts: 568
Quote:
Originally Posted by emveepee View Post
I know in addition to the artwork changes we tested with NextPVR SD introduced blocking for multiple uses of user credentials. So you have various SD clients, if the token isn't re-authenticated on failure things won't work.

Previous behaviour was all tokens were valid for 24 hours, and I'm not sure how SageTV deals with this. If you have multiple servers calling SD definitely don't run EPG updates at the same time.

Martin
'blocking for multiple uses of user credentials' might have caused my issue. Thanks for the clue! I only have one instance of SageTV and it is the only thing that grabs guide data from Schedules Direct. However, I now have three Internet connections in a load-balance and failover configuration. Connections from my SageTV server could randomly appear to be coming from three different IP addresses.

Regardless of the error I was seeing in the SageTV log, my guide data was still filling out and updating. The OTA broadcast channels that got shuffled around over the weekend are now mostly fixed. I think there is now just one channel with the wrong guide data and a couple of channels that still have the wrong channel logo.

I have reconfigured my router to route all traffic from my SageTV server through only one of the load-balance Internet connections and the failover Internet connection. After doing that and restarting SageTV, I haven't seen any EPG errors.
__________________
--Jason

Server Hardware: GIGABYTE GA-EP45-UD3R, Intel Q9550 CPU 2.83GHz, 11GB RAM, 1xHDHR, 1xHVR1600, 1xHVR2250
29TB Server Storage: 1TB SSD (OS), 1TB (data), 2x6TB+2x10TB (22TB FlexRaid storage pool), 2x2TB (recordings), 1x750GB (VMs).
Server Software: Win10 Pro x64 OS, SageTV 64bit v9.2.0.441, Java 1.8 u241, PlayOn, Comskip (Donator) v0.82.003, WampServer v2.5.
Clients: 3xHD300s, 2xHD100, 2xPlaceshifters
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with program guide data updating sflamm SageTV EPG Service 4 02-19-2017 01:56 AM
Existing Program Information Not Updating on Some Channels ptzink SageTV EPG Service 6 10-29-2013 07:50 AM
STV Import: Alternative Program Guide & Mini Guide for Default STV wado1971 SageTV Customizations 24 09-13-2009 01:32 PM
SageTV V6 Program Guide empty and not updating JasonEngel SageTV EPG Service 2 03-20-2007 08:40 PM
How to disable the popup window in the program guide? How to keep the program guide? metropole SageTV Software 8 05-18-2006 06:25 PM


All times are GMT -6. The time now is 01:04 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.