SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-22-2006, 12:17 PM
blade blade is offline
SageTVaholic
 
Join Date: Jan 2005
Posts: 2,500
Best version of java for dedicated Sage server?

I never playback video on my server. I think the last time I launched the gui was during the original setup nearly 2 years ago. I'm running java v1.4.2_12 on it. I remember reading performance was better with the newer version (except for the handle leak).

Would there be any benefits with the newer version when using the service or any drawbacks?
Reply With Quote
  #2  
Old 09-22-2006, 12:26 PM
bcjenkins bcjenkins is offline
SageTVaholic
 
Join Date: Jan 2006
Posts: 3,764
Quote:
Originally Posted by blade
I never playback video on my server. I think the last time I launched the gui was during the original setup nearly 2 years ago. I'm running java v1.4.2_12 on it. I remember reading performance was better with the newer version (except for the handle leak).

Would there be any benefits with the newer version when using the service or any drawbacks?
I thought 1.5 offered some performance improvements over 1.4? Also, I have noticed some plugins, which you might use MVP or PS, require 1.5 or higher?

If you're not running VMR and FSE on the box, I would think 1.5 would be the way to go.

HIH

B
Reply With Quote
  #3  
Old 09-22-2006, 01:11 PM
GKusnick's Avatar
GKusnick GKusnick is offline
SageTVaholic
 
Join Date: Dec 2005
Posts: 5,083
Sage still ships with 1.4.2 and that's what their support people recommend.

However some third-party plugins (like mine for instance) require 1.5. Among the 1.5 subversions, I've found that 1.5.0_05 does not leak handles on my system, but 1.5.0_06 does. YMMV.

Lately I've been using beta versions of 1.6, which seem pretty good as far as leakage and stability go. There has not been a non-beta release of 1.6 yet, and the Sage devs have not given it their seal of approval, but a number of people are using it successfully.

If your system is working well as is, then I'd say the "if it ain't broke" rule applies. If there's some plugin you just have to have right now that won't work with 1.4, then I'd suggest skipping 1.5 and trying the 1.6 beta. Otherwise it's probably best to wait for an official release of 1.6 before upgrading.
__________________
-- Greg
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:36 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.