SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux > SageTV for unRAID/Docker

Notices

SageTV for unRAID/Docker Discussion related to SageTV for unRAID/Docker. Questions, issues, problems, suggestions, etc. relating to SageTV for unRAID/Docker should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-31-2018, 04:42 PM
poto poto is offline
Sage User
 
Join Date: May 2013
Location: 29349
Posts: 46
SageTV Unraid/Docker install - log file errors, server not found

I'm starting to try out the docker containers available through UnRaid repositories, but having some trouble getting SageTV server recognized on HD300 extender.

My current setup has VM host running esxi 6.5, with SageTV v7 in a Windows 7 VM. Media files are accessed via UnRaid server. This setup is very stable, no problems, but I would like to learn more about Dockers, and possibly consolidate VM services on UnRaid server.

I was able to install SageTV docker, Java 8 version, but am seeing some errors in docker log file. Also, the server is not found by HD300 extender.

Would appreciate any suggestions to troubleshoot.

Thanks!

Code:
Aug 31 18:51:05 unraid-one syslog-ng[17]: syslog-ng starting up; version='3.5.6'

Aug 31 18:51:06 unraid-one syslog-ng[17]: EOF on control channel, closing connection;
*** Running /etc/my_init.d/20-upgrade-sagetv...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
SageTV Home: /opt/sagetv/server
SageTV Already At Version: 9.1.9.514, exiting...

*** Running /etc/my_init.d/25-add-license...
*** Running /etc/my_init.d/25-sagetv-docker-env...
Updating Java Mem 768
*** Running /etc/my_init.d/25-upgrade-commandir...
*** Running /etc/my_init.d/25-upgrade-comskip...
*** Running /etc/my_init.d/25-upgrade-gentuner...
*** Running /etc/my_init.d/30-setperms...
*** Running /etc/my_init.d/40-lirc...
mode of '/usr/bin/irsend' changed from 0755 (rwxr-xr-x) to 4755 (rwsr-xr-x)
*** Running /etc/my_init.d/85-user-script...
*** Running /etc/my_init.d/90-sagetv...
Changing to SageTV directory /opt/sagetv/server
chmod: cannot access '/var/media/videos': No such file or directory
chmod: cannot access '/var/media/pictures': No such file or directory
chmod: cannot access '/var/media/music': No such file or directory
Executing pre-scripts
*** Running /etc/my_init.d/95-jstatd...
JSTATD Remote Java Debugging is disabled.
*** Running /etc/my_init.d/99-zmessage...

************************************************
SageTV unRAID/Docker (Container Version: 1.0.4) is running

If this is your first time, install the Windows/Mac/Linux Placeshifter or the Android MiniClient and complete the configuration
Setting up tuners, scheduling recordings, installing plugins, etc, requires using the Placeshifter or MiniClient
To gain browser access, install the Jetty WebServer Plugin
- The SageTV Team -
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 95
Aug 31 18:51:08 unraid-one cron[98]: (CRON) INFO (pidfile fd = 3)
Aug 31 18:51:08 unraid-one cron[98]: (CRON) INFO (Skipping @reboot jobs -- not system startup)
Starting server mode
mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

mmap failed for CEN and END part of zip file

Error: Could not find or load main class sage.Sage

Aug 31 19:17:01 unraid-one CRON[171]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Aug 31 20:17:01 unraid-one CRON[174]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Aug 31 21:17:01 unraid-one CRON[177]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Aug 31 22:17:01 unraid-one CRON[180]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Attached Images
File Type: jpg Sagetv docker settings.jpg (31.4 KB, 78 views)
Reply With Quote
  #2  
Old 09-02-2018, 10:05 AM
rrhorer rrhorer is offline
Sage Advanced User
 
Join Date: Nov 2008
Posts: 211
I have a working unRAID/Docker setup, but am by no means an expert. However, I'll try to help if I can. Is your sagemedia share accessible? I believe the SMB Security Settings for "Export:" and "Security:" need to be set to "Yes" and "Public", respectively. At least, I had trouble mapping the share's folders in Windows 10 until I set "Export:" to Yes. I also had a network issue at one point (no Sage at all) that was caused, I believe, by a faulty DNS Server Assignment (see Interface eth0 under Settings/Network Settings). Lastly, I selected Java 8 (just as you have installed) but updated to "stuckless-sagetv-server-java10" immediately. I have no idea whether this would make a difference or not. If none of this helps, someone who really knows should be able to help.
__________________
unRAID Basic Server, Sage & OpenDCT Dockers, Core i3-8100, 8G Memory, HDHR Prime, HD300 Extender, Shield & Android Miniclient, Harmony Hub/Remote
Reply With Quote
  #3  
Old 09-02-2018, 11:23 AM
poto poto is offline
Sage User
 
Join Date: May 2013
Location: 29349
Posts: 46
Thanks for jumping in!
- verified sagemedia share set to export>yes, security>public
- compared network settings/assignments to testbox running working sagetv install, and they match, other than ipv4-assigned ip address
- deleted, then reinstalled docker twice

Nothing was helping, until I updated to java v10 of container, then it all just worked.

Still not sure what changed, as testbox works fine with default install of java v8 container. Only thing I can think of is that something with permissions was different, as I have all non-media directories in production array set to cache-only, so they run from and persist on NVME cache drive.

Either way, it will be nice to enjoy some of the improvements, as my windows vm was frozen around 2013.

Thanks again!
Reply With Quote
  #4  
Old 09-03-2018, 09:21 AM
rrhorer rrhorer is offline
Sage Advanced User
 
Join Date: Nov 2008
Posts: 211
Speaking of a Windows VM, I am running a Windows 10 VM in my unRAID setup just for PlayON desktop (to record from Netflix, Amazon Video, etc.) and Avidemux (to cut out lead-in and ending segments of the recordings). See https://forums.sagetv.com/forums/sho...747#post615747.
__________________
unRAID Basic Server, Sage & OpenDCT Dockers, Core i3-8100, 8G Memory, HDHR Prime, HD300 Extender, Shield & Android Miniclient, Harmony Hub/Remote
Reply With Quote
  #5  
Old 09-03-2018, 04:16 PM
poto poto is offline
Sage User
 
Join Date: May 2013
Location: 29349
Posts: 46
Thanks, I'm probably overdue to move on from Win7 anyhow.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SageTV / unraid server crashed today. Huge endless recording found. glenner SageTV for unRAID/Docker 29 08-23-2017 10:36 AM
Errors in unRAID logs when restarting SageTV docker wayner SageTV for unRAID/Docker 0 06-16-2017 08:09 PM
New unRAID/Docker Install questions willieb SageTV for unRAID/Docker 6 03-19-2017 02:07 PM
Tag latest not found in repository docker.io/stuckless/sagetv-server-java8 hmtavares SageTV for unRAID/Docker 4 01-03-2017 09:10 PM
SageTV Server Linux with Comskip for Docker (and unRAID) Support Thread stuckless SageTV for unRAID/Docker 409 10-10-2016 07:22 AM


All times are GMT -6. The time now is 04:09 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.