SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-03-2003, 03:54 PM
PaulModz PaulModz is offline
Sage User
 
Join Date: Jul 2003
Posts: 26
wiz.bin corruption?

I have about 15 or 20 favorites selected in Sage. Whenever I add, change or remove a favorite, Sage will shoot to 100% CPU usage for 1 to 2 munutes. In addition, when I start Sage, it uses 100% CPU for over 5 minutes, and is using 180MB of memory at that point.

I have been able to consistenly get this to happen by performing the following steps:

shut down sage
delete my wiz.bin and wiz.bak files
restart sage
wait until EPG download is done
start adding favorites

The first few favorites that I add go smoothly, but as I continue to add favorites, Sage takes longer and longer to resolve conflicts, until changing the watched status on a single show can cause Sage to use 100% CPU for several minutes, with Sage using over 300MB of memory and it never goes back down.

Is this expected behavior? I have an Athlon XP 2400+ with 512MB, so its not like I'm at the bottom end of the requirements.

I've also noticed that sometimes Sage seems to refuse to record anything when it runs into conflicts. I can clearly see in the guide that multiple favorites are on during a time period, but that time period is blank in my recording schedule, and Sage never asked me which one I would prefer to record.

Am I right in assuming that once CPU usage has gone back down after adding a favorite, the schedule should be accurate, or will Sage go back later and resolve conflicts?
Reply With Quote
  #2  
Old 08-03-2003, 04:20 PM
fidget's Avatar
fidget fidget is offline
Sage Icon
 
Join Date: Jun 2003
Location: Cedar Rapids, Iowa, USA
Posts: 1,179
What version are you running? The 100% CPU and wiz.bin corruption problems are suppose to be fixed with 1.4.7 Beta. I have had no problems with the stability of the Beta, but YMMV.

-Jonathan
Reply With Quote
  #3  
Old 08-03-2003, 04:41 PM
PaulModz PaulModz is offline
Sage User
 
Join Date: Jul 2003
Posts: 26
I'm using 1.4.5, I didn't even notice that 1.4.7 came out this week. I'll upgrade and see what happens.
Reply With Quote
  #4  
Old 08-03-2003, 05:13 PM
PaulModz PaulModz is offline
Sage User
 
Join Date: Jul 2003
Posts: 26
Upgrading to 1.4.7 didn't help. I can easily cause Sage to spend minutes at a time processing favorites changes, and Sage routinely uses up to 300MB of memory. In addition, I sometimes have a completely blank recording schedule on start up.

The EPG Guide drawing seems to have some problems in 1.4.7 as well.
Reply With Quote
  #5  
Old 08-04-2003, 08:01 AM
dkardatzke's Avatar
dkardatzke dkardatzke is offline
SageTV Co-Founder
 
Join Date: Feb 2003
Location: Chicago, IL
Posts: 1,220
Paul,

Please e-mail your log file to support@freytechnologies.com so we can have a detailed look at the problem.
__________________
Dan Kardatzke, Co-Founder
SageTV, LLC
Reply With Quote
  #6  
Old 08-04-2003, 11:03 AM
salsbst's Avatar
salsbst salsbst is offline
SageTVaholic
 
Join Date: Jun 2003
Posts: 2,592
Paul, I'm sure Frey will help you out... but for me, the solution to these same problems was to set "disable_phase1_optimization=false" in the sage.properties file. THis has the effect that sometimes the first airing of a favorite isn't recorded, but the beneficial effect that SageTV works again for me.
Reply With Quote
  #7  
Old 08-04-2003, 05:49 PM
PaulModz PaulModz is offline
Sage User
 
Join Date: Jul 2003
Posts: 26
Dan,

I've sent my log files to you guys, but I must say I was shocked to see that one of the log files was 183MB, and another was 368MB, is that a problem? (They all zipped down to 3.5MB).

Also, Sage seems to be working fine now. Yesterday, even changing the channel caused me to have 100% CPU for a few minutes, now I can add a favorite with no noticable CPU usage. So, whatever is going on, it seems related to adding a lot of favorites in a very short period of time.
Reply With Quote
  #8  
Old 08-05-2003, 06:30 PM
Narflex's Avatar
Narflex Narflex is offline
Sage
 
Join Date: Feb 2003
Location: Redondo Beach, CA
Posts: 6,313
I took a look at the logs. There was a debug statement I left in there that caused the logs to get really big under a certain circumstance, that itself was slowing down Sage. It's fixed for the next build. That along with the fixes in 1.4.7 you have now, should solve the problem.
__________________
Jeffrey Kardatzke
Google
Founder of SageTV
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.