SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 10-02-2010, 11:27 AM
Brent94Z Brent94Z is offline
Sage Fanatic
 
Join Date: Aug 2004
Posts: 863
Quote:
Originally Posted by michaeldjcox View Post
I should clarify.

If you don't yet have SageTV V7 then install and upgrade using the provided installer.

If you have have Sage TV V7 and intially installed WFE on SageTV using the plugin manager then do use the plugin manager to upgrade. Three cheers for the plugin manager!

If however you already installed WebFeedEncoder using the provided installer (i.e. because you had Sage V6 then) but you now have SageTV V7 there are special instructions for the one time hop into the SageTV 7 management of the plugin.

The general jist is backup the old installation, uninstall it (but using the 0.9.7 installer), install new version via the plugin manager, choose the config option to import settings.

Michael
I gotcha. Sweet. I'm good to go then Thanks much!!!!
Reply With Quote
  #42  
Old 10-06-2010, 08:04 AM
RetroBox RetroBox is offline
Sage Advanced User
 
Join Date: Aug 2009
Location: Texas
Posts: 139
Quote:
Originally Posted by michaeldjcox View Post
Latest fixes:
  • Install web feed encoder as a service.
  • Use web start to launch config tool.
Hi Michael,

Would these two updates change the issues in launching the config tool I've experienced in Windows 7? I performed the update via the Plugin Manager (since I already had Sage 7 running) and still get a UAC warning when launching the Config tool. It is, however; still accessible via the cmd line.
__________________
Server: SageTV 7 (latest), Windows 7 (32-bit); Core2 Q8200, Asus P5N-D, ATI Sapphire HD5670 with Bitstreaming; DVD/BD Drive, 4GB Ram, 8TB Storage Internal
Tuners: Clear QAM Dual Tuner; HD-PVR -- Time Warner Cable / Control STB via Firewire; use USB-UIRT with LM Gestion Remote KeyMap
Reply With Quote
  #43  
Old 10-06-2010, 08:33 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by RetroBox View Post
Hi Michael,

Would these two updates change the issues in launching the config tool I've experienced in Windows 7? I performed the update via the Plugin Manager (since I already had Sage 7 running) and still get a UAC warning when launching the Config tool. It is, however; still accessible via the cmd line.
Hi,

It should help with the UAC issue.

Are you launching config tool from the (new) webfeedencoder web page?

It should help with the other issue too as we can specify the user the encoder runs as

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #44  
Old 10-06-2010, 09:55 AM
RetroBox RetroBox is offline
Sage Advanced User
 
Join Date: Aug 2009
Location: Texas
Posts: 139
Quote:
Originally Posted by michaeldjcox View Post
Hi,

It should help with the UAC issue.

Are you launching config tool from the (new) webfeedencoder web page?

It should help with the other issue too as we can specify the user the encoder runs as

Michael
I am trying to launch the webfeedencoder web page, but am having issues connecting. I opened the port in my router and I am trying to hit the box using my LAN address followed by the port number (set to 8085).... am I missing something?

i.e. http://192.168.1.66/8085
__________________
Server: SageTV 7 (latest), Windows 7 (32-bit); Core2 Q8200, Asus P5N-D, ATI Sapphire HD5670 with Bitstreaming; DVD/BD Drive, 4GB Ram, 8TB Storage Internal
Tuners: Clear QAM Dual Tuner; HD-PVR -- Time Warner Cable / Control STB via Firewire; use USB-UIRT with LM Gestion Remote KeyMap
Reply With Quote
  #45  
Old 10-06-2010, 10:43 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by RetroBox View Post
I am trying to launch the webfeedencoder web page, but am having issues connecting. I opened the port in my router and I am trying to hit the box using my LAN address followed by the port number (set to 8085).... am I missing something?

i.e. http://192.168.1.66/8085
HI,

Some thoughts...

So you mean:

http://192.168.1.66:8085

WFE feed encoder has loads of port numbers now.

Is 8085 the Web Service Port one which defaults to 8888 in the config screen?

LAN address should be the address that the web feed encoder server is running on i.e. your SageTV server box.

The encoder.log file outputs debug if it is asked to serve up any web content. Pasting that here may help.

Do you have a monitor on your server box - can you try locally?

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #46  
Old 10-06-2010, 12:26 PM
RetroBox RetroBox is offline
Sage Advanced User
 
Join Date: Aug 2009
Location: Texas
Posts: 139
Quote:
Originally Posted by michaeldjcox View Post
HI,

Some thoughts...

So you mean:

http://192.168.1.66:8085
Yes, my original post had a typo - would have certainly made troubleshooting easier if that was the problem.

Quote:
Originally Posted by michaeldjcox View Post
WFE feed encoder has loads of port numbers now.

Is 8085 the Web Service Port one which defaults to 8888 in the config screen?

LAN address should be the address that the web feed encoder server is running on i.e. your SageTV server box.

The encoder.log file outputs debug if it is asked to serve up any web content. Pasting that here may help.

Do you have a monitor on your server box - can you try locally?
I did try all your suggestions and made sure all my settings were correct, but couldn't get the config web page to show up. I have not been great tracking versions, so I decided to uninstall the plugin, remove the webfeedencoder folder and perform a fresh re-install. All working now!

I really like having access to the config tool via web page - brilliant. Thanks so much for all your effots.
__________________
Server: SageTV 7 (latest), Windows 7 (32-bit); Core2 Q8200, Asus P5N-D, ATI Sapphire HD5670 with Bitstreaming; DVD/BD Drive, 4GB Ram, 8TB Storage Internal
Tuners: Clear QAM Dual Tuner; HD-PVR -- Time Warner Cable / Control STB via Firewire; use USB-UIRT with LM Gestion Remote KeyMap
Reply With Quote
  #47  
Old 10-07-2010, 05:14 PM
Zippster's Avatar
Zippster Zippster is offline
Sage Aficionado
 
Join Date: Jun 2008
Location: Buffalo NY
Posts: 314
Installed brand new via the plugin manager, where is the setup tool for the channels? I would prefer to do it on the server instead of opening ports etc for the webpage if possible.
Reply With Quote
  #48  
Old 10-08-2010, 09:32 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by Zippster View Post
Installed brand new via the plugin manager, where is the setup tool for the channels? I would prefer to do it on the server instead of opening ports etc for the webpage if possible.
Do you want to run the config tools on a different host to the host that runs sageTV server and web feed encoder?

If its the same host you can:

Use a browser without opening ports - it should work right the opening ports on router is about access from outside.

Or you can run it the old way:

java -jar webfeedencoder/libs/configtool.jar

(running from a command shell in the SageTV directory)

If its from a different host you can copy the webfeedencoder/libs and create a logs directory and run it

java -jar webfeedencoder/libs/configtool.jar -host=<serverhost> -port=<wfemgtport>

(But your possibly still going to have to open some ports)

With the java web start way you can ask shortcuts to be installed so it never goes via a browser.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #49  
Old 10-08-2010, 09:23 PM
Zippster's Avatar
Zippster Zippster is offline
Sage Aficionado
 
Join Date: Jun 2008
Location: Buffalo NY
Posts: 314
Command shell is what I missed, thanks Michael, gonna give it a whirl.
Reply With Quote
  #50  
Old 11-15-2010, 08:16 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Arrow Web Feed Encoder 0.9.7 RC2

Web Feed Encoder 0.9.7 RC2 (for SageTV V7 only)
  • Make sure we remove any additional encoder props added by SageTV on uninstall.
  • On disable tidy away any partially built network encoder entries
  • Add addSeriesInfoPublic method to the EPG plugin.
  • Improve code for finding free encoder numbers on install.
  • Make lineup send more resilient to internet connection issues.
  • Fix slowness in stopping plugin when SageTV service is stopped.
  • Add missing command scripts for linux.
  • Many fixes to allow webfeedencoder operation in linux.
  • Fix stop encoder button which is occasionally enabled when it should not be.
  • Multi-platform service wrapper support.
  • Send logs to developer menu item added to help menu of the config tool.
  • Remove BBC Backstage EPG grabber which the BBC no longer supports.
  • Update the BBC sample channels so that the EPG comes from radiotime.

Just submitted plugin update for SageTV V7.

Use the SageTV V7 plugin manager to take the upgrade.

The user guide is here:

http://www.keepandshare.com/doc/2373...ser-guide?da=y

Anyone who used my sample BBC channels is advised to recopy those channels from the channels/samples directory into the channels directory and restart the encoder and resend the EPG. This is to fix mnissing EPG because the BBC stop supporting the EPG feed.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer

Last edited by michaeldjcox; 11-15-2010 at 08:48 AM.
Reply With Quote
  #51  
Old 11-15-2010, 08:57 PM
Brent94Z Brent94Z is offline
Sage Fanatic
 
Join Date: Aug 2004
Posts: 863
Thanks, Michael! Installed the new version now have to play around with it Thanks much again for your work on this!
Reply With Quote
  #52  
Old 11-16-2010, 03:13 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
WFE 0.9.7 downloads.

My file sharing provider says I have exceeded my daily bandwidth limit yesterday and blocked a number of WFE downloads.

Please try again later...

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #53  
Old 12-16-2010, 09:51 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
So final version of WFE 0.9.7 released.

Hosting is now with SageTV so bandwidth issues hopefully are less of an issue.

You'll also notice in the plugin manager that there is now a demo video.

My first try at producing a video - so could be slicker.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #54  
Old 12-18-2010, 06:26 PM
freewheeling's Avatar
freewheeling freewheeling is offline
Sage Aficionado
 
Join Date: Nov 2009
Location: Virginia
Posts: 482
PJTV or XFinity On Demand?

I was wondering if it's possible to implement either of these using WebFeedEncoder? Both require a username and password, and it doesn't appear that that's possible. They're also pretty complex sites so a PlayOn script might be a better way to go, but neither has been developed yet.

http://www.pjtv.com
http://www.fancast.com/ondemand

(Xfinity and Fancast seem to be the same thing.)
Reply With Quote
  #55  
Old 12-19-2010, 05:13 PM
freewheeling's Avatar
freewheeling freewheeling is offline
Sage Aficionado
 
Join Date: Nov 2009
Location: Virginia
Posts: 482
I've installed the plugin on SageTV 7 and have the configuration tool working. I got the NPR book tour podcast to work, but none of the online TV channels work. Here's the VLC log for BBC One:

[Update: I do get something on the NASA channel with the link posted earlier on this thread. It's mostly just black screen but it flickers every once in awhile.]

[Update 2: I tried the "Watch Live" link in the debug file on my browser and got the message that it's "not available in your area" so that probably explain why there's nothing to play. But I get basically the same result with all of the online TV links from that site. Is there a link that reliably puts out programming that I can try just to verify that it *would* work if there were something on?]

[Well, I'm about to give up on this. There's "nothing to play" even on the post highly rated of the channels. They're all pretty much DOA.]



Code:
- logger module started --
main debug: using interface module "logger"
main debug: TIMER module_need() : 49.000 ms - Total 49.000 ms / 1 intvls (Avg 49.000 ms)
main debug: thread (interface) created at priority 0 (../.././src/interface/interface.c:151)
main debug: looking for interface module: 1 candidate
main debug: using interface module "hotkeys"
main debug: TIMER module_need() : 51.000 ms - Total 51.000 ms / 1 intvls (Avg 51.000 ms)
main debug: thread (interface) created at priority 0 (../.././src/interface/interface.c:151)
main debug: adding item `http://www.bbc.co.uk/bbcone/watchlive/' ( http://www.bbc.co.uk/bbcone/watchlive/ )
main debug: looking for interface module: 1 candidate
main debug: rebuilding array of current - root Playlist
main debug: rebuild done - 1 items, index -1
main debug: thread started
main debug: thread started
main debug: thread ended
main debug: using interface module "globalhotkeys"
main debug: TIMER module_need() : 61.000 ms - Total 61.000 ms / 1 intvls (Avg 61.000 ms)
main debug: thread (interface) created at priority 0 (../.././src/interface/interface.c:151)
main debug: looking for interface module: 1 candidate
rc debug: base: localhost, port: 5003
main debug: net: listening to localhost port 5003
main debug: thread started
main debug: thread ended
main debug: using interface module "rc"
main debug: TIMER module_need() : 80.000 ms - Total 80.000 ms / 1 intvls (Avg 80.000 ms)
main debug: thread (interface) created at priority 0 (../.././src/interface/interface.c:151)
main debug: thread started
main debug: processing request item null node Playlist skip 0
main debug: starting new item
main debug: creating new input thread
main debug: Creating an input for 'http://www.bbc.co.uk/bbcone/watchlive/'
main debug: thread (input) created at priority 1 (../.././src/input/input.c:230)
main debug: thread started
main debug: stream=`transcode'
main debug: looking for sout stream module: 1 candidate
main debug: stream=`duplicate'
main debug: looking for sout stream module: 1 candidate
stream_out_duplicate debug: creating 'duplicate'
stream_out_duplicate debug:  * adding `std{access=file,mux=ts,dst='C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\tmp\BBCOne_test.mpg'}'
main debug: stream=`std'
main debug: looking for sout stream module: 1 candidate
main debug: set config option: sout-standard-access to file
main debug: set config option: sout-standard-mux to ts
main debug: set config option: sout-standard-dst to C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\tmp\BBCOne_test.mpg
stream_out_standard debug: creating `file/ts://C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\tmp\BBCOne_test.mpg'
stream_out_standard debug: extension is mpg
stream_out_standard debug: extension -> mux=ps
stream_out_standard debug: using `file/ts://C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\tmp\BBCOne_test.mpg'
main debug: looking for sout access module: 1 candidate
access_output_file debug: file access output opened (C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\tmp\BBCOne_test.mpg)
main debug: using sout access module "access_output_file"
main debug: TIMER module_need() : 31.000 ms - Total 31.000 ms / 1 intvls (Avg 31.000 ms)
stream_out_standard debug: access opened
main debug: looking for sout mux module: 1 candidate
mux_ts debug: shaping=200000 pcr=70000 dts_delay=400000
main debug: using sout mux module "mux_ts"
main debug: TIMER module_need() : 51.000 ms - Total 51.000 ms / 1 intvls (Avg 51.000 ms)
main debug: muxer support adding stream at any time
main debug: muxer prefers to wait for all ES before starting to mux
stream_out_standard debug: mux opened
main debug: using sout stream module "stream_out_standard"
main debug: TIMER module_need() : 109.000 ms - Total 109.000 ms / 1 intvls (Avg 109.000 ms)
main debug: using sout stream module "stream_out_duplicate"
main debug: TIMER module_need() : 132.000 ms - Total 132.000 ms / 1 intvls (Avg 132.000 ms)
main debug: set config option: sout-transcode-vcodec to mp2v
main debug: set config option: sout-transcode-vb to 800
main debug: set config option: sout-transcode-fps to 30
main debug: set config option: sout-transcode-scale to 1
main debug: set config option: sout-transcode-width to 720
main debug: set config option: sout-transcode-height to 576
main debug: set config option: sout-transcode-acodec to mpga
main debug: set config option: sout-transcode-ab to 128
main debug: set config option: sout-transcode-channels to 2
stream_out_transcode debug: codec audio=mpga 0Hz 2 channels 128Kb/s
stream_out_transcode debug: codec video=mp2v 720x576 scaling: 1.000000 800kb/s
main debug: using sout stream module "stream_out_transcode"
main debug: TIMER module_need() : 180.000 ms - Total 180.000 ms / 1 intvls (Avg 180.000 ms)
main debug: using timeshift granularity of 50 MBytes
main debug: using timeshift path 'C:\Windows\system32\config\systemprofile\AppData\Local\Temp'
main debug: `http://www.bbc.co.uk/bbcone/watchlive/' gives access `http' demux `' path `www.bbc.co.uk/bbcone/watchlive/'
main debug: creating demux: access='http' demux='' path='www.bbc.co.uk/bbcone/watchlive/'
main debug: looking for access_demux module: 0 candidates
main debug: no access_demux module matched "http"
main debug: TIMER module_need() : 1.000 ms - Total 1.000 ms / 1 intvls (Avg 1.000 ms)
main debug: creating access 'http' path='www.bbc.co.uk/bbcone/watchlive/'
main debug: looking for access module: 2 candidates
access_http debug: http: server='www.bbc.co.uk' port=80 file='/bbcone/watchlive/
main debug: net: connecting to www.bbc.co.uk port 80
main debug: connection: Resource temporarily unavailable
main debug: connection succeeded (socket = 608)
access_http debug: protocol 'HTTP' answer code 200
access_http debug: Server: Apache
access_http debug: Accepting Cookie: BBC-UID=d4fda01e09809261853c487911e15501ac57635f30f0a1d4343fa987cd96816f0VLC%20media%20player%20%2d%20version%201%2e0%2e5%20Goldeneye%20%2d%20%28c%29%201996%2d2010%20the%20VideoLAN%20team; expires=Thu, 18-Dec-14 23:07:13 GMT; path=/; domain=bbc.co.uk;
access_http debug: Transfer-Encoding: chunked
access_http debug: Content-Type: text/html
main debug: using access module "access_http"
main debug: TIMER module_need() : 836.000 ms - Total 836.000 ms / 1 intvls (Avg 836.000 ms)
main debug: Using AStream*Stream
main debug: pre buffering
main debug: received first data after 0 ms
main debug: pre-buffering done 605 bytes in 0s - 590820 kbytes/s
main debug: looking for stream_filter module: 2 candidates
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: looking for stream_filter module: 1 candidate
main debug: using stream_filter module "stream_filter_record"
main debug: TIMER module_need() : 1.000 ms - Total 1.000 ms / 1 intvls (Avg 1.000 ms)
main debug: creating demux: access='http' demux='' path='www.bbc.co.uk/bbcone/watchlive/'
main debug: looking for demux module: 50 candidates
ts warning: TS module discarded (lost sync)
lua debug: Trying Lua scripts in C:\Windows\system32\config\systemprofile\AppData\Roaming\vlc\lua\playlist
lua debug: Trying Lua scripts in C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\anevia_streams.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\appletrailers.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\bbc_co_uk.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\break.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\canalplus.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\cue.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\dailymotion.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\france2.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\googlevideo.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\joox.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\koreus.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\lelombrik.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\megavideo.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\metacafe.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\mpora.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\vimeo.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\youtube.lua
lua debug: Trying Lua playlist script C:\Program Files (x86)\VideoLAN\VLC\\lua\playlist\youtube_homepage.lua
lua debug: Trying Lua scripts in C:\Program Files (x86)\VideoLAN\VLC\\share\lua\playlist
avformat debug: couldn't guess format
vobsub debug: this doesn't seem to be a vobsub file
ps warning: this does not look like an MPEG PS stream, continuing anyway
main debug: using demux module "ps"
main debug: TIMER module_need() : 1934.000 ms - Total 1934.000 ms / 1 intvls (Avg 1934.000 ms)
main debug: looking for a subtitle file in C:\Program Files (x86)\SageTV\SageTV\webfeedencoder\wrapper\
main debug: starting in sync mode
main debug: `http://www.bbc.co.uk/bbcone/watchlive/' successfully opened
ps warning: garbage at input, trying to resync...
main debug: EOF reached
main debug: removing module "ps"
main debug: removing module "stream_filter_record"
main debug: removing module "access_http"
main debug: waitpipe: object killed
main debug: finished input
main debug: thread ended
main debug: dead input
main debug: destroying useless sout
main debug: destroying chain... (name=transcode)
main debug: destroying chain... (name=duplicate)
stream_out_duplicate debug: closing a duplication
main debug: destroying chain... (name=std)
main debug: removing module "mux_ts"
access_output_file debug: file access output closed
main debug: removing module "access_output_file"
main debug: removing module "stream_out_standard"
main debug: destroying chain done
main debug: removing module "stream_out_duplicate"
main debug: destroying chain done
main debug: removing module "stream_out_transcode"
main debug: destroying chain done
main debug: thread times: real 0m2.985000s, kernel 0m0.031200s, user 0m0.046800s
main debug: TIMER input launching for 'http://www.bbc.co.uk/bbcone/watchlive/' : 2978.000 ms - Total 2978.000 ms / 1 intvls (Avg 2978.000 ms)
main debug: changing item without a request (current 0/1)
main debug: nothing to play

Last edited by Opus4; 12-20-2010 at 05:06 AM. Reason: Use [code] not [quote] for logs
Reply With Quote
  #56  
Old 12-20-2010, 03:57 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Hi,

You won't be able to get access to BBC channels outside the UK in a similar way we cannot get access to any US channels or Hulu here in the UK.

TV can be problematic - my source of TV stream links - allinternettv.com is a little unreliable these days. Links get out of date etc.

NASATV is always reliable - but the link published on allinternettv.com is wrong.

The NASATV sample channel is good though - if you cannot see that then there may be something to fix in your installation.

Are you using VLC version 1.0.5? Its the latest one that works. All the VLC 1.1 versions have issues at the moment.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #57  
Old 12-20-2010, 04:16 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by freewheeling View Post
I was wondering if it's possible to implement either of these using WebFeedEncoder? Both require a username and password, and it doesn't appear that that's possible. They're also pretty complex sites so a PlayOn script might be a better way to go, but neither has been developed yet.

http://www.pjtv.com
http://www.fancast.com/ondemand

(Xfinity and Fancast seem to be the same thing.)
Not tried these.

On the username/password - may need some work - although often username passwords are sent in URLs anyway.

This that tend to be more of an issue are DRM and flashplayers where we cannot get access to the actual stream URL.

I can add the PJTV video rss as a podcast in WFE and export to SageTV - but theres only about 7 videos there. Possibly more if you register I guess.

UPDATE: but not of the links can play because they pull up a web page with a flash player in it. We need a stream URL to playback.

Generally I'm having a big think about where WFE fits in the picture where there is some overlap between Playon, TVersity, WFE. More on this soon.

Michael
Attached Images
File Type: jpg pjtv.jpg (306.5 KB, 137 views)
__________________
Web Feed Encoder developer
SageTV Catchup developer

Last edited by michaeldjcox; 12-20-2010 at 05:35 AM.
Reply With Quote
  #58  
Old 12-20-2010, 01:53 PM
freewheeling's Avatar
freewheeling freewheeling is offline
Sage Aficionado
 
Join Date: Nov 2009
Location: Virginia
Posts: 482
Quote:
Originally Posted by michaeldjcox View Post

The NASATV sample channel is good though - if you cannot see that then there may be something to fix in your installation.

Are you using VLC version 1.0.5? Its the latest one that works. All the VLC 1.1 versions have issues at the moment.
Yeah, I re-installed version 1.0.5 but wasn't sure what properties to set. I've allowed all traffic on all ports in my firewall for VLC, and the three ports mentioned for WFE: 8888, 1099 & 1111 .
Reply With Quote
  #59  
Old 12-20-2010, 02:04 PM
freewheeling's Avatar
freewheeling freewheeling is offline
Sage Aficionado
 
Join Date: Nov 2009
Location: Virginia
Posts: 482
Quote:
Originally Posted by michaeldjcox View Post

Generally I'm having a big think about where WFE fits in the picture where there is some overlap between Playon, TVersity, WFE. More on this soon.

Michael
Thanks. I use Playon for HULU which is part of their main channels section. You can enter a username and password for HULU, Amazon VOD, etc.. Most of these Online TV Channels are on demand, but there are a number that are schedule based and it would be nice to integrate those into the "program guide."

Someone mentioned "Breitbart TV" but that's not really an online channel so much as a text commentary on media with an occasional Youtube embedded.

BTW, the Netflix implementation in PlayOn works in SageTV, but it's not nearly as user friendly as the implementation in Plex. I don't know what it's like on the "game systems". In fact Netflix in Plex works better than any of the other connections I've tried. It's way faster than on my Samsung Bluray player, for instance.
Reply With Quote
  #60  
Old 12-21-2010, 01:16 PM
freewheeling's Avatar
freewheeling freewheeling is offline
Sage Aficionado
 
Join Date: Nov 2009
Location: Virginia
Posts: 482
Is there a better place, or perhaps an app, that discovers the tuning parameters of an online channel? Allinternettv seems sort of clunky.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Utility: Web Radio and TV Encoder michaeldjcox SageTV Customizations 857 03-06-2016 09:59 AM
Plugin: SageTV Web Interface V2 for Jetty jreichen SageTV Customizations 256 02-09-2014 08:05 AM
Web Radio and TV encoder Announcement Thread michaeldjcox Customization Announcements 6 12-10-2010 03:56 PM
SageTV and web radio michaeldjcox SageTV Customizations 3 12-01-2008 11:09 AM
STV Import: Web Radio Plugin for SageMC v1.1b 7/31/06 Morgan111 SageMC Custom Interface 90 03-24-2008 08:17 AM


All times are GMT -6. The time now is 03:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.