SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations > SageMC Custom Interface

Notices

SageMC Custom Interface This forum is for discussing the user-created SageMC custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-15-2009, 11:02 AM
kfontenot kfontenot is offline
Sage User
 
Join Date: Jul 2008
Location: Texas
Posts: 25
Dynamic Video Menu missing some movies

I have created a dynamic menu to point to a specific video library, but I noticed that some of the videos are not showing up when I view the new menu. I was attempting to split up my BluRay and DVDs into two different menus. When I view the existitng SageTV Video library menu item all of the movies show up as expected. I am running the latest version of SageTV 6.5.12 and SageMC also. Here is the code I used to create the dynamic menu :

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<!DOCTYPE sageMenu PUBLIC "-//NIELM//DTD SAGEMENU XML 1.4//EN" "http://www.sage-community.org/~nielm/nielm_modules/dynamic_menu/sagemenu_1_3.dtd">
<sageMenu version="1.4">
<internalScreenMenuItem icon="C:\Program Files (x86)\SageTV\SageTV\nBlue\STVs\SageTV3\SageMCE\Themes\nBlue\MenuIcons\videos.png" screen="Video Library Folder View" title="My Videos">
<evalExpression>AddStaticContext("PathFilterExprs", new_java_util_ArrayList())</evalExpression>
<evalExpression>java_util_List_add(PathFilterExprs, "\\\\TOWER\\Movies")</evalExpression>
<evalExpression>AddStaticContext("PathFilterExcludes", false)</evalExpression>
</internalScreenMenuItem>
</sageMenu>

I do not have any filters set. I ran Sage with debug_logging=TRUE and saw the following messages for the movies that I saw missing from the menu :

Sun 3/15 3:43:30.817 Attempted to add already existing file path to database: \\TOWER\Movies\BECOMING_JANE\VIDEO_TS returning exisitng MF of: MediaFile[id=2531752 A[2531755,2531753,"BECOMING_JANE/VIDEO_TS",0@0627.17:27,0] host=hther encodedBy= format=null \\tower\Movies\BECOMING_JANE\VIDEO_TS, Seg0[Fri 6/27 17:27:57.999-Fri 6/27 17:27:58.000]]
Sun 3/15 3:43:30.818 New Library DVD/BluRay MediaFile[id=2531752 A[2531755,2531753,"BECOMING_JANE/VIDEO_TS",0@0627.17:27,0] host=hther encodedBy= format=null \\tower\Movies\BECOMING_JANE\VIDEO_TS, Seg0[Fri 6/27 17:27:57.999-Fri 6/27 17:27:58.000]]

Should I send a bug report for this? Has anyone else run into this problem?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem using dynamic menu to filter video screen Tiki SageMC Custom Interface 5 11-14-2009 06:54 AM
Dock menu problem/dynamic menu issue? planetc SageMC Custom Interface 0 01-10-2009 07:31 PM
Dynamic menu import breaks Custom Online Video Feeds pants55 SageTV Customizations 0 05-24-2008 07:26 AM
Dynamic Menu codacoda SageTV Customizations 3 04-03-2006 12:40 PM
Imported movies missing Dalhectar SageTV Software 2 01-02-2005 04:01 PM


All times are GMT -6. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.