SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Phoenix

Notices

Phoenix This forum is for discussing the user-created Phoenix custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-22-2016, 03:49 PM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
Brand new phoenix missing views

Code:
016-09-22 17:43:28,294 [PluginEventQueue] WARN  sagex.phoenix.vfs.VFSManager - Failed to load vfs sources from: .\userdata\Phoenix\cache\vfs-cached.xml; Dynamic Views/Sources will most likely be empty until the problem is resolved.
java.lang.NullPointerException
	at sagex.phoenix.vfs.builder.FactoryItemBuilder.startElement(FactoryItemBuilder.java:36)
	at sagex.phoenix.vfs.builder.VFSBuilder.startElement(VFSBuilder.java:115)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.emptyElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at sagex.phoenix.vfs.builder.VFSBuilder.registerVFSSources(VFSBuilder.java:87)
	at sagex.phoenix.vfs.builder.VFSBuilder.registerVFSSources(VFSBuilder.java:53)
	at sagex.phoenix.vfs.VFSManager.visitConfigurationFile(VFSManager.java:195)
	at sagex.phoenix.vfs.VFSManager.rebuildCache(VFSManager.java:256)
	at sagex.phoenix.vfs.VFSManager.loadConfigurations(VFSManager.java:209)
	at sagex.phoenix.Phoenix.initServices(Phoenix.java:237)
	at sagex.phoenix.plugin.PhoenixPlugin.onPluginsLoaded(PhoenixPlugin.java:294)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at sagex.plugin.AbstractPlugin.invoke(AbstractPlugin.java:267)
	at sagex.plugin.AbstractPlugin.sageEvent(AbstractPlugin.java:201)
	at sage.plugin.PluginEventManager.run(PluginEventManager.java:241)
	at java.lang.Thread.run(Unknown Source)
Attached my files as well, any ideas why this happens on all my new installs?
Attached Files
File Type: zip attachs.zip (21.2 KB, 47 views)
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders
Reply With Quote
  #2  
Old 09-22-2016, 05:07 PM
trk2 trk2 is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Maine
Posts: 340
It's probably this issue.
Reply With Quote
  #3  
Old 09-22-2016, 05:15 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,538
reinstall Phoenix... i can tell from the x-vfs.xml file that this is "old" vfs file. Seems like sagetv is not updating phoenix.

Maybe remove phoenix and phoenix-api and then remove the STVs/Phoenix/ directory and then re-install them both.
Reply With Quote
  #4  
Old 09-22-2016, 06:05 PM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
This was a brand new install (today). The views were missing, so i copied the xml files over from a "working" client.

ill try again
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders
Reply With Quote
  #5  
Old 09-22-2016, 06:31 PM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
well that didnt work. I unistalled every plugin i had.

1. Install Gemstone
2. Reload UI
3. empty views (it still sees my old views, so something isnt getting deleted/update).
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders
Reply With Quote
  #6  
Old 09-22-2016, 08:59 PM
jptheripper jptheripper is offline
Sage Fanatic
 
Join Date: Dec 2007
Location: Florida
Posts: 935
Downloading the replacement X-vfs file fixed the issue. Thanks all
__________________
Gigabyte GA-MA770-DS3/4gb DDR2/AMD Phenom 955 3.2ghz Quad Core
Windows 7 64bit Home Premium
Hauppauge 1600/1850/2250/colossus/2650(CableCard 2 tuner)
8tb RAID5 storage/media/other &3tb RAID5 backup storage on a HighPoint RocketRaid 2680
1tb 3 disk Recording Pool
all in a beautiful Antec 1200
SageMyMovies/Comskip/PlayON/SageDCT/SRE
HD100/HD300 extenders
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Using sagex with phoenix views HokiePerogi SageTV v7 Customizations 6 03-25-2014 02:27 PM
upgraded phoenix & stv, now views not loading JonTom Phoenix 13 05-09-2013 04:55 PM
User Categories in Phoenix views Fuzzy Phoenix 4 01-02-2012 09:19 AM
I am missing all my views... Biggen Batch Metadata Tools 4 10-05-2011 07:52 AM
VFS Views - What's missing? stuckless Phoenix 20 03-12-2011 06:26 PM


All times are GMT -6. The time now is 08:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.