SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #2921  
Old 01-13-2022, 04:50 PM
CptKirk CptKirk is offline
Sage Aficionado
 
Join Date: Sep 2010
Posts: 251
Yes, I was following that post step by step as well when I started this little torture trip (which I thought would be a piece of cake ).

I was just trying to follow JustFred's suggestions exactly.

I started the opendct service, checked sage.properties for the mmc/encoder entries. Not there.

I started the sagetv service, checked sage.properties for the mmc/encoder entries. Not there.



I'll message enternoescape and see if he would be willing to try and take a look.
__________________
SageTV running on: Win10 21H2
SageTV 9.2.6.976 (64 bit)
Java 1.8.0 311 (64 bit)
OpenDCT 0.5.32 (64 bit)
Clients: HD300 (x2)
HDHR3-CC Prime 20220203 (Comcast CableCard) - 3 Tuners
HDFX-4K Flex 20220203 (OTA) - 4 Tuners

Last edited by CptKirk; 01-13-2022 at 04:53 PM.
Reply With Quote
  #2922  
Old 01-13-2022, 05:29 PM
trk2 trk2 is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Maine
Posts: 480
One thing I see from both openDCT and Sage logs is Sage is repeatedly requesting your old, now removed, prime tuners. I would delete the old prime tuners from your Sage properties file.

Remove the "mmc/encoders" entries for each obsolete tuner identified. (Ex. "mmc/encoders/UNIQUE_ID/video_capture_device_name=DCT-HDHomeRun Prime Tuner 13182976". So delete all "mmc/encoders/UNIQUE_ID that correspond to 13182976.
Reply With Quote
  #2923  
Old 01-13-2022, 05:46 PM
CptKirk CptKirk is offline
Sage Aficionado
 
Join Date: Sep 2010
Posts: 251
I had left one, 13182976-0, so that I could copy the lineup from it to the new prime tuners. I deleted 13182976-1 and 13182976-2.

Guess I will try to delete that other one as well.

Edit...

Removed the last entry for the old 13182976 removed tuner. Did the whole services shutdown, opendct as console, services back on. Checked sage.properties the opendct tuners do not show up.
__________________
SageTV running on: Win10 21H2
SageTV 9.2.6.976 (64 bit)
Java 1.8.0 311 (64 bit)
OpenDCT 0.5.32 (64 bit)
Clients: HD300 (x2)
HDHR3-CC Prime 20220203 (Comcast CableCard) - 3 Tuners
HDFX-4K Flex 20220203 (OTA) - 4 Tuners

Last edited by CptKirk; 01-13-2022 at 08:34 PM.
Reply With Quote
  #2924  
Old 01-13-2022, 10:18 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,657
From looking at your log, it looks like there's some confusion about what's configured and what's being called by SageTV:

Code:
17:12:37.660 [HDHomeRunDiscoveryReceive-39] INFO  SageTVManager - The capture device 'DCT-HDHomeRun Prime Tuner 1324B362-2' is ready.
17:13:14.289 [SageTVRequestHandler-132:Unknown] DEBUG SageTVManager - The capture device 'DCT-HDHomeRun Prime Tuner 13182976-2' is not yet available.
The first line shows that OpenDCT found and made available 1324B362. The second line shows SageTV calling 13182976 which OpenDCT did not discover. I didn't note you mentioning two HDHomeRun Primes.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #2925  
Old 01-13-2022, 10:26 PM
CptKirk CptKirk is offline
Sage Aficionado
 
Join Date: Sep 2010
Posts: 251
13182976 is the Prime that got damaged by lightning. It is not connected to the network (actually in the trash).

1324B362 is the new Prime purchased to replace the damaged one.

I cleaned up (removed) all references to 13182976 in the sage.properties file.

I unplugged the power as ENE suggested to just have the 1324B362 Prime connected to the network and tried to do the config again.

No luck unfortunately. 1324B362 did not show up in the sage.properties file.

Log files attached.
Attached Files
File Type: zip opendct2.zip (177.9 KB, 17 views)
__________________
SageTV running on: Win10 21H2
SageTV 9.2.6.976 (64 bit)
Java 1.8.0 311 (64 bit)
OpenDCT 0.5.32 (64 bit)
Clients: HD300 (x2)
HDHR3-CC Prime 20220203 (Comcast CableCard) - 3 Tuners
HDFX-4K Flex 20220203 (OTA) - 4 Tuners
Reply With Quote
  #2926  
Old 01-14-2022, 08:17 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,657
I'm confused about what I'm seeing. It looks like OpenDCT was completely ready by 22:15:06.181, then the service was stopped 30 seconds later. The SageTV log shows SageTV started at 20:31:24.150 and shut down at 22:09:23.029. OpenDCT needs to be running before SageTV starts. SageTV only does the discovery broadcast at startup which was done at 20:31:31.202 which would have been before OpenDCT appears to have even been running.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #2927  
Old 01-14-2022, 11:50 PM
CptKirk CptKirk is offline
Sage Aficionado
 
Join Date: Sep 2010
Posts: 251
My process is always:

1. Run "OpenDCT Run as Console".
2. CTRL-C on OpenDCT Following Download of Channel Lineups.
3. Run "OpenDCT Start Service" - Success!
4. Start SageTV Service.
5. Start SageTV and try to add new source

I was trying a number of different things (firewall changes, upnp changes, etc). But I always waited until after OpenDCT Service before starting the SageTV Service.

I keep Computer Management-Services open so that I can see when the two services are running or not.

I got too frustrated with it after all day yesterday so stepped back from it today. Did not think about it or look at until now.

I will dig into it more tomorrow morning.

Hopefully with some better logs.

I appreciate you taking the time to take a look.
__________________
SageTV running on: Win10 21H2
SageTV 9.2.6.976 (64 bit)
Java 1.8.0 311 (64 bit)
OpenDCT 0.5.32 (64 bit)
Clients: HD300 (x2)
HDHR3-CC Prime 20220203 (Comcast CableCard) - 3 Tuners
HDFX-4K Flex 20220203 (OTA) - 4 Tuners
Reply With Quote
  #2928  
Old 01-17-2022, 01:28 PM
willieb willieb is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: Philadelphia
Posts: 173
I'm pretty sure I once knew the answer to what I am about to ask, but when things "just work" for 18 months or so you forget everything next time you start tinkering.

I have been getting some pauses and stutters with my miniclient in certain fios channels using my HDHR Prime lately. I am actually pretty sure it is an exoplayer problem and I am hoping Josh's new version with a new exoplayer will be out of beta soon (I am a patreon supporter of his, but I have been too lazy to sideload the apk!) and will fix it. But for today I thought I would check opendct to see if I can get it to clean up the streams some.

I am running on Unraid. New sage/opendct implementation using java 11 by jusjoken. I have been taking to opportunity to look at my opendct.properties file. There is a line:

consumer.dynamic.default=opendct.consumer.MediaServerConsumerImpl

I could have sworn at some point I changed this to:

consumer.dynamic.default=opendct.consumer.FFmpegTransSageTVConsumerImpl

So I just tried changing it several times and every time I restart the docker it changes it back to MediaServerConsumer instead of FFmpegTransSageConsumer. I think i remember that starting the docker rebuilds certain things every time and I am sure that is what's going on here, but is there any way I can change the default and have it not get overwritten? Is there a different file somewhere where I can set the default that it uses to overwrite with?

I should also say that I DO have all of my tuners set to:

sagetv.device.-xxxxxxxxxx.consumer=opendct.consumer.FFmpegTransSageTVConsumerImpl

And that sticks. So maybe I don't even need to worry about the consumer.dynamic.default, but I wanted to ask. I seem to recall that opendct can "clean up" some irregularities in streams coming over the fios using ffmpeg so I want to make sure it is doing that.

Can anyone shed any light? Thanks very much!
Reply With Quote
  #2929  
Old 01-17-2022, 03:07 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,566
Quote:
Originally Posted by willieb View Post
I'm pretty sure I once knew the answer to what I am about to ask, but when things "just work" for 18 months or so you forget everything next time you start tinkering.

I have been getting some pauses and stutters with my miniclient in certain fios channels using my HDHR Prime lately. I am actually pretty sure it is an exoplayer problem and I am hoping Josh's new version with a new exoplayer will be out of beta soon (I am a patreon supporter of his, but I have been too lazy to sideload the apk!) and will fix it. But for today I thought I would check opendct to see if I can get it to clean up the streams some.

I am running on Unraid. New sage/opendct implementation using java 11 by jusjoken. I have been taking to opportunity to look at my opendct.properties file. There is a line:

consumer.dynamic.default=opendct.consumer.MediaServerConsumerImpl

I could have sworn at some point I changed this to:

consumer.dynamic.default=opendct.consumer.FFmpegTransSageTVConsumerImpl

So I just tried changing it several times and every time I restart the docker it changes it back to MediaServerConsumer instead of FFmpegTransSageConsumer. I think i remember that starting the docker rebuilds certain things every time and I am sure that is what's going on here, but is there any way I can change the default and have it not get overwritten? Is there a different file somewhere where I can set the default that it uses to overwrite with?

I should also say that I DO have all of my tuners set to:

sagetv.device.-xxxxxxxxxx.consumer=opendct.consumer.FFmpegTransSageTVConsumerImpl

And that sticks. So maybe I don't even need to worry about the consumer.dynamic.default, but I wanted to ask. I seem to recall that opendct can "clean up" some irregularities in streams coming over the fios using ffmpeg so I want to make sure it is doing that.

Can anyone shed any light? Thanks very much!
For some reason unknown to me that line is added by the docker... So when I made the new dockers i left the code in there that adds it.

I can change the docker to NOT add this line but would like to understand what it does and why fuzzy likely decided it needed to be forced.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #2930  
Old 01-17-2022, 03:17 PM
willieb willieb is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: Philadelphia
Posts: 173
Quote:
Originally Posted by jusjoken View Post
For some reason unknown to me that line is added by the docker... So when I made the new dockers i left the code in there that adds it.

I can change the docker to NOT add this line but would like to understand what it does and why fuzzy likely decided it needed to be forced.

K
Got it. Yeah I am not sure either. I wonder if I am ok since I changed all of my tuners to use the FFmpegTransSage option. My only concern was that this default line was overriding the tuner-specific properties.
Reply With Quote
  #2931  
Old 01-17-2022, 04:06 PM
technazz's Avatar
technazz technazz is offline
Sage Aficionado
 
Join Date: Jul 2004
Location: Hamilton, ON, CA
Posts: 490
Quote:
Originally Posted by willieb View Post
Got it. Yeah I am not sure either. I wonder if I am ok since I changed all of my tuners to use the FFmpegTransSage option. My only concern was that this default line was overriding the tuner-specific properties.
Try changing them to
sagetv.device.XXXXXXXXXX.consumer=opendct.consumer.RawSageTVConsumerImpl

Ive been using this setting for a few years
__________________
SageTV V9.xx 2 x HD300's, 2 x Nvidia Shields Running Mini Client
Reply With Quote
  #2932  
Old 01-17-2022, 05:41 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
SageTVaholic
 
Join Date: Dec 2006
Posts: 2,636
Quote:
Originally Posted by CptKirk View Post
I had left one, 13182976-0, so that I could copy the lineup from it to the new prime tuners.
I wonder if this idea we had actually became a problem. Is it okay to *copy* a lineup to a new tuner, and then remove the tuner with the original lineup? Does Sage try and maintain some kind of relationship with the original tuner even when missing?
Reply With Quote
  #2933  
Old 01-17-2022, 07:06 PM
JustFred JustFred is offline
Sage Expert
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 562
Quote:
Originally Posted by KryptoNyte View Post
I wonder if this idea we had actually became a problem. Is it okay to *copy* a lineup to a new tuner, and then remove the tuner with the original lineup? Does Sage try and maintain some kind of relationship with the original tuner even when missing?
By choosing to *copy* an existing lineup in Sage, the resulting lineup is static; it's no longer automatically updated with changes from the original EPG source. Except for special cases, this is probably undesirable.

On the other hand, Sage remains happy if choosing "Use existing lineup" for a new tuner and then removing the old tuner.
__________________
System #1: Win7-64, I7-920, 8 GB mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB mem, 4TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HVR2250; Spectrum Cable via HDPVR & USB-UIRT. 3x HD-200.
Reply With Quote
  #2934  
Old 01-17-2022, 07:13 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
SageTVaholic
 
Join Date: Dec 2006
Posts: 2,636
Got it. Thanks for the clarification, Fred.

Just for curiosity sake, is there any reason that you can think of why *copying* a lineup for a different tuner would result in the inability to assign tuner merit specifically?
Reply With Quote
  #2935  
Old 01-17-2022, 08:19 PM
JustFred JustFred is offline
Sage Expert
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 562
Quote:
Originally Posted by KryptoNyte View Post
Got it. Thanks for the clarification, Fred.

Just for curiosity sake, is there any reason that you can think of why *copying* a lineup for a different tuner would result in the inability to assign tuner merit specifically?
Not that I'm aware of.

The tuner merit setting seems to be the source of much confusion and debate. There have been reports that merit seems to be ignored among tuners sharing a common EPG lineup.
__________________
System #1: Win7-64, I7-920, 8 GB mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB mem, 4TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HVR2250; Spectrum Cable via HDPVR & USB-UIRT. 3x HD-200.
Reply With Quote
  #2936  
Old 01-17-2022, 11:01 PM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 7,373
I appear to have, or at least used to have, OpenDCT running on a couple of my PCs as if I go to add a new tuner in SageTV I can see a whole bunch of devices listed like:

HDHomeRun HDHR-US Tuner 1011f5ea-0 on 127.0.0.1:9001
HDHomeRun HDHR-US Tuner 1011f5ea-0 on 192.168.1.99:9000
HDHomeRun HDHR-US Tuner 1011f5ea-1 on 127.0.0.1:9001
HDHomeRun HDHR-US Tuner 1011f5ea-1 on 192.168.1.99:9000
HDHomeRun HDHR-US Tuner 1040e3e1-0 on 192.168.1.99:9000
HDHomeRun HDHR-US Tuner 1040e3e1-1 on 192.168.1.99:9000

But I don't think these are active anymore. For example, 192.168.1.99 is an unRAID server and the OpenDCT docker isn't running. Can I just delete all of these extra tuners? If so, how do I do that? Do I nuke them out of my Sage.properties?

The one that shows up as local host on this instance may actually still be running on a Windows PC. How do I tell if OpenDCT tuner is running on a windows PC. And how do I uninstall it? Do I just use the Uninstall from Programs and Features in Windows Control Panel?
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #2937  
Old 01-21-2022, 06:59 PM
CptKirk CptKirk is offline
Sage Aficionado
 
Join Date: Sep 2010
Posts: 251
Thanks for folks that were giving feedback on my hdhr problems.

I have ended up building a new sagetv server and I have my hdhr tuners detected and working on the new server.

Something I had planned on doing for awhile and since I was getting a real headache I figured that I might as well do it.

Not going to try and debug on the old server anymore.
__________________
SageTV running on: Win10 21H2
SageTV 9.2.6.976 (64 bit)
Java 1.8.0 311 (64 bit)
OpenDCT 0.5.32 (64 bit)
Clients: HD300 (x2)
HDHR3-CC Prime 20220203 (Comcast CableCard) - 3 Tuners
HDFX-4K Flex 20220203 (OTA) - 4 Tuners
Reply With Quote
  #2938  
Old 01-30-2022, 12:30 PM
boukmandutty boukmandutty is offline
Sage Advanced User
 
Join Date: Oct 2011
Location: Norman OK
Posts: 182
I have this recurring problem with my TVE recordings. I draw the feed from channels dvr into sagetv. Every now and then I get an error where the first part of the recording fails. I cant figure out what might be the cause. I thought it was perhaps ffmpeg and switched recently to trying the streamlink but the result is the same. I see the problem whenever the server has not tuned a channel for a couple of hours and then has to tune to record.

The opendct log looks like this:

Code:
06:00:00.030 [SageTVRequestHandler-144:Unknown] DEBUG SageTVRequestHandler - SageTV sent: 'START tuner1 HDMI|140632219|6041|3287088000060|/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg|MPEG2 Max Quality'
06:00:00.031 [SageTVRequestHandler-144:tuner1] DEBUG GenericPipeCaptureDevice - Capture device is now re-locked.
06:00:00.031 [SageTVRequestHandler-144:tuner1] DEBUG SageTVRequestHandler - Starting network encoder via upload ID '140632219' to file name '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg'.
06:00:00.031 [SageTVRequestHandler-144:tuner1] DEBUG BasicCaptureDevice - Consumer is not in progress.
06:00:00.031 [SageTVRequestHandler-144:tuner1] DEBUG DynamicConsumerImpl - Using default consumer 'opendct.consumer.FFmpegTransSageTVConsumerImpl' for channel '6041'
06:00:00.034 [SageTVRequestHandler-144:tuner1] INFO  GenericPipeCaptureDevice - Starting the encoding for the channel '6041' from the device 'tuner1' to the file '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg' via the upload id '140632219'...
06:00:00.034 [SageTVRequestHandler-144:tuner1] DEBUG GenericPipeCaptureDevice - Executing: '/opt/opendct/StreamLink.sh 6041'
06:00:00.035 [SageTVRequestHandler-144:tuner1] INFO  GenericPipeCaptureDevice - Configuring and starting the new SageTV producer...
06:00:00.035 [SageTVRequestHandler-144:tuner1] INFO  GenericPipeCaptureDevice - Configuring and starting the new SageTV consumer...
06:00:00.035 [SageTVRequestHandler-144:tuner1] INFO  NIOSageTVMediaServer - Connecting to SageTV server on socket /192.168.1.228:7818...
06:00:00.035 [SageTVRequestHandler-144:tuner1] INFO  NIOSageTVMediaServer - Sending 'WRITEOPEN /mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg 140632219' to SageTV server...
06:00:00.036 [SageTVRequestHandler-144:tuner1] DEBUG BasicCaptureDevice - Consumer is not in progress.
06:00:00.036 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegTransSageTVConsumerImpl - FFmpeg Transcoder consumer thread is now running.
06:00:00.036 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegTransSageTVConsumerImpl - Thread priority is 9.
06:00:00.036 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegStreamDetection - Calling avformat_open_input
06:00:01.822 [StreamLogger-149] DEBUG GenericPipeCaptureDevice - err: [cli][info] streamlink is running as root! Be careful!
06:00:01.823 [StreamLogger-149] DEBUG GenericPipeCaptureDevice - err: [cli][info] Found matching plugin hls for URL http://127.0.0.1:8089/devices/ANY/channels/6041/hls/master.m3u8
06:00:02.043 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:04.051 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:06.058 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:08.065 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:09.937 [StreamLogger-149] DEBUG GenericPipeCaptureDevice - err: [cli][info] Available streams: 1080p (worst, best)
06:00:09.937 [StreamLogger-149] DEBUG GenericPipeCaptureDevice - err: [cli][info] Opening stream: 1080p (hls)
06:00:10.075 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:10.077 [FFmpegTransSageTVConsumerImpl-151:tuner1] ERROR FFmpegContext - initTsStream: avformat_open_input returned error code -1094995529
06:00:10.078 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegStreamDetection - Calling avformat_open_input
06:00:12.087 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:14.096 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:15.037 [SageTVRequestHandler-144:tuner1] DEBUG SageTVRequestHandler - Replied: 'OK'
06:00:15.037 [SageTVRequestHandler-152:Unknown] DEBUG SageTVRequestHandler - SageTV sent: 'START tuner1 HDMI|140632219|6041|3287088000060|/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg|MPEG2 Max Quality'
06:00:15.037 [SageTVRequestHandler-152:tuner1] INFO  GenericPipeCaptureDevice - Capture device was already locked.
06:00:15.038 [SageTVRequestHandler-152:tuner1] DEBUG SageTVRequestHandler - Starting network encoder via upload ID '140632219' to file name '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg'.
06:00:15.039 [SageTVRequestHandler-152:tuner1] INFO  GenericPipeCaptureDevice - Re-tune came back too fast. Skipping.
06:00:15.039 [SageTVRequestHandler-152:tuner1] DEBUG SageTVRequestHandler - Replied: 'OK'
06:00:16.105 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:18.115 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:20.124 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:20.124 [FFmpegTransSageTVConsumerImpl-151:tuner1] ERROR FFmpegContext - initTsStream: avformat_open_input returned error code -1094995529
06:00:30.126 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegStreamDetection - Calling avformat_open_input
06:00:32.133 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:34.142 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:36.150 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:38.158 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:39.988 [StreamLogger-149] DEBUG GenericPipeCaptureDevice - Stream logger terminated => Stream closed
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] ERROR FFmpegContext - initTsStream: avformat_open_input returned error code -1094995529
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegTransSageTVConsumerImpl - Unable to detect any video.
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  NIOSageTVMediaServer - Sending 'CLOSE' to SageTV server...
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  NIOSageTVMediaServer - Sending 'QUIT' to SageTV server...
06:00:40.174 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegTransSageTVConsumerImpl - FFmpeg Transcoder consumer thread stopped.
06:00:51.458 [SageTVTuningMonitor-48] DEBUG SageTVTuningMonitor - The consumer appears to be stuck at 0, file system length 0, file name '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg', copy protection NONE.
06:00:51.458 [SageTVTuningMonitor-48] DEBUG SageTVTuningMonitor - The producer appears to be stuck at 0.
06:01:07.467 [SageTVTuningMonitor-48] DEBUG SageTVTuningMonitor - The consumer appears to be stuck at 0, file system length 0, file name '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-0.mpg', copy protection NONE.
06:01:07.467 [SageTVTuningMonitor-48] DEBUG SageTVTuningMonitor - The producer appears to be stuck at 0.
06:01:21.828 [SageTVRequestHandler-152:Unknown] DEBUG SageTVRequestHandler - SageTV sent: 'STOP tuner1 HDMI'
06:01:21.828 [SageTVRequestHandler-152:tuner1] DEBUG GenericPipeCaptureDevice - Stopping encoding...
06:01:21.828 [SageTVRequestHandler-152:tuner1] DEBUG InputStreamCaptureDeviceServices - Stopping producer thread...
06:01:21.828 [SageTVRequestHandler-152:tuner1] DEBUG BasicCaptureDevice - Consumer is not in progress.
06:01:21.828 [SageTVRequestHandler-152:tuner1] DEBUG GenericPipeCaptureDevice - Capture device is now re-unlocked.
06:01:21.828 [SageTVRequestHandler-152:tuner1] DEBUG SageTVRequestHandler - Replied: 'OK'
06:01:21.829 [SageTVRequestHandler-152:tuner1] DEBUG SageTVRequestHandler - SageTV sent: 'START tuner1 HDMI|298219091|6041|3287088163658|/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-1.mpg|MPEG2 Max Quality'
06:01:21.829 [SageTVRequestHandler-152:tuner1] DEBUG GenericPipeCaptureDevice - Capture device is now re-locked.
06:01:21.829 [SageTVRequestHandler-152:tuner1] DEBUG SageTVRequestHandler - Starting network encoder via upload ID '298219091' to file name '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-1.mpg'.
06:01:21.829 [SageTVRequestHandler-152:tuner1] DEBUG BasicCaptureDevice - Consumer is not in progress.
06:01:21.829 [SageTVRequestHandler-152:tuner1] DEBUG DynamicConsumerImpl - Using default consumer 'opendct.consumer.FFmpegTransSageTVConsumerImpl' for channel '6041'
06:01:21.832 [SageTVRequestHandler-152:tuner1] INFO  GenericPipeCaptureDevice - Starting the encoding for the channel '6041' from the device 'tuner1' to the file '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-1.mpg' via the upload id '298219091'...
06:01:21.833 [SageTVRequestHandler-152:tuner1] DEBUG GenericPipeCaptureDevice - Executing: '/opt/opendct/StreamLink.sh 6041'
06:01:21.833 [SageTVRequestHandler-152:tuner1] INFO  GenericPipeCaptureDevice - Configuring and starting the new SageTV producer...
06:01:21.833 [SageTVRequestHandler-152:tuner1] INFO  GenericPipeCaptureDevice - Configuring and starting the new SageTV consumer...
06:01:21.833 [SageTVRequestHandler-152:tuner1] INFO  NIOSageTVMediaServer - Connecting to SageTV server on socket /192.168.1.228:7818...
06:01:21.833 [SageTVRequestHandler-152:tuner1] INFO  NIOSageTVMediaServer - Sending 'WRITEOPEN /mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-1.mpg 298219091' to SageTV server...
06:01:21.834 [SageTVRequestHandler-152:tuner1] DEBUG BasicCaptureDevice - Consumer is not in progress.
06:01:21.834 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegTransSageTVConsumerImpl - FFmpeg Transcoder consumer thread is now running.
06:01:21.834 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegTransSageTVConsumerImpl - Thread priority is 9.
06:01:21.834 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegStreamDetection - Calling avformat_open_input
06:01:23.503 [StreamLogger-154] DEBUG GenericPipeCaptureDevice - err: [cli][info] streamlink is running as root! Be careful!
06:01:23.503 [StreamLogger-154] DEBUG GenericPipeCaptureDevice - err: [cli][info] Found matching plugin hls for URL http://127.0.0.1:8089/devices/ANY/channels/6041/hls/master.m3u8
06:01:23.841 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:01:24.079 [StreamLogger-154] DEBUG GenericPipeCaptureDevice - err: [cli][info] Available streams: 720p (worst, best)
06:01:24.079 [StreamLogger-154] DEBUG GenericPipeCaptureDevice - err: [cli][info] Opening stream: 720p (hls)
06:01:24.120 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegStreamDetection - Before avformat_find_stream_info() pos=131072 bytes_read=131072 seek_count=0. probesize: 165628 analyzeduration: 2000000.
06:01:24.136 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 262144
06:01:24.137 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 262144, returnValue = 3645237
06:01:24.137 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 262144
06:01:24.137 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 262144, returnValue = 3645237
06:01:24.137 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 0, offset = 3395237, readIndex = 262144
06:01:24.137 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 0, offset = 3395237, readIndex = 3395237, returnValue = 3395237
06:01:26.145 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Returning AVERROR_EOF in readCallback.call()
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 3645236
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 3645236, returnValue = 3645237
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 0, offset = 0, readIndex = 3645236
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 0, offset = 0, readIndex = 0, returnValue = 0
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 0
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegCircularBufferNIO - Seek: wence = 65536, offset = 0, readIndex = 0, returnValue = 3645237
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegStreamDetection - After avformat_find_stream_info() pos=0 bytes_read=512143 seek_count=2. probesize: 165628 analyzeduration: 2000000.
06:01:26.146 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegStreamDetection - current container duration = 6.052966 seconds
06:01:26.147 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegStreamDetection - Primary program has been detected: 1.
06:01:26.147 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegStreamDetection - FFmpeg stream detection done in 4313ms,
06:01:26.147 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegTranscoder - Initializing FFmpeg transcoder stream output.
06:01:26.148 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Primary: 
Input #0, mpegts, from 'input-mpeg-ts.ts':
  Duration: 00:00:06.05, start: 4.023767, bitrate: 4817 kb/s
  Program 1
    Metadata:
      service_name    : Service01
      service_provider: FFmpeg
    Stream #0:0[0x100], 5, 1/90000: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p, 1280x720, Closed Captions, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x101], 9, 1/90000: Audio: aac (LC) ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 132 kb/s

06:01:26.148 [FFmpegTransSageTVConsumerImpl-151:tuner1] DEBUG FFmpegContext - Calling avformat_alloc_output_context2
06:01:26.149 [FFmpegTransSageTVConsumerImpl-151:tuner1] INFO  FFmpegContext - Primary: 
Output #0, mpegts, to '/mnt/sagetv_recordings/SAGETV_RECORDINGS/TeenTitans-DivideandConquer-25387189-1.mpg':
    Stream #0:0, 0, 1/90000: Video: h264, yuv420p, 1280x720, q=2-31, 90k tbn, 59.94 tbc
I have attached pictures of the error in sagetv.
Attached Images
File Type: png Screenshot from 2022-01-30 12-25-12.png (379.1 KB, 18 views)
File Type: png Screenshot from 2022-01-30 12-26-29.png (732.1 KB, 17 views)
Reply With Quote
  #2939  
Old 01-30-2022, 05:35 PM
boukmandutty boukmandutty is offline
Sage Advanced User
 
Join Date: Oct 2011
Location: Norman OK
Posts: 182
Following hvymetal I went with a script for tuning instead of having to stop opendct to edit the config all the time. I came up with the following borrowing from his script for PlutoTV.

Code:
#!/bin/bash
ch_num=$1
pipe_ip=127.0.0.1
pipe_port=8089
pipe_path1=devices/ANY/channels
pipe_path2=hls/master.m3u8
#
#Tested Opendct tuning commands:
#
#ffmpeg -i http\://127.0.0.1\:8089/devices/ANY/channels/%c%/stream.mpg?format\=hls -f mpegts -codec\:v copy -codec\:a copy -
#
#/usr/bin/streamlink --stdout --hls-segment-stream-data --twitch-disable-hosting --ringbuffer-size 8M --hls-segment-attempts 2 --hls-segment-timeout 5 http\://192.168.1.228\:8089/devices/ANY/channels/$ch_num/hls/master.m3u8 best
#
#Currenty testing --> simple curl to get it active, then tune since I cant seem to ping the stream.
curl http\://$pipe_ip\:$pipe_port/$pipe_path1/$ch_num/$pipe_path2
streamlink --stdout --hls-segment-stream-data --twitch-disable-hosting --ringbuffer-size 8M --hls-segment-attempts 2 --hls-segment-timeout 5 http://$pipe_ip:$pipe_port/$pipe_path1/$ch_num/$pipe_path2 best
Will watch to see if the curl helps to activate the stream before it has to record so that I dont get the error.
Reply With Quote
  #2940  
Old 01-30-2022, 06:39 PM
hvymetal hvymetal is offline
Sage Advanced User
 
Join Date: Nov 2007
Posts: 143
Quote:
Originally Posted by boukmandutty View Post
#Currenty testing --> simple curl to get it active, then tune since I cant seem to ping the stream.
curl http\://$pipe_ip\:$pipe_port/$pipe_path1/$ch_num/$pipe_path2
streamlink --stdout --hls-segment-stream-data --twitch-disable-hosting --ringbuffer-size 8M --hls-segment-attempts 2 --hls-segment-timeout 5 http://$pipe_ip:$pipe_port/$pipe_path1/$ch_num/$pipe_path2 best[/CODE]

Will watch to see if the curl helps to activate the stream before it has to record so that I dont get the error.
With streamlink you do not have to download stream with curl just use httpstream:// in front of the URL it has the same effect. So URL would be

httpstream://http://$pipe_ip/:$pipe_port

Also if you put double quotes around the curl URL you do not have escape the /

Last edited by hvymetal; 01-30-2022 at 06:56 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI TV Wonder Digital Cable Tuner & SageTV nyle Hardware Support 4 02-17-2009 10:12 PM
ATI TV Wonder Digital Cable Tuner rajczi Hardware Support 4 01-14-2008 08:24 PM
ATI TV Wonder™ Digital Cable Tuner dadams Hardware Support 4 01-09-2007 10:55 AM
Digital Cable - one guide - need HD on one tuner reg tv on other Kimper SageTV Beta Test Software 14 11-27-2006 08:15 PM
Multi-tuner Digital Cable mlbdude SageTV Software 0 06-26-2003 01:08 PM


All times are GMT -6. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.