SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-08-2012, 06:03 PM
Diego Garcia Diego Garcia is offline
Sage Aficionado
 
Join Date: Mar 2008
Location: Bay Area, California
Posts: 264
Hauppauge HD PVR Green Tint

I was having problems with all my HDPVR recorded video having a green tint. It turns out that the values for "hue" in Sage.properties don't map to the values used in the latest HDPVR drivers.

For example, the HDPVR's default setting for hue, as determined by the ArcSoft Total Media Extreme application, is 0. But if you set the "hue" value in Sage.properties to 0 you get green tinted recordings. Fortunately, if you open up TME and examine what it thinks the HDPVR settings are you'll see that the hue/tint is now at -30.

It looks like the Sage.properties value for hue range from 0 to 255, while the HDPVR driver values range from -30 to +31. Setting the Sage.properties value to 128 makes the HDPVR have neutral tint (i.e., a TME-displayed value of 0).

Interestingly, there doesn't seem to be a similar problem for the other values such as contrast. A Sage.properties value of 64 for contrast shows up as 64 (the default) in TME. Go figure .
Reply With Quote
  #2  
Old 01-08-2012, 08:06 PM
SHS's Avatar
SHS SHS is offline
Moderator
 
Join Date: Mar 2003
Location: Vinita, Oklahoma
Posts: 4,586
Close SageTV
Edit Sage.properties and fine the line with video_capture_device_name=Hauppauge HD PVR Capture Device
Just above it look for
mmc/encoders/-???????????/?/0/brightness=(change default setting to)128
mmc/encoders/-???????????/?/0/contrast=(change default setting to)64
mmc/encoders/-???????????/?/0/hue=(change default setting to)128
mmc/encoders/-???????????/?/0/saturation=(change default setting to)64
mmc/encoders/-???????????/?/0/sharpness=(change default setting to)128
The old drivers default setting don't work with new device driver default setting
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Green vs Blue hd pvr from Hauppauge DRB Hardware Support 1 12-14-2011 08:04 AM
Disabling Green Button on Hauppauge 2250 MCE Remote remmy925 Hardware Support 7 06-19-2009 08:32 AM
Hauppauge MVP image turns green! henk99 SageTV Media Extender 4 06-04-2008 10:29 PM
Hauppauge WinTV-350 green screen szirger Hardware Support 0 01-19-2008 11:12 AM
Orange tint with hauppauge 150 and GeForce FX 5200 gu014 Hardware Support 0 12-11-2006 05:52 PM


All times are GMT -6. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.