SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Github Development

Notices

SageTV Github Development Discussion related to SageTV Open Source Development. Use this forum for development topics about the Open Source versions of SageTV, hosted on Github.

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 07-06-2017, 11:47 AM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Are they showing up as available for selection but not showing? Or is it as if they aren't there at all?
Reply With Quote
  #22  
Old 07-06-2017, 11:54 AM
Toddupton Toddupton is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 114
They are all there and I can select any of them but none of them work. Something had to have been changed between 7 and 9. Captions on tv works for recordings as well as .srt files it just will not read the subtitles in the .mkv package.
Reply With Quote
  #23  
Old 07-06-2017, 11:57 AM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Quote:
Originally Posted by Toddupton View Post
They are all there and I can select any of them but none of them work. Something had to have been changed between 7 and 9. Captions on tv works for recordings as well as .srt files it just will not read the subtitles in the .mkv package.
What type of subtitles are they? Can you post a MediaInfo dump of one or two?
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #24  
Old 07-06-2017, 12:20 PM
Toddupton Toddupton is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 114
Here are 2 samples
Attached Files
File Type: txt file 1.txt (7.7 KB, 43 views)
File Type: txt file 2.txt (11.6 KB, 22 views)
Reply With Quote
  #25  
Old 07-06-2017, 03:17 PM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Quote:
Originally Posted by Toddupton View Post
They are all there and I can select any of them but none of them work. Something had to have been changed between 7 and 9. Captions on tv works for recordings as well as .srt files it just will not read the subtitles in the .mkv package.
Weird, I haven't had any issues with MKV subs since upgrading to V9.
Reply With Quote
  #26  
Old 07-06-2017, 03:42 PM
Toddupton Toddupton is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 114
I know this is nuts. I can instal 7 and it works I do a fresh install of 9 and won't work neither will an upgrade from 7 to 9.
Reply With Quote
  #27  
Old 07-07-2017, 03:44 PM
Toddupton Toddupton is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 114
Anyone have anymore ideas?
Reply With Quote
  #28  
Old 07-08-2017, 03:22 PM
trk2 trk2 is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Maine
Posts: 341
I would post this in the Open Source forum since this seems to be a V9 issue instead of a media extender issue. You're more likely to attract the attention you need if you post in that forum.
Reply With Quote
  #29  
Old 07-08-2017, 03:35 PM
Toddupton Toddupton is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 114
Embedded subtitles on HD300 and version 9

I just installed the 9.1 version going up from old sageTV 7 and everything is great except embedded subtitles no longer work on my HD300. Is this a known issue or just me? Thx

* merged & moved to open source forum; see previous posts for details *
Reply With Quote
  #30  
Old 07-08-2017, 05:08 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
I'm going to test an mkv with VOB subtitles. Most of the movies in my collection that have subtitles are ripped from Blu-ray. When I rip from DVD I convert to AVC and burn the subtitles into the video. I discovered that the MPEG2 video from DVD's varies so much that converting it is more compatible. Burning the subtitles gets around the limitation of SageTV not recognizing the mkv forced flag.

I'll post back with my findings.
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #31  
Old 07-08-2017, 06:33 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Ok, I've verified on my HD300 that VOBSUB subtitles don't show. It doesn't look like anything in the log is obviously wrong. Maybe someone else can figure it out. The video I played was "Wolf Creek (2005).mkv" and I changed subs a few times.
Attached Files
File Type: zip sagetv_0.zip (439.2 KB, 25 views)
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #32  
Old 07-08-2017, 06:40 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Just to add I tested one of my Blu-ray rips with PGS subtitles and they aren't working now either. Something has definitely changed. This was working on a previous v9 release.
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #33  
Old 07-08-2017, 08:22 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,088
Quote:
Originally Posted by Taddeusz View Post
Ok, I've verified on my HD300 that VOBSUB subtitles don't show. It doesn't look like anything in the log is obviously wrong. Maybe someone else can figure it out. The video I played was "Wolf Creek (2005).mkv" and I changed subs a few times.

Is this a clue or normal? I'm not sure if DVDSubtitle is what we're dealing with here.

Code:
Sat 7/8 18:42:20.995 [FinalRender-0023a5000d5b@1695e046] MiniClient did not succeed with menu hint change to:menuName:MediaPlayer OSD, popupName:DVDSubtitle, hasTextInput:false, errcode=1
EDIT: Looks like menu hints were added to support the Android mini player and may simply be unsupported by the HD300. In other words I think this error may be normal.

Last edited by wnjj; 07-08-2017 at 08:35 PM.
Reply With Quote
  #34  
Old 07-08-2017, 08:57 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,088
What about this stuff?

Code:
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] VIDEO FRAME EXCEPTION THROWN:java.lang.IllegalMonitorStateException
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] java.lang.IllegalMonitorStateException
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.ReentrantReadWriteLock$Sync.tryRelease(ReentrantReadWriteLock.java:371)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.AbstractQueuedSynchronizer.release(AbstractQueuedSynchronizer.java:1261)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.ReentrantReadWriteLock$WriteLock.unlock(ReentrantReadWriteLock.java:1131)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] sage.media.sub.VobSubSubtitleHandler.getSubtitleBitmap(VobSubSubtitleHandler.java:441)
Some file handling for CC was overhauled/changed about a year ago but not sure if it's relevant to this issue.

Notice this error starts from an attempt to release a lock on a file in VobSibtitleHandler.

Pull request from last year here: https://github.com/google/sagetv/pull/156

Last edited by wnjj; 07-08-2017 at 09:10 PM.
Reply With Quote
  #35  
Old 07-09-2017, 07:20 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,554
Quote:
Originally Posted by wnjj View Post
What about this stuff?

Code:
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] VIDEO FRAME EXCEPTION THROWN:java.lang.IllegalMonitorStateException
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] java.lang.IllegalMonitorStateException
Sat 7/8 18:42:29.635 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.ReentrantReadWriteLock$Sync.tryRelease(ReentrantReadWriteLock.java:371)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.AbstractQueuedSynchronizer.release(AbstractQueuedSynchronizer.java:1261)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] java.util.concurrent.locks.ReentrantReadWriteLock$WriteLock.unlock(ReentrantReadWriteLock.java:1131)
Sat 7/8 18:42:29.636 [VideoFrame-0023a5000d5b@12ad1e2c] sage.media.sub.VobSubSubtitleHandler.getSubtitleBitmap(VobSubSubtitleHandler.java:441)
Some file handling for CC was overhauled/changed about a year ago but not sure if it's relevant to this issue.

Notice this error starts from an attempt to release a lock on a file in VobSibtitleHandler.

Pull request from last year here: https://github.com/google/sagetv/pull/156
That's a good catch, and it is likely that the issue is a sideeffect of this change. The code changed from using syncronized blocks to using read/write locks, which can perform better than syncronized, but comes at a cost of complexity and more possibility for errors.

I'm not sure why the code changed from using synchronized blocks to this, and in reviewing the changed, I don't see anything that stands out as being wrong (and after reading the comments, I don't see jeff questioning this as well).

The only thing that I would likely change is to use NonFair locking which will perform than synchronized and offer same protections, where as Fair locking performs worse, generally.

There is a good article, for those that are interested, on using Reentrant Lock in Java vs Synchronized.

https://www.ibm.com/developerworks/j...ry/j-jtp10264/

Typically using a ReadWrite lock would be used in cases where extreme performance is critical or when lists are extremely large. I don't see this code as fitting either of those cases. Personally, I would not have rewritten it use ReadWrite locks, and at a glance it appears to be implemented correctly, but the error is proof that somewhere, unlock() is being called more times than lock().
Reply With Quote
  #36  
Old 07-09-2017, 07:25 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,554
Actually after re-reviewing it again, I found 2 errors in the locking...

https://github.com/google/sagetv/blo...dler.java#L282

and

https://github.com/google/sagetv/blo...ndler.java#L61

In both of these cases, it will result in an error in the unlock(), because lock() is never called.

I'll enter an issue for this.
Reply With Quote
  #37  
Old 09-09-2017, 11:38 AM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 273
Quote:
Originally Posted by Toddupton View Post
I just installed the 9.1 version going up from old sageTV 7 and everything is great except embedded subtitles no longer work. Is this a known issue or just me? Thx
My subtitles also don't work. SageTV detects them, but they don't appear on my screen. The checkbox appears in the menu when I play a MKV file with subtitles. MPC and VLC play them without issues.
__________________
ASRock B450M Pro4 AM4 mATX AMD Motherboard, AMD Ryzen 5 2600 3.4GHz, Crucial Ballistix Sport LT 16GB (2 x 8GB) DDR4-3200, EVGA GT 1030SC, WD - Black SN750 NVMe SSD 250GB, 1x WD80EFAX 8TB, 2x WDBH2D0040HNC 4TB, USB-UIRT, HD-PVR2, WinTV-dualHD USB, Windows 10 64bit
Reply With Quote
  #38  
Old 09-09-2017, 12:38 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Quote:
Originally Posted by Malfunction View Post
My subtitles also don't work. SageTV detects them, but they don't appear on my screen. The checkbox appears in the menu when I play a MKV file with subtitles. MPC and VLC play them without issues.
Make sure you are updated to the latest version of SageTV. There was a fix already implemented for this problem.
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #39  
Old 09-10-2017, 12:37 PM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 273
Quote:
Originally Posted by Taddeusz View Post
Make sure you are updated to the latest version of SageTV. There was a fix already implemented for this problem.
Done, still broken. There must be a different issue.
__________________
ASRock B450M Pro4 AM4 mATX AMD Motherboard, AMD Ryzen 5 2600 3.4GHz, Crucial Ballistix Sport LT 16GB (2 x 8GB) DDR4-3200, EVGA GT 1030SC, WD - Black SN750 NVMe SSD 250GB, 1x WD80EFAX 8TB, 2x WDBH2D0040HNC 4TB, USB-UIRT, HD-PVR2, WinTV-dualHD USB, Windows 10 64bit
Reply With Quote
  #40  
Old 09-10-2017, 03:39 PM
Narflex's Avatar
Narflex Narflex is offline
Sage
 
Join Date: Feb 2003
Location: Redondo Beach, CA
Posts: 6,305
It's going to depend upon what client you are using for playing them back..what are you using for playback?
__________________
Jeffrey Kardatzke
Google
Founder of SageTV
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Embedded CC/subtitles valnar SageTV Github Development 15 06-06-2017 04:01 PM
Sage v7 PC client and mkv embedded subtitles Gustovier SageTV Software 6 05-08-2014 06:05 AM
Embedded metadata ehfortin SageTV Beta Test Software 12 05-28-2010 06:24 AM
embedded web server?? ChePazzo SageTV Beta Test Software 7 07-05-2007 11:00 AM


All times are GMT -6. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.