SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-14-2008, 02:44 AM
IanV IanV is offline
Sage User
 
Join Date: Apr 2008
Posts: 14
HAUPPAUGE NOVA-T-500 Dual DVB-T PCI & DVICO Fusion DVB-T Dual Express

Is anyone using either of these cards with SageTV for Linux and how well do they work?

Ian
Reply With Quote
  #2  
Old 08-31-2008, 11:50 AM
jonno jonno is offline
Sage User
 
Join Date: Jun 2008
Posts: 7
I'm running sage under linux with the Nova-T 500 and in the past I've had it working very well. In particular I noticed that the zap times with the Nova-T underlinux were much better than when I ran windows on the same hardware. Also any recent distro of linux will support the Nova-T card out of the box - you'll have to upload the firmware but that's about it.

However - there's always a 'but' - I've recently had problems with sage attempting the tune to an out of range frequency and you'll see I've just posted to this forum to see if I can get help with the problem. That said I have had this working under linux very successfully in the past so I guess it's something peculiar to my current config.

Jonny
Reply With Quote
  #3  
Old 09-05-2008, 02:38 AM
IanV IanV is offline
Sage User
 
Join Date: Apr 2008
Posts: 14
Thanks for that Jonny. I've been struggling to get mine working with the current Gentoo distribution. I may have done too much if all that is required is the firmware. I installed Mercurial, retrieved the v4bl-dvb tree, changed to the v4l-dvd directory downloaded the firmware, did a "make menuconfig" them "make" then "make install" then "make load". dMseg seems to recognise that there is a Nova-T-500 there but it won't work.

As you can see, I am very new to Linux. Any guidance you can give me on getting this card to work would be much appreciated.

Thanks,
Ian
Reply With Quote
  #4  
Old 09-05-2008, 02:51 PM
jonno jonno is offline
Sage User
 
Join Date: Jun 2008
Posts: 7
Ian,
I don't think it should be that complex. I've never used gentoo but support for this card had been in 2.6 kernels for a while so I guess a recent gentoo distro should be easy enough to configure.

You say you downloaded the firmware and did a build - did you actually copy the firmware to the correct location? On fedora core 9 it needs to be in /lib/firmware.

If you do a 'dmesg | grep dvb' and post the results it would be a help. If the firmware is not in the correct location you'll see it in the log output given by this command. If the card was working correctly you'd see something like this in the log.

Code:
[   30.965645] dib0700: loaded with support for 5 different device-types
[   30.965925] dvb-usb: found a 'Hauppauge Nova-T 500 Dual DVB-T' in cold state, will try to load a firmware
[   31.008899] dvb-usb: downloading firmware from file 'dvb-usb-dib0700-03-pre1.fw'
[   31.206081] dib0700: firmware started successfully.
[   31.711176] dvb-usb: found a 'Hauppauge Nova-T 500 Dual DVB-T' in warm state.
[   31.711222] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[   31.711325] DVB: registering new adapter (Hauppauge Nova-T 500 Dual DVB-T)
[   31.831535] DVB: registering frontend 0 (DiBcom 3000MC/P)...
[   31.854890] MT2060: successfully identified (IF1 = 1220)
[   32.388673] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[   32.388853] DVB: registering new adapter (Hauppauge Nova-T 500 Dual DVB-T)
[   32.394293] DVB: registering frontend 1 (DiBcom 3000MC/P)...
[   32.398790] MT2060: successfully identified (IF1 = 1220)
[   32.959607] input: IR-receiver inside an USB DVB receiver as /class/input/input4
[   32.959633] dvb-usb: schedule remote query interval to 150 msecs.
[   32.959637] dvb-usb: Hauppauge Nova-T 500 Dual DVB-T successfully initialized and connected.
[   32.959657] usbcore: registered new interface driver dvb_usb_dib0700
I've built a few linux machines with SageTV now and I've never had much trouble getting this card to work. Certainly with fedora there's no need to start building additional components such as v4l. It should all be out of the box with the exception of firmware of course.

Once you get past this basic problem there are a couple of other hints I can give you though. You need to enable the on board amp otherwise you'll get terrible performance.

If you do the follwoing : -
Code:
sudo gedit /etc/modprobe.d/options
then add: -
Code:
options dvb-usb-dib0700 force_lna_activation=1
you should be sorted.

Let me know how you get on. I'm very happy to help,

Jonny
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Closed Captions and Hauppauge 500 Card BicycleRider SageTV Customizations 3 01-18-2006 07:19 AM
Are you using all your PCI Slots? jptaz Hardware Support 10 01-13-2006 06:41 AM
AUUUGH I Give UP!!! TripleTapper SageTV Media Extender 46 01-03-2006 02:35 PM
Setting up my Hauppauge 500 Lastb0isct Hardware Support 2 12-04-2005 04:50 PM
Hauppauge 150 & 500 on sage, 1 will not decode... doron_amedey Hardware Support 0 11-06-2005 03:06 AM


All times are GMT -6. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.