SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-22-2022, 11:48 AM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
Question Well, this is odd, recorded shows suddenly being renamed to "Surround" or "Stereo"

I'm not sure what I did, but starting Sunday Feb 20th, a variety of new (and some old!) recordings have had their media types changed to "Movie" from "TV" and their titles and episode names changed to either "Surround" or Stereo" And they also lose their recordings status and are relegated to being imports. Quite a Mess.

here is a snippet from phoenix.log that shows it has already happened to a couple new recordings from last night:

Code:
2022-02-22 05:41:41,952 - AUTO; MEDIA; \\sagetv-server\BigMedia2-Recordings\Jeopardy! - S38E116 - 97215031-0.mkv; Surround; 97662797
2022-02-22 05:41:41,972 - SKIP; \\sagetv-server\BigMedia2-Recordings\Jeopardy! - S38E116 - 97215031-0.mkv; Surround; 97662797
2022-02-22 05:41:42,381 - AUTO; MEDIA; \\sagetv-server\sagetv\Below Deck Sailing Yacht - S03E01 - Tom Foolery - 97218059-0.mkv; Surround; 97662800
I had been playing with the phoenix-renamer as well a couple of days ago, but I never installed it in the Sage folder or anything to put it in play.

The *only* thing I remember changing on Sunday, was modifying the
"extended_filenames" property from "false" to "true," and that adds spaces and whatnot to the file name.
What I'm wondering is if my overnight SJQv4 process, which runs MediaShrink to convert new recordings to mkv's is involved. Maybe, once the extension type has changed from .ts to .mkv and rescanned by SageTV, things go haywire now that there are spaces? It sure feels like it's BMT/Phoenix doing something, but I don't know why.

For now, I've changed back "extended_filenames" to "false" to see if that fixes it.

I've scanned what logs I can think of and all I found was the phoenix log showing they already had been changed late in the morning. I have yet to go through all the sagetvXX.txt files. I notice the new jetty is throwing a lot of exceptions in there so have to figure that out (some are related to not finding channel icons).

and what's up with the titles being picked, Surround or Stereo??? sure feels like that's being grabbed from the metadata of the show itself.

Anyone out there have any ideas of where to look? thanks!

Last edited by phelme; 02-22-2022 at 11:52 AM.
Reply With Quote
  #2  
Old 02-22-2022, 02:44 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,615
Quote:
Originally Posted by phelme View Post
I'm not sure what I did, but starting Sunday Feb 20th, a variety of new (and some old!) recordings have had their media types changed to "Movie" from "TV" and their titles and episode names changed to either "Surround" or Stereo" And they also lose their recordings status and are relegated to being imports. Quite a Mess.

here is a snippet from phoenix.log that shows it has already happened to a couple new recordings from last night:

Code:
2022-02-22 05:41:41,952 - AUTO; MEDIA; \\sagetv-server\BigMedia2-Recordings\Jeopardy! - S38E116 - 97215031-0.mkv; Surround; 97662797
2022-02-22 05:41:41,972 - SKIP; \\sagetv-server\BigMedia2-Recordings\Jeopardy! - S38E116 - 97215031-0.mkv; Surround; 97662797
2022-02-22 05:41:42,381 - AUTO; MEDIA; \\sagetv-server\sagetv\Below Deck Sailing Yacht - S03E01 - Tom Foolery - 97218059-0.mkv; Surround; 97662800
I had been playing with the phoenix-renamer as well a couple of days ago, but I never installed it in the Sage folder or anything to put it in play.

The *only* thing I remember changing on Sunday, was modifying the
"extended_filenames" property from "false" to "true," and that adds spaces and whatnot to the file name.
What I'm wondering is if my overnight SJQv4 process, which runs MediaShrink to convert new recordings to mkv's is involved. Maybe, once the extension type has changed from .ts to .mkv and rescanned by SageTV, things go haywire now that there are spaces? It sure feels like it's BMT/Phoenix doing something, but I don't know why.

For now, I've changed back "extended_filenames" to "false" to see if that fixes it.

I've scanned what logs I can think of and all I found was the phoenix log showing they already had been changed late in the morning. I have yet to go through all the sagetvXX.txt files. I notice the new jetty is throwing a lot of exceptions in there so have to figure that out (some are related to not finding channel icons).

and what's up with the titles being picked, Surround or Stereo??? sure feels like that's being grabbed from the metadata of the show itself.

Anyone out there have any ideas of where to look? thanks!
Some thoughts..
  • Jetty has nothing to do with file naming so I would not bother looking there
  • Phoenix renamer does not need to be installed as far as I am aware. it uses sagex remote processes to use sage and Phoenix functions but also runs only on demand unless there is an auto process I am not aware of
  • new media defaults to MOVIE unless it matches a rule you created to make it TV
.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #3  
Old 02-22-2022, 04:28 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
Thanks K.

It feels like this might be happening by CMT/BMT due to properties file building after recordings are finished. They take priority in SageTV metadata, right? And if I'm not mistaken, there were some changes to some of the JARs used by them in the jetty upgrade. Can't be a coincidence. You may be correct that these were seen as new media Movie files because their recording info was wiped.

I ran a couple tests after changing extended_filenames back to false and so far things are fine.

Still can't figure out why Stereo and Surround were being used as title names. Haven't found anything useful in the sagetvXX.txt files I had available.
Reply With Quote
  #4  
Old 02-22-2022, 09:44 PM
JREkiwi's Avatar
JREkiwi JREkiwi is offline
Sage Icon
 
Join Date: Jan 2005
Location: Auckland, New Zealand
Posts: 2,123
I can categorically say CMT does absolutely NOTHING with file names

John
Reply With Quote
  #5  
Old 02-23-2022, 07:39 AM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
Quote:
Originally Posted by phelme View Post
and their titles and episode names changed to either "Surround" or Stereo"
I imported a few files over the past few days and one of the files I imported yesterday ended up with a name of "Surround 5.1". See the attached images..... I have never seen this before..... Is this a defect or maybe a change on the source pages the data is being pulled from?
Attached Images
File Type: jpg Surround Name.jpg (87.7 KB, 40 views)
File Type: jpg Surround video details.jpg (122.9 KB, 40 views)
Reply With Quote
  #6  
Old 02-23-2022, 10:46 AM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,615
Quote:
Originally Posted by phantomii View Post
I imported a few files over the past few days and one of the files I imported yesterday ended up with a name of "Surround 5.1". See the attached images..... I have never seen this before..... Is this a defect or maybe a change on the source pages the data is being pulled from?
Perhaps TVDB changed their api again. We are using an old api and I believe they fake out the old apt to call their new api which caused TV banners to fail a few months ago. this could be similar.

Can one or both of you post a complete Phoenix and Metadata log after the issue occurs and I will look into it.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #7  
Old 02-23-2022, 11:05 AM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
Quote:
Originally Posted by jusjoken View Post
Can one or both of you post a complete Phoenix and Metadata log after the issue occurs and I will look into it.
I would be happy to provide a log but not really sure where to find this??? Sorry......
Reply With Quote
  #8  
Old 02-23-2022, 12:39 PM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
I also took a look at the video properties file for the imported video and this was all that was in it.....

"PropertiesWrittenBy=CMT"
Reply With Quote
  #9  
Old 02-23-2022, 01:10 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
Quote:
Originally Posted by phantomii View Post
I imported a few files over the past few days and one of the files I imported yesterday ended up with a name of "Surround 5.1". See the attached images..... I have never seen this before.....
hey I'm not alone!

Quote:
Originally Posted by jusjoken View Post
Perhaps TVDB changed their api again. We are using an old api and I believe they fake out the old apt to call their new api which caused TV banners to fail a few months ago. this could be similar.

Can one or both of you post a complete Phoenix and Metadata log after the issue occurs and I will look into it.

K
it hasn't happened again since I turned off the extended filenames. might be just a coincidence.

I enclosed two sets of what I have. unfortunately these look like they are recycled every so often so I don't have one from Sunday where there were more samples. there are definitely some TVDB exceptions going on.

thanks for looking into this!

Edit: looks like I have some network permission problems on the Fanart folder. I recently redirected it from "Programs Files (x86)" to "Program Files." Have to fix that.
Attached Files
File Type: zip phoenix1.zip (7.2 KB, 20 views)
File Type: zip phoenix2.zip (32.1 KB, 20 views)

Last edited by phelme; 02-23-2022 at 01:37 PM.
Reply With Quote
  #10  
Old 02-23-2022, 01:13 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
Quote:
Originally Posted by phantomii View Post
I would be happy to provide a log but not really sure where to find this??? Sorry......
on Windows: C:\Program Files\SageTV\SageTV\logs
Reply With Quote
  #11  
Old 02-23-2022, 02:06 PM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
I am on an unraid server I will take a look after work and see if I can determine the files to send! Thanks!
Reply With Quote
  #12  
Old 02-23-2022, 02:31 PM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
Quote:
Originally Posted by jusjoken View Post
Can one or both of you post a complete Phoenix and Metadata log after the issue occurs and I will look into it.
Hope this helps!
Attached Files
File Type: zip phoenix.zip (6.1 KB, 25 views)
File Type: zip phoenix-metadata.zip (448 Bytes, 22 views)
Reply With Quote
  #13  
Old 02-26-2022, 08:53 AM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,615
I set up a clean system with my 8000 test files (series and movies) and all of them received proper titles through TMDB and TVDB. None were named oddly like Surround.

I also ran all the built in tests in the phoenix core project and all the tests passed.

I will give this more thought but am at a loss why the two of you are seeing this issue.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #14  
Old 02-26-2022, 08:24 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
thanks for looking into this. I haven't had another incident since I changed the extended_filenames property back to the way it was (false). I'll try setting it to "true" sometime this week and see if anything happens.
Reply With Quote
  #15  
Old 02-27-2022, 07:24 AM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
So I believe I have identified the issue that is causing the incorrect file names. At least in my example. Gonna try and keep this short and clear.....

If you remember jusjoken, a couple weeks back you helped me with a different issue with Imported title lengths being zero length. In the end I updated my Docker from a very old version to the newest Java 11 version and reset the permissions on the ffmpeg file in the server directory. This fixed not only that issue for me but a few other issues with No video when using the placeshifter. All was good.

Then I installed the Linux version of the SageTVTranscoder plugin as I have been trying to improve the ability to watch SageTV in a remote location smoothly and in good quality. THis was about two weeks ago and all seemed good. I had imported a few files since then without issue. In fact the day I imported the file that got the name "Surround 5.1" I imported 3 other files which imported fine.

So based on the above and your test results I decided to uninstall the SageTVTranscoder plugin, delete the incorrectly named file and reimport it to see if it made a difference. When I imported the file this morning it got the correct name but was again zero length. So I reset the permissions on the ffmpeg file and deleted and reimported the file and it worked correctly with the correct file name and length. Clearly uninstalling the SageTVTranscoder plugin does not appear to correct the permissions on the original ffmpeg file.

Then I reinstalled the SageTVTranscoder plugin and did the delete/reload dance again and the file was again named "Surround 5.1". Once more I deleted the SageTVTranscoder plugin and reset the permissions on the ffmpeg file and did the delete/reload dance again and the file was totally correct.

It appears that the SageTVTranscoder plugin or a conflict with that and something else is causing the issue for me. It does though only impact (at least so far) the one specific file as I imported about 5-10 video files over the two weeks I had the SageTVTranscoder plugin and all others seemed to import correctly.

Sorry for the long winded answer, and sorrier if it is not clear, but for now I have uninstalled the SageTVTranscoder plugin and will leave it this way until there is another update. Not sure that is the only or the whole issue, but clearly when it is installed something is not right!
Reply With Quote
  #16  
Old 02-27-2022, 11:46 AM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,615
Quote:
Originally Posted by phantomii View Post
So I believe I have identified the issue that is causing the incorrect file names. At least in my example. Gonna try and keep this short and clear.....

If you remember jusjoken, a couple weeks back you helped me with a different issue with Imported title lengths being zero length. In the end I updated my Docker from a very old version to the newest Java 11 version and reset the permissions on the ffmpeg file in the server directory. This fixed not only that issue for me but a few other issues with No video when using the placeshifter. All was good.

Then I installed the Linux version of the SageTVTranscoder plugin as I have been trying to improve the ability to watch SageTV in a remote location smoothly and in good quality. THis was about two weeks ago and all seemed good. I had imported a few files since then without issue. In fact the day I imported the file that got the name "Surround 5.1" I imported 3 other files which imported fine.

So based on the above and your test results I decided to uninstall the SageTVTranscoder plugin, delete the incorrectly named file and reimport it to see if it made a difference. When I imported the file this morning it got the correct name but was again zero length. So I reset the permissions on the ffmpeg file and deleted and reimported the file and it worked correctly with the correct file name and length. Clearly uninstalling the SageTVTranscoder plugin does not appear to correct the permissions on the original ffmpeg file.

Then I reinstalled the SageTVTranscoder plugin and did the delete/reload dance again and the file was again named "Surround 5.1". Once more I deleted the SageTVTranscoder plugin and reset the permissions on the ffmpeg file and did the delete/reload dance again and the file was totally correct.

It appears that the SageTVTranscoder plugin or a conflict with that and something else is causing the issue for me. It does though only impact (at least so far) the one specific file as I imported about 5-10 video files over the two weeks I had the SageTVTranscoder plugin and all others seemed to import correctly.

Sorry for the long winded answer, and sorrier if it is not clear, but for now I have uninstalled the SageTVTranscoder plugin and will leave it this way until there is another update. Not sure that is the only or the whole issue, but clearly when it is installed something is not right!
Definitely clear...thanks for the great testing and details. I am not at all familiar with that plugin so you may want to post a link to these details in the thread for that plugin as the author may be able to assist.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #17  
Old 02-28-2022, 01:40 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
Quote:
Originally Posted by phantomii View Post
SageTVTranscoder plugin
i have this as well, but on Windows. have had every iteration since it came out in 2020.

phantomii, did you happen to save the logs when you did the import again and it failed?
Reply With Quote
  #18  
Old 03-01-2022, 04:59 PM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 225
Quote:
Originally Posted by phelme View Post
phantomii, did you happen to save the logs when you did the import again and it failed?
I did not save the files again as I went through the import. I could (in theory) do this again if it would add real value above the imports files I already posted. Would need to find and hour or two to do it. Maybe this weekend time will allow.....
Reply With Quote
  #19  
Old 03-02-2022, 12:23 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,136
you're definitely on to something. it's some interaction between plugins after video/recording files are scanned for media info entry.

In my case, it has something to do with nightly compression which changes file extensions from ".ts" to ".mkv" which causes SageTV (and plugins) to take another look at the files. as I said, it hasn't happened again for me since I toggled "extended_filenames" back to "false." I did that for Plex use actually, but since the SageTV media scanner for Plex works fine the way it is, I probably won't change the extended property back.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Backdrops" "SageTV" "Covers" folders - what's creating them mp328 Sage My Movies 4 09-20-2010 05:31 PM
"Sort By Title" most shows end up under "T" as in "The" grauchy SageMC Custom Interface 1 09-25-2009 06:44 AM
Would love to see a "Recorded Shows" view for "Videos" (SageMC)... Addict SageMC Custom Interface 3 08-02-2008 09:47 AM
"Set defaults" for Series forgets "Keep"/"Auto-delete" setting maxpower SageMC Custom Interface 9 05-14-2008 09:44 PM


All times are GMT -6. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.