SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-16-2008, 09:21 AM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Talking SageTV using HD-PVR and VMware ESXi

Here's a neat solution that I've been able to get working. It's not fully baked, and while there are many nerd knobs that I haven't yet tried, I thought I'd write up something. It may help someone else.

I've set up a small single-core 3.2 GHz P4 machine. It's running VMware ESXi. On top of that I added a virtual machine running Windows XP SP3, and on that I loaded SageTV 6.4. To get the video into the virtual server, I ran the new HD-PVR. This is of course a USB device. I linked the HD-PVR into the virtual machine using a Lantronics UBox-2100. The UBox supports isochronous traffic, which is required for audio and video streaming.

When I installed the HD-PVR, the trick is to install everything on the disk from Hauppauge. You'll get an error when the ArcSoft TotalMedia Extreme installs, complaining that it doesn't like being run on a virtual machine - just ignore it.

I had problems getting the cdrom/dvd player that in the physical host machine, on which I'm running my virtual SageTV server, so for a while I mounted a dvd drive on the second port of the UBox-2100. The HD-PVR has to be connected during the install of the drivers and software, or that step will fail.

Once the HD-PVR was installed, when I added it to SageTV, I'd get an error >> Sage.playbackException: Error (-5,0x80040256): There was a problem rendering the audio portion of the content for playback. I discovered that there was no audio hardware listed in my virtual machine. I fixed that by adding a Griffin iMic usb soundcard to port 2 of the UBox-2100, and linking it into the virtual machine.

Then I got another error. This one was regarding graphics >> sagePlaybackException: ERROR (-4,0x80040217): There was a problem rendering the video portion of the content for playback. I fixed this in two ways. I changed the default recording detail to the lowest resolution, and set the video codecs to default. That's what worked. I had read on the forum that people were having better luck with 720p rather than 1020i. This was also a key to success.

In fact if I set my Comcast cable box to 480p, the lip sync is good, and even my MVP works, even when watching live tv. Likewise, 480p makes PlaceShifter work ok. 720p still has issues, and 1080i, and ironically 480i both result in a blank black screen.

The ESX machine is running a gigabit ethernet connection, as is the machine on which I ran PlaceShifter. The UBox and MVP are of course 100Mb devices. There are three switches in this test network. It's important that the switch you use to have low latency. Recently, I run mostly Linksys SLM2008 switches.

The conclusions are that SageTV can run on VMware ESXi, and also VMware ESX 3.5. You can use a HD-PVR to stream video into a virtual server by connecting it to a Lantronics UBox-2100. You can even watch live tv on PlaceShifter and MVPs. You just have to balance the SageTV host's processing power and the video resolution that you use.

I'm not sure where I'm headed with this setup. I think it might be improved with the addition of some video encoding hardware, like maybe a ADSTech Instant Video-to-go USB H.264 encoder. It's a work-in-progress. I had fun getting it working and now I can record a tv show on the (beloved) upper cable channels if I like.
__________________
Radioman
Reply With Quote
  #2  
Old 09-16-2008, 11:56 AM
pat_smith1969 pat_smith1969 is offline
Sage Aficionado
 
Join Date: Jan 2007
Posts: 305
I have recently started messing with VMWare (ESX) as part of my job description. I had thought of making a VMWare client that is running SageTV, with the idea that you could cluster two SageTV servers and theoretically increase up time on the sagetv service. I had not put as much time and effort into it as you have though. KUDOS !!!
Reply With Quote
  #3  
Old 09-16-2008, 08:32 PM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Thanks Pat. Best of luck to you with your ESX efforts at your job.
__________________
Radioman
Reply With Quote
  #4  
Old 09-16-2008, 10:48 PM
mayamaniac's Avatar
mayamaniac mayamaniac is offline
Sage Icon
 
Join Date: May 2004
Posts: 2,177
I thought VMWare supports USB?

Also, are you saying you could stream HD-PVR recordings to the Placeshifter and MVP?
__________________
Mayamaniac

- SageTV 7.1.9 Server. Win7 32bit in VMWare Fusion. HDHR (FiOS Coax). HDHR Prime 3 Tuners (FiOS Cable Card). Gemstone theme.
- SageTV HD300 - HDMI 1080p Samsung 75" LED.
Reply With Quote
  #5  
Old 09-17-2008, 05:30 AM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Hi Mayamaniac. I used VMware ESX in this post. ESX sits directly on the bare metal rather than on top of another host operating system, as in VMware workstation. I've used USB devices in VMware workstation, although I've not tried SageTV and HD-PVR on VMware workstation.

Using the Lantronics Ubox-2100 allows simple deterministic control of which USB devices connect to which hosts. I got it for this project, but I've come to use it with my non-VM hosts because it allows me to swap USB devices around to different machines without having to move the physical USB cables. (I don't work for Lantronics by the way. I have no association with them.)

And yes. I was able to run SageTV on a virtual XP SP3 host, and connect to it from both a Placeshifter client and also an MVP, and to watch live tv being streamed from the SageTV server. The video is perfect at 480p. 720p is perfect on the virtual machine itself, but on the remote clients, there is some lip sync delay, and flickering in text which can be distracting. I'd say 720p is close enough to working that there might be a set of tweaks or with a software upgrade, it could probably be fixed.
__________________
Radioman
Reply With Quote
  #6  
Old 09-17-2008, 05:48 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,610
I wonder if the delays are caused by the Ubox.... USB supports 480mbits and your network will only support 100mbits... So when you are remotely accessing the sage on the vmware server, your network is sending from the Ubox to the vmware server and then the vmware server is sending it back to a client.... I would think that would be alot of bandwidth for HD content.
Reply With Quote
  #7  
Old 09-17-2008, 07:52 AM
harrijay harrijay is offline
Sage Advanced User
 
Join Date: Jan 2007
Location: Wisconsin
Posts: 152
Just to add information I was running 2 HDPVR's connected Directly to Vmware Server 2.0, which was ontop of Ubuntu 8.04 and was not having any issues with capturing. I have since then switched to a direct connection to my linux sage server just to simplify things.
__________________
ESXi Host Intel Xeon x3440 on Intel S3420PLX, 4GB RAM, 80GB Primary
Server:2 CPU's and 2GB memory Allocated, 15GB Virtual Primary, 1.5 TB RDM Physical Disk,
A180 using VMDirectPath, 1 xHDHR
Headless ArchLinux 2.6.34 64-bit, SageTV 7.0.15
Sun JRE 1.6.0_20
Comskip&PlayonWindows XP 2CPU and 1GB Ram Allocated
Clients: 1 Media MVP and 2 STX-HD100
Reply With Quote
  #8  
Old 09-17-2008, 10:11 AM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Hi Stuckless... you make some good points. It's pretty clear that at least at lower resolutions (like when my cable box is set for 480p) that the stream from the UBox is less than 100 Mbps, because the picture & audio is perfect on the Sage server itself. If I were to send the ip stream to the Place shifter out a different port, that could possible help. It surely would help eliminate queuing delay at my ESXi server's gig port.

I don't thing the delay and lip sync issues at 720p are due (entirely) to the UBox's 100Mbps speed. This is because others have reported the same thing with actual physical machines and the HD-PVR directly connected.

Hi Harrijay... what you did with VMware workstation on Ubuntu is pretty cool. That's also excellent info. It's good to know. I decided to try the ESXi to UBox to HD-PVR just to see if I could get it to work. In the long run it was more of a sandbox. I'll probably rebuild a new physical server and set out to try something else on ESXi.

If you haven't tried ESXi, you should give it a look. It's very fast, and it's a free download.
__________________
Radioman
Reply With Quote
  #9  
Old 09-17-2008, 10:14 AM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Ahhh... Harrijay. You said VMware Server 2.0. Also cool. My mistake. Everything I said still applies.
__________________
Radioman
Reply With Quote
  #10  
Old 05-28-2009, 12:59 PM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Talking SageTV & ESXi 4.0, aka: vSphere

This is an update on what's possible with SageTV and VMware ESX. I'd posted earlier, http://forums.sagetv.com/forums/showthread.php?t=35621 on ESX 3.5. This new testing is with ESXi 4.0 (aka vSphere) and the latest SageTV V6.5.16 Beta.

The new flavor of ESX is only 64bit, so I built up a new machine for testing >>

ASUS P5Q-EM motherboard
Intel Core 2 Quad Q9650 3.0GHz 12MB L2 Cache LGA 775 95W Quad-Core Processor
LiteON DH-52C2S-04 black sata combo cd/dvd drive
ICY DOCK MB671SK-BB Tray-less 3.5" SATA I & II Mobile Rack Removable Hard Drive Kit
WD Caviar WD10EADS 1GB green sata drive
Intel EXPI9402PT 10/100/1000Mbps PCI-Express Two Gigabit Copper Server Connections 2 x RJ45
two 4GB dimms from Crucial (specific for P5Q-EM)
Nexus Caterpillar Silent PC Case
Nexus NX-8060 600 Watt 80-Plus Silent PSU REV. 2
Nexus FLC-3000 Universal CPU Cooler

It's a nice quiet machine, and a real pleasure to use. You must define the storage as AHCI, and then ESXi 4 loads very easily.

Then, as before, I connected the HD-PVR to a guest Windows XP SP3 machine (4 cores, 4GB dram, 250GB of storage) using a Lantronics ubox-2100. For sound, I connected a Turtle Beach Amigo usb sound card (port 2 on the ubox-2100). You can just connect the Turtle Beach card. You don't have to fool with their driver installation disk.

There is a little trick. I had to use the new 1.5.6.0 beta drivers when I installed the HD-PVR. Then I continued with the software install (Button 2) off of the Hauppauge cd, just as before. Actually, I copied the cd onto the guest XP machine, and executed it there.

The results this time are much better than I expected! I don't have much "stick time" with it yet, but the early results are really great. I suspect the improvement in server hardware, especially the cpu, is a good portion of the better results.

Video at 720p is fine. Lip synch is fine. I can even watch live TV, from an HD source, streamed to my MVP client. On the MVP, the lip sync is perfect, there are no weird sound artifacts, all the channel changing is perfect, and it's very responsive. I've never had the MVP work this well with an HD channel before. I don't yet have an STP-HD200 HD Media Extender, but I'm pretty certain it would be great as well.

A neat conclusion here is that the 100Mbps speed of the ubox-2100 is not a giant concern with regard to the H.264 video stream that the HD-PVR is sending. This is consistent with the generic results that any of us get using a service like Hulu over the internet.

I'm not sure where I'm headed with this. I thought I'd write it up. Sometimes knowing what's possible is half the battle. I'll post an update to this if I hit any snags or figure out anything else.

* merged *
__________________
Radioman
Reply With Quote
  #11  
Old 06-03-2009, 09:33 AM
radioman radioman is offline
Sage User
 
Join Date: Sep 2008
Posts: 14
Unhappy fun but not yet practical

I've done a bit more stress testing. The SageTV 6.5.16 beta code works very well with the HD-PVR and 1.5.6 beta firmware. This is on an Asus P5Q-EM running native XP-SP3. When I extend the HD-PVR away from the server using the ubox-2100, then I start to get stability issues. The performance is very good. It's just not stable at all. It could well be the 1.5.6 beta code. That's hard to prove. I cannot get any earlier HD-PVR drivers to work with the ubox. For my test, I had just one very-low-latency layer-2 switch between the Sage server and the ubox. Well, software (and drivers) do improve over time. For now, getting the pvr function on a virtual server is for the challenge. It's not yet very practical, but for reasons that center on extension of the video streams.
__________________
Radioman
Reply With Quote
  #12  
Old 07-19-2010, 09:57 AM
MTisza MTisza is offline
Sage User
 
Join Date: Mar 2006
Location: Brambleton, VA USA
Posts: 46
Has anyone tried ESXi 4.1 with the HD-PVR via USB passthrough?

Hi all,

I'm interested in consolidating some servers, and the only thing I know of that would prevent me from merging my sageTV server into the ESXi server is USB support of the HDPVR. However it looks like the newest version of ESXi supports USB passthough.

My SageTV server is headless anyway, so I don't care about graphics output performance to a TV or display. I just use HD200's for that, and occasionally a placeshifter on a laptop.

Has anyone tried this?
Any comments?

Thanks,
Miki
__________________
Server: ESXi 4.1 running on i7-930 24GB RAM
VM with Sage: win7 pro 8 cores, 4GB RAM Sage v7
Tuners: 2x dual tuner HDHR + 1xHD-PVR
Provider: FIOS
Clients: 3xHD200 (20100909 0)
2xHD300
Reply With Quote
  #13  
Old 07-19-2010, 10:06 AM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Quote:
Originally Posted by radioman View Post
I've done a bit more stress testing. The SageTV 6.5.16 beta code works very well with the HD-PVR and 1.5.6 beta firmware. This is on an Asus P5Q-EM running native XP-SP3. When I extend the HD-PVR away from the server using the ubox-2100, then I start to get stability issues. The performance is very good. It's just not stable at all. It could well be the 1.5.6 beta code. That's hard to prove. I cannot get any earlier HD-PVR drivers to work with the ubox. For my test, I had just one very-low-latency layer-2 switch between the Sage server and the ubox. Well, software (and drivers) do improve over time. For now, getting the pvr function on a virtual server is for the challenge. It's not yet very practical, but for reasons that center on extension of the video streams.
Tried using VMDirectPath to passthrough a USB controller instead of using a USB extender?
Reply With Quote
  #14  
Old 07-19-2010, 10:09 AM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Quote:
Originally Posted by MTisza View Post
I'm interested in consolidating some servers, and the only thing I know of that would prevent me from merging my sageTV server into the ESXi server is USB support of the HDPVR. However it looks like the newest version of ESXi supports USB passthough.
Really? And not via VMDirectPath (pci passthrough)?

-edit

http://kb.vmware.com/selfservice/sea...rnalId=1022290

So it seems, I'm going to have to update and play around some more... That opens up a lot of options potentially. Finding VT-d hardware is somewhat tricky afterall.

Last edited by stanger89; 07-19-2010 at 10:11 AM.
Reply With Quote
  #15  
Old 07-20-2010, 07:00 PM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
FWIW, I got my USB-UIRT, HD PVR, and R5000 installed in an XP SP3 VM on ESXi 4.1 (ATI 780G board). Sage saw the HD PVR, but I ran out of time before I could get them configured to actually try them out. Seems promising though.
Reply With Quote
  #16  
Old 07-22-2010, 12:39 PM
MTisza MTisza is offline
Sage User
 
Join Date: Mar 2006
Location: Brambleton, VA USA
Posts: 46
Quote:
FWIW, I got my USB-UIRT, HD PVR, and R5000 installed in an XP SP3 VM on ESXi 4.1 (ATI 780G board). Sage saw the HD PVR, but I ran out of time before I could get them configured to actually try them out. Seems promising though.
Thanks for trying this out. Once I move, I'm going to try to get this setup working as well. I'ver tinkered with ESXi for all of 2 days about 6 months back, so I'm a noob with it. It'll be fun, it always is!
Miki
__________________
Server: ESXi 4.1 running on i7-930 24GB RAM
VM with Sage: win7 pro 8 cores, 4GB RAM Sage v7
Tuners: 2x dual tuner HDHR + 1xHD-PVR
Provider: FIOS
Clients: 3xHD200 (20100909 0)
2xHD300
Reply With Quote
  #17  
Old 07-23-2010, 02:41 PM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
So far so good, last night I managed to record 4 shows at the same time, R5000, HD PVR, and 2x HDHR, from my SageTV VM to my unRAID VM
Reply With Quote
  #18  
Old 07-23-2010, 04:54 PM
mayamaniac's Avatar
mayamaniac mayamaniac is offline
Sage Icon
 
Join Date: May 2004
Posts: 2,177
My Win7 server is running perfectly right now so I'm not gonna mess with it, but I think I will eventually switch over to VMware and run SageTV as a VM guest host. So this is really good news that the USB pass through is working well.
__________________
Mayamaniac

- SageTV 7.1.9 Server. Win7 32bit in VMWare Fusion. HDHR (FiOS Coax). HDHR Prime 3 Tuners (FiOS Cable Card). Gemstone theme.
- SageTV HD300 - HDMI 1080p Samsung 75" LED.
Reply With Quote
  #19  
Old 07-23-2010, 08:56 PM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Working at least, I reserve final judgement on "well" until I've had more than a half hour of recording time with it
Reply With Quote
  #20  
Old 07-23-2010, 09:07 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
I think if my server was headless, I'd also go this route. however, since I'm still running my main viewing location from it as well, it'll have to be pushed off. to be honest, though, the only advantage i see of doing this is the ability to run the linux based storage system, with the windows based server.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
Reply

Tags
esx, esxi, hd-pvr, lantronics, ubox-2100, vmware, vsphere


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.