SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-07-2021, 08:15 PM
Galaxysurfer Galaxysurfer is offline
Sage Aficionado
 
Join Date: Jun 2009
Location: Calgary, AB CANADA
Posts: 378
updating Sagetv 9.2.5 on Linux

After updating both server & client software on linux server I can't connect to the Placeshifter. I am able to connect to another server on Win 10 just not the Linux Placeshifter installed on same pc as the server. I am gathering it is most likely a permission issue. Which file needs to be changed for everything to work again? I had it working previously on last version of software.

I am hoping to avoid having to do a clean install & lose all my settings.
Reply With Quote
  #2  
Old 08-08-2021, 07:37 PM
Galaxysurfer Galaxysurfer is offline
Sage Aficionado
 
Join Date: Jun 2009
Location: Calgary, AB CANADA
Posts: 378
Turns out it was the SystemD vs Sysinit install. Using sysinit it would hang, so I had to go temporarily into SystemD mode as when I updated before for my distro. I also ended up switching from Openjdk 8 to Openjdk 11. Time will tell if I can resolve some of my playback issues that got me to go with an update.

Last edited by Galaxysurfer; 08-09-2021 at 03:53 AM.
Reply With Quote
  #3  
Old 09-09-2021, 01:24 PM
RobertRathbone RobertRathbone is offline
Sage User
 
Join Date: Dec 2007
Location: Cleveland TN (USA)
Posts: 24
updating Sagetv 9.2.5 on Linux

Can you go into more detail about what you mean by "SystemD vs Sysinit install"? I've updated my SageTV server running on Ubuntu Server 20.04.3 from 9.2.1 to 9.2.5 and now I can't connect to it from my HD300, Placeshifter running on another Linux machine, or even the SageTV Android client. I executed the "dpkg -i sagetv-server_9.2.5_amd64.deb" command and then rebooted. Now I can't connect. Maybe what you did will help me...

Of course, if anyone else has an idea, I welcome your input.

Thanks,
Robert

UPDATE: I decided to try using dpkg to revert back to the previous version of SageTV that I had (v. 9.2.1) and I am now able to connect to and use SageTV server again. It seems the problem lies in 9.2.5 or how I installed it. Or perhaps 9.2.5 is incompatible with my setup and I need to adjust something on my server to allow it to operate correctly. Any ideas?

Last edited by RobertRathbone; 09-10-2021 at 05:41 AM. Reason: Updated information
Reply With Quote
  #4  
Old 09-13-2021, 09:11 AM
ASegredo ASegredo is offline
Sage Advanced User
 
Join Date: Jun 2005
Posts: 141
Placeshifter should not depend on the init system at all.
Reply With Quote
  #5  
Old 09-13-2021, 09:34 AM
RobertRathbone RobertRathbone is offline
Sage User
 
Join Date: Dec 2007
Location: Cleveland TN (USA)
Posts: 24
The problem is not in Placeshifter but in SageTV server. When I install 9.2.5 nothing can connect to SageTV...Placeshifter, my HD300, my HD100, or the Android version of SageTV. Once I downgrade back to 9.2.1, everything can once again connect.

Robert
Reply With Quote
  #6  
Old 09-13-2021, 01:30 PM
ASegredo ASegredo is offline
Sage Advanced User
 
Join Date: Jun 2005
Posts: 141
How about 9.2.2?
9.2.2 is working for me.
Reply With Quote
  #7  
Old 09-13-2021, 03:05 PM
RobertRathbone RobertRathbone is offline
Sage User
 
Join Date: Dec 2007
Location: Cleveland TN (USA)
Posts: 24
I finally found where to download 9.2.2 and installed it. It seems to be working fine. Just before that I installed 9.2.5 again after stopping the service and the problem connecting returned. So I'm back to 9.2.2 for now...

Thanks,
Robert
Reply With Quote
  #8  
Old 01-04-2022, 10:27 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,601
Quote:
Originally Posted by RobertRathbone View Post
I finally found where to download 9.2.2 and installed it. It seems to be working fine. Just before that I installed 9.2.5 again after stopping the service and the problem connecting returned. So I'm back to 9.2.2 for now...

Thanks,
Robert
9.2.5 and 9.2.6 had an issue that caused them not to work on Linux under Java 8.

9.2.7 should solve that issue.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #9  
Old 01-05-2022, 09:31 AM
RobertRathbone RobertRathbone is offline
Sage User
 
Join Date: Dec 2007
Location: Cleveland TN (USA)
Posts: 24
Yes, this version does indeed work for me! Thanks for letting me know!

Robert
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Basic linux desktop install of Sagetv using Mx Linux with Hauppauge pci cards Galaxysurfer SageTV Linux 0 06-03-2019 01:12 PM
Updating Sage on Linux gary201 SageTV Linux 2 10-01-2017 09:20 PM
Can't see tuner after updating sagetv 7 stv rnadeau SageTV Github Development 9 10-14-2015 03:57 PM
Close to building a Linux SageTV Computer, which Linux distribution is best? davephan SageTV Linux 8 02-24-2011 06:57 PM
Updating SageTV on WHS dflachbart SageTV Beta Test Software 5 08-09-2007 12:09 PM


All times are GMT -6. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.