SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-07-2014, 09:27 AM
UgaData's Avatar
UgaData UgaData is offline
Sage Aficionado
 
Join Date: Sep 2005
Posts: 436
TMI audio in MKV file

For some time now, I have ripped Blu-Rays to an ISO file. I was playing them back using TMT. I have tried using Sage to play back the files with less than stellar results. Just recently, I have had better luck playing back the BD ISO rips in Sage but not all play back well.

I have have tried to create MKV files from the ISO's using Handbrake and MakeMKV.

Handbrake (for me) has been a pain. It may have something to do with the FFMpeg version Handbrake is now using. Sage usually doesn't recognize the file as playable and aborts with some message about not finding the FFMpeg library or some such. TMT will play the MKV but Sage will not.

This weekend I tried using MakeMKV to create an MKV file. In this case it was Iron Man 2. All seemed to be good until I tried to playback the MKV in Sage. It does play and I do get a correct bitstream but I also get an audio description of what is happening in the movie as well.

Example- as the movie starts in the Paramount logo opening sequence (paraphrasing) "Stars falling from sky. Circle mountain. Paramount a Viacom Company.". This isn't subtitles being printed on the screen it is part of the audio. I don't use subtitles but when text is printed on the screen it is also spoken. And it continues to describe the action happening through out the movie. "A goateed Tony Stark is talking to reporters"

This particular MKV has 2 audio tracks DTS-MA & AC3 both tracks have the audio descriptions in them. I use a Sage PC client on Win7 32 for playback.
I use Arcsoft HD video decoder and FFMpeg for audio decoding. Again TMT will playback the MKV correctly.

A quick perusal through Sage's settings didn't have anything jump out at me nor a look through Sage.Properties and SageClient.properties files.
I really hope this is a simple setting somewhere that can be toggled as needed (for me, toggled off).

FWIW - I didn't use any special settings in MakeMKV, just whatever opening the ISO file gave me. Not sure there are a lot choices to be made in MakeMKV.
This isn't what I would consider to be a 'commentary' track. It's more like subtitles for the visually impaired.
__________________
"Unencumbered by the thought process"

The only constant in the Universe is change.
Reply With Quote
  #2  
Old 09-08-2014, 09:36 AM
MattHelm MattHelm is offline
Sage Icon
 
Join Date: Jun 2005
Location: Chicago, IL
Posts: 1,207
I had this issue last spring. I think all I did to fix it, was re-rip and selecting the HD audio only. Then I used a program somewhere here to make an AC-3 track. (Sorry, unsure after 1+ year)

Here's the link to the program I use to make AC-3 audio files. I did have to update the eac3to software a while back (see the message near the last of that thread)
http://forums.sagetv.com/forums/showthread.php?t=45902
__________________
Server #1= AMD A10-5800, 8G RAM, F2A85-M PRO, 12TB, HDHomerun Prime, HDHR, Colossus (Playback - HD-200)
Server #2= AMD X2 3800+, 2G RAM, M2NPV-VM, 2TB, 3x HDHR OTA (Playback - HD-200)

Last edited by MattHelm; 09-08-2014 at 04:17 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mpg video file Sage thinks is an audio file kmp14 SageTV Software 1 03-14-2010 08:01 PM
5.1 audio with an MP4 file? moamoa SageTV Software 2 02-01-2010 05:00 PM
H.264 file, audio is ok but video locks up dwalton22 SageTV Beta Test Software 2 08-14-2007 06:40 AM
getting audio from mpg file wjohn General Discussion 0 09-15-2005 09:53 AM
audio file formats vrkev69 SageTV Beta Test Software 8 01-30-2004 01:21 PM


All times are GMT -6. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.