SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-15-2015, 06:15 AM
davidk21770 davidk21770 is offline
Sage Expert
 
Join Date: Mar 2006
Location: Maryland
Posts: 513
Audio synch

I've been having a problem with audio-video synch for quite a while now. My audio slowly gets out of synch with the video. If I do a small jump, they go back into synch, but start to diverge again, slowly getting farther apart. It's much worse in the shows where I've removed the commercials. I've tried changing the decoders that sage is using, but that doesn't seem to make any difference. Any suggestions?

(These videos play fine in other players).
__________________
HDHomeRun x2
Cable Box via Hauppauge HD PVR and USB-UIRT
2 SageTV's HD300

Intel Core 2 Quad Q9650 @4025 MHz, 8G G.Skill Performance
DFI Lanparty DK X48-T2RS Plus; SilverStone Decathlon DA1000 (died - back to an ancient enermax)
eVGA 7900 GT KO RoHS -- Zalman VP900CU Cooling
Synology NAS 22TB
Reply With Quote
  #2  
Old 06-15-2015, 03:52 PM
cncb cncb is offline
Sage Icon
 
Join Date: Jul 2006
Posts: 1,271
I had this problem but I can't remember whether it was LAV or the MS decoders that caused the sync problems and can't check since my trial has run out. Some combination of video/audio decoders did seem to avoid the issue, though.
__________________
-Craig
Reply With Quote
  #3  
Old 06-16-2015, 02:21 AM
troycheek's Avatar
troycheek troycheek is offline
Sage Advanced User
 
Join Date: Feb 2008
Posts: 148
Define "removed the commercials."
Reply With Quote
  #4  
Old 06-16-2015, 11:16 AM
davidk21770 davidk21770 is offline
Sage Expert
 
Join Date: Mar 2006
Location: Maryland
Posts: 513
Quote:
Originally Posted by troycheek View Post
Define "removed the commercials."
Edited the video to physically remove the commercials (VideoReDo).

I've tried all combinations of video and audio filters and none appear to make any difference in this. When using directshow, the default splitter appears to be haali on my system, so I upgraded that to the latest version and that didn't make a difference either. (I don't see a way to specify the splitter to Sage).
__________________
HDHomeRun x2
Cable Box via Hauppauge HD PVR and USB-UIRT
2 SageTV's HD300

Intel Core 2 Quad Q9650 @4025 MHz, 8G G.Skill Performance
DFI Lanparty DK X48-T2RS Plus; SilverStone Decathlon DA1000 (died - back to an ancient enermax)
eVGA 7900 GT KO RoHS -- Zalman VP900CU Cooling
Synology NAS 22TB

Last edited by davidk21770; 06-16-2015 at 11:32 AM.
Reply With Quote
  #5  
Old 06-16-2015, 03:35 PM
davidk21770 davidk21770 is offline
Sage Expert
 
Join Date: Mar 2006
Location: Maryland
Posts: 513
I thought that it might have something to do with the edited files since that's what I watch the most (TV shows where I've removed the commercials), but I just watched a movie that was unedited and it had the same problem.
__________________
HDHomeRun x2
Cable Box via Hauppauge HD PVR and USB-UIRT
2 SageTV's HD300

Intel Core 2 Quad Q9650 @4025 MHz, 8G G.Skill Performance
DFI Lanparty DK X48-T2RS Plus; SilverStone Decathlon DA1000 (died - back to an ancient enermax)
eVGA 7900 GT KO RoHS -- Zalman VP900CU Cooling
Synology NAS 22TB
Reply With Quote
  #6  
Old 06-16-2015, 04:10 PM
troycheek's Avatar
troycheek troycheek is offline
Sage Advanced User
 
Join Date: Feb 2008
Posts: 148
Well, that was going to be my suggestion: go back to the original unaltered files and see if they had the problem before you started editing. Have you tried a different player? VLC, Windows Media Player, etc? The problem might be with the original video. ffmpeg has some commands designed to help sync up files, but I've been unable to figure them out so far.
Reply With Quote
  #7  
Old 06-17-2015, 02:45 AM
davidk21770 davidk21770 is offline
Sage Expert
 
Join Date: Mar 2006
Location: Maryland
Posts: 513
Yes, I've tried the files in MPC and VLC and they play fine. The problem is definitely in Sage.

I've considered doing a repair reinstall, but it's been so long and I've made so many fine tuning adjustments over the years that I'm afraid of losing something that I can't rediscover without a LOT of work. I have backups of the sage program folder so that can be restored, it's the registry entries that I'm worried about. I wish that I could figure out how to unpack the install package without actually doing an install -- then I could at least make sure that the sagetv/common files are correct.
__________________
HDHomeRun x2
Cable Box via Hauppauge HD PVR and USB-UIRT
2 SageTV's HD300

Intel Core 2 Quad Q9650 @4025 MHz, 8G G.Skill Performance
DFI Lanparty DK X48-T2RS Plus; SilverStone Decathlon DA1000 (died - back to an ancient enermax)
eVGA 7900 GT KO RoHS -- Zalman VP900CU Cooling
Synology NAS 22TB
Reply With Quote
  #8  
Old 06-17-2015, 08:29 PM
troycheek's Avatar
troycheek troycheek is offline
Sage Advanced User
 
Join Date: Feb 2008
Posts: 148
Quote:
Originally Posted by davidk21770 View Post
I wish that I could figure out how to unpack the install package without actually doing an install -- then I could at least make sure that the sagetv/common files are correct.
I use 7-zip because it comes in handy for just these situations.
  1. Install 7-zip
  2. Find SageTV_V7_1_9Setup.exe
  3. Right click on file and tell 7-zip to Extract to SageTV_V7_1_9Setup\
  4. Navigate to SageTV_V7_1_9Setup\
  5. Find .WISE
  6. Right click on file and tell 7-zip to Extract to _
  7. Navigate to _
  8. Find Cabs.w1.cab
  9. Right click on file and tell 7-zip to Extract to Cabs.w1\
  10. Navigate to Cabs.w1\
These should be the files you're looking for.
Reply With Quote
  #9  
Old 06-18-2015, 01:17 AM
davidk21770 davidk21770 is offline
Sage Expert
 
Join Date: Mar 2006
Location: Maryland
Posts: 513
I've use 7zip the same way in the past. This time it didn't reduce to something that I could use -- the only cab left a mystery after unpacking. So I grabbed virtual box, created a windows machine, installed it in there, and copied it out ;-). Unfortunately, it just told me that all of my files in sage/common (and in sage/sage) are ok. (I'm not still using anything from the mpeg beta tests back in 2008/2009). It did not have the mpeg drivers. I'll have to check elsewhere for them.
__________________
HDHomeRun x2
Cable Box via Hauppauge HD PVR and USB-UIRT
2 SageTV's HD300

Intel Core 2 Quad Q9650 @4025 MHz, 8G G.Skill Performance
DFI Lanparty DK X48-T2RS Plus; SilverStone Decathlon DA1000 (died - back to an ancient enermax)
eVGA 7900 GT KO RoHS -- Zalman VP900CU Cooling
Synology NAS 22TB

Last edited by davidk21770; 06-18-2015 at 01:18 AM. Reason: typeos
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HVR-1600 Audio out of synch on Analog tuner Karride Hardware Support 0 09-19-2008 12:35 PM
Audio not in synch with video? heffneil SageTV Media Extender 1 05-27-2008 11:43 AM
h.264 synch problems Patilan SageTV Beta Test Software 1 07-12-2007 08:28 PM
Audio Synch Problems with Divx/AVIs rsagetv99 SageTV Beta Test Software 0 04-20-2006 01:08 PM
Audio synch problem using Ulead DVD Movie Factory newtbert SageTV Recorder Software 1 11-15-2003 03:03 AM


All times are GMT -6. The time now is 01:31 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.