SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-05-2018, 08:24 AM
gary201 gary201 is offline
Sage Advanced User
 
Join Date: Dec 2010
Location: Rochester NY
Posts: 97
java cpu usage

Has anyone else noticed that over the past couple weeks java has started consuming 100% of the CPU? Sage is still responsive on this Linux VM I have been using for a while. I'm using the current version 9.1.9.514. It doesn't necessarily seem to be a Sage issue as the CPU usage continues even if nothing is happening (nothing is being recorded or watched, the sagetv_0.txt is only periodically getting blocks of lines showing sage is checking for things to do, finds nothing, then idles).

Some other details:
-Only network tuners are used (2x hdhomerun OTA tuners)
-Linux mint VM used only for Sage (nothing else): 2 cpu, 2gb/ram, 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
-java: 1.8.0_181

Trying to stop sage (sudo ./stopsage) doesn't seem to work ("SageTV service did not stop within 30 seconds") even after running this a few times. The temporary fix is to kill -9 the java process and reboot, but that's just temporary as the issue returns usually within about 2 hours.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
slow UI and high java mem usage... jbuszkie SageTV v7 Customizations 21 10-17-2013 09:51 AM
SageTV 6 Client problems after Java 7 install, Java 6 uninstall alisonnic SageTV Software 5 01-24-2013 02:51 PM
Java SE7 Favorite limit day problem (vs Java SE6) voidpt SageTV Software 0 10-21-2012 12:29 PM
Tables, Java - Java Not being Called for each TableComponent Cell stuckless SageTV Studio 3 04-02-2008 03:03 PM
Beta V1.2.2 Java java.lang Null Pointer Exception hamptonhills SageTV Beta Test Software 1 03-27-2003 12:11 PM


All times are GMT -6. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.