SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Clients Development

Notices

SageTV Clients Development This forum is for discussions relating to SageTV Open Source Clients Development.

Reply
 
Thread Tools Search this Thread Display Modes
  #61  
Old 10-12-2018, 11:33 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,430
Quote:
Originally Posted by KryptoNyte View Post
Same issues here. I've rolled back to 1.2.8 for now, which has everything working on my hardware.

Thank you for your work on this.
That's too bad. While there are number of changes since 1.2.8, my guess is that the newer versions of IJK and ExoPlayer are main reasons for the issues. That's too bad, since I try to keep those up to date, so that we can pick up any bug fixes, and especially enhancements.
Reply With Quote
  #62  
Old 10-12-2018, 05:10 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,054
Sean, please don't take my roll-back (for use on my old Galaxy Note 4) as a typical usage. I can't tell you how much myself, and likely countless others, appreciate your hard work on getting us a valid way to use SageTV here in 2018.

If there is a way I can help troubleshoot, please let me know how.
Reply With Quote
  #63  
Old 10-12-2018, 07:20 PM
technazz's Avatar
technazz technazz is offline
Sage Aficionado
 
Join Date: Jul 2004
Location: Hamilton, ON, CA
Posts: 464
Where can we download the 1.2.8 apk?

Chris
__________________
SageTV V9.xx 2 x HD300's, 2 x Nvidia Shields Running Mini Client
Reply With Quote
  #64  
Old 10-13-2018, 04:23 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,430
Quote:
Originally Posted by technazz View Post
Where can we download the 1.2.8 apk?

Chris
In my sig, there is a link to Android Miniclient, that takes you to Bintray where all the binaries are posted.
Reply With Quote
  #65  
Old 10-13-2018, 07:43 AM
peterjb peterjb is offline
Sage Advanced User
 
Join Date: Feb 2004
Location: Canberra, Australia
Posts: 199
Firstly I'd like to say thanks for the work on the Android Client.. It's great to have the option of another type client and it works really well for the main functions that I still use SageTV for, the awesome PVR.. I've spent this evening doing some testing to try and isolate my issues with Oz DVB-T in SageTV 9 and the Android Client 1.3.4. I appear to have made some progress after switching to MPEG TS recording format, so I thought I'd document my findings thus far..

Shield
SageTV TS - PAL DVB 576i SDTV 25fps with MP2 2 Channel Stereo Audio
Exoplayer - Always get a Picture & Out of Sync Audio
IKJPLayer - Works 98% of the time - randomly hangs on LiveTV playback after tuning ( recording on server continues )

SageTV TS - PAL DVB 1080i HDTV 25fps H264 with AC3 2 Channel Stereo
Exoplayer - No Picture & No Audio
IKJPLayer - Works 98% of the time - randomly hangs on LiveTV playback after tuning ( recording on server continues )

SageTV TS - PAL DVB 576i SDTV 25fps H264 with MP2 2 Channel Stereo
Exoplayer - No Picture & No Audio
IKJPLayer - Works 98% of the time - randomly hangs on LiveTV playback after tuning ( recording on server continues )

SageTV TS - PAL DVB 576i SDTV 25fps H264 with AAC-HE 2 Channel Stereo
Exoplayer - No Picture & No Audio
IKJPLayer - Picture but no Audio

MiBox ( Oreo )
SageTV TS - PAL DVB 576i SDTV 25fps with MP2 2 Channel Stereo Audio
Exoplayer - Always get a Picture & No Audio ( recording on server continues )
IKJPlayer - Works 20% of the time - 80% hangs on LiveTV playback after tuning ( recording on server continues ) crashes App

SageTV TS - PAL DVB 1080i HDTV 25fps H264 with AC3 2 Channel Stereo
Exoplayer - No Picture & No Audio ( recording on server continues )
IKJPlayer - Works 20% of the time - 80% hangs on LiveTV playback after tuning ( recording on server continues ) crashes App

SageTV TS - PAL DVB 576i SDTV 25fps H264 with MP2 2 Channel Stereo
Exoplayer - No Picture & No Audio ( recording on server continues )
IKJPlayer - Works 20% of the time - 80% hangs on LiveTV playback after tuning ( recording on server continues ) crashes App

SageTV TS - PAL DVB 576i SDTV 25fps H264 with AAC-HE 2 Channel Stereo
Exoplayer - No Picture & No Audio ( recording on server continues )
IKJPLayer - Picture but no Audio ( recording on server continues )

It would appear that I'm getting HW decoding support on both platforms, although the de-interlacing support for PAL SDTV on the MiBox is woeful - But it's not the primary device in the house. It's great the Shields are now available locally in Oz, but I'm not too sure I want to equip the whole house with Shields..

Ideally I'd like to try and work out these issues and have both platforms working as well as they can within the limitations that they have. So I suppose the question is what can I do to help progress the resolution of these issues? And where should I start?

Cheers

Peter
Reply With Quote
  #66  
Old 10-13-2018, 08:27 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,430
I wonder if your issues are related to the 1080i (ie, the interlacing). My HDPVR has the ability to record in 720p or 1080i, but, "i" has always given me issues, even in sagetv, so, I use "p".

Are you able to test an "p" streams. I really don't think it's a PAL thing, vs a interlacing issue.

The no audio in ExoPlayer is directly related to the fact that ExoPlayer can only hardware decode (there is no software decoding). So if doesn't have the hardware decoder for an audio stream, you get no audio. You can turn on software decoding in the settings, but then you lose hardware pass-through that exoplayer provides.
Reply With Quote
  #67  
Old 10-16-2018, 08:09 AM
sacrament055 sacrament055 is offline
Sage Aficionado
 
Join Date: Jul 2007
Posts: 423
I'm sure you already know this but a bit of experimenting on my Shield showed me that ATSC streams via HD Homerun were crashing the miniclient on IJK player but if I switched to EXO player it would play a bit stuttery but no crashing. Don't know if it helps but I thought I'd add my observation.
Reply With Quote
  #68  
Old 10-16-2018, 09:21 AM
CSCO_TECH CSCO_TECH is offline
Sage User
 
Join Date: Dec 2010
Posts: 6
I'm also experiencing the crash issues on my older shield. I have not tested my new one yet, as I have an HD300 on that set. If I can provide anything for troubleshooting, let me know. On a side note, I was unable to download any of the older apk files for side loading. Everything gives me a forbidden error.
Reply With Quote
  #69  
Old 10-29-2018, 04:04 AM
peterjb peterjb is offline
Sage Advanced User
 
Join Date: Feb 2004
Location: Canberra, Australia
Posts: 199
Quote:
Originally Posted by stuckless View Post
I wonder if your issues are related to the 1080i (ie, the interlacing). My HDPVR has the ability to record in 720p or 1080i, but, "i" has always given me issues, even in sagetv, so, I use "p".

Are you able to test an "p" streams. I really don't think it's a PAL thing, vs a interlacing issue.

The no audio in ExoPlayer is directly related to the fact that ExoPlayer can only hardware decode (there is no software decoding). So if doesn't have the hardware decoder for an audio stream, you get no audio. You can turn on software decoding in the settings, but then you lose hardware pass-through that exoplayer provides.
Thanks for your reply. My apologies for the delay in getting back to you.. I've been distracted by work unfortunately.. All OTA Broadcasts in Oz are interlaced. So I have no control over the type of stream I'm recording. They are all either DVB-T or DVB-T2 OTA TV Broadcast streams from a number of different generation HDHomeRun devices..

Also for Exoplayer, when I select the option to Disable Audio Pass-thru - It still does not play any sound, But it should - Right? The audio is MP2 or AC3 two channel stereo.. Am I missing something? I'm suspecting the issue could be the way that SageTV v9 records from DVB-T broadcasts.. Even my trusty HD300 is hiccuping on some of the recordings - regardless of whether I use PS or TS..

I might try and see if I can use OpenDCT to mux it into a TS - If that is even an option..

Cheers

Peter

Last edited by peterjb; 10-29-2018 at 04:08 AM.
Reply With Quote
  #70  
Old 11-08-2018, 06:24 AM
peterjb peterjb is offline
Sage Advanced User
 
Join Date: Feb 2004
Location: Canberra, Australia
Posts: 199
Just a final Update.. I Implemented Oz DVB-T Support ( au-bcast ) in OpenDCT and surprise surprise ijkplayer now plays the recorded programs and live TV for all channels with no issue on both my Shield and MiBox.. Exoplayer still seems to be a bit of a crapshoot.. Hopefully the TS fixes in latest version resolves the issue... Once I clean up the code in OpenDCT I'll package a patch to push it upstream..

Cheers

Peter

Last edited by peterjb; 11-08-2018 at 06:26 AM.
Reply With Quote
  #71  
Old 11-11-2018, 11:41 AM
gdippel gdippel is offline
Sage Aficionado
 
Join Date: Oct 2003
Location: Bayside, New York
Posts: 268
Weather Underground icons

Iím using the mini client 1.30 on an Amazon Firestick. The weather plugin doesnít display icons. When I go to weather configuration and select icons options the field is blank. Any suggestions?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Android MiniClient 1.2.9 stuckless SageTV Clients Development 53 04-16-2018 07:30 AM
New Android TV Box and Miniclient rickgillyon SageTV Clients Development 4 01-03-2018 05:19 PM
Android MiniClient 1.2.12 Released stuckless SageTV Clients Development 18 11-13-2017 01:05 PM
Android MiniClient - ExoPlayer stuckless SageTV Clients Development 46 12-28-2016 01:46 PM
Android Miniclient and UK TV rickgillyon SageTV Clients Development 6 12-01-2016 05:58 PM


All times are GMT -6. The time now is 10:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.