SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #281  
Old 03-08-2013, 10:08 AM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
It appears SA isn't licensed. As I mentioned in the other thread, email notifications are only available in the licensed version of the plugin.

Code:
2013-03-07 21:05:05,544 INFO  [ab]: Returning eventId: PAUSES_TV_127.0.0.1
2013-03-07 21:05:05,881 WARN  [m]: Email notification ignored; your copy of SageAlert is not licensed! [The registered email ['user@masked'] does not match the email in the license file!]
2013-03-07 21:05:05,882 WARN  [af]: Only notifying one listener for event 'TV playback paused' because this copy of SageAlert is not licensed! [The registered email ['user@masked'] does not match the email in the license file!]
And only one target per event is performed in the non-licensed version so if you also had csv file as a target along with email, it probably wouldn't have worked. If you just want to see events being handled in the non-licensed version then remove the email notifications from your events and just have the csv file as the only target (you don't need to delete the email address "server", just uncheck the target).
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #282  
Old 03-08-2013, 01:11 PM
71_Cuda 71_Cuda is offline
Sage Advanced User
 
Join Date: Feb 2009
Posts: 101
Quote:
Originally Posted by Slugger View Post
It appears SA isn't licensed. As I mentioned in the other thread, email notifications are only available in the licensed version of the plugin.

Code:
2013-03-07 21:05:05,544 INFO  [ab]: Returning eventId: PAUSES_TV_127.0.0.1
2013-03-07 21:05:05,881 WARN  [m]: Email notification ignored; your copy of SageAlert is not licensed! [The registered email ['user@masked'] does not match the email in the license file!]
2013-03-07 21:05:05,882 WARN  [af]: Only notifying one listener for event 'TV playback paused' because this copy of SageAlert is not licensed! [The registered email ['user@masked'] does not match the email in the license file!]
And only one target per event is performed in the non-licensed version so if you also had csv file as a target along with email, it probably wouldn't have worked. If you just want to see events being handled in the non-licensed version then remove the email notifications from your events and just have the csv file as the only target (you don't need to delete the email address "server", just uncheck the target).

I remembered that initially. So I requested and installed the 7-day free trial license to test it out. I put it in the Addons folder as instructed and configured the plugin with my email address and the file location (which was already there by default). I've also restarted SageTV. The only thing I didn't do in the instructions was check the logfile to ensure the license file was accepted.

I'll recheck everything when I get home this evening. I'll also check the CSV file to see if it is working. I only had the CSV file selected on the Auto-Delete event (per your recommendation to achieve what I'm trying to do), so it probably hasn't logged anything yet as I currently have space on the server.
Reply With Quote
  #283  
Old 03-08-2013, 01:51 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
Quote:
Originally Posted by 71_Cuda View Post
I remembered that initially. So I requested and installed the 7-day free trial license to test it out. I put it in the Addons folder as instructed and configured the plugin with my email address and the file location (which was already there by default). I've also restarted SageTV. The only thing I didn't do in the instructions was check the logfile to ensure the license file was accepted.

I'll recheck everything when I get home this evening. I'll also check the CSV file to see if it is working. I only had the CSV file selected on the Auto-Delete event (per your recommendation to achieve what I'm trying to do), so it probably hasn't logged anything yet as I currently have space on the server.
Hopefully this is enough to get you going, if not PM me for more details...

The email address you used to get the trial license is not the same address you registered in sagetv-addons settings.

According to my db, the address you used to get the trial license was x@y.force9.z but in the SA log you provided, it seems you entered x@y.force.z as your email address (based on the error message in the sagealert.log file). Add the 9 in your email address in the plugin settings and the license should be accepted.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #284  
Old 03-08-2013, 02:15 PM
71_Cuda 71_Cuda is offline
Sage Advanced User
 
Join Date: Feb 2009
Posts: 101
Quote:
Originally Posted by Slugger View Post
Hopefully this is enough to get you going, if not PM me for more details...

The email address you used to get the trial license is not the same address you registered in sagetv-addons settings.

According to my db, the address you used to get the trial license was x@y.force9.z but in the SA log you provided, it seems you entered x@y.force.z as your email address (based on the error message in the sagealert.log file). Add the 9 in your email address in the plugin settings and the license should be accepted.
Thanks! I figured I goofed something up like that, which is why I planned to check everything tonight. Thanks for figuring it out for me. I expect that will correct it.
Reply With Quote
  #285  
Old 03-08-2013, 10:20 PM
71_Cuda 71_Cuda is offline
Sage Advanced User
 
Join Date: Feb 2009
Posts: 101
Quote:
Originally Posted by Slugger View Post
Hopefully this is enough to get you going, if not PM me for more details...

The email address you used to get the trial license is not the same address you registered in sagetv-addons settings.

According to my db, the address you used to get the trial license was x@y.force9.z but in the SA log you provided, it seems you entered x@y.force.z as your email address (based on the error message in the sagealert.log file). Add the 9 in your email address in the plugin settings and the license should be accepted.
Looks like I got it working. The email address in the plugin settings was, of course, wrong. I also had a problem in the SMTP settings, which I found out from the log file after getting the license corrected. I used the SMTP settings for a different account and now its working.

Thanks for your help.

I'll try it out for the next few days and if all goes well, I'll buy the license.
Reply With Quote
  #286  
Old 06-21-2013, 08:48 AM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 6,577
For the last week or so I have stopped receiving Tweets from SageAlert. I am wondering if this is just a problem on my end or if the interface is broken? I have not changed my password or anything else on Twitter recently.

SageAlert does work for emails. When I go into the SageAlert web UI and look at my Twitter accounts under Servers I can't figure out how to edit the accounts.
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #287  
Old 06-21-2013, 11:44 AM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
What does the sagealert.log file have to say when it fails to tweet? There should be errors logged in that log file (along with stacktraces). My first guess is that the twitter lib I used in SageAlert is now outdated and can no longer communicate with Twitter's servers and would require an update.

I stopped using/testing twitter functionality when the project went eol; I don't use twitter (with SageAlert), just email so that's my guess and if I'm right, unfortunately, I have no plans to fix it.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #288  
Old 06-21-2013, 02:27 PM
nethead nethead is offline
Sage User
 
Join Date: Jun 2009
Location: Washington, D.C.
Posts: 63
Quote:
Originally Posted by wayner View Post
For the last week or so I have stopped receiving Tweets from SageAlert. I am wondering if this is just a problem on my end or if the interface is broken? I have not changed my password or anything else on Twitter recently.

SageAlert does work for emails. When I go into the SageAlert web UI and look at my Twitter accounts under Servers I can't figure out how to edit the accounts.

Twitter has created a "Gardened Wall" and dropped support api v1, all apps need to be updated to use api v1.1.

Change has been coming for the past year.

https://dev.twitter.com/blog/api-v1-is-retired
__________________
Twitter: @nethead
Server: Intel i7, 24GB RAM, 1 x 3TB OS HD Win 2K8r2, 6 x 3TB recording drives (RAID 5)
Drive Towers(eSATA): 15TB (Raid 5)
Capture: 3 x HDHomerun
Software: SageTV 7.1.9, Java 1.6.0_29
Clients: 3 x HD200, 1 x iPad
Reply With Quote
  #289  
Old 06-21-2013, 04:53 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
Quote:
Originally Posted by nethead View Post
Twitter has created a "Gardened Wall" and dropped support api v1, all apps need to be updated to use api v1.1.

Change has been coming for the past year.

https://dev.twitter.com/blog/api-v1-is-retired
Yup, that would do it. Twitter support in SageAlert should now be considered broken. Again, I have no plans to address this.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #290  
Old 08-05-2013, 08:29 AM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
Important licensing info

Please read the following. By updating the license server plugin, you can now unlock all features of this plugin. Enjoy!
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #291  
Old 11-10-2013, 04:58 PM
Russ563 Russ563 is offline
New Member
 
Join Date: Sep 2013
Location: Rome, NY
Posts: 4
Here is the post that this is in reply to: http://forums.sagetv.com/forums/show...2&postcount=41

I had thought about posting here first, it was a 50/50 chance.

----------------------------------------------------------------------------------

I went to the link you provided (Event Handler Manager) and it listed 2 Growls for every event. I then went to the web UI and it all appeared to be just how I had originally set it up. But I have since found out how to temporarily fix it, but not why it's wrong.

Shortly after your post I did a Java update and it was fixed
About a week later I rebooted the computer and it was broke again, and once (after many reboots) it even was giving 3 alerts per event

After a lot of thinking of what I did different, I realized that for a Java update, I need to stop the SageTV Service. That was it. Since then all I need to do is stop the service before a reboot and it all works fine.

So why the change? Do you need some logs?
Reply With Quote
  #292  
Old 11-11-2013, 03:15 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
Hmm... what you describe is likely some kind of edge case bug with my code; probably not handling Sage shutdown properly, which is causing an additional registration of events or something. Seems likely it's only an issue with the Growl notifier as I don't use Growl and never specifically shutdown Sage before I reboot/shutdown the server and yet have never seen this type of thing with any of the notifiers I do use (email & csv file).

You could send logs, I might skim thru them and see what I can find, but based on what you're describing, I'd say it's likely a bug with my code and it's a bug that I will just never fix at this point, especially since you've discovered a work around, sorry.

I had to go look, but I last modified the source code for SageAlert back in spring 2011 and I haven't looked at the source code since. Though functional, the project is long since dead and there's just no chance I'll be fixing bugs at this point. Feel free to send me the logs though if you still want to.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #293  
Old 09-23-2014, 07:44 PM
razrsharpe razrsharpe is offline
Sage Icon
 
Join Date: Sep 2008
Location: Boston, MA
Posts: 2,111
I'm getting a 503: Service unavailable when trying to access the sage alert web ui at (http://server : port/sagealert). All other sage jetty powered websites are working normally… Any ideas??
__________________
Server 2003 r2 32bit, SageTV9 (finally!)
2x Dual HDHR (OTA), 1x HD-PVR (Comcast), 1x HDHR-3CC via SageDCT (Comcast)
2x HD300, 1x SageClient (Win10 Test/Development)
Check out TVExplorer
Reply With Quote
  #294  
Old 09-23-2014, 08:24 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
Should be an exception logged somewhere. Maybe in sagealert.log or if not then in the jetty log or else in the sage debug log. If nothing obvious anywhere there then I'd try a Sage restart. If that doesn't fix it then the usual cause is a jar file has gone missing/corrupt.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #295  
Old 12-07-2014, 02:34 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,152
Did anyone ever determine a resolution or workaround for the SSL-only issue? I'd like to use my regular email server but it won't allow for SSL. I do have it working with Gmail, but had to turn down my gmail security level to allow it, and because there is financial tied to it, not too comfortable with that.

In the scenario without SSL on my attempt to get my regular email server working, the SSL checkbox is unchecked, but seems to force it in some fashion anyways and then fails.
Reply With Quote
  #296  
Old 12-07-2014, 03:46 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
I vaguely remember the details of this, but I think it has to do with a bug where if SSL is advertised by a server then I just force into SSL mode regardless of the checkbox value? Or something like that? I don't think there's a way around it from the SageAlert side of things other than for me to fix the bug. Unfortunately, since moving last year I have no environment available and configured to do a new build of SageAlert and no plans to rebuild such an environment. It is very unlikely that there will be another release of SageAlert (done by me). I just took another quick look at the code and the fix is rather easy if you're able to build it. The fix should just be a matter of moving line 123 of this file inside the if block just above it. That's all that's needed, I just don't have anything setup to do a new build and release into the Sage repository for this plugin and it would literally take me hours of effort to rebuild such an environment and I just don't have the stomach to attempt it, unfortunately.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #297  
Old 12-07-2014, 04:05 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,152
No problem, Slugger - just wanted to see if anyone had a quick workaround. I'd like to make the change, but I don't know what "rebuild" means, and if it would take you a few hours, it would probably take me a few years!

I think I can limp it along the way it is. Really helpful tool that I just stumbled on today, thanks.
Reply With Quote
  #298  
Old 03-25-2015, 08:01 PM
Slugger Slugger is offline
SageTVaholic
 
Join Date: Mar 2007
Location: Kingston, ON
Posts: 4,008
As of tonight, I have unsubscribed from this thread. What does this mean? It means I am no longer actively developing or supporting this plugin. All my plugins have actually been EOL'd since about 2012-2013, but tonight I unsubscribe from these threads which means I no longer get instant email notifications when people post. I'm not leaving, I'm still a user, I'm still around these forums, but I no longer support these out of date plugins and since I don't sub to these threads any longer, I may or may not notice your questions and therefore may or may not answer them -- assume that I won't, certainly not in a timely manner.

This also means I will never release another version of this plugin to the repository. I remain the owner of the plugin in the repository, but will approve a transfer if requested. No one has taken me up on that offer since my original announcement many weeks back. Unless someone does, there will be no more releases of this plugin.
__________________
Twitter: @ddb_db
Server: Intel i5-4570 Quad Core, 16GB RAM, 1 x 128GB OS SSD (Win7 Pro x64 SP1), 1 x 2TB media drive
Capture: 2 x Colossus
STB Controller: 1 x USB-UIRT
Software:Java 1.7.0_71; SageTV 7.1.9
Clients: 1 x HD300, 2 x HD200, 1 x SageClient, 1 x PlaceShifter
Plugins: Too many to list now...
Reply With Quote
  #299  
Old 09-28-2016, 12:26 PM
phareous phareous is offline
Sage Advanced User
 
Join Date: Jul 2009
Location: Charlotte, NC
Posts: 233
If anyone wants to set this up to use gmail here are the settings:

Hostname: smtp.gmail.com
Port: 465
Username: YOURUSERNAME@gmail.com
Password: YOURPASSWORD
Connect over SSL: checked
Sender address: YOURUSERNAME@gmail.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugin: MizookLCD (Alternate SageTV LCDSmartie Plugin) cslatt SageTV Customizations 48 06-11-2012 10:44 AM
MediaPlayer Plugin/STV Import: Winamp Media Player Plugin deria SageTV Customizations 447 12-11-2010 07:38 PM
Plugin: SageAlert Slugger SageTV Customizations 201 06-28-2010 07:47 PM
SageAlert new release notifications Slugger Customization Announcements 2 03-06-2010 09:53 AM
Hulu: Possible to Use XBMC Hulu Plugin to create SageTV Plugin? Brent SageTV Customizations 8 02-24-2009 04:16 PM


All times are GMT -6. The time now is 02:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.