SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-20-2006, 12:16 PM
JBurgin JBurgin is offline
Sage User
 
Join Date: Feb 2006
Posts: 21
Problem with importing ASF files

Howdy all,

We are testing out the SAGETV server and client for our school system. We are experimenting with the different video files our teachers would use and have run into a problem.

AVI and MPG files will import just fine. We can pick those files and choose to copy them to the server, thereby importing them into our "library", so they work and play fine. We are having an issue with "ASF" files however (primarily downloaded from www.unitedstreaming.com).

When we try to import the file into the server's library, it goes through the process of copying the file to the server. But when we look for the file in our library list, it's not there. There is no mention of the file we tried to import, although there are multiple AVI and MPG files located there, so we know the library is working. We can also navigate to the Video Library location through Windows Explorer and see that the file has been copied over.

We tried playing the ASF files directly for the local machine and not importing it into the media player, and this works. It can be played just fine, but it does not show up in the video library when we import it.


Any ideas?

I believe we are running the latest version, as we downloaded our trials just a few days ago.
Reply With Quote
  #2  
Old 02-20-2006, 01:22 PM
garcia21's Avatar
garcia21 garcia21 is offline
Sage User
 
Join Date: Apr 2004
Posts: 47
Shut down SageTV. In your Sage folder open up SAGE.PROPERTIES (on your server) or SAGECLIENT.PROPERTIES (on the client PC) and look for:
seeker/video_library_import_filename_extensions=
Make sure .asf is included. If not, added it in. Restart Sage and you should be good to go.
Reply With Quote
  #3  
Old 02-20-2006, 01:32 PM
JBurgin JBurgin is offline
Sage User
 
Join Date: Feb 2006
Posts: 21
Already there

garcia,

I checked what you offered, but it is already listed in the properties files. I checked both the server copy and the client copy.
Reply With Quote
  #4  
Old 02-20-2006, 02:33 PM
garcia21's Avatar
garcia21 garcia21 is offline
Sage User
 
Join Date: Apr 2004
Posts: 47
Just so I understand this correctly, if you go to Media Center and choose Browse Media Files, you are able to locate and play the file(s)?
Reply With Quote
  #5  
Old 02-20-2006, 03:01 PM
JBurgin JBurgin is offline
Sage User
 
Join Date: Feb 2006
Posts: 21
Correct. There are some quirks though:

If I play the file (do not attempt to copy it to the Library), it shows up in the library as a local file. However, if you click on the file and select Video Info, it states that the file size is 0.00MB and it shows where it is located. That is it.

There is no name in the library, just an empty box.

The file will stay in the library until you shutdown the client and restart it.
Reply With Quote
  #6  
Old 02-20-2006, 03:21 PM
garcia21's Avatar
garcia21 garcia21 is offline
Sage User
 
Join Date: Apr 2004
Posts: 47
Are you using UNCs for your directory paths? Are you having the same problem on your server?
Reply With Quote
  #7  
Old 02-21-2006, 07:51 AM
JBurgin JBurgin is offline
Sage User
 
Join Date: Feb 2006
Posts: 21
The problem exists on the server and client PC's. The directory paths are viewed as local paths, not UNC's.

In case you are curious, SageTV server is running in Service Mode.
Reply With Quote
  #8  
Old 02-22-2006, 10:10 AM
JBurgin JBurgin is offline
Sage User
 
Join Date: Feb 2006
Posts: 21
Gotta love it

I think I've solved my own issue. Don't ya love it when that happens?

Either way, here was my initial setup and I think this might be what caused the issue.

My media center import directories and recording directories were the same "Documents and settings/adminsitrator/my documents/my videos/sagetv"

I considered it odd that it never crossed my mind, but even though Mpeg and AVI files show up fine, here were the things NOT showing up in my video library, even though they were in the same directory as the Mpeg and AVI files:

WMV files
Recorded TV shows (even though recorded in the MPEG format)

I even tried expanding that location to include pictures and music. But nothing made the ASF files show up.

Either way, I decided to head out to our school and do some at the keyboard testing and fixing, since doing it remotely was becoming a hassle (schools been having power outages)

When I got here, the first thing I did was try to add an ASF file. No go. Then I noticed something. The files we d/l from unitedstreaming.com have underscores "_" in them. I wondered if THAT might be the issue. So I removed the underscores and tried to reimport the file. No go still. Kinda irritating.

Then, I noticed I had a problem with a tuner card. About two days ago I accidentally tuned one of our "channels" to a FM tuner "station". Did not realise I could do this, but if you go to Media Center, then Music. It says we have 4 FM tuners installed. Clicking on one of those caused the system to lockup and display a "playback error"

Either way, long story short. No matter what I did, rebooting, or editing the properties file. Every time I tried to watch Live TV, that tuner would ALWAYS tune to that "bad channel" and wouldn't let me switch. I finally got that problem fixed, or so I thought until it popped up again today. I ended up removing that parciular capture device and re-adding it.

In that process, I decided to run through the configuration wizard and give it some fresh options. When I got to the sections about Media Center Import Directories, I decided that maybe it would be better to separate the imported file from the recorded files. Less of a mess.

So I separated the imported files. I deleted any ASF, AVI or MPG file that I had ever imported and started over fresh.

After getting everything set, I picked out my ASF file to try and reimport. I found it and copied it to the library. I checked the video import library and there was no file. Kinda irritated. So I backed out and decided to try a different file from the unitedstreaming.com website. As I was downloaded the new file, I got a little click happy and accidentally put myself back into the Imported Videos library, and my file was there. Just as happy as it could be. File name and all. No blank box. When I clicked on the file to play it, it played beautifully.

So I imported another ASF file, worked like a charm.

Then I tried a WMV file I had tried earlier that wouldn't import. It imported as well. The best part is that I technically don't HAVE to use the Import option to copy files to the library, I can do it manually. I can used maybe windows explorer to dump several files into that directory and it will find them all.

I'm extremely glad to have this working, this was a major bump in our road to seeing whether or not this will work for our school.

Thanks garcia for your help.

Can any of the higher ups confirm that you HAVE to have the imported videos separated from the recorded shows for the media center library to work properly?

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.