SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Placeshifter

Notices

SageTV Placeshifter Discussion related to the SageTV Placeshifter application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV Placeshifter software application should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-21-2008, 10:20 PM
STV-Newbe STV-Newbe is offline
Sage User
 
Join Date: Jan 2008
Posts: 8
Placeshifter Router issues...

Hello,
Trying to get my place shifter working.

Got it working with laptop hardwired to the same side of my Linksys BEFSR81 router as the SageTV server machine, both machines have ip's 10.0.0.XX and it works fine.

This BEFSR81 router is connected to my DSL which has 5 static IP addresses, the BEFSR81 is assigned one of the static IP addresses. I have forwarded port 31099 in the BEFSR81 to the local IP of my SageTV server machine but when I move the laptop to the other side of the BEFSR81 router and assign one of my DSL static IP's to the laptop the Placeshifter stops working. More specifically, Placeshifter asks for User/Pass and accepts my user/pass, the interface loads and shows the overlay and channel info, I can even change the channel but the video doesn't play. Are there other ports that need to be forwarded beyond 31099?

I ultimately want to use the placeshifter on the laptop over my wireless, but since it wasn't working I went with hard wire LAN IP (worked) then moved to hard wire Internet IP (Didn't Work) so I am stuck here, I know he wireless will never work until I can get it working with the wire through the BEFSR81.

I am pretty sure that there are no software firewall issues since placeshifter works when both computers have LAN IP's, but that could be a bad assumption perhaps??

Any suggestions would be very appreciated...
Thanks
Reply With Quote
  #2  
Old 10-22-2008, 05:17 AM
Djc208's Avatar
Djc208 Djc208 is offline
Sage Expert
 
Join Date: Feb 2007
Location: SE Virginia
Posts: 674
From page 222 of the user's manual:

Quote:
The following port is used by a Placeshifter Client:
o 31099 (TCP) For SageTV usage. This port should be opened on your
firewall/router and forwarded to the computer that is running the SageTV server.
o 31100 (UDP) For SageTV Placeshifter usage. The Placeshifter uses this port to auto-discover SageTV servers on the local network.
o 8018 (TCP) For SageTV Placeshifter usage. When using a Locator ID to locate your SageTV server, your server uses this port to register its Locator ID and the Placeshifter client uses this port to contact the Locator server to find your server.
Note: If an IP address is used instead of a Locator ID, this port does not need to be used.
o 7818 (TCP) For SageTV Placeshifter usage. When the Placeshifter is set to not transcode the video over a local network connection, this port is used to stream the media.
What kind of server are you running? What is the server doing when you try and watch a video (CPU load, etc). What kind of video are you trying to watch?

There are different bandwith limitations going over your LAN vice over the internet. The server will have to transcode the video to a lower resolution in most cases. If the server isn't up to this you'll get no video. Try it with an SD recording first. HD and live TV seem to be harder.
__________________
Server: Core 2 Duo E4200 2 GB RAM, nVidia 6200LE, 480 GB in pool, 500GB WHS backup drive, 1x750 GB & 1x1TB Sage drives, Hauppage HVR-1600, HD PVR, Windows Home Server SP2
Media center: 46" Samsung DLP, HD-100 extender.
Gaming: Intel Core2 Duo E7300, 4GB RAM, ATI HD3870, Intel X-25M G2 80GB SSD, 200 & 120 GB HDD, 23" Dell LCD, Windows 7 Home Premium.
Laptop: HP dm3z, AMD (1.6 GHz) 4 GB RAM, 60 GB OCZ SSD, AMD HD3200 graphics, 13.3" widescreen LCD, Windows 7 x64/Sage placeshifter.
Reply With Quote
  #3  
Old 10-22-2008, 11:42 AM
STV-Newbe STV-Newbe is offline
Sage User
 
Join Date: Jan 2008
Posts: 8
Hello, and thanks for the reply.
I dont have HD so that's not an issue. I had been trying to watch live tv and some of the recorded programs, same stuff that worked when I was using the LAN IP. The server machine is a Pentium4 3GHz with 2Gig ram, and it is not choking on the video or anything. I am almost certain this is some sort of firewall issue. I guess I could pull my server out from behind my router and router firewall and test it from an internet IP that way to see if the internet part is an issue, but I am pretty sure it isnt. Since my laptop was assigned one of the static IP's in my DSL router and the router that my server is connected to is assigned another static IP from my DSL router I don't think the traffic has to go through the internet anyway, wouldnt it just go as far as my DSL router???
Reply With Quote
  #4  
Old 10-22-2008, 07:42 PM
sainswor99's Avatar
sainswor99 sainswor99 is offline
Sage Expert
 
Join Date: Sep 2006
Posts: 703
A couple of questions:

1. Why is it not working inside the network? Do you know that you can specify streaming settings for Placeshifter in the Manager? You may need to downgrade your stream on the LAN if your wireless connection is flaky (I would specify the settings rather than relying on Dynamic Streaming).

2. What are the specs on your laptop? You may need to adjust some of the option in the streaming settings if your GPU is not playing well on the laptop.

Hope that gets you started.

Stu
Reply With Quote
  #5  
Old 11-08-2008, 02:23 PM
EdPhotoguy EdPhotoguy is offline
Sage User
 
Join Date: Jan 2008
Posts: 54
MY problem with Placeshifter

I also have an issue with Placeshifter which I can't figure out

Placeshifter works fine with in my LAN, When I try to go over the internet, I get the same issues The menues work fine but no video or audio. I have tried ever possible setteng bot in SAGE and placeshifter.

The only workaround that I founds is If I use an older verson of SAGE on the server and the current version of Placeshifter on my laptop it will work.

This has some other issues but the streaming works over the Internet.

In both the Server AMD dual core and Laptop IBM P4 the processors are not maxed out.

I am using a fairly new net NETGEAR N router and the port is forwarded ,

Versions of SAGE 6.3 and the newest placeshifter version 6.4 works ok.

Any help please.

I am trying to stream SD live tv and videos.

Ed
Reply With Quote
  #6  
Old 11-08-2008, 04:19 PM
STV-Newbe STV-Newbe is offline
Sage User
 
Join Date: Jan 2008
Posts: 8
SageTV support was helpful in solving my issue.
Open the PlaceShifter on your remote machine, click the Settings button, in the STREAMING Tab change from the SageTV Dynamic Streaming to the MANUAL Streaming Settings, leave everything at their default setting and apply and then try to connect. Worked like a charm for me, TV and media files now play great. I don't know why the Dynamic streaming doest work for me, but the support team is aware of the issue.
After I got it working I went and changed the manuals settings to increase the video quality, I haven't had any problems streaming while using the manual settings at any bitrate...
Hope this is helpful to you.....


Quote:
Originally Posted by EdPhotoguy View Post
I also have an issue with Placeshifter which I can't figure out

Placeshifter works fine with in my LAN, When I try to go over the internet, I get the same issues The menues work fine but no video or audio. I have tried ever possible setteng bot in SAGE and placeshifter.

The only workaround that I founds is If I use an older verson of SAGE on the server and the current version of Placeshifter on my laptop it will work.

This has some other issues but the streaming works over the Internet.

In both the Server AMD dual core and Laptop IBM P4 the processors are not maxed out.

I am using a fairly new net NETGEAR N router and the port is forwarded ,

Versions of SAGE 6.3 and the newest placeshifter version 6.4 works ok.

Any help please.

I am trying to stream SD live tv and videos.

Ed
Reply With Quote
  #7  
Old 11-08-2008, 06:27 PM
EdPhotoguy EdPhotoguy is offline
Sage User
 
Join Date: Jan 2008
Posts: 54
Thank you

That was the cure.

It now works great

Thanks again

Ed
Reply With Quote
  #8  
Old 11-08-2008, 06:57 PM
EdPhotoguy EdPhotoguy is offline
Sage User
 
Join Date: Jan 2008
Posts: 54
Another question

I have noticed a lot more pixelation in the streaming I did try different settings in Placeshifter and don't seem to notice any difference. I also have tried to stream different files types.

Did you find any manual settings that work better

ed
Reply With Quote
  #9  
Old 11-08-2008, 07:19 PM
STV-Newbe STV-Newbe is offline
Sage User
 
Join Date: Jan 2008
Posts: 8
Your qaulity of the stream is going to hinge on the speed of your connection, you can increase the bandwidth and the quality should increase until you hit the point where the stream chokes your bandwidth. All I can say is try cranking up the video Bitrate about 100 at a time until the connection chokes and then back it down a bit from there. Thats what I did, the quality isnt as good as on the server machine but that is to be expected....
Good luck....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio Issues with Placeshifter taylormadearmy SageTV Placeshifter 1 03-10-2008 04:18 PM
Mac Placeshifter issues ptaylor SageTV Placeshifter 8 12-21-2006 07:36 PM
Issues: Linux Placeshifter jroe SageTV Placeshifter 4 08-13-2006 03:27 PM
SageTV V4.1.11 Beta Is Available - Better Placeshifting! Narflex SageTV Beta Test Software 81 04-04-2006 09:39 PM
Channel changing issues with placeshifter and MVP hchucky SageTV Beta Test Software 0 03-07-2006 12:50 PM


All times are GMT -6. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.