SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-15-2017, 07:32 PM
atchoo atchoo is offline
Sage User
 
Join Date: Aug 2009
Location: Montreal
Posts: 36
v7 Upgrade to v9 problems

Hi All...

Today I upgraded my v7 install (on Windows XP) with the latest v9 in order to get the EPG working again. Installation process when fine with no errors (it took a very long time to pass the Processing : SageTV step but it did.

Now I can run the v9 server but what should I do next? I tried changing the EPG to Schedule Direct, it prompted me for my username and password but after submitting it it kept loading with the spinning wheel for about 30 minutes so I cancelled it. Do I need to delete my sources and recreate them?

Also, I noticed that my extenders can't connect anymore. HD-200 and HD-300. They don't find the server. If I input the server IP manually and force it to load it stays on a black screen. I can ping the extenders from the server but they don't find it. Just because upgrading to v9 the extenders were working fine and could find the server. Nothing else changed beside upgrading and rebooting.

I also think I read something about the plugins but I am not sure what I should do with the plugins. I did not see any plugin with a note that it needed upgrade and I have a bunch of plugins it doesn't make sense to uninstall everything and reinstall? Is it what I have to do?

Would appreciate some help. Did I miss some upgrade guidelines posted somewhere?

Martin
Reply With Quote
  #2  
Old 08-15-2017, 09:42 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,505
The symptoms sound a lot like either a firewall is blocking everything on your server or your router needs to be power cycled. You should post your sagetv_0.txt log after trying to connect to Schedules Direct. Someone else had something similar happen and it was DNS related which on a normal home setup would be the responsibility of the router.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #3  
Old 08-16-2017, 06:51 AM
atchoo atchoo is offline
Sage User
 
Join Date: Aug 2009
Location: Montreal
Posts: 36
Quote:
The symptoms sound a lot like either a firewall is blocking everything on your server....
What port is the sageTV server listening to?

Went to sleep, woke up this morning and retried setting Schedules Direct as the EPG and it seems to work! I get "Channel lineup is being downloaded...." it is very slow and it's been stucked there for at least 10 minutes now, but I will give it some time to complete.

localhost:8080/bmt also works this morning (it did not work yesterday) but it is not reachable from it's IP address so the firewall thing could make sense.... but I haven't changed anything I only installed v9 over v7.

Will try to figure it out.
Martin
Reply With Quote
  #4  
Old 08-16-2017, 07:26 AM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,806
Quote:
Originally Posted by atchoo View Post
What port is the sageTV server listening to?

Went to sleep, woke up this morning and retried setting Schedules Direct as the EPG and it seems to work! I get "Channel lineup is being downloaded...." it is very slow and it's been stucked there for at least 10 minutes now, but I will give it some time to complete.

localhost:8080/bmt also works this morning (it did not work yesterday) but it is not reachable from it's IP address so the firewall thing could make sense.... but I haven't changed anything I only installed v9 over v7.

Will try to figure it out.
Martin
Usually takes more than an hour to complete.
__________________
Server: Athlon II X4 630 CPU, Gigabyte MA770T-UD3P (AM3) Motherboard, VisionTek Radeon HD4670 PCIe w/ Component output to 50" CRT Rear-Projection HDTV (Mitsubishi), Win7-64Bit (Home Premium), 4GB RAM
Capture Devices (8 tuners): Colossus (x1), HD-PVR (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250
Reply With Quote
  #5  
Old 08-16-2017, 10:33 AM
atchoo atchoo is offline
Sage User
 
Join Date: Aug 2009
Location: Montreal
Posts: 36
I disabled XP's Firewall and my extenders and the web server at :8080 now work. Not sure why the exceptions in the firewall rules don't work with version 9 but it seems that they don't.

I was able to set the EPG to Schedule Direct and used the Import/Export channel list plugin to restore my channel list and guide. As noted, you need to be patient while it downloads the channel list from Schedules Direct it took something like 45 minutes to complete.

No nightmare so far.... upgrade went pretty well and everything seems to be working like before the upgrade.... surprising since this old Mac-Mini with Windows XP is running SageTV since 2009 !

Reply With Quote
  #6  
Old 08-16-2017, 06:23 PM
JustFred JustFred is offline
Sage Aficionado
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 429
Quote:
Originally Posted by atchoo View Post
I disabled XP's Firewall and my extenders and the web server at :8080 now work. Not sure why the exceptions in the firewall rules don't work with version 9 but it seems that they don't.
How was the upgrade from V7 to V9 performed? Was the installer run, following the instructions here:
https://forums.sagetv.com/forums/sho...25&postcount=1

Was the installer run TWICE, selecting Repair the 2nd time?

On the other hand, attempting to upgrade by **manually** replacing existing .exe, dll, etc files is likely to encounter this problem. It's really best to run the installer, because that also updates Windows' firewall settings for any given program. Even though visual inspection of the firewall rules may show the name of the Sage program, that's for the OLD v7 Sage (and it's unique signature), not the new v9 Sage.
__________________
System #1: Win7-64, Core2-Quad Q9400, 8 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB Mem, 2TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HVR2250; Spectrum Cable via HDPVR & USB-UIRT. 3x HD-200.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade to HD-PVR Problems - Help! SkierHiker SageTV Software 23 10-04-2010 11:34 PM
upgrade problems from 6.x to 6.6 jimbolocke SageTV Software 0 04-24-2010 04:29 PM
upgrade problems sage 6.1.9 Homebuilder SageTV Customizations 4 06-06-2007 10:34 PM
Two problems since V6.0.19 upgrade Falcon64 SageTV Software 6 01-05-2007 09:31 PM
VIDEO PROBLEMS SINCE 2.1 UPGRADE - HELP, PLEASE! srothwell SageTV Software 4 11-23-2004 09:13 AM


All times are GMT -6. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.