SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-09-2006, 03:03 PM
Box8489 Box8489 is offline
Sage User
 
Join Date: Apr 2005
Location: Denmark, Europe
Posts: 33
Send a message via MSN to Box8489
Do I have a Java problem ?

Hi again,

I'm sorry to disturb you experts again, but I really want to learn more about Linux so I have installed a Fedora Core 6 to play with. (learned a lot already )

I have also installed SageTV without any obvious problems.
But when I start my Client from an Windows pc, he detects the server but says: "An exception occurred in Java: Java.lang.NullPointerException".
When I start my Linux Client at the same machine where the server is running, is the GUI completely empty.

Any idea of in which direction I should look for the problem?

Regards:
Michael
Attached Files
File Type: txt sagetv_0.txt (33.7 KB, 241 views)
Reply With Quote
  #2  
Old 12-09-2006, 04:10 PM
joat joat is offline
Sage User
 
Join Date: Dec 2006
Location: Virginia
Posts: 25
Missing Java or path?

I had similar errors when I didn't have the path set for the JRE. Assuming that you have IVTV (or whatever it is that you use to encode) installed properly:

1) Grab the latest JRE from java.sun.com (it might be called JSE-something).
2) Run it in your home directory. It'll create a directory called "jre-something". For simplicity, rename it to "jre"
3) Edit your .bashrc to include "export PATH=/home/yourhomedir/jre/bin:$PATH'
4) If you run the server as root, repeat step #3 for the root .bashrc
5) Try running the server and client again

- joat
Reply With Quote
  #3  
Old 12-09-2006, 05:19 PM
Box8489 Box8489 is offline
Sage User
 
Join Date: Apr 2005
Location: Denmark, Europe
Posts: 33
Send a message via MSN to Box8489
Hi joat,

Thank U so much.... that was it, fantastic..
Now I can move on to the next challenges

Regards:
Michael
Reply With Quote
  #4  
Old 02-17-2007, 06:53 PM
joat joat is offline
Sage User
 
Join Date: Dec 2006
Location: Virginia
Posts: 25
No problem

No problem. Uh, is it me or is the clock/calendar for these posts a bit screwy?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.