SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations > SageMC Custom Interface

Notices

SageMC Custom Interface This forum is for discussing the user-created SageMC custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-15-2009, 06:47 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
SageMC 6.3.9b_2 pre-release breaks My Videos?

After loading this, I now only see a single folder called "Untitled" under My Videos. When I click on it, there's nothing there. This is using "File System" and "Folder View" with "No Filter". All other views (such as All Videos, Date Added, etc.) seems OK.

I do not have BMT 3.1 installed, so perhaps that's why.

Thanks for your work, MeInMaui!
Reply With Quote
  #2  
Old 09-15-2009, 06:50 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
What version of the phoenix api does it say is running in the Settings screen?
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)
Reply With Quote
  #3  
Old 09-15-2009, 07:00 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
Quote:
Originally Posted by MeInMaui View Post
What version of the phoenix api does it say is running in the Settings screen?
It says
SageMC STV version: 6.3.9a
sagemc.jar Version: 6.3.8
df_sageutils.jar Version: 2.2
phoenix.jar Version: 1.42
Current STV File: SageMC_6_3_9b_2.xml

I had re-named existing phoenix.jar to "phoenix (1.42).jar" and copied the contents of "Phoenix JAR v1.44.zip" into my JARs directory.
Reply With Quote
  #4  
Old 09-15-2009, 07:04 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
Quote:
Originally Posted by jsin View Post
It says
SageMC STV version: 6.3.9a
sagemc.jar Version: 6.3.8
df_sageutils.jar Version: 2.2
phoenix.jar Version: 1.42
Current STV File: SageMC_6_3_9b_2.xml

I had re-named existing phoenix.jar to "phoenix (1.42).jar" and copied the contents of "Phoenix JAR v1.44.zip" into my JARs directory.
Ah ha! Removing the "phoenix (1.42).jar" and stop/start the SageTV Service made it all better! Now it reports phoenix.jar Version of 1.44 and I can see the contents of "My Videos".

Thanks for the hint!
Reply With Quote
  #5  
Old 09-15-2009, 07:04 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,598
Quote:
Originally Posted by jsin View Post
It says
SageMC STV version: 6.3.9a
sagemc.jar Version: 6.3.8
df_sageutils.jar Version: 2.2
phoenix.jar Version: 1.42
Current STV File: SageMC_6_3_9b_2.xml

I had re-named existing phoenix.jar to "phoenix (1.42).jar" and copied the contents of "Phoenix JAR v1.44.zip" into my JARs directory.
While it's ok to rename a jar... you'll also have to pull it out of the JARs directory. ie, if your JARs dir has both "phoenix.jar" and "phoenix (1.42).jar", then it's a crap shoot as to which jar file will be loaded by the JVM (java), but for sure, both will not be loaded.

So to be safe, backup your jars to another folder (BACKUP-JARs) and then restart sage.

EDIT: I guess you figured it out yourself
Reply With Quote
  #6  
Old 09-15-2009, 07:06 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
You will have to move/delete the v1.42 jar file and install the v1.44 phoenix.jar file that I posted. Make sure you exit sage first, copy in the file, and then restart sage or else the new jar file will not be picked up.

Aloha,
Mike

Edit: Glad you got it working.
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)

Last edited by MeInMaui; 09-15-2009 at 07:08 PM.
Reply With Quote
  #7  
Old 09-15-2009, 07:09 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
Quote:
Originally Posted by stuckless View Post
While it's ok to rename a jar... you'll also have to pull it out of the JARs directory. ie, if your JARs dir has both "phoenix.jar" and "phoenix (1.42).jar", then it's a crap shoot as to which jar file will be loaded by the JVM (java), but for sure, both will not be loaded.

So to be safe, backup your jars to another folder (BACKUP-JARs) and then restart sage.

EDIT: I guess you figured it out yourself
Yeah - in the past when I did something like that (re-naming instead of deleting JAR files), there have been occasions when it worked fine. But I guess now I know better. I'll be sure to do it correctly from now on!

Thanks - your help is much appreciated!
Reply With Quote
  #8  
Old 09-15-2009, 07:21 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
Just wanted to say a big "Thanks!!!" to MeInMaui and Stuckless; so far there are 5 SageTV add-ons that I always rely on - I don't think I'd've stuck with SageTV as long as I have (~2 years, replacing Microsoft Windows MCE and Vista MCE as well as BeyondTV) had it not been for those add-ons:

SageMC
BMT (but only in command line mode)
Sleep-Timer by flachbar
Web-based User Interface by nielm
Comskip Monitor by Steep

Thanks again, guys!
Reply With Quote
  #9  
Old 09-15-2009, 09:51 PM
technazz's Avatar
technazz technazz is offline
Sage Aficionado
 
Join Date: Jul 2004
Location: Hamilton, ON, CA
Posts: 474
I just updated and I now notice that when im in Folder view the titles use the filename instead of the movie name. I have Cars.mkv instead of Cars

This update does fix the issue with bmt with videos showing up in the root folder.

Technazz
__________________
SageTV V9.xx 2 x HD300's, 2 x Nvidia Shields Running Mini Client
Reply With Quote
  #10  
Old 09-15-2009, 10:03 PM
jsin jsin is offline
Sage User
 
Join Date: Jun 2009
Location: Irvine, CA
Posts: 58
Quote:
Originally Posted by technazz View Post
I just updated and I now notice that when im in Folder view the titles use the filename instead of the movie name. I have Cars.mkv instead of Cars

Technazz
Yes, it does. Same here.
Reply With Quote
  #11  
Old 09-15-2009, 10:53 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
Quote:
Originally Posted by technazz View Post
I just updated and I now notice that when im in Folder view the titles use the filename instead of the movie name. I have Cars.mkv instead of Cars

This update does fix the issue with bmt with videos showing up in the root folder.

Technazz
I'll take a look at it. Thanks.
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)
Reply With Quote
  #12  
Old 09-15-2009, 11:28 PM
KJake KJake is offline
Sage Icon
 
Join Date: May 2003
Location: West Michigan
Posts: 1,117
A few things that I've noticed:

* The version on the Settings page still reports 6.3.9a.
* My Videos now has an Untitled folder in the File System view - the folder contains nothing.
* The alphabetical navigation doesn't work in My Videos any more. You can view and select the letter you want, but the list does not jump.
* If you have multiple levels of folders, with videos, the file name is listed in the File System view instead of the Display Title in the meta-data (as it was before). When you select a file to view the Video Info, it then changes to displaying the main Display Title.
* If you right-click in the Settings screen with the focus on any of the buttons, you get a message asking if you want to "power off extender".
* In My Videos, if you have a bunch of files in a folder, the Watched Icon no longer appears next to Watched titles.


Here are the versions reported--Hope this info helps!

SageTV V6.6.2.218
Java: 1.6.0_15
SageMC: 6.3.9a
sagemc.jar: 6.3.8
df_sageutils.jar: 2.2
phoenix.jar: 1.44
Reply With Quote
  #13  
Old 09-16-2009, 12:09 AM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
Always with the unintended consequences.

Thanks for the info KJake.
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)
Reply With Quote
  #14  
Old 09-16-2009, 07:07 AM
KJake KJake is offline
Sage Icon
 
Join Date: May 2003
Location: West Michigan
Posts: 1,117
Quote:
Originally Posted by MeInMaui View Post
Always with the unintended consequences.

Thanks for the info KJake.
No problem - sorry for the laundry list

I can give you good new though too

Before this update, if I went to the second page (page down once) in the Genre View, it would hang the client and put Sage into what seemed to be an endless error fest in the logs. Restarting the extender wouldn't fix it; I would have to restart Sage entirely. I just assumed that I have too many videos and Genres now for the STV to handle and I've been watching TV series more than Movies lately, so I never reported it.

Also, even before BMT 3.1, I noticed that the File System view was hiding a lot of videos - it looked like it was trying to hide duplicate movie titles. This 'b' update definitely fixed that too

Thanks for your work!
Reply With Quote
  #15  
Old 09-17-2009, 03:12 PM
disco340 disco340 is offline
Sage User
 
Join Date: Jan 2009
Posts: 60
Quote:
Originally Posted by KJake View Post
A few things that I've noticed:

* My Videos now has an Untitled folder in the File System view - the folder contains nothing.
Could this possibly be what I'm experiencing? See post below.

http://forums.sagetv.com/forums/showthread.php?t=44206
Reply With Quote
  #16  
Old 09-17-2009, 04:48 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
Quote:
Originally Posted by KJake View Post
A few things that I've noticed:

* The version on the Settings page still reports 6.3.9a.
* My Videos now has an Untitled folder in the File System view - the folder contains nothing.
* The alphabetical navigation doesn't work in My Videos any more. You can view and select the letter you want, but the list does not jump.
* If you have multiple levels of folders, with videos, the file name is listed in the File System view instead of the Display Title in the meta-data (as it was before). When you select a file to view the Video Info, it then changes to displaying the main Display Title.
* If you right-click in the Settings screen with the focus on any of the buttons, you get a message asking if you want to "power off extender".
* In My Videos, if you have a bunch of files in a folder, the Watched Icon no longer appears next to Watched titles.
A new pre-release has been posted that addresses most of these issues. I did not change the "power off extender" dialog because it looks like that is a feature to allow you to shut down an extender remotely if you have set up its MAC address in the properties file (sagemc/extender_mac). I have only had the opportunity to do limited testing of this, so let me know how it goes. Thanks.

Aloha,
Mike
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)

Last edited by MeInMaui; 09-17-2009 at 04:50 PM.
Reply With Quote
  #17  
Old 09-17-2009, 06:49 PM
Peter_h Peter_h is offline
Sage Fanatic
 
Join Date: May 2008
Location: Kailua, HI
Posts: 798
Hey Mike,

Thanks for the quick turnaround on these new versions.

Did you get a chance to fix the Music fanart refresh issue, I reported?

Music Fanart not refreshing with new track.

Basically, the first fanart background to load will stay during an entire playlist. It is not refreshing when a new artist comes up in the playlist. If you navigate away from the "now playing" screen and then go back to it, it will then display new fanart corresponding to the current fan art. However, the same cycle continues. You have to go to a different screen and then back to the now playing to get the fanart to load if a new artist comes up.

Last edited by Peter_h; 09-17-2009 at 06:54 PM.
Reply With Quote
  #18  
Old 09-17-2009, 07:04 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
I forgot about that one. Thanks for the reminder.
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)
Reply With Quote
  #19  
Old 09-17-2009, 07:22 PM
KJake KJake is offline
Sage Icon
 
Join Date: May 2003
Location: West Michigan
Posts: 1,117
Thanks for the update Mike; however, the File System view is now completely empty for me. It looks like possibly an issue with the Filter. If I cycle through the Filter, DVD works, but the rest do not. All the other views appear to work and the quick letter jump is definitely working.

A note on the Genre view. I said that it was working for me again, but not entirely. It goes into a spinning circle by the 7th page down now. The last genre on my screen is Filming Material. Again, if I had to guess, I would have to say that I've introduced too many Genres using BMT - but that's just an uneducated guess.

I tested on a Placeshifter and a HD200.

Versions --
SageTV 6.6.2.218
Java: 1.6.0_15
SageMC: 6.3.9b pre 3
sagemc.jar: 6.3.8
df_sageutils.jar: 2.2
phoenix.jar: 1.44
Reply With Quote
  #20  
Old 09-17-2009, 07:33 PM
MeInMaui's Avatar
MeInMaui MeInMaui is offline
SageTVaholic
 
Join Date: Feb 2005
Location: Maui. HI
Posts: 4,203
@KJake

That's very strange. All of the filters and views are working fine for me. I'll have to do more testing tonight.

Aloha,
Mike
__________________
"Everything doesn't exist. I'm thirsty." ...later... "No, it's real!!! I'm full."
- Nikolaus (4yrs old)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest SageMC Pre-Release Announcement Thread MeInMaui Customization Announcements 20 06-07-2010 03:26 AM
Latest pre-release SageMC 6.3.9a-7 issues gplasky SageMC Custom Interface 13 04-06-2009 01:51 PM
**Official** SageMC v6.3.8b pre-release 12 Bug Reports Thread MeInMaui SageMC Custom Interface 28 03-13-2009 05:37 PM
6.3.8b Pre-release 12 Recorded TV Screwy Taddeusz SageMC Custom Interface 12 03-09-2009 03:49 AM
Latest version of SageMV SageMC v6.3.8b pre-release 6 Question Peter_h SageMC Custom Interface 9 01-17-2009 10:06 AM


All times are GMT -6. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.