SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux > SageTV for unRAID/Docker

Notices

SageTV for unRAID/Docker Discussion related to SageTV for unRAID/Docker. Questions, issues, problems, suggestions, etc. relating to SageTV for unRAID/Docker should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-25-2020, 12:54 AM
Striker:WG Striker:WG is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 279
Sage TV Docker Not Running Sage?

So, I've been messing around with getting Sage working in an Unraid Docker. Just got my Firewire card working, and things were moving along.

It's happened twice now where I had to restart my docker container and then Sage just wouldn't start. The container comes up and I can work with the file system through the console, but Sage itself doesn't startup.

The first time this happened, I deleted the docker, removed the trace files from the appdata folder and started fresh. My fresh start didn't go well as it refused to let me install the Jetty web server claiming I was missing the Ant dependency jar, but I couldn't find a way to install it through the plugin manager. I tried manually copying it in, but then the container started refusing to work again.

Has anyone else run into issues like this? I'm still pretty new to Unraid, Dockers, and even Linux, so forgive my n00b questions, but how does one go about troubleshooting this?

Thanks for any advice offered!
Reply With Quote
  #2  
Old 07-25-2020, 12:59 AM
Striker:WG Striker:WG is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 279
OK, so I'm not sure what changed, but after restarting the docker container AGAIN, Sage did come up.

Still not able to install the Jetty web server though.

How does one go about getting the Ant 1.8.2+ dependency jar installed and registered?

Thanks!
Reply With Quote
  #3  
Old 07-31-2020, 01:02 AM
Striker:WG Striker:WG is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 279
Hooray! My ANT+ plugin issue was resolved.

Going back to the original issue in this thread, it appears to be a very long startup time for the docker container. Probably about 7 minutes.

My UNRAID server is an older 3rd generation i7 /w 36GB DDR3 RAM, so it's not the fastest thing around, but its no slouch either.

Is this just a normal startup time?
Reply With Quote
  #4  
Old 07-31-2020, 05:03 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,610
If you look at the docker startup scripts for sagetv on unRAID it runs a few scripts. But, I suspect this is the one that is causing your delay

https://github.com/stuckless/sagetv-....d/30-setperms

This script will set the sagetv permissions on all files before allowing sagetv to start. So if you have lots of media files this could take some time.

It appears that if you set the OPT_SETPERMS to N it will skip it.
Reply With Quote
  #5  
Old 07-31-2020, 08:39 AM
Striker:WG Striker:WG is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 279
Thanks! It does seem to be starting up a lot faster now. About 1 minute or less!
Reply With Quote
  #6  
Old 08-03-2020, 02:38 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,597
I wanted to share when I had a similar issue, it was because my cache drive was starting to fail. Just something else to check on if anyone finds this thread in the future.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing Sage.prop in docker- file always in use? btrcp2000 SageTV for unRAID/Docker 3 10-25-2017 03:11 PM
Moving to Unraid with Docker from Windows Sage V9 bill321 SageTV for unRAID/Docker 20 10-16-2017 09:28 PM
Sage for Docker crashed on me wayner SageTV for unRAID/Docker 3 02-22-2017 11:51 AM
How are you running ComSkip in unRaid/Docker setups with v9? mgpaulus SageTV v9 Customizations 5 01-22-2017 05:53 PM
Installing Sage docker to cache drive wayner SageTV for unRAID/Docker 4 01-21-2017 02:49 PM


All times are GMT -6. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.