SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations > SageMC Custom Interface

Notices

SageMC Custom Interface This forum is for discussing the user-created SageMC custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-01-2008, 08:21 PM
richardcrowther richardcrowther is offline
Sage User
 
Join Date: Jan 2007
Posts: 18
Recovering group and genre data

I've just re-installed the full version of 6.3.7a to get the autocompression working correctly on EP's plugin and to get the Netflix plugin working properly.
After doing the re-install, all of my previous settings for menus etc were still available but I was missing all of the custom groups and genre allocations that I had set up.
I have a full backup of my SageTV directory prior to the re-install, is there any way to use the files in this to get back the group and genre assignments for my imported video files?
Any help would be much appreciated since it took a long time to save and group all of those files.
Reply With Quote
  #2  
Old 04-01-2008, 08:37 PM
dflachbart dflachbart is offline
SageTVaholic
 
Join Date: Jan 2006
Location: Brookfield, CT
Posts: 2,743
Quote:
Originally Posted by richardcrowther View Post
I've just re-installed the full version of 6.3.7a to get the autocompression working correctly on EP's plugin and to get the Netflix plugin working properly.
After doing the re-install, all of my previous settings for menus etc were still available but I was missing all of the custom groups and genre allocations that I had set up.
I have a full backup of my SageTV directory prior to the re-install, is there any way to use the files in this to get back the group and genre assignments for my imported video files?
Any help would be much appreciated since it took a long time to save and group all of those files.
All the custom group definitions are stored in Sage.properties on the server. Look for all properties that begin with "sagemc/video_category/..." and copy them to your new server properties file (after you shut down the server).

Dirk
Reply With Quote
  #3  
Old 04-02-2008, 08:12 PM
richardcrowther richardcrowther is offline
Sage User
 
Join Date: Jan 2007
Posts: 18
Thanks for the quick reply Dirk but I don't think that is the problem. The categories that I set up are still in my .properties file. The problem is that all of my imported videos that were assigned to those categories now show up as "unassigned" and the IMDB data that I had saved for each one is now missing so they don't show up in any of the genres either.

I saw a reference to a file for meta data called collection.xml in the .properties file. I had hoped the info would be stored there but I cannot find any file called that on my PC.

Where is the IMDB, genre and group data saved for an imported file? If it's stored in one of the Sage files then would I be able to restore the backup that I took before upgrading?
Thanks, for the help,
Richard
Reply With Quote
  #4  
Old 04-02-2008, 08:25 PM
dflachbart dflachbart is offline
SageTVaholic
 
Join Date: Jan 2006
Location: Brookfield, CT
Posts: 2,743
Quote:
Originally Posted by richardcrowther View Post
Thanks for the quick reply Dirk but I don't think that is the problem. The categories that I set up are still in my .properties file. The problem is that all of my imported videos that were assigned to those categories now show up as "unassigned" and the IMDB data that I had saved for each one is now missing so they don't show up in any of the genres either.

I saw a reference to a file for meta data called collection.xml in the .properties file. I had hoped the info would be stored there but I cannot find any file called that on my PC.

Where is the IMDB, genre and group data saved for an imported file? If it's stored in one of the Sage files then would I be able to restore the backup that I took before upgrading?
Thanks, for the help,
Richard
It's stored in the SageTV Metadata in the wiz.bin. So for some reason this has been lost for your files, and I'm afraid that you won't be able to recover it...

Dirk
Reply With Quote
  #5  
Old 04-02-2008, 09:35 PM
richardcrowther richardcrowther is offline
Sage User
 
Join Date: Jan 2007
Posts: 18
I just tried restoring the backup of the wiz.bin that I made before the upgrade but that had the same problem. I think the network drive holding the video files got corrupted / disconnected before then which wiped them from the wiz.bin. When it got re-connected the video files were imported again but minus the metadata. Oh well, guess I'd better get on with clicking through all those files to save the IMDB data again

Thanks for the help though
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STV: SageMC 16x9 Version 6.x (latest dev build) dflachbart SageMC Custom Interface 6112 04-04-2008 11:16 PM
SageTV V6.3.10 Release Candidate Narflex SageTV Beta Test Software 0 02-28-2008 06:07 PM


All times are GMT -6. The time now is 02:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.