SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Gemstone for v7

Notices

Gemstone for v7 This forum is for discussing the user-created Gemstone custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-26-2012, 10:29 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
Populating a Flow

So I must be missing something obvious....
I'm trying Gemstone out on one of my clients and I can't get any Flows to populate with any content. I create a new Flow and give it a filter (like including an import path or including the 'TV' media type). But nothing seems to ever show up in my Flows. I've tried choosing "Reload Views" ...not sure if it's necessary but it doesn't seem to help. What am I missing?
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #2  
Old 10-26-2012, 11:34 PM
jorton jorton is offline
Sage Icon
 
Join Date: Jul 2005
Location: Canada
Posts: 1,273
Have of tried just creating the default flows to see how they are setup? You should see your movies and TV shows listed in them.

The Gemstone VFS are setup to work in the way that most of us organize our recordings or movies. Or you can select one of the base VFS and build your own.
Reply With Quote
  #3  
Old 10-27-2012, 09:20 AM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
Yep, I've added the default flows but they show up empty too. This client was previously running Phoenix...not sure if that would matter.
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #4  
Old 10-27-2012, 09:33 AM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
The best place to start is to see if you get media displaying in the BMT Web Interface as it will also use the vfs views that Gemstone/Phoenix use.

Let us know what you see in BMT and then we can work from there.

k
Reply With Quote
  #5  
Old 10-27-2012, 09:55 AM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
When I look in BMT I see this error:

Quote:
Fri Oct 26 21:08:43 GMT-700 2012 - Phoenix Error

Error in VFS File: .\STVs\Phoenix\vfs\z-gemstone-vfs.xml; C:\Program Files (x86)\SageTV\SageTV\vfs.dtd (The system cannot find the file specified)
Do I need to put a copy of "z-gemstone-vfs.xml" on the server (where BMT is installed but is not running Gemstone)?
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #6  
Old 10-27-2012, 12:28 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
I think the error is saying it cannot find "C:\Program Files (x86)\SageTV\SageTV\vfs.dtd".

Perhaps you need to pop over to the BMT forum and get it working first as I think this file missing has occurred before (if I remember correctly).

k
Reply With Quote
  #7  
Old 10-27-2012, 03:06 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
You were right! I copied vfs.dtd from the server to "C:\Program Files (x86)\SageTV\SageTV" on the client and now all the views have content. Thanks for your help!
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #8  
Old 11-08-2012, 03:41 PM
Naylia's Avatar
Naylia Naylia is offline
Sage Fanatic
 
Join Date: Feb 2005
Location: Mountain View, CA
Posts: 754
Which option menu gets edited to change the media type/folder that it is pointing at? That's what I haven't been able to figure out.
__________________
You can find me at Missing Remote. Or playing FF XIV. For XLobby users: XLobby MC
Reply With Quote
  #9  
Old 11-08-2012, 04:27 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
Quote:
Originally Posted by Naylia View Post
Which option menu gets edited to change the media type/folder that it is pointing at? That's what I haven't been able to figure out.
Not sure I understand the question...do you mean where do you set which media will show inside a flow? If so... Press options while in the flow and select View... And then pick from the first list of predefined flow views for gemstone.

k
Reply With Quote
  #10  
Old 11-20-2012, 08:39 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
I just installed version 1.0182 and I can't get the UserCategory filters to work.

I'm trying to create a kids TV view. I've assigned a 'kids' UserCategory to a few Favorites but when I try to filter (include or exclude) with it, it does not work. I've tried both the Simplified and Inline Flow without any luck.
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #11  
Old 11-20-2012, 08:52 PM
jorton jorton is offline
Sage Icon
 
Join Date: Jul 2005
Location: Canada
Posts: 1,273
I just tried it and it's working for me. I assigned a user defined category to two different kids show called "Kids" and then used the default Simplified Flow with the UserCategory Filters set to "Kids" and include and after backing out of the options menu the only items displayed are the two shows I flagged as "Kids".







Attached Images
File Type: jpg UCFilter_1.jpg (37.3 KB, 289 views)
File Type: jpg UCFilter_2.jpg (32.3 KB, 285 views)
File Type: jpg UCFilter_3.jpg (22.8 KB, 303 views)
File Type: jpg UCFilter_4.jpg (44.4 KB, 274 views)
Reply With Quote
  #12  
Old 11-20-2012, 09:17 PM
nyplayer nyplayer is offline
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,137
I am getting this error and all my flows are blank NUll... This is a client Install.

Tue Nov 20 19:03:49 GMT-800 2012 - Phoenix Error

Error in VFS File: .\STVs\Phoenix\vfs\z-gemstone-vfs.xml; null

Code:
pri=3;type=10200;time=1353467029544;msg=Error in VFS File: .\\STVs\\Phoenix\\vfs\\z-gemstone-vfs.xml\; null;end=1353467704631;rep=8;Vseverity=3;Vexception=java.lang.NullPointerException
	at sagex.phoenix.vfs.builder.FactoryItemBuilder.startElement(FactoryItemBuilder.java:36)
	at sagex.phoenix.vfs.builder.FiltersBuilder.startElement(FiltersBuilder.java:96)
	at sagex.phoenix.vfs.builder.VFSBuilder.startElement(VFSBuilder.java:113)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.startElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at sagex.phoenix.vfs.builder.VFSBuilder.registerVFSSources(VFSBuilder.java:85)
	at sagex.phoenix.vfs.builder.VFSBuilder.registerVFSSources(VFSBuilder.java:53)
	at sagex.phoenix.vfs.VFSManager.visitConfigurationFile(VFSManager.java:189)
	at sagex.phoenix.common.SystemConfigurationFileManager.visitFiles(SystemConfigurationFileManager.java:100)
	at sagex.phoenix.common.SystemConfigurationFileManager.accept(SystemConfigurationFileManager.java:73)
	at sagex.phoenix.vfs.VFSManager.loadConfigurations(VFSManager.java:202)
	at sagex.phoenix.Phoenix.initServices(Phoenix.java:251)
	at sagex.phoenix.Phoenix.<clinit>(Phoenix.java:83)
	at sagex.phoenix.configuration.proxy.FieldProxy.getProperty(FieldProxy.java:29)
	at sagex.phoenix.configuration.proxy.FieldProxy.get(FieldProxy.java:33)
	at sagex.phoenix.weather.WeatherConfiguration.getUnits(WeatherConfiguration.java:34)
	at sagex.phoenix.weather.worldweather.WorldWeatherWeatherSupport.getUnits(WorldWeatherWeatherSupport.java:126)
	at phoenix.impl.WeatherAPI2.GetUnits(WeatherAPI2.java:297)
	at phoenix.weather2.GetUnits(weather2.java:729)
	at Gemstone.Weather.setUnits(Weather.java:89)
	at Gemstone.Weather.Init(Weather.java:48)
	at Gemstone.api.Load(api.java:57)
	at Gemstone.GemstonePlugin.start(GemstonePlugin.java:90)
	at sage.plugin.a.case(Unknown Source)
	at sage.SageTV.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
;Vtypename=Phoenix Error;Vmessage=Error in VFS File: .\\STVs\\Phoenix\\vfs\\z-gemstone-vfs.xml\; null;Vcode=10200;
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.

Last edited by nyplayer; 11-20-2012 at 09:20 PM.
Reply With Quote
  #13  
Old 11-20-2012, 09:21 PM
jorton jorton is offline
Sage Icon
 
Join Date: Jul 2005
Location: Canada
Posts: 1,273
Did you see this thread,

http://forums.sagetv.com/forums/showthread.php?t=59496

There seems to be a problem installing sagex-api.

Maybe try copying it from a working client to this one.

J
Reply With Quote
  #14  
Old 11-20-2012, 09:56 PM
nyplayer nyplayer is offline
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,137
Quote:
Originally Posted by jorton View Post
Did you see this thread,

http://forums.sagetv.com/forums/showthread.php?t=59496

There seems to be a problem installing sagex-api.

Maybe try copying it from a working client to this one.

J
I even tried a clean Install Phoenix Core will not extract and other problems with other phoenix parts giving up on it for tonight will try again maybe tomorrow. Replacing the jars does not work because it appears it is not updating the property files when it fails.
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
  #15  
Old 11-20-2012, 10:09 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
I think I'm doing the same thing as you, but when I back out of the options menu after setting the UserCategory filter the flow is empty.







Attached Images
File Type: jpg Capture1.JPG (55.9 KB, 255 views)
File Type: jpg Capture2.JPG (62.7 KB, 268 views)
File Type: jpg Capture3.JPG (52.2 KB, 273 views)
File Type: jpg Capture4.JPG (33.2 KB, 272 views)
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #16  
Old 11-21-2012, 03:47 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
Ok. I think I see what I'm doing different. I am assigning the UserCategory to Favorites.....not recordings themselves. When I assigned it to a specific recording it worked.

Is it not expected that it would work when a UserCategory is assigned to a Favorite. Or maybe, because I've now assigned the UserCategory to a few Favorites, all future recordings of these Favorites will get this UserCategory assigned and then they will show up in this Flow?

What I want is a Flow for kids TV shows that is filtered to include a UserCategory assigned to a few Favorites (so I don't have to manually assign it after each time a new episode is recorded) AND also include a specified folder (of TV ripped content). Is this possible?
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #17  
Old 11-21-2012, 04:28 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
I think that is what you already setup. I do not use UserCategories but if I understand them what you did will assign the kids category to each recording of that favorite and the flow should now show them after they are recorded.

k
Reply With Quote
  #18  
Old 11-22-2012, 11:25 AM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
Quote:
Originally Posted by jusjoken View Post
I do not use UserCategories but if I understand them what you did will assign the kids category to each recording of that favorite and the flow should now show them after they are recorded.
It does not appear to be working this way for me. A recording that was made by a Favorite that has an assigned User Category is not inheriting that Favorite's assigned User Category? It seems like it should. Maybe I'm missing the point of assigning a User Category to a Favorite?
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #19  
Old 11-23-2012, 04:33 PM
alfi33 alfi33 is offline
Sage Aficionado
 
Join Date: Jun 2008
Posts: 301
Ok, I may be getting a little closer to understanding what is going on. There appears to be two kinds of User Category 'tags' (not sure if that's the right word).

The first is a "User Category/Recording" tag which is set on each recording individually.

The second is a "User Category/Favorite" tag which is set on a Favorite and gets passed to recordings that are made by the Favorite.

It looks like the UserCategory filter in Gemstone only pays attention to the "User Category/Recording" tag.

This recording was recorded by a Favorite that had the 'kids' User Category assigned to it. I also manually added the 'kids' User Category to the recording. It shows up in my Flow using the 'kids' UserCategory filter:


This recording was also recorded by a Favorite that had the 'kids' User Category assigned to it but I did not manually add the 'kids' User Category to the recording. It does NOT show up my Flow using the 'kids' UserCategory filter:
Attached Images
File Type: jpg Capture3.JPG (65.1 KB, 233 views)
File Type: jpg Capture4.JPG (72.2 KB, 238 views)
__________________
Server: SageTV v9 on unRAID Docker; i5-2400; 16GB RAM; 9TB storage array; SiliconDust HDHR3
Client: Windows10; Intel Core2Duo; 4GB RAM; NVIDIA GeForce GT 1030
Client: NVIDIA ShieldTV
Client: Fire TV Stick 4K
Reply With Quote
  #20  
Old 11-23-2012, 10:02 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
Can you open an issue on the issues site with these pics and I will look into fixing this for the next release.

k
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only 1 defined flow at a time possible? sagetv5150 Gemstone for v7 29 12-25-2012 11:50 PM
Bug in Category Flow? cwills75 Diamond 2 07-20-2011 06:14 AM
Movie Flow and Collections? wrems Phoenix 3 07-06-2011 10:25 PM
EPG not populating rfeyer SageTV EPG Service 9 05-09-2011 07:04 AM
Populating Tables from Java Functions tpboyce SageTV Studio 3 05-17-2009 05:11 PM


All times are GMT -6. The time now is 11:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.