SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-11-2015, 10:05 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
Favorites/recordings disappearing-reappearing?

For the second time this week, my recordings have disappeared and then reappeared. This is quasi-associated with seeing lots of "no data" in the listings.
Also, my favorites have also vanished.
The first time, I deleted wiz.bin, both my tuners and channel lineups and rebuilt those, after which everything worked fine for three days.
Now, it's happening again.
Also, "physical memory" is reading very high in Task Manager at 67% - 1.84gb on my 4gb Win 7 32 bit system.
That seems high all of a sudden.

Is this a SageTV server problem causing this, or is my two-year-old SSD boot drive likely the cause?
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson

Last edited by tvmaster2; 06-11-2015 at 10:38 AM.
Reply With Quote
  #2  
Old 06-11-2015, 02:48 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,466
I'd run some tests on your HDs to make sure one or more of them aren't on their last legs.
A lot of the symptoms you describe sure sound like a file/data problem.
__________________
Wayne Dunham
Reply With Quote
  #3  
Old 06-11-2015, 02:56 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Quote:
Originally Posted by waynedunham View Post
I'd run some tests on your HDs to make sure one or more of them aren't on their last legs.
A lot of the symptoms you describe sure sound like a file/data problem.
I'll second this. Check your Windows System log for any hard drive related errors.
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #4  
Old 06-11-2015, 06:11 PM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
Quote:
Originally Posted by Taddeusz View Post
I'll second this. Check your Windows System log for any hard drive related errors.
thanks - what would the errors appear as if a drive was failing, do you think?
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #5  
Old 06-11-2015, 06:16 PM
Taddeusz Taddeusz is offline
SageTVaholic
 
Join Date: Nov 2004
Location: Yukon, OK
Posts: 3,919
Quote:
Originally Posted by tvmaster2 View Post
thanks - what would the errors appear as if a drive was failing, do you think?
Sometimes a delay write fail. Or the drive is no longer available. I can't remember the exact error messages but something like that.
__________________
Server: i5 8400, ASUS Prime H370M-Plus/CSM, 16GB RAM, 15TB drive array + 500GB cache, 2 HDHR's, SageTV 9, unRAID 6.6.3
Client 1: HD300 (latest FW), HDMI to an Insignia 65" 1080p LCD and optical SPDIF to a Sony Receiver
Client 2: HD200 (latest FW), HDMI to an Insignia NS-LCD42HD-09 1080p LCD
Reply With Quote
  #6  
Old 06-11-2015, 06:17 PM
nyplayer nyplayer is online now
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,798
Quote:
Originally Posted by tvmaster2 View Post
thanks - what would the errors appear as if a drive was failing, do you think?
I use HDSentinel has saved my butt many times. I think the trail will test for errors... but not fix them ... but will let you know if you have errors.

http://www.hdsentinel.com/
Reply With Quote
  #7  
Old 06-11-2015, 07:27 PM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
ok, I just ran chkdsk on every drive in the box, and every one came back with 0 bad sectors. Each time this has happened, the dreaded "no data" has been evident on several channels in both tuners listings.
I'll keep checking - maybe a bad cable or connection
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #8  
Old 06-12-2015, 06:08 AM
Boolah's Avatar
Boolah Boolah is offline
Sage Advanced User
 
Join Date: May 2004
Posts: 133
Did you run chkdsk with the /r option? It may not find bad sectors without it. I second nyplayer's suggestion of using HDSentinel. It can tell you if there's a problem with the cable and/or SATA interface instead of the drive itself.
Reply With Quote
  #9  
Old 06-12-2015, 08:56 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
Quote:
Originally Posted by nyplayer View Post
I use HDSentinel has saved my butt many times. I think the trail will test for errors... but not fix them ... but will let you know if you have errors.

http://www.hdsentinel.com/
OK, good tip - I've installed the trial version (30 days) to see how the app works. To your knowledge, does the trial version do everything that's needed to check all I would need to check?
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #10  
Old 06-12-2015, 09:10 AM
nyplayer nyplayer is online now
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,798
Quote:
Originally Posted by tvmaster2 View Post
OK, good tip - I've installed the trial version (30 days) to see how the app works. To your knowledge, does the trial version do everything that's needed to check all I would need to check?
I am sure the professional does more to fix errors. As far as the trial checking I am sure it does enough. I prefer the registered version because it emails you etc.. and you can fix errors which chkdsk cannot. You can also check warranty and it will tell you when you should warranty the drive.
Reply With Quote
  #11  
Old 06-12-2015, 09:51 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
Quote:
Originally Posted by nyplayer View Post
I am sure the professional does more to fix errors. As far as the trial checking I am sure it does enough. I prefer the registered version because it emails you etc.. and you can fix errors which chkdsk cannot. You can also check warranty and it will tell you when you should warranty the drive.
all drives but one passed with 100%. One drive, a recording drive, was met with this:

"here's what it said about one drive: "the drive tried to examine and relocate data sectors 11 times. There are 16 weak sectors found on the disk surface. They may be remapped at any time in the later use of the disk. At this point, warranty replacement of the disk is not yet possible, only if the health drops further (currently rated at 84% - excellent)."

does that sound like enough to cause my favorites to disappear and recordings to be archived?
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #12  
Old 06-12-2015, 10:18 AM
Skirge01's Avatar
Skirge01 Skirge01 is offline
SageTVaholic
 
Join Date: Jun 2007
Location: New Jersey
Posts: 2,599
Quote:
Originally Posted by tvmaster2 View Post
all drives but one passed with 100%. One drive, a recording drive, was met with this:

"here's what it said about one drive: "the drive tried to examine and relocate data sectors 11 times. There are 16 weak sectors found on the disk surface. They may be remapped at any time in the later use of the disk. At this point, warranty replacement of the disk is not yet possible, only if the health drops further (currently rated at 84% - excellent)."

does that sound like enough to cause my favorites to disappear and recordings to be archived?
I don't see how a recording drive would cause the loss of favorites. In HDS, also run the short and long tests on the drives. Every once in a while they find issues which are missed by the health checks HDS does. Additionally, in the advanced options, change the health calculation method to the "more strict" option for servers and see if the health drops any further.

With that one drive at 84%, I'd recommend copying everything off of it, getting the pro version of HDS (get v4.20 for free here) and doing a surface regeneration (wipes all data) to see if you can get the health back up to 100%. In my experience with HDS, once a drive drops below 90% and HDS can't fix it, the drive's health tends to plummet.
__________________
Server: XP, SuperMicro X9SAE-V, i7 3770T, Thermalright Archon SB-E, 32GB Corsair DDR3, 2 x IBM M1015, Corsair HX1000W PSU, CoolerMaster CM Storm Stryker case
Storage: 2 x Addonics 5-in-3 3.5" bays, 1 x Addonics 4-in-1 2.5" bay, 24TB
Client: Windows 7 64-bit, Foxconn G9657MA-8EKRS2H, Core2Duo E6600, Zalman CNPS7500, 2GB Corsair, 320GB, HIS ATI 4650, Antec Fusion
Tuners: 2 x HD-PVR (HTTP tuning), 2 x HDHR, USB-UIRT
Software: SageTV 7
Reply With Quote
  #13  
Old 06-12-2015, 11:18 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,118
Quote:
Originally Posted by Skirge01 View Post
I don't see how a recording drive would cause the loss of favorites. In HDS, also run the short and long tests on the drives. Every once in a while they find issues which are missed by the health checks HDS does. Additionally, in the advanced options, change the health calculation method to the "more strict" option for servers and see if the health drops any further.

With that one drive at 84%, I'd recommend copying everything off of it, getting the pro version of HDS (get v4.20 for free here) and doing a surface regeneration (wipes all data) to see if you can get the health back up to 100%. In my experience with HDS, once a drive drops below 90% and HDS can't fix it, the drive's health tends to plummet.
I agree that the recording drive shouldn't cause favorites to disappear - my thought would be the drive which Sage is installed in would be responsible for that
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
favorites and manual recording disappearing again..argggg tvmaster2 SageTV Software 20 08-13-2013 09:12 PM
SageTV Recordings/Media files disappearing kistoff SageTV Software 2 03-03-2009 07:07 AM
Deleted SageTV save directory keeps reappearing in WHS Nerva SageTV Software 2 11-14-2008 12:35 PM
Help! Disappearing recordings. Joe Mama SageTV Software 7 10-08-2005 07:39 PM
Scheduled Recordings intermittently disappearing in 1.2.2 Beta edmc SageTV Beta Test Software 2 04-02-2003 02:36 PM


All times are GMT -6. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.