SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-11-2016, 01:42 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Updates to BMT, Phoenix, and Core SageTV

Today, I pushed out a new SageTV core (9.0.7) and a new BMT (4.100.0) and an new Phoenix (3.0.0).

To install the updated BMT, you will will need SageTV 9.0.7. This update is a refresh update that simply upgrades the underlying libraries, and fixes a couple of things... (A quick way to upgrade SageTV core it to simply update the Sage.jar with the newer one -- If you on unRAID then restarting the sagetv container will upgrade it)

BMT
Quote:
4.100.0
* Updated for SageTV V9
* Fixed Search so that it does a title contains search by default
* Fixed Add Matcher so that it works with () and so that it cleans up older entries with same ID.
Phoenix
Quote:
* removed upnp support
* removed nest support
* upgraded tvdb api
* upgraded tmdb api
* rewrote filename scraping
Phoenix actually has quite a few updates under the hood... include a new filename scraper, and upgraded apis for themoviedb and thetvdb. It also includes some new views... Jusjoken created a view to detect gaps in TV shows.


I tested this in a clean SageTV setup and it all worked well... I then tested this on my production setup and sagetv did not upgrade half of the plugins, etc, and my install was a mess I did get it sorted out, but took a couple hours.... The strangest thing that was after I upgraded, sagetv thought that "sagex-api" was no longer installed and so all the plugins failed to load... I had to re-install sagex-api and then things kind of started working.. but still required some hand holding
Reply With Quote
  #2  
Old 09-11-2016, 03:41 PM
weeber weeber is offline
Sage Advanced User
 
Join Date: Jul 2004
Posts: 104
I got the upgrades earlier today, and I'm having problems with finding FanArt for movies.

When I search for fanart for most movies, it comes up with "no results", Others are just flat out wrong.

For instance, I'm trying to find fanart for "50 First Dates", and I get No Results found.

I also tried searching for fanart for the 1984 classic "Splash". The only result that comes up is "Thomas & Friends: Splish, Splash, Splosh!" (29% match).

However, searching for "Hot Tub Time Machine" worked OK, but finding ones that work is rare.

All TV shows pulldown O.K. But something is definitely up with searching for movie fanart on my system. I'll also add that my system shows that "The Movie DB Library" v. 4.1.0 installed on 9/11 is listed. As far as I can tell, everything is upgraded on my system.

Last edited by weeber; 09-11-2016 at 03:49 PM.
Reply With Quote
  #3  
Old 09-11-2016, 04:23 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by weeber View Post
I got the upgrades earlier today, and I'm having problems with finding FanArt for movies.

When I search for fanart for most movies, it comes up with "no results", Others are just flat out wrong.

For instance, I'm trying to find fanart for "50 First Dates", and I get No Results found.

I also tried searching for fanart for the 1984 classic "Splash". The only result that comes up is "Thomas & Friends: Splish, Splash, Splosh!" (29% match).

However, searching for "Hot Tub Time Machine" worked OK, but finding ones that work is rare.

All TV shows pulldown O.K. But something is definitely up with searching for movie fanart on my system. I'll also add that my system shows that "The Movie DB Library" v. 4.1.0 installed on 9/11 is listed. As far as I can tell, everything is upgraded on my system.
Could I get the file names of the problem entries?
Reply With Quote
  #4  
Old 09-11-2016, 04:30 PM
weeber weeber is offline
Sage Advanced User
 
Join Date: Jul 2004
Posts: 104
No filenames - I'm searching from the Guide.
Reply With Quote
  #5  
Old 09-12-2016, 06:54 AM
starfire starfire is offline
Sage Expert
 
Join Date: Mar 2008
Location: England, UK
Posts: 505
Quote:
Originally Posted by stuckless View Post
Today, I pushed out a new SageTV core (9.0.7) and a new BMT (4.100.0) and an new Phoenix (3.0.0).
Since the upgrade I am getting red alert messages about the EPG which I never did before:-

The license key set for use with the EPG server is invalid. Please go to Setup Video Sources->[Select Source]->EPG Lineup, which will ask you to re-enter your license key. For further assistance, try the SageTV forums.


I use the schedules direct plugin for my EPG.

Also, my SageTV windows client has crashed multiple times (never has before), does that need updating? :-

Faulting application name: SageTVClient.exe, version: 9.0.0.4, time stamp: 0x55f1b5e8
Faulting module name: SageTVClient.exe, version: 9.0.0.4, time stamp: 0x55f1b5e8
Exception code: 0xc0000005
Fault offset: 0x0000370a
Faulting process ID: 0x3d94
Faulting application start time: 0x01d20cf42629c43b
Faulting application path: C:\Program Files (x86)\SageTV\SageTV\SageTVClient.exe
Faulting module path: C:\Program Files (x86)\SageTV\SageTV\SageTVClient.exe
Report ID: 36577998-561c-4731-9903-a65a074efa92
Faulting package full name:
Faulting package-relative application ID:

Thanks.
__________________
2 X HD300, 2 X HD100 & KVM unRAID Host with SageTV Docker using TBS 6285 Quad DVB-T2 & TBS 6984 Quad DVB-S2 Tuners

Last edited by starfire; 09-12-2016 at 06:58 AM.
Reply With Quote
  #6  
Old 09-12-2016, 07:05 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by starfire View Post
Since the upgrade I am getting red alert messages about the EPG which I never did before:-

The license key set for use with the EPG server is invalid. Please go to Setup Video Sources->[Select Source]->EPG Lineup, which will ask you to re-enter your license key. For further assistance, try the SageTV forums.


I use the schedules direct plugin for my EPG.

Also, my SageTV windows client has crashed multiple times (never has before), does that need updating? :-

Faulting application name: SageTVClient.exe, version: 9.0.0.4, time stamp: 0x55f1b5e8
Faulting module name: SageTVClient.exe, version: 9.0.0.4, time stamp: 0x55f1b5e8
Exception code: 0xc0000005
Fault offset: 0x0000370a
Faulting process ID: 0x3d94
Faulting application start time: 0x01d20cf42629c43b
Faulting application path: C:\Program Files (x86)\SageTV\SageTV\SageTVClient.exe
Faulting module path: C:\Program Files (x86)\SageTV\SageTV\SageTVClient.exe
Report ID: 36577998-561c-4731-9903-a65a074efa92
Faulting package full name:
Faulting package-relative application ID:

Thanks.
Since you are on windows, I assume the you updated by just copying over the update Sage.jar?
Reply With Quote
  #7  
Old 09-12-2016, 07:21 AM
starfire starfire is offline
Sage Expert
 
Join Date: Mar 2008
Location: England, UK
Posts: 505
From my notes I believe I followed this
__________________
2 X HD300, 2 X HD100 & KVM unRAID Host with SageTV Docker using TBS 6285 Quad DVB-T2 & TBS 6984 Quad DVB-S2 Tuners
Reply With Quote
  #8  
Old 09-12-2016, 07:32 AM
starfire starfire is offline
Sage Expert
 
Join Date: Mar 2008
Location: England, UK
Posts: 505
OK, I see there is a new sage.jar so trying 9.0.7.362 on my client now.

edit: still crashes with new jar
__________________
2 X HD300, 2 X HD100 & KVM unRAID Host with SageTV Docker using TBS 6285 Quad DVB-T2 & TBS 6984 Quad DVB-S2 Tuners
Reply With Quote
  #9  
Old 09-12-2016, 08:37 AM
sigl sigl is offline
Sage User
 
Join Date: Apr 2011
Location: Montréal, Canada
Posts: 34
I get an error then I tried (several times) to install BMT:


Plugin Install Progress: Done - FAILED - Resource Download
http://dl.bintray.com/opensagetv/sag...ar-4.100.0.zip



If i go the console (ubuntu) and tried to download the file using the wget command it is downloading but it took several second to respond!


Code:
--2016-09-12 10:30:30--  http://dl.bintray.com/opensagetv/sag...ar-4.100.0.zip
Resolving dl.bintray.com (dl.bintray.com)... 108.168.243.150, 75.126.118.188
Connecting to dl.bintray.com (dl.bintray.com)|108.168.243.150|:80... connected.
HTTP request sent, awaiting response... 302
Location: http://akamai.bintray.com/cc/cc0f3fb...gqBaRFVXj_5aEw [following]
--2016-09-12 10:30:30--  http://akamai.bintray.com/cc/cc0f3fb...gqBaRFVXj_5aEw
Resolving akamai.bintray.com (akamai.bintray.com)... 184.86.35.203
Connecting to akamai.bintray.com (akamai.bintray.com)|184.86.35.203|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 11734884 (11M) [application/octet-stream]
Saving to: ‘bmtweb-war-4.100.0.zip.2’

100%[======================================================================================================>] 11,734,884  --.-K/s   in 0.1s

2016-09-12 10:31:33 (91.1 MB/s) - ‘bmtweb-war-4.100.0.zip.2’ saved [11734884/11734884]
Reply With Quote
  #10  
Old 09-12-2016, 08:52 AM
boonest boonest is offline
Sage User
 
Join Date: Sep 2008
Posts: 22
Lost favorites

installed SageTV core (9.0.7) and a new BMT (4.100.0) and an new Phoenix (3.0.0) and lost recording favorites. And shows wiz.bin as corrupt (Wiz.bin.corrupt6).
Reply With Quote
  #11  
Old 09-12-2016, 09:11 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by sigl View Post
I get an error then I tried (several times) to install BMT:


Plugin Install Progress: Done - FAILED - Resource Download
http://dl.bintray.com/opensagetv/sag...ar-4.100.0.zip



If i go the console (ubuntu) and tried to download the file using the wget command it is downloading but it took several second to respond!
I've encountered this recently with several other plugins before going 9.0.7. I eventually got everything installed by just retrying it about 10 times. I haven't encountered this myself, yet, on 9.0.7, although there'd be not real reason for it to fail or not fail on 9.0.7 since the download code hasn't changed.

Quote:
Originally Posted by boonest View Post
installed SageTV core (9.0.7) and a new BMT (4.100.0) and an new Phoenix (3.0.0) and lost recording favorites. And shows wiz.bin as corrupt (Wiz.bin.corrupt6).
What were you upgrading from?
Reply With Quote
  #12  
Old 09-12-2016, 09:27 AM
sigl sigl is offline
Sage User
 
Join Date: Apr 2011
Location: Montréal, Canada
Posts: 34
I tried to download more and 20 times and I got always the same error!!
Reply With Quote
  #13  
Old 09-12-2016, 09:37 AM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
I believe sage's download timeout is hardcoded at 30 seconds, so if for some reason bintray (or whatever server it's pulling from) is running slow (very busy, servers down, etc) it may end up failing. trying repeatedly at the same time is unlikely to result in a better scenario, and instead trying again 15-30 minutes later may be a better option.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #14  
Old 09-12-2016, 10:03 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by sigl View Post
I tried to download more and 20 times and I got always the same error!!
Maybe turn on debug_logging and see if there is some other error happing the logs.
Reply With Quote
  #15  
Old 09-12-2016, 10:13 AM
sigl sigl is offline
Sage User
 
Join Date: Apr 2011
Location: Montréal, Canada
Posts: 34
Here is the result when debug is ON. Its look as a timeout error


Mon 9/12 12:10:03.841 [ReProcessHook@1cb99bb1] ERROR with file download of:java.net.SocketTimeoutException: Read timed out
Mon 9/12 12:10:03.841 [ReProcessHook@1cb99bb1] Resource download failed from http://dl.bintray.com/opensagetv/sag...ar-4.100.0.zip
Attached Files
File Type: txt sagetv_0.txt (490.0 KB, 52 views)

Last edited by sigl; 09-12-2016 at 10:16 AM.
Reply With Quote
  #16  
Old 09-12-2016, 01:16 PM
boonest boonest is offline
Sage User
 
Join Date: Sep 2008
Posts: 22
What were you upgrading from?[/QUOTE]

I am using Windows and upgraded from SageTV 9.04.287 and latest previous versions of BMT and Phoenix. I am pretty relentless when it comes to updating, to a fault I guess. Have not tried my extenders yet, but all seems to work, just have to re-favorite my TV shows so they will record. Hopefully.
Reply With Quote
  #17  
Old 09-12-2016, 02:05 PM
Korny Korny is offline
Sage Advanced User
 
Join Date: Nov 2010
Location: Minnesota
Posts: 87
Stuckless, did you by any chance move the minimum java version to 1.8?
Code:
Mon 9/12 14:53:56.588 [SageTV@286ee8d5] ::WARN:  Failed startup of context org.mortbay.jetty.webapp.WebAppContext@3dcb7efa{/bmt,/opt/sagetv/server/jetty/webapps/bmt.war}
Mon 9/12 14:53:56.588 [SageTV@286ee8d5] org.mortbay.util.MultiException[java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/BrowsingServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/DataBrowserServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/DebugServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/FileChooserServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/GlobalServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/MediaHandlerServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/PhoenixConfigurationImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/PreferencesServiceImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/SageServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/StatusServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/VideoThumbnailServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/ViewServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/CustomVideoServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/FanartServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/ServiceServlet : Unsupported major.minor version 52.0]
From what have been reading it can cause that exact error.
I just switched to java 1.8 in ubuntu an all fixed. But it broke jetty app.war lol. So if anyone is having problems with BMT not starting , check your java version.
I'd be stoked if someone fixed apps.war
Thanks
Aarn
__________________
Intel I7 4790k @ stock speeds, 32 GB of ram. 8TB of recording space.
Reply With Quote
  #18  
Old 09-12-2016, 02:14 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by Korny View Post
Stuckless, did you by any chance move the minimum java version to 1.8?
Code:
Mon 9/12 14:53:56.588 [SageTV@286ee8d5] ::WARN:  Failed startup of context org.mortbay.jetty.webapp.WebAppContext@3dcb7efa{/bmt,/opt/sagetv/server/jetty/webapps/bmt.war}
Mon 9/12 14:53:56.588 [SageTV@286ee8d5] org.mortbay.util.MultiException[java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/BrowsingServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/DataBrowserServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/DebugServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/FileChooserServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/GlobalServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/MediaHandlerServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/PhoenixConfigurationImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/PreferencesServiceImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/SageServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/StatusServicesImpl : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/VideoThumbnailServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: org/jdna/bmt/web/server/ViewServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/CustomVideoServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/FanartServlet : Unsupported major.minor version 52.0, java.lang.UnsupportedClassVersionError: sagex/phoenix/rest/ServiceServlet : Unsupported major.minor version 52.0]
From what have been reading it can cause that exact error.
I just switched to java 1.8 in ubuntu an all fixed. But it broke jetty app.war lol. So if anyone is having problems with BMT not starting , check your java version.
I'd be stoked if someone fixed apps.war
Thanks
Aarn
There is a good chance it is... I don't have Java 7 installed anywhere, and for development I tend to use Java 1.8 and newer versions of Phoenix/BMT will eventually require 1.8.
Reply With Quote
  #19  
Old 09-12-2016, 02:15 PM
Korny Korny is offline
Sage Advanced User
 
Join Date: Nov 2010
Location: Minnesota
Posts: 87
At least its an easy fix, thanks again, I spoke to soon however on everything working, when I perform a refresh in BMT I get this error
Code:
Failed to find class instance for factory for sagex.phoenix.upnp.UPnPSourceFactory at line 84 and column 105
Quote:
Originally Posted by stuckless View Post
There is a good chance it is... I don't have Java 7 installed anywhere, and for development I tend to use Java 1.8 and newer versions of Phoenix/BMT will eventually require 1.8.
__________________
Intel I7 4790k @ stock speeds, 32 GB of ram. 8TB of recording space.

Last edited by Korny; 09-12-2016 at 02:30 PM.
Reply With Quote
  #20  
Old 09-12-2016, 05:40 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,607
Quote:
Originally Posted by Korny View Post
At least its an easy fix, thanks again, I spoke to soon however on everything working, when I perform a refresh in BMT I get this error
Code:
Failed to find class instance for factory for sagex.phoenix.upnp.UPnPSourceFactory at line 84 and column 105
This actually looks like Phoenix is updated (since upnp was removed), but the x-vfs.xml vfs file was not updated. you can try manually download and replace your x-vfs.xml file.

https://raw.githubusercontent.com/st.../vfs/x-vfs.xml

I wish SageTV had a "re-install" option in the plugin manager...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Phoenix Core 2.5.8 stuckless Phoenix 12 10-04-2013 08:43 AM
New Phoenix Core 2.5.6 stuckless Phoenix 17 10-02-2013 04:47 PM
New Phoenix Core 2.5.7 stuckless Phoenix 0 10-01-2013 06:04 PM
Phoenix 2.5.0 Update (api, core, and UI) stuckless Phoenix 38 05-15-2013 03:49 PM
6.2.5 Core Updates Shield SageTV Beta Test Software 5 08-04-2007 09:26 PM


All times are GMT -6. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.