SageTV Community  

Go Back   SageTV Community > SageTV BETA Release Products > SageTV Beta Test Software

Notices

SageTV Beta Test Software Discussion related to BETA Releases of the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. regarding SageTV Beta Releases should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-26-2006, 02:12 PM
Alfiegerner Alfiegerner is offline
Sage Aficionado
 
Join Date: Oct 2005
Location: Auckland, NZ
Posts: 383
Pal transcoding?

I've seen around the forum people succesfully transcoding material to their mvp's with an athlon 2800. When I try with my athlon 2800 i'm getting jerky playback and blocky artefacts everywhere.

Is there any chance that this is PAL related?: are there any users in PAL land succefully using the transcoding feature? I just want to know for sure if upgrading my kit will solve the problem.
Reply With Quote
  #2  
Old 02-27-2006, 03:28 PM
rtengvad rtengvad is offline
Sage Aficionado
 
Join Date: Jul 2005
Location: Copenhagen, Denmark
Posts: 425
Tell me how to create a divx file and I'll check if my system creates problems

rtengvad
__________________
Server: Win7 SageTV v7.1.9 GA-MA785GM-US2H Athlon 64 X2 BE-2350 2 Gb RAM 4x 1Tb WD RE-2 GP in RAID5, Adaptec 5405 Raid controller 2x firewire DVB-C FloppyDTV C/CI, 1x TechnoTrend CT-3650 CI via the LM Smart DVB Recorder plug-in.

Clients: HD300 to a Samsung PS50C7705 (PN50C8000) via a DVDO Edge HD200 Placeshifter

Remote: Universal Remote Control MX-980
Reply With Quote
  #3  
Old 02-27-2006, 05:21 PM
Henki Henki is offline
Sage User
 
Join Date: Aug 2004
Location: Oslo, Norway
Posts: 31
I've experienced the same with an athlon xp2500. But after some testing it looks like the reason is bad frame rate conversion in ffmpeg.

Xvid/divx files in Pal frame rate 25 is playing perfectly, but files in NTSC frame rates 23.9 or 29 are jerky and blocky.

I'll to look more into ffmpeg to see if there is a solution.
Reply With Quote
  #4  
Old 02-27-2006, 06:07 PM
Henki Henki is offline
Sage User
 
Join Date: Aug 2004
Location: Oslo, Norway
Posts: 31
It looks like it wasn't bad conversion, but actually no conversion at all. The problem is that PAL MVP doesn't like files with an other frame rate than 25.

Anyway this worked for me:

In sage.properties, find your "media_server/transcode_quality" that you have made for PAL, and put in "-r 25" before "-f DVD")

In my sage.properties it looks like this:
media_server/transcode_quality/DVD2=-r 25 -f dvd -b 4000 -s 720x576 -acodec mp2 -ab 384

Last edited by Henki; 02-27-2006 at 06:36 PM.
Reply With Quote
  #5  
Old 02-28-2006, 04:38 AM
Alfiegerner Alfiegerner is offline
Sage Aficionado
 
Join Date: Oct 2005
Location: Auckland, NZ
Posts: 383
Excellent news! Thanks Henki that's really made my day.

I had a quick chance to try a 25fps .avi file before work this morning and found it played back perfectly. Previously I had been tring ntsc encoded files.

I'' try changing the setting later tonight.

edit: I'm wondering why the MVP should struggle playing back other frame rates than 25fps ? Is this a hardware limitation or an issue with the sage media player?

Last edited by Alfiegerner; 02-28-2006 at 05:09 AM.
Reply With Quote
  #6  
Old 02-28-2006, 03:25 PM
Alfiegerner Alfiegerner is offline
Sage Aficionado
 
Join Date: Oct 2005
Location: Auckland, NZ
Posts: 383
Now streaming divx Thanks Henki.
Reply With Quote
  #7  
Old 03-01-2006, 01:51 PM
deanm deanm is offline
Sage Aficionado
 
Join Date: Apr 2005
Location: North East, UK
Posts: 303
This does not work for me. If I close Sage down and put "-r 25" before "-f dvd" like you said, I still have a jerky and blocky picture. If I then close Sage down again and go back into my sage.properties file the -r 25 has been removed. My system is an Intel P4 2400. Any ideas anyone?
Reply With Quote
  #8  
Old 03-01-2006, 02:15 PM
Alfiegerner Alfiegerner is offline
Sage Aficionado
 
Join Date: Oct 2005
Location: Auckland, NZ
Posts: 383
Yeah I had the same problem. You need to create a new transcode quality.

Create another entry for media_server/transcode_quality except make it DVD2. Add the proper pal settings to that one, i.e. like Henki said:

media_server/transcode_quality/DVD2=-r 25 -f dvd -b 4000 -s 720x576 -acodec mp2 -ab 384

Then in you MVP's MAC.properties in the clients folder change the miniclient/transcode_mode so it points to the new setting, i.e:

miniclient/transcode_mode=DVD2
Reply With Quote
  #9  
Old 03-01-2006, 03:01 PM
deanm deanm is offline
Sage Aficionado
 
Join Date: Apr 2005
Location: North East, UK
Posts: 303
Fantastic Thanks Alfiegerner and Henki

I can finaly watch Lost seson 2 on my MPVs. All I need now is DVDs to work
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.