SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-31-2016, 05:20 PM
scottkoontz scottkoontz is offline
Sage User
 
Join Date: Jun 2006
Posts: 7
SlimPlayer plugin install fails on GKusnick plugin

I am moving my SageTV server to new hardware. When I attempt to install the SlimPlayer Internet Radio plugin on the new server, the install fails on the gkusnicktoolslib dependency. If you check the gkusnicktoolslib URL, the files are gone.

I still have the old server, so if someone can guide me through the process of manually installing a plugin, that would be an option. Otherwise, how do we get the plugin repaired?

Thanks in advance,

Scott
Reply With Quote
  #2  
Old 10-31-2016, 07:27 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,486
there's a patched up repository posted here:

https://forums.sagetv.com/forums/att...7&d=1474830257

try extracting the xml file inside to your sagetv folder, and see if the plugin will install. This points to a new server. If this works, let me know, and I'll see if I can fix this 'properly' in at least the v9 repo.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #3  
Old 10-31-2016, 08:43 PM
scottkoontz scottkoontz is offline
Sage User
 
Join Date: Jun 2006
Posts: 7
Progress

Progress! Some plugins succeeded. This time it failed on saxon. Install saxon-FAILED resource download http://storage.googleapis.com/google...axon-9.jar.zip
Reply With Quote
  #4  
Old 11-05-2016, 06:51 PM
scottkoontz scottkoontz is offline
Sage User
 
Join Date: Jun 2006
Posts: 7
Success!

The saxon issue was related to my firewall, so the file you sent me fixed the problem. Thanks!
Reply With Quote
  #5  
Old 12-14-2016, 02:32 PM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 3,015
Quote:
Originally Posted by Fuzzy View Post
there's a patched up repository posted here:

https://forums.sagetv.com/forums/att...7&d=1474830257

try extracting the xml file inside to your sagetv folder, and see if the plugin will install. This points to a new server. If this works, let me know, and I'll see if I can fix this 'properly' in at least the v9 repo.
I had this same problem trying to install SageTCPServer, as it also needs the GKusnick Library Tools. However, I already have a SageTVPluginsDev.xml file in my SageTV folder, and it has no reference to GKusnick.
Suggestions?
thanks
__________________
Sage 7 server = Gigabyte AMD dual core - 2 gigs - integrated ATI HD4200 chipset - Seagate/Hitachi Deskstar - HD-PVR - Colossus - Win7 32 bit. HD200 networked. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #6  
Old 12-15-2016, 02:35 AM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,486
Quote:
Originally Posted by tvmaster2 View Post
I had this same problem trying to install SageTCPServer, as it also needs the GKusnick Library Tools. However, I already have a SageTVPluginsDev.xml file in my SageTV folder, and it has no reference to GKusnick.
Suggestions?
thanks
Is there something you are using that requires the Dev file? You could add the entries from my posted dev to yours, or just upgrade to v9, and you won't need it.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #7  
Old 12-15-2016, 09:19 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 3,015
Quote:
Originally Posted by Fuzzy View Post
Is there something you are using that requires the Dev file? You could add the entries from my posted dev to yours, or just upgrade to v9, and you won't need it.
ok, i'll poke around inside and see if I need to create a monster-dev. I've held off on v.9 since most people here says other than Schedules Direct, there isn't a big difference. But it's inevitable...

UPDATE: seems to be a UPNP plugin from tmiranda, as well as or including something regarding PlayOn
__________________
Sage 7 server = Gigabyte AMD dual core - 2 gigs - integrated ATI HD4200 chipset - Seagate/Hitachi Deskstar - HD-PVR - Colossus - Win7 32 bit. HD200 networked. "If you've given up on Weird Al, you've given up on life" - Homer Simpson

Last edited by tvmaster2; 12-15-2016 at 12:19 PM.
Reply With Quote
  #8  
Old 12-30-2016, 06:06 PM
daddyd daddyd is offline
Sage User
 
Join Date: Oct 2008
Location: Windsor, Ont
Posts: 26
Need Some Help

Trying to re-install the SageTCPServer plugin - I'm still on V7.1.9.256 and it tells me the the install failed and it shows the old and evidently now defunct http://talluscorp.com/Software/SageTCPServer-2.3.4.zip directory. I need to figure out how to manually install this plug in - I use this for both mymovies and CQC..

Any help that can be lent would be greatly appreciated (and let me know if I should move this question to the V7 forum...),
Reply With Quote
  #9  
Old 01-07-2017, 10:06 AM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 5,531
Quote:
Originally Posted by Fuzzy View Post
there's a patched up repository posted here:

https://forums.sagetv.com/forums/att...7&d=1474830257

try extracting the xml file inside to your sagetv folder, and see if the plugin will install. This points to a new server. If this works, let me know, and I'll see if I can fix this 'properly' in at least the v9 repo.
Do you have to restart after installing the xml file into the server directory?
__________________
Sage7 on Win7Pro-i660CPU with 4.6TB, 2xHD-PVR(connected to SA3250HD+SA4250HD-Rogers Cable), HDHR(2xOTA), HVR-1850(one OTA, one connected to SA3200 SD cable box), 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #10  
Old 01-07-2017, 10:29 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 3,015
Quote:
Originally Posted by daddyd View Post
Trying to re-install the SageTCPServer plugin - I'm still on V7.1.9.256 and it tells me the the install failed and it shows the old and evidently now defunct http://talluscorp.com/Software/SageTCPServer-2.3.4.zip directory. I need to figure out how to manually install this plug in - I use this for both mymovies and CQC..

Any help that can be lent would be greatly appreciated (and let me know if I should move this question to the V7 forum...),
this seems to be a growing problem with Sage plugins: reliant files that have stopped being supported by the author, or dead links. It's getting to be a bit of a pain, actually - especially if you're not a computer programmer
__________________
Sage 7 server = Gigabyte AMD dual core - 2 gigs - integrated ATI HD4200 chipset - Seagate/Hitachi Deskstar - HD-PVR - Colossus - Win7 32 bit. HD200 networked. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #11  
Old 01-07-2017, 10:57 AM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 5,531
True - but this was built by Fonceur - try PMing him.
__________________
Sage7 on Win7Pro-i660CPU with 4.6TB, 2xHD-PVR(connected to SA3250HD+SA4250HD-Rogers Cable), HDHR(2xOTA), HVR-1850(one OTA, one connected to SA3200 SD cable box), 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #12  
Old 01-07-2017, 07:34 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,486
Quote:
Originally Posted by wayner View Post
Do you have to restart after installing the xml file into the server directory?
No, any time you enter the Plugin system, the file is checked.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SlimPlayer Internet Radio plugin koelec SageTV v7 Customizations 204 10-23-2013 02:22 PM
plugin, install once, available everywhere? Deacon Crusher SageTV Beta Test Software 4 07-23-2010 12:52 PM
Plugin manager fails bsung SageTV Beta Test Software 3 07-22-2010 05:15 AM
Plugin Request: Configuration before install PLUCKYHD SageTV Studio 16 07-07-2010 04:43 AM
Install auto compress plugin? meno SageTV Customizations 5 09-02-2009 12:26 PM


All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.