SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-28-2004, 03:36 PM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
New version of XMLTV plugin

This is a somewhat major rewrite of the XMLTVImportPlugin of http://mta.techno.org/epg/
I couldn't get it to work with the newest version of XMLTV (version 0.5.34). Also i
assumed that the errors were in the XMLTVImportPlugin, but couldn't find any log. So
i made a version that outputs errormessages and other messages to a logfile.

In addition i wanted to use a newer version of xerces than was being used, partly because
xerces2 produces better error messages.

I implemented a version that basically just retrieves time, title and description info
from the xml-file generated by xmltv. This might not be enough for you, but for me it
seems sufficient.

In Norway the frequency used by the different channels is defined by the cable operators.
This means that any attempt to retrieve information about the frequency from the xmltv.xml
file is futile. This is fairly easily remedied, since you can do a manual mapping one
time and Sage will store the mapping for the future.

See the README.txt for installation guide.

Hope it will be useful.
Attached Files
File Type: zip xmltv_plugin.zip (29.2 KB, 877 views)

Last edited by TallyHo; 08-15-2004 at 04:32 PM.
Reply With Quote
  #2  
Old 08-01-2004, 02:32 PM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

thanks for taking the time to do this.
I've tried setting this up, sa per your instructions, and find that SAGE keeps saying that it downloading the program listings for XMLTV Lineup.

however it just keeps doing that. I left it for 3 hrs to see if I was just being impatient , but still no joy.

I had a look in the XMLTV subdirectory in the sage directory , but couldn't see the log file you referred to. Am I doing something really stupid ?

Any help greatfully recoeved.

Cheers

Mark
Reply With Quote
  #3  
Old 08-01-2004, 02:51 PM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

I've tried running the plugin test and recieved the following :-

C:\Program Files\Frey Technologies\SageTV>java PluginTester
Hello. Starting PluginTester.

Getting providers...

Got provider ID=867507149; XMLTV Lineup

Updating Guide,..

java.lang.NumberFormatException: For input string: "Adventure"
at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1111)
at xmltv.XMLTVImportPlugin.updateGuide(XMLTVImportPlugin.java:70)
at PluginTester.main(PluginTester.java:43)
Test complete, result was 'false'.

Im not actually sure what any of it means though - Any help most appreciated.

Cheers

Mark
Reply With Quote
  #4  
Old 08-01-2004, 03:20 PM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
Since i first posted this i've realized that SageTV actually has a console window. Amazing what you can find out when you take the time to read the troubelshooting faq...

Anyway, if you don't even get the xmltv_plugin.log file, that tells me that something went wrong probably even before that was set up, and that is the first thing the plugin does. So i've made a version that also outputs to the console window. So if you download this and set up the console window for any error messages and tell me what they are, i may be able to help you.

Set up the console window this way:
Is there a debugging console for SageTV?
The console can be used to troubleshoot problems. You can do this by creating a new DWORD value in the registry. Go to start, run and type in regedit. Here's the path: \HKEY_LOCAL_MACHINE\SOFTWARE\ Frey Technologies\Common. Right click on the Common folder and select New – DWORD Value. Name it "consolewin" without the quotes and hit enter. Now double click on consolewin and change the value from 0 to 1. This will open up a DOS window for debugging when you start SageTV.

After you set up the console window the second line should read:
Initializing XMLTVImportPlugin (perhaps without the last letter, as that seems to be gone on my console). If you have any stacktrace instead, can you copy that into a reply?

Regarding the plugin tester, i'm not sure that it will work with my version of the plugin, so don't worry too much about that.

[I have relocated the attachment to the first post]

Last edited by TallyHo; 08-02-2004 at 02:43 PM.
Reply With Quote
  #5  
Old 08-02-2004, 02:34 AM
nielm's Avatar
nielm nielm is offline
SageTVaholic
 
Join Date: Oct 2003
Location: Belgium
Posts: 4,496
The plugintester(s) should work with any XMLTV plugin that uses the same class name as the original -- it uses the same APIs that Sage itself calls.

The error shown:
java.lang.NumberFormatException: For input string: "Adventure"
at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1111)"

Looks like that a string is being parsed for a number (Perhaps when retrieving channel numbers from channel names, which is not always the case in XMLTV)
__________________
Check out my enhancements for Sage in the Sage Customisations and Sageplugins Wiki
Reply With Quote
  #6  
Old 08-02-2004, 06:32 AM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
Red face

Woops, after checking the first zipfile, I realize that i've included the old XMLTVImportPlugin.class-file and the old channel.class-file.

The second zip-file contains the correct class-files.

Sorry for the stupid mistake.

After looking at the plugin_tester i also agree that it should work with my plugin. So please report any errors produced by the plugin_tester.

Last edited by TallyHo; 08-02-2004 at 02:43 PM.
Reply With Quote
  #7  
Old 08-02-2004, 02:40 PM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
I have replaced the original attachment in the first post with a version that actually works. It also contains the java-files, which the second version did not.

This also includes the xmltv.dtd that also is needed by the parser.

Perhaps now somebody else than me will get this to work.

I'm interested in any feedback especially if you find something not working.

I have only tested this with norwegian xmltv data, so i'm wondering whether it will work also for other countries. If it doesn't i will try to fix it if somebody gives me a hint.
Reply With Quote
  #8  
Old 08-03-2004, 01:44 AM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

Thanks for that , I will install and test this evening, and get back to you ASAP with the results.

Cheers

Mark
Reply With Quote
  #9  
Old 08-03-2004, 03:00 PM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

I had installed the 1'st version originally, however I installed your 2'nd version and am getting the following when I run the plug in tester

Hello. Starting PluginTester.

Getting providers...

Got provider ID=867507149; XMLTV Lineup

Updating Guide,..

<03.Aug.2004, 21:55:06> updateGuide called
<03.Aug.2004, 21:55:06> FatalError
<03.Aug.2004, 21:55:06> line number: 0, column number: 0
org.xml.sax.SAXException: Stopping after fatal error: File "xmltv.dtd" not found
.
at org.apache.xerces.framework.XMLParser.reportError(XMLParser.java:1245
)
at org.apache.xerces.readers.DefaultEntityHandler.startReadingFromExtern
alEntity(DefaultEntityHandler.java:780)
at org.apache.xerces.readers.DefaultEntityHandler.startReadingFromExtern
alSubset(DefaultEntityHandler.java:571)
at org.apache.xerces.framework.XMLDTDScanner.scanDoctypeDecl(XMLDTDScann
er.java:1139)
at org.apache.xerces.framework.XMLDocumentScanner.scanDoctypeDecl(XMLDoc
umentScanner.java:2145)
at org.apache.xerces.framework.XMLDocumentScanner.access$0(XMLDocumentSc
anner.java:2100)
at org.apache.xerces.framework.XMLDocumentScanner$PrologDispatcher.dispa
tch(XMLDocumentScanner.java:831)
at org.apache.xerces.framework.XMLDocumentScanner.parseSome(XMLDocumentS
canner.java:381)
at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1098)
at xmltv.XMLTVImportPlugin.updateGuide(XMLTVImportPlugin.java:187)
at PluginTester.main(PluginTester.java:43)
<03.Aug.2004, 21:55:06> Error
Test complete, result was 'true'.


Im a littlle puzzled as I can see a file called xmltv.dtd in the sagetv directory

once again help most appreciated.
As a quick aside - in Sage, it now doesn't hang at the downloading XMLTV lineup as it did previously.

Cheers

Mark
Reply With Quote
  #10  
Old 08-03-2004, 03:36 PM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

I wondered if I had done something stupid, so I uninstalled Sage, deleted the old directories.

Reinstalled, followed your instructions and now get the following

C:\Program Files\Frey Technologies\SageTV\xmltv>java PluginTester
Exception in thread "main" java.lang.NoClassDefFoundError: sage/EPGDBPublic

C:\Program Files\Frey Technologies\SageTV\xmltv>cd ..

C:\Program Files\Frey Technologies\SageTV>java PluginTester
Exception in thread "main" java.lang.NoClassDefFoundError: sage/EPGDBPublic

C:\Program Files\Frey Technologies\SageTV>java PluginTester
Exception in thread "main" java.lang.NoClassDefFoundError: sage/EPGDBPublic

Is this worse ?

Cheers

Mark
Reply With Quote
  #11  
Old 08-04-2004, 06:10 AM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
Regarding the first error:
org.xml.sax.SAXException: Stopping after fatal error: File "xmltv.dtd" not found

You are still utilizing the old Xerces parser, as can be seen from the line:
at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1098)

The new parser has the package path: org.apache.xercex.parsers.SAXParser

Are you sure you installed the new parser properly? Perhaps you should make sure you remove the old one as well.

Regarding the second error:
If your commandline is reported correctly, you skipped the -cp .;sage.jar part, your command line should look like:
java -cp .;sage.jar PluginTester
Reply With Quote
  #12  
Old 08-04-2004, 02:16 PM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
You are a star !!!

I had stupidly forgot to reapply the new Xerces (I had also uninstalled Java). I reinstalled it, ran the test - all worked great. Fired up sage - And .....
I have a working EPG , I still have to remap the channels , etc. but the data is there !!!!!!!!!

Thank you so much for all your time, it is really appreciated.

Gratefully yours

Mark
Reply With Quote
  #13  
Old 08-07-2004, 08:40 AM
parkimar parkimar is offline
Sage Aficionado
 
Join Date: Feb 2004
Location: NJ USA
Posts: 329
Hi,

I had the XMLTV plugin working , but after the 1'st successful upload , it now updates, but the EPG has boxes that show 'no data', it is odd, because the box times and channells correspond to actual shows in the epgdata.xml file.

Anyone got any suggestions ?

Mark
Reply With Quote
  #14  
Old 08-13-2004, 05:58 PM
Henki Henki is offline
Sage User
 
Join Date: Aug 2004
Location: Oslo, Norway
Posts: 31
Seems like the XMLTV plugin i need. The installation went well and i didn't get any error messages in the log, but the EPG is a mess. Channels are listed twise, dubbel listing on the same time etc. Do you have any idea what is wrong?

I've tested the xml file with another program and it's seems to be ok.

Henrik
Reply With Quote
  #15  
Old 08-14-2004, 03:03 AM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
Can you post the epgdata.xml file you are using so i can try to figure this out?
Reply With Quote
  #16  
Old 08-15-2004, 07:37 AM
g4dgolos g4dgolos is offline
New Member
 
Join Date: Aug 2004
Location: fr
Posts: 1
i had installed the plugin + xercesImpl.jar(20/02/2004) like you said
but i have the following errors

thanks for your help

nb: winxp sp1, sage 2.0.19, xmltv-0.5.34-win32, french epgdata

xmltv_plugin.log
Initializing XMLTVImportPlugin
working directory is: C:\Outils\tv\SageTV\SageTV
<15.août.2004, 15:02:00> loading properties
<15.août.2004, 15:02:00> Initializing properties
<15.août.2004, 15:02:00> Completed initializing properties
<15.août.2004, 15:02:28> updateGuide called
<15.août.2004, 15:02:29> Error
java.lang.NullPointerException
at xmltv.XMLParserCallback.startElement(XMLParserCallback.java:103)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at xmltv.XMLTVImportPlugin.updateGuide(XMLTVImportPlugin.java:187)
at sage.l.c(Unknown Source)
at sage.o.char(Unknown Source)
at sage.m.aI(Unknown Source)
at sage.l.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Attached Files
File Type: zip epgdata.zip (139.0 KB, 2142 views)
Reply With Quote
  #17  
Old 08-15-2004, 11:09 AM
Henki Henki is offline
Sage User
 
Join Date: Aug 2004
Location: Oslo, Norway
Posts: 31
Here is my epgdata.xml file and a screenshot.

Henrik
Attached Files
File Type: zip epgdata.zip (162.0 KB, 480 views)
Reply With Quote
  #18  
Old 08-15-2004, 04:30 PM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
I have also noticed the problem with 'no data', but assumed that it was caused by actual 'no data' in the xml-file from the XMLTV program. However, after checking, it seems that in some cases the data actually is there, but is not picked up by Sage. You can help me test this by downloading the new XMLTV_plugin. This outputs a lot more debug info if you enable the Debug property in the properties file to 'true' (not actually with the '). In the output you should be able to find lines like this:

<16.aug.2004, 00:27:46> addAiringPublic for title: Politiske mord, extId: 96107910, stationID: -1165766696, start: 18.08.2004 01:30, duration: 00:30

If you find lines like this that shows programmes that shows up as 'no data' in the LiveTV Guide, please zip up the entire logfile and send it to me. I suspect it can be too large for attaching here, but you can find my email in the java-files.
Reply With Quote
  #19  
Old 08-15-2004, 04:32 PM
TallyHo TallyHo is offline
Sage User
 
Join Date: Jul 2004
Location: Oslo, Norway
Posts: 8
The french xmltv data contained a bit different XML, but i have fixed the code so it should work now.

The new xmltv_plugin has been attached to the first post.
Reply With Quote
  #20  
Old 08-16-2004, 01:25 AM
Henki Henki is offline
Sage User
 
Join Date: Aug 2004
Location: Oslo, Norway
Posts: 31
Heres the log i've got with the new plugin, but i'm not sure what you are looking for.

I also did a reinstall of Sagetv but this time i did't remap the channels. When i went directly to the epg, everyting looked fine for the fist time except for that there still were some boxes wil "no data". The strange part is when i closed sagetv and started it up again, the epg was back as I reported earlyer. The data to some of the channels just dissapeared i the EPG. and the log was "empty"with just the regular lines.
Attached Files
File Type: zip xmltv_plugin_log.zip (625.9 KB, 484 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:12 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.