SageTV Community  

Go Back   SageTV Community > Information & Announcements > SageTV Downloads & Instructions

Notices

SageTV Downloads & Instructions This forum is for discussions containing Downloads and Instructions related to the Open Source version of SageTV. Please do not post questions in this forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #441  
Old 04-16-2019, 10:47 AM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 203
Quote:
Originally Posted by Pelicanjoe View Post
Anyone know how to get the weather api to display the true weather information instead of null degrees?

I've looked on the forum, but could not find the answer.

Thanks!

Joe
You should look here:
https://forums.sagetv.com/forums/showthread.php?t=65764

The old weather service was discontinued in late January. This update is needed to continue receiving weather info.
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450
Reply With Quote
  #442  
Old 04-20-2019, 10:53 AM
valnar valnar is offline
Sage Icon
 
Join Date: Oct 2003
Posts: 1,220
Send a message via ICQ to valnar
Does anyone have the version before 9.2.1? It broke my USB-IR function. Thanks.
__________________
Server: ASUS P7F-E, Intel Xeon x3440, 4GB RAM, DR-400-6 RM case, 2x Addonics Disk Array 3SA, 7TB disk,
2x Nvidia DualTV, 2x HDHomeRun, HD-PVR 1212, Win7-32bit, Sage 7 latest
Client 1: HD300 on Panasonic Plasma TC-P50ST60
Client 2: HD300 on Vizio 40"
Others: Sage Client & Placeshifter
Reply With Quote
  #443  
Old 04-20-2019, 02:52 PM
Pelicanjoe Pelicanjoe is offline
Sage Advanced User
 
Join Date: Aug 2009
Location: Huntersville, NC
Posts: 149
removing channel

I keep on having my video source halt because a channel that is not even listed on the channel set up page is attempted to record. I've removed all reference of that channel from the sagetv properties file an restarted, but that channel still keeps coming up. Anyone know where I need to remove this channel? It is not in the channel setup. This only started happening after I installed the new 64 bit Windows program.

Thanks!

Joe
Reply With Quote
  #444  
Old 04-20-2019, 09:20 PM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 203
Quote:
Originally Posted by valnar View Post
Does anyone have the version before 9.2.1? It broke my USB-IR function. Thanks.
It's on the same download site bintray, you just have to search around.

https://bintray.com/opensagetv/saget...getvwin/9.1.10
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450
Reply With Quote
  #445  
Old 05-28-2019, 02:46 PM
hoosierengineer hoosierengineer is offline
Sage User
 
Join Date: Aug 2007
Posts: 19
Question Subtitles not working

The only way I have found to get SageTV to display Closed Captioning (Captions) to work is with the following setup (SageTV/Client 9.1.10.783)
Video Render : VMR9
MPEG2 Video Decoder Filter : SageTV MPEG Video Decoder
SageTV MPEG Video Decoder uses DXVA (Hardware acceleration) : Yes.

The 64-bit version of this software does not seem to have these options, but LAV Video Decoder filters is new (hardware acceleration does not show up). Captions are not being displayed.

Upon installing SageTV x64, I get the the following error:

SageTV Client(x64) Setup
Could not write value AlwaysSwapForAC3Filter to key \SOFTWARE\FreyTechnologies\Common\DSFilters\AudioDec. Verify that you have sufficient access to that key, or contact your support personnel.

(I selected Ignore after the other options proved pointless).

As part of my investigation, I believe I also installed the 32-bit version, it also didn't seem to have SAGETV MPEG Video Decoder as an option.

Anybody been using CC on Sage? How do I get rid of the error?
Reply With Quote
  #446  
Old 05-28-2019, 04:03 PM
wnjj wnjj is online now
Sage Icon
 
Join Date: Jan 2009
Posts: 1,002
Quote:
Originally Posted by hoosierengineer View Post
The only way I have found to get SageTV to display Closed Captioning (Captions) to work is with the following setup (SageTV/Client 9.1.10.783)
Video Render : VMR9
MPEG2 Video Decoder Filter : SageTV MPEG Video Decoder
SageTV MPEG Video Decoder uses DXVA (Hardware acceleration) : Yes.

The 64-bit version of this software does not seem to have these options, but LAV Video Decoder filters is new (hardware acceleration does not show up). Captions are not being displayed.

Upon installing SageTV x64, I get the the following error:

SageTV Client(x64) Setup
Could not write value AlwaysSwapForAC3Filter to key \SOFTWARE\FreyTechnologies\Common\DSFilters\AudioDec. Verify that you have sufficient access to that key, or contact your support personnel.

(I selected Ignore after the other options proved pointless).

As part of my investigation, I believe I also installed the 32-bit version, it also didn't seem to have SAGETV MPEG Video Decoder as an option.

Anybody been using CC on Sage? How do I get rid of the error?
The SageTV MPEG decoder is only available in V7 of SageTV and the only way I've heard to get CC. You must install V7 first and V9 over top to use those decoders. You are correct that 64-bit does not have that option.

Those 2 installer errors are known and 'Ignore' is fine.
Reply With Quote
  #447  
Old 05-28-2019, 11:43 PM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 203
One other video decoder I found years ago that works with CC is Cyberlink Video/SP Decoder, which can be installed separately.

However, either of these only work for mpeg format video files. If you are on cable, many stations are encoding in H264. I do not believe any decoder can display CC for those types of files directly.

However, you can run ccextractor on those saved files and display CC as subtitle files.
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450
Reply With Quote
  #448  
Old 05-30-2019, 10:36 AM
Zogg Zogg is offline
Sage Advanced User
 
Join Date: May 2011
Location: Frisco, TX
Posts: 120
I had Cyberlink Video/SP Decoder listed on my systems but it did not work. It also only showed up on the "List all decoders" list.

However, I had PowerDVD8 installed on an old XP system and I got the CLVsd.ax file from it and it seems to work just fine on both a Win7 (VMR) and a Win10 (EVR) system. Both are running the 32-bit version of Sage Client. The decoder shows up as "Cyberlink Video/SP Decoder (PDVD8)" and it shows up on the short list.
Reply With Quote
  #449  
Old 06-16-2019, 10:27 AM
crl crl is online now
Sage User
 
Join Date: Dec 2005
Location: Burlington, ON
Posts: 17
Migrated to Sage9.2.1 x64

Thanks to the community for the great work on the x64 for Windows build! After many years since the last clean install of Sage (2009) I performed a fresh install of x64. Process was similar to earlier replies but in short I installed Java 8 runtime, did the install, copied most files & folders from old install into the new program directory (NOT overwriting existing files) and omitted the cached fanart folder that had grown to a few gigs. My properties file didn't need to be edited as my previous install was so old it was running on an x86 OS too. In SageTV removed all plugins, restarted, then reinstalled plugins. Got stuck on jetty/web interface but all I had to do was generate a Java cert.

Everything is running well with ONE exception:

I've been using the XBMC/Kodi addon from Android TV boxes to access SageTV content. The installation of this includes adding an xbmc.js file to the sagex\services folder. When I try to access this interface it fails. Specifically, when accessing the sagex API at this endpoint:
http://sageserver:8080/sagex/api?c=x...0&encoder=json

I get:
java.lang.RuntimeException: javax.script.ScriptException: TypeError: java.util.HashMap is not a function in <eval> at line number 19
(Full Error in Pastebin)

I realize this is an old plugin but I'm betting this could be something easy to fix. It looks like a class simply isn't imported, but since this was working with the same sagex-utils version (9.1.7.0) on the old x86 system (SageTV 9.1.5) I'm not sure what broke. Any ideas?

Edit: I fired up the old Sage box, confirmed it's using Java 7 and the API call works. Installed Java 8u212, confirmed Sage is using it, and now I get the same error. This issue appears to be specific to JRE, not x86/x64. I probably should've tagged @stuckless as he'd likely know what's going on.

Last edited by crl; 06-16-2019 at 11:53 AM. Reason: more details added
Reply With Quote
  #450  
Old 06-16-2019, 01:14 PM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 203
Quote:
Originally Posted by crl View Post
Thanks to the community for the great work on the x64 for Windows build! After many years since the last clean install of Sage (2009) I performed a fresh install of x64. Process was similar to earlier replies but in short I installed Java 8 runtime, did the install, copied most files & folders from old install into the new program directory (NOT overwriting existing files) and omitted the cached fanart folder that had grown to a few gigs. My properties file didn't need to be edited as my previous install was so old it was running on an x86 OS too. In SageTV removed all plugins, restarted, then reinstalled plugins. Got stuck on jetty/web interface but all I had to do was generate a Java cert.

Everything is running well with ONE exception:

I've been using the XBMC/Kodi addon from Android TV boxes to access SageTV content. The installation of this includes adding an xbmc.js file to the sagex\services folder. When I try to access this interface it fails. Specifically, when accessing the sagex API at this endpoint:
http://sageserver:8080/sagex/api?c=x...0&encoder=json

I get:
java.lang.RuntimeException: javax.script.ScriptException: TypeError: java.util.HashMap is not a function in <eval> at line number 19
(Full Error in Pastebin)

I realize this is an old plugin but I'm betting this could be something easy to fix. It looks like a class simply isn't imported, but since this was working with the same sagex-utils version (9.1.7.0) on the old x86 system (SageTV 9.1.5) I'm not sure what broke. Any ideas?

Edit: I fired up the old Sage box, confirmed it's using Java 7 and the API call works. Installed Java 8u212, confirmed Sage is using it, and now I get the same error. This issue appears to be specific to JRE, not x86/x64. I probably should've tagged @stuckless as he'd likely know what's going on.
You beat me to it. Known issue re Java 7 vs 8. I use that plugin quite rarely, but stay on Java 7 on my SageTV server just to keep it functional. There are a few old threads floating around where we discussed how to keep it functional for another issue (I forget what exactly, I think it was another Java issue).
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450

Last edited by waylo; 06-16-2019 at 01:37 PM.
Reply With Quote
  #451  
Old Yesterday, 04:29 PM
crl crl is online now
Sage User
 
Join Date: Dec 2005
Location: Burlington, ON
Posts: 17
Quote:
Originally Posted by waylo View Post
You beat me to it. Known issue re Java 7 vs 8. I use that plugin quite rarely, but stay on Java 7 on my SageTV server just to keep it functional. There are a few old threads floating around where we discussed how to keep it functional for another issue (I forget what exactly, I think it was another Java issue).
Thanks for the reply! I attempted to install java 7 and that unleashed a world of hurt. SageTV would fail to start, saying no JVM found. There are other threads with similar issues and I tried everything. After numerous failed attempts to fix I restored a drive image taken a couple days earlier. No Kodi plugin for me, but I'll take the Android client for a spin.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Open Source Windows Installer jusjoken SageTV Github Development 460 08-21-2017 03:47 AM
Windows installer and running as a service Opus4 SageTV Github Development 13 01-01-2016 07:33 AM
Any news on the Windows installer? Damstas SageTV Github Development 2 09-03-2015 10:09 AM
Web Interface - where is the Windows installer ckewinjones SageTV Customizations 2 01-09-2011 10:36 AM


All times are GMT -6. The time now is 11:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.