SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Diamond

Notices

Diamond This forums is for discussing the user-created Diamond plugin for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-04-2012, 01:58 PM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
Need some help troubleshooting my diamond fanart

My fanart was running great last week - before I rebuild my OS and Sage installation. Everything else seems to be back in working order, but I am only getting partial fanart (on my DVD/imported movies).

For example, I am only getting a few posters:

despite having multiple posters and backgrounds for each of these movies:


BMT data also seems complete:



I had, at one point, a number of folder.jpg's that I have since deleted. Everything should now be in the central fanart folder.

Any thoughts about how to troubleshoot it? I'm happy to uninstall some plugins and start in a specific order, if that's needed/helpful.

Thanks for any help.

Matt
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
  #2  
Old 03-04-2012, 03:45 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
First thing to try would be to delete the cache. (should be somewhere in sagetv/userdata). Then rebuild it by using the scale fanart option.

The other possibility is that your fanart location is set incorrectly on that particular client, so it is unable to access the images. Check for the fanart folder location in both your sage.properties file, and each .properties file in the sagetv/clients folder to make sure they are all pointing to the right place.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #3  
Old 03-04-2012, 03:52 PM
jorton jorton is offline
Sage Icon
 
Join Date: Jul 2005
Location: Canada
Posts: 1,273
In the Sideways Flow, try pushing delete when one of the "blank" fanart images is highlighted and then select "Delete Diamond Cached Fanart for Show" to recache the fanart for the single item.

I have those blanks occasionally and this usually works to "recache" them.

If you have lots of them, go to Setup/Detailed Setup and under the Diamond section select to "Delete All Cached Fanart" and then recache when prompted.

Hope this clears it up for you.

PS - The Diamond cache is under "SageTV\cache\DiamondImages". Diamond fetches the fanart from the main Phoenix Fanart folder and then caches locally in the folder mentioned.

J

Last edited by jorton; 03-04-2012 at 03:56 PM.
Reply With Quote
  #4  
Old 03-04-2012, 05:27 PM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
Quote:
Originally Posted by jorton View Post
In the Sideways Flow, try pushing delete when one of the "blank" fanart images is highlighted and then select "Delete Diamond Cached Fanart for Show" to recache the fanart for the single item.
this works perfectly.

Quote:
If you have lots of them, go to Setup/Detailed Setup and under the Diamond section select to "Delete All Cached Fanart" and then recache when prompted.
I tried this (three times, actually) and it didn't seem to do anything to populate the blank images. It rebuilt the images - i could watch them pop up in windows explorer, and they seem to be fine. But they never "transferred" over to any of the Diamond views.

Quote:
PS - The Diamond cache is under "SageTV\cache\DiamondImages". Diamond fetches the fanart from the main Phoenix Fanart folder and then caches locally in the folder mentioned.
i tired blasting this directory too, but it didn't seem to help.

Is there a specific order that things should be done? There seem to be a few fanart cache options in various places, and I'm not really sure which is which.

Is there a best practices to get the fanart right? I can go through and hit delete for each of my ~ 300 movies. Not a huge deal, but it seems that there is just some setting/switch that might do it automagically for me.

Thanks again
Matt
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
  #5  
Old 03-04-2012, 11:10 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
do you see this problem on all clients/extenders? or just certain ones?
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #6  
Old 03-05-2012, 04:40 AM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
All extenders. When I fix the art for one movie from one extender, its fixed on the other extenders as well.
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Diamond/MyMovies Fanart giacinto41 Diamond 21 08-22-2011 08:38 AM
BMT shows fanart, but nothing in Diamond? aweber1nj Diamond 5 06-13-2011 12:28 AM
Phoenix Fanart with SMM + Diamond 3.1 nateziemann Sage My Movies 5 04-06-2011 08:30 PM
Diamond Fanart dstanley Diamond 7 03-20-2011 06:35 PM
BMT/Diamond FanArt ? HuMan321 Diamond 2 03-12-2011 05:39 PM


All times are GMT -6. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.