SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-06-2008, 01:09 PM
bwalton bwalton is offline
New Member
 
Join Date: Nov 2008
Location: San Jose CA
Posts: 3
Can't setup an IR Blaster

I am considering a switch from Beyond TV to Sage + extender. I am using a trial version and have hit a snag on install.

My setup: Dell Studio Hybrid core2duo 2.16Ghz, 3g RAM, Vista Home Premium, Hauppauge HD PVR, comcast stb (non pvr), USBUIRT

From reading the manual and browsing the forum it seems I should be able to configure the USBUIRT as an IR blaster during the setup wizard once I get to the screen "Please select a tuning option for..." If I select the option to use an external cable or satellite receiver I am only given an option for DirecTV Serial Control.

I have tried several clean installs... I have also tried installing LMRemoteKeyMap (found in these forums) and I've followed the instructions to configure and install the plugin (placing the files into the common directory under sage). I have the same exact behavior... I can get my remote working with USBUIRT but never see an option to use in Sage to use anything except the DirecTv Serial Control.

What am I doing wrong? Any suggestions?

I was excited to discover the extender option and from what I've seen so far I'm sure It make the switch if I can figure this out...
Reply With Quote
  #2  
Old 11-06-2008, 06:38 PM
StephaneM's Avatar
StephaneM StephaneM is offline
Sage Icon
 
Join Date: Mar 2006
Location: France
Posts: 1,463
Quote:
Originally Posted by bwalton View Post
I have also tried installing LMRemoteKeyMap (found in these forums) and I've followed the instructions to configure and install the plugin (placing the files into the common directory under sage)
For the native support of the USBUIRT in SageTV, you have to make sure if you use SageTV service, that both the SageTV service and the SageTV UI are using the same security context (in XP it's easy service and UI must run with the same user account, on Vista this may not work however)

For LM RKM, the security context issue is removed as both the receiver role and blaster role are managed via the same process. To make sure it works in SageTV ensure that :

* you are indeed able to use the USBUIRT with LM RKM as a remote receiver and as a blaster. To make sure of this, create an IR device and learn the IR codes from your original set top box (also to be on the safe side don't include special characters in the device name)

* copy the dll and ir files as requested in the SageTV\Common directory (you have to copy the files with their folders)

* be sure to restart SageTV (UI and service) after copying thoses files and the LM Remote KeyMap tuner plugin will be available as an option when you create your video source.

Regards,
Stéphane.
Reply With Quote
  #3  
Old 11-06-2008, 09:36 PM
bwalton bwalton is offline
New Member
 
Join Date: Nov 2008
Location: San Jose CA
Posts: 3
still not working...

Thanks Stéphane,

I have confirmed that I can use USBUIRT as both a receiver and a blaster in LM RKM. I did re-learn the codes for my stb again to be sure this is all working. I then copied the dll and remote codes directory into the common folder.

After restarting Sage (both client and service) I still get the same behavior... Only the Directv Serial Control is available. I guess this means the underlying issue is not the security context?

Not sure if this helps - I tried to install an STVI plugin (trying the Slimplayer SageMC plugin) and also unable to get anywhere. I follow the instructions and install files in the correct place but cannot see them in the UI to install them.

Regards,
-Brian
Reply With Quote
  #4  
Old 11-07-2008, 01:10 AM
bwalton bwalton is offline
New Member
 
Join Date: Nov 2008
Location: San Jose CA
Posts: 3
fixed

FYI - Fixed with the 'sledgehammer' method. This is a fairly new PC so I restored windows from the original image and it has fixed the problem.

Thanks,
-Brian
Reply With Quote
  #5  
Old 11-07-2008, 10:39 AM
StephaneM's Avatar
StephaneM StephaneM is offline
Sage Icon
 
Join Date: Mar 2006
Location: France
Posts: 1,463
Quote:
Originally Posted by bwalton View Post
FYI - Fixed with the 'sledgehammer' method. This is a fairly new PC so I restored windows from the original image and it has fixed the problem.
The issue was probably related to Vista virtualization feature : the "Program Files" directory doesn't allow users to write files here. But as many programs do write file in there (such as SageTV), Vista will allow write by "virtualizing" the folder into a user folder (the VirtualStore folder) leaving the program files unmodified (then depending on which user launch the application => files will be loaded either from the VirtualStore either from the ProgramFiles directory...)

My advice would be to not disable UAC, but modifying permissions on the C:\Program Files\SageTV folder allowing full control for the Users group.

Regards,
Stéphane.
Reply With Quote
Reply

Tags
usbuirt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A valid setup for HP HomeServer? stefam Hardware Support 8 10-18-2008 12:23 AM
Hauppage HD PVR BSOD on IR Blaster Config bastian74 Hardware Support 1 10-15-2008 01:28 PM
Using 1 IR Blaster on a 3 tuner System reggie14 Hardware Support 5 09-15-2008 12:31 PM
PVR-150 IR Blaster mbowling Hardware Support 0 09-13-2008 10:45 AM
PVR-150 MCE IR Blaster Problem inf1niti Hardware Support 8 01-25-2007 10:03 PM


All times are GMT -6. The time now is 05:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.