SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #881  
Old 04-26-2016, 06:34 PM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 205
Quote:
Originally Posted by EnterNoEscape View Post
The MPEG-TS muxrate setting appears to be very fickle in the pre-compiled JavaCPP binary. I can set it up to 9K. If I go beyond 9K to lets say 10K, suddenly FFmpeg interprets it as 997M which will create absurdly huge files because of all the null packets. I can't really tell if it's a bug in JNI, JavaCPP or the version of FFmpeg it's currently based on. I'll be compiling the most recent binaries eventually, but for now this will continue to be an issue. Since I personally am most interested in SageTV clients and miniclients, I'll be putting an option in for the transcoding consumer so you can optionally enable the old timebase approach for compatibility. Does this sound good to everyone?
Sounds good to me! Didn't mean to create waves in something that overwhelmingly works fine within Sage itself. But given the meticulous nature of this fanbase, I figured it probably would have come up to someone eventually
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450
Reply With Quote
  #882  
Old 04-26-2016, 07:06 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by waylo View Post
Sounds good to me! Didn't mean to create waves in something that overwhelmingly works fine within Sage itself. But given the meticulous nature of this fanbase, I figured it probably would have come up to someone eventually
I added all of the code to count up the bitrates and come up with a good value for CBR so the containers only as big as they need to be, then I ran into this annoying bug. The craziest thing is that if I pull the value back out, it's the same value I put in, but the files it creates are insanely huge and MediaInfo reports the CBR value is nearly 1G.

Another option would be to just change over to program streams (MPEG-PS) since they don't appear to have any of these issues.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #883  
Old 04-26-2016, 08:05 PM
HelenWeathers's Avatar
HelenWeathers HelenWeathers is offline
Sage Icon
 
Join Date: Aug 2008
Location: Miami, Florida
Posts: 1,321
Quote:
Originally Posted by EnterNoEscape View Post
I added all of the code to count up the bitrates and come up with a good value for CBR so the containers only as big as they need to be, then I ran into this annoying bug........

Another option would be to just change over to program streams (MPEG-PS) since they don't appear to have any of these issues.
Sometimes I share a recording with someone who doesn't have SageTV and would prefer that it play in other players too. I've had no experience with PS files to know their upside/downside.

I'm OK with things as they are now, but hope you'll get a chance to look at this again at a later date when you have less on your plate.

You've done some incredible work on this encoder. Thank you!!
__________________
Server: SageTV 9, Win10/32, Intel DP55KG Mb, Intel QC i5 2.66GHz , 4GB 1333MHz DDR3 SDRAM, 2 Hauppauge 2255s for 4 OTA ATSC tuners, HDHRPrime w Comcast, 3 STP-HD300s 20101007-0 firmware, nVidia Shield. Java v7u55. Plugins:SD EPG, OpenDCT

Last edited by HelenWeathers; 04-26-2016 at 08:12 PM.
Reply With Quote
  #884  
Old 04-27-2016, 07:16 AM
gprichardson1 gprichardson1 is offline
Sage User
 
Join Date: Nov 2004
Location: Massachusetts, USA
Posts: 58
Over the last few days the video pauses and pixelation returned to my recordings so I decided to finally update to 0.4.48 (I had been running 0.3.17). Last night's recordings look to be much better. I thought I'd take a look at the OpenDCT log and saw these errors right at the top, which is when I first started up the service after going to 0.4.48.

Code:
19:57:51.189 [cling-38:HDHomeRun Prime Tuner 1315E054-0] ERROR Config - The property 'sagetv.device.1617308578.consumer' with the value 'opendct.consumer.FFmpegSageTVConsumerImpl' does not refer to a valid SageTVConsumer implementation. Using default implementation 'opendct.consumer.FFmpegSageTVConsumerImpl' => java.lang.ClassNotFoundException: opendct.consumer.FFmpegSageTVConsumerImpl
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at opendct.config.Config.getSageTVConsumer(Config.java:1010)
	at opendct.capture.BasicCaptureDevice.getNewSageTVConsumer(BasicCaptureDevice.java:694)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:154)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:89)
	at opendct.capture.RTPCaptureDevice.<init>(RTPCaptureDevice.java:60)
	at opendct.capture.DCTCaptureDeviceImpl.<init>(DCTCaptureDeviceImpl.java:129)
	at opendct.tuning.upnp.listener.RegisterDevice.addRemoteDevice(RegisterDevice.java:72)
	at opendct.tuning.upnp.listener.DCTRegistryListener.remoteDeviceAdded(DCTRegistryListener.java:52)
	at org.fourthline.cling.registry.RemoteItems$1.run(RemoteItems.java:111)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

19:57:51.230 [cling-38:HDHomeRun Prime Tuner 1315E054-0] ERROR Config - The default property 'sagetv.device.1617308578.consumer' with the value 'opendct.consumer.FFmpegSageTVConsumerImpl' does not refer to a valid SageTVConsumer implementation. Returning built in default 'NIOSageTVRawConsumerImpl' => java.lang.ClassNotFoundException: opendct.consumer.FFmpegSageTVConsumerImpl
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at opendct.config.Config.getSageTVConsumer(Config.java:1014)
	at opendct.capture.BasicCaptureDevice.getNewSageTVConsumer(BasicCaptureDevice.java:694)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:154)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:89)
	at opendct.capture.RTPCaptureDevice.<init>(RTPCaptureDevice.java:60)
	at opendct.capture.DCTCaptureDeviceImpl.<init>(DCTCaptureDeviceImpl.java:129)
	at opendct.tuning.upnp.listener.RegisterDevice.addRemoteDevice(RegisterDevice.java:72)
	at opendct.tuning.upnp.listener.DCTRegistryListener.remoteDeviceAdded(DCTRegistryListener.java:52)
	at org.fourthline.cling.registry.RemoteItems$1.run(RemoteItems.java:111)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Do I need to be concerned about these? Is this something as simple as I just have something wrong/missing from my properties file? I looked in the properties file but didn't find the property "sagetv.device.1617308578.consumer" that the errors mention. The only things I found that seem close are:

Code:
sagetv.device.parent.1283155467.consumer=opendct.consumer.FFmpegSageTVConsumerImpl

and

sagetv.new.default_consumer_impl=opendct.consumer.FFmpegSageTVConsumerImpl
I've attached last night's log and my properties file for full reference. Thanks for any help!

BTW, OpenDCT has brought new life to my SageTV setup. Thanks so much for all your hard work and effort!
Attached Files
File Type: txt opendct.2016-04-26-2.log.txt (128.2 KB, 29 views)
File Type: txt opendct.properties.txt (5.1 KB, 35 views)

Last edited by gprichardson1; 04-27-2016 at 07:19 AM.
Reply With Quote
  #885  
Old 04-27-2016, 08:36 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by gprichardson1 View Post
Over the last few days the video pauses and pixelation returned to my recordings so I decided to finally update to 0.4.48 (I had been running 0.3.17). Last night's recordings look to be much better. I thought I'd take a look at the OpenDCT log and saw these errors right at the top, which is when I first started up the service after going to 0.4.48.

Code:
19:57:51.189 [cling-38:HDHomeRun Prime Tuner 1315E054-0] ERROR Config - The property 'sagetv.device.1617308578.consumer' with the value 'opendct.consumer.FFmpegSageTVConsumerImpl' does not refer to a valid SageTVConsumer implementation. Using default implementation 'opendct.consumer.FFmpegSageTVConsumerImpl' => java.lang.ClassNotFoundException: opendct.consumer.FFmpegSageTVConsumerImpl
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at opendct.config.Config.getSageTVConsumer(Config.java:1010)
	at opendct.capture.BasicCaptureDevice.getNewSageTVConsumer(BasicCaptureDevice.java:694)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:154)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:89)
	at opendct.capture.RTPCaptureDevice.<init>(RTPCaptureDevice.java:60)
	at opendct.capture.DCTCaptureDeviceImpl.<init>(DCTCaptureDeviceImpl.java:129)
	at opendct.tuning.upnp.listener.RegisterDevice.addRemoteDevice(RegisterDevice.java:72)
	at opendct.tuning.upnp.listener.DCTRegistryListener.remoteDeviceAdded(DCTRegistryListener.java:52)
	at org.fourthline.cling.registry.RemoteItems$1.run(RemoteItems.java:111)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

19:57:51.230 [cling-38:HDHomeRun Prime Tuner 1315E054-0] ERROR Config - The default property 'sagetv.device.1617308578.consumer' with the value 'opendct.consumer.FFmpegSageTVConsumerImpl' does not refer to a valid SageTVConsumer implementation. Returning built in default 'NIOSageTVRawConsumerImpl' => java.lang.ClassNotFoundException: opendct.consumer.FFmpegSageTVConsumerImpl
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at opendct.config.Config.getSageTVConsumer(Config.java:1014)
	at opendct.capture.BasicCaptureDevice.getNewSageTVConsumer(BasicCaptureDevice.java:694)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:154)
	at opendct.capture.BasicCaptureDevice.<init>(BasicCaptureDevice.java:89)
	at opendct.capture.RTPCaptureDevice.<init>(RTPCaptureDevice.java:60)
	at opendct.capture.DCTCaptureDeviceImpl.<init>(DCTCaptureDeviceImpl.java:129)
	at opendct.tuning.upnp.listener.RegisterDevice.addRemoteDevice(RegisterDevice.java:72)
	at opendct.tuning.upnp.listener.DCTRegistryListener.remoteDeviceAdded(DCTRegistryListener.java:52)
	at org.fourthline.cling.registry.RemoteItems$1.run(RemoteItems.java:111)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Do I need to be concerned about these? Is this something as simple as I just have something wrong/missing from my properties file? I looked in the properties file but didn't find the property "sagetv.device.1617308578.consumer" that the errors mention. The only things I found that seem close are:

Code:
sagetv.device.parent.1283155467.consumer=opendct.consumer.FFmpegSageTVConsumerImpl

and

sagetv.new.default_consumer_impl=opendct.consumer.FFmpegSageTVConsumerImpl
I've attached last night's log and my properties file for full reference. Thanks for any help!

BTW, OpenDCT has brought new life to my SageTV setup. Thanks so much for all your hard work and effort!
That's actually an intentional error. I renamed the old FFmpeg consumer to force everyone onto the newer one unless they explicitly change it back to the old one by using it's new name. NIOSageTVRawConsumerImpl is a static string that I forgot to update, it's actually loading FFmpegTransSageTVConsumerImpl. If you don't want to see this error when starting recordings, you will need to change opendct.consumer.FFmpegSageTVConsumerImpl to opendct.consumer.FFmpegTransSageTVConsumerImpl in opendct.properties. Be sure to stop the service before making changes.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #886  
Old 04-27-2016, 11:39 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by EnterNoEscape View Post
I added all of the code to count up the bitrates and come up with a good value for CBR so the containers only as big as they need to be, then I ran into this annoying bug. The craziest thing is that if I pull the value back out, it's the same value I put in, but the files it creates are insanely huge and MediaInfo reports the CBR value is nearly 1G.

Another option would be to just change over to program streams (MPEG-PS) since they don't appear to have any of these issues.
I figured out what was happening. Technically FFmpeg was working correctly. The problem is that the dts offset is rarely anywhere near 0 when you cut randomly into a stream and FFmpeg was actually writing out null packets to make up the entire difference which to me is a bug, but I'm not an AV expert, so maybe that's a normal thing. Anyhow, the fix was to calculate the offset and set the offset for the stream to match the difference between the first dts packet to be written and 0 with a little slack. After making this change, the insane file sizes stopped happening, so lots of progress in a very short time has been made. Since this mode is really only needed for some users who are having issues playing these files in places other than SageTV and because CBR generates sometimes significantly larger files than what is actually needed, turning on CBR TS containers will be an option that's disabled by default.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #887  
Old 04-27-2016, 04:29 PM
waylo waylo is offline
Sage Advanced User
 
Join Date: Feb 2006
Posts: 205
Can you comment on how your recordings worked fine in VLC when you checked, but you were so aptly able to deduce the issue?

Do they behave differently in VLC vs. Window Media Player?
__________________

Server: SageTV 9.2.1x86 on Windows 7 x64 Home Premium, Core 2 Quad Q6600, 4gb RAM, OpenDCT, Java 1.7u80
Display: EVGA 1030 GT to Sony LED TV via DVI-HDMI
Capture Devices: HDHR Prime for Comcast, HDHR Dual for OTA
Clients: Nvidia Shield Android miniclient, 2 PCs
Retired: ATI HDTV Wonder for OTA HD, VBox DTA-150 for OTA HD, Conexant 2388x (Blackbird) analog capture to Comcast DTA cable box with USBUirt, ATI Remote Wonder Plus, Fanless Radeon HD 6450
Reply With Quote
  #888  
Old 04-27-2016, 05:00 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by waylo View Post
Can you comment on how your recordings worked fine in VLC when you checked, but you were so aptly able to deduce the issue?

Do they behave differently in VLC vs. Window Media Player?
All of my recordings worked fine in VLC, but many channels do not work well at all in WMC when FFmpeg muxes to MPEG-TS in VBR mode. I'm so used to WMC being fickle that I don't usually even think about using it for anything.

I was able to get VLC to have issues, but only when I tried to open a file that was still recording. If I waited for the recording to end or made a copy of the file as it was being recorded and opened the copy it played back without issue. My only advice on this would be to make sure you're running a relatively recent copy.

MPC-HC which is my preferred player doesn't have any issues with any of the files in any format which is why I didn't notice that anything had changed.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #889  
Old 04-28-2016, 05:22 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,258
Been running OpenDCT version 0.4.30 (per the properties file) saving as mpeg-ps. I record the morning news at 4:30am, and still, about 3 out of 5 of those come in with the black screen and audio only. Comskip actually processes the file and cuts the commercials, so I'm not sure why the HD300 can't render the video. This is the Sage Server that's using the Infinitv4, firmware already upgraded.

What would be the best path here to eliminate the black screen video?
Reply With Quote
  #890  
Old 04-28-2016, 05:37 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by KryptoNyte View Post
Been running OpenDCT version 0.4.30 (per the properties file) saving as mpeg-ps. I record the morning news at 4:30am, and still, about 3 out of 5 of those come in with the black screen and audio only. Comskip actually processes the file and cuts the commercials, so I'm not sure why the HD300 can't render the video. This is the Sage Server that's using the Infinitv4, firmware already upgraded.

What would be the best path here to eliminate the black screen video?
I made a lot of changes to optimize the stream for your exact situation in 0.5.2. I made these changes after I was channel browsing using PS for a while and noticed that every so often even with a 30 second delay I sometimes didn't get any picture. I found that if I force the first video key frame to the front of the stream, I stopped seeing these issues. So my suggestion is what you probably figured I was going to say; upgrade to the latest beta.

Edit: My best determination is that it has to do with how SageTV detects the streams in the .mpg file and not much to do with it not being able to play it. If the video doesn't show up fast enough in the stream timeline, it seems to assume it isn't there. I say this because if you rename the file and have SageTV re-detect it I have yet to have it not see the video stream the second time around.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG

Last edited by EnterNoEscape; 04-28-2016 at 05:53 PM.
Reply With Quote
  #891  
Old 04-28-2016, 05:53 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,258
Will do. Thank you!!
Reply With Quote
  #892  
Old 04-28-2016, 07:11 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by KryptoNyte View Post
Will do. Thank you!!
No problem. I realized I meant to say 0.5.1, but same difference. You might as well be on the latest if you're upgrading.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #893  
Old 04-29-2016, 06:09 AM
Greg2dot0's Avatar
Greg2dot0 Greg2dot0 is offline
Sage Advanced User
 
Join Date: Dec 2008
Posts: 82
Just wanted to give you an update since you resolved my big issues back in 4.38 or something like that. I loaded 5.2 yesterday morning and ran through a bunch of recordings and it seems to be rock solid.

While I can do many many test recordings and look for errors in the log, there's nothing like watching one of the recordings to say that I didn't seem to be experiencing any drops, tears or other erratic behavior.

Many thanks again for all the great work you've done and continue to do!

You really inspired me to go back and re-think my overall DVR approach and gave me the motivation to migrate off of my windows desktop to a 64-bit linux server.
__________________
Production SageTV Server: ASUS P8P67-Pro, 16gb RAM, Crucial m4 256GB SSD, Unbunto 16.4.04 LTS (Server x64), WDC Red 4TB
Capture: 1x HDHR Prime, 1x HDHomeRun (ClearQAM)
Clients: 1x HD300, 2x HD200, 2x Placeshifters
Reply With Quote
  #894  
Old 04-29-2016, 12:32 PM
KarylFStein KarylFStein is offline
Sage Fanatic
 
Join Date: Apr 2006
Location: Westland, Michigan, USA
Posts: 999
Music Channel Raw Capture and Placeshifter

I updated to the latest BETA and set my music channels for raw capture. This tunes them just like any other channel now, (no more long waits and "no signal" messages). This works great on my SHIELD (although first time it caused a FC, but I haven't been able to reproduce), my Android tablet and my HD300. Placeshifter on PC, (I tried three), however, stutters horribly on the music channels. It'll tune in the same amount of time (~10sec), but it'll play a second or two, pause about the same, play, pause, etc.
__________________
Home Network: https://karylstein.com/technology.html
Reply With Quote
  #895  
Old 04-29-2016, 02:39 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by KarylFStein View Post
I updated to the latest BETA and set my music channels for raw capture. This tunes them just like any other channel now, (no more long waits and "no signal" messages). This works great on my SHIELD (although first time it caused a FC, but I haven't been able to reproduce), my Android tablet and my HD300. Placeshifter on PC, (I tried three), however, stutters horribly on the music channels. It'll tune in the same amount of time (~10sec), but it'll play a second or two, pause about the same, play, pause, etc.
A lot of players can't work with the Music Choice content. I'm not surprised at all that the placeshifter isn't working with it in raw. I was running an old version of mplayer (the current placeshifter is in that boat) because it's what came with some software I was playing with and it could not figure out how to play it without messing up the video timing horribly. I have yet to figure out how ffmpeg.exe is able to figure out that the spacing between the video packets is normal.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #896  
Old 04-29-2016, 05:57 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,258
If I wanted to just grab the raw stream from Time Warner (local channels only of course) with the Infinitv4 w/cablecard, would I modify a value in the opendct.properties file, or add a new value of some sort?

If the raw stream comes in without complaint, is there an advantage/disadvantage to doing this?
Reply With Quote
  #897  
Old 04-29-2016, 07:48 PM
KarylFStein KarylFStein is offline
Sage Fanatic
 
Join Date: Apr 2006
Location: Westland, Michigan, USA
Posts: 999
Quote:
Originally Posted by KryptoNyte View Post
If I wanted to just grab the raw stream from Time Warner (local channels only of course) with the Infinitv4 w/cablecard, would I modify a value in the opendct.properties file, or add a new value of some sort?

If the raw stream comes in without complaint, is there an advantage/disadvantage to doing this?
The end of this thread has the instructions for forcing raw capture on select channels:

http://forums.sagetv.com/forums/showthread.php?t=63159

I don't know about advantages/disadvantages.
__________________
Home Network: https://karylstein.com/technology.html
Reply With Quote
  #898  
Old 04-30-2016, 06:23 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,535
Quote:
Originally Posted by KryptoNyte View Post
If I wanted to just grab the raw stream from Time Warner (local channels only of course) with the Infinitv4 w/cablecard, would I modify a value in the opendct.properties file, or add a new value of some sort?

If the raw stream comes in without complaint, is there an advantage/disadvantage to doing this?
Per the link provided by KarylFStein, setting yourself up with the dynamic consumer is actually probably the easier way to do things because then in the future you only need to change one value to change the consumer that will be used. It's also the default in 0.5+.

The biggest disadvantage is that sometimes you may get a recording that's unplayable in SageTV. Running that unplayable recording through VideoRedo always fixed it for me, but it's an extra step and if it's live then you need to wait for it finish just to watch it. For me the unplayable recording would happen something like once a month, but it didn't make it any less annoying.

Also in your case, .mpg files would actually be TS instead of PS, which as you've proven isn't necessarily an issue.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #899  
Old 04-30-2016, 07:51 AM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,258
I originally had SageDCT setup as RAW (on the Time Warner CC system only), and the channels that the Infinitv4 tunes are only the channels that I used to grab with the clear qam HDhomerun tuners. Fortunately I never experienced those strange blank recordings on this system like I do on the Charter Cable Sage system. Heck, I'm not even sure we're fully digital here yet, but I like the fact that I don't ever have the hassle of remapping channels.

I'm going to head on over to that other thread and see how this goes ...
Reply With Quote
  #900  
Old 04-30-2016, 04:05 PM
nyplayer nyplayer is offline
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,098
What does this do.??
upload_id_enabled=true


Setting it to true improved the response of my Android miniclient... Also improved my livetv channel changes on the miniclient.
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI TV Wonder Digital Cable Tuner & SageTV nyle Hardware Support 4 02-17-2009 10:12 PM
ATI TV Wonder Digital Cable Tuner rajczi Hardware Support 4 01-14-2008 08:24 PM
ATI TV Wonder™ Digital Cable Tuner dadams Hardware Support 4 01-09-2007 10:55 AM
Digital Cable - one guide - need HD on one tuner reg tv on other Kimper SageTV Beta Test Software 14 11-27-2006 08:15 PM
Multi-tuner Digital Cable mlbdude SageTV Software 0 06-26-2003 01:08 PM


All times are GMT -6. The time now is 06:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.