SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-25-2009, 01:49 PM
jklenk jklenk is offline
Sage User
 
Join Date: Sep 2004
Posts: 24
Question Sage does not register Motorola DCT6000 remote codes via USB-UIRT

I cannot get Sage (v6.4.8) to recognize codes from the remote control of my Motorola DCT6000 cable box through my USB-UIRT.

It was working at some point last year with an older version of the cable box. Then at some point, I started having a problem where wong digits were being sent from Sage (or at least wrong digits were being interpreted by the cable box). I think this was before I switched to FIOS and got a newer cable box, but I'm not 100% sure on that.

I have tried holding the remote very close to the USB-UIRT, as well as 5-10 feet away.

I removed the cable box entry from Sage, to get a fresh start. But now when Sage asks me to hold down the zero button on my remote, it just times out and says "There was an error learning the remote control code. Please release the button on the remote control."

I have downloaded the latest firmware for my USB-UIRT (firm.sys dated 3/26/04).

I have made sure that the USB-UIRT works in Girder (including receiving a code for the zero button on my Motorola remote). (I do not normally use the USB-UIRT with Girder; I have an IRMan receiver for that. And I did disable the USB-UIRT plugin in Girder before testing with Sage. And I have rebooted.)

Something very interesting is that while Sage is waiting for me to press the zero button, the USB-UIRT's indicator light never comes on when I am pressing the remote buttons. As soon as Sage times out on waiting for the remote code, the light starts working again.

So it seems to me that there is a serious bug with Sage, since it works with Girder.


Any ideas? I haven't been able to use Sage with my cable box for probably a year now. I only use it for OTA HD channels, and use my cable box for recording other channels. It is actually rare for me to want to use Sage for other channels, considering the awful SVideo quality, but occasionally when I am at one of my other PCs that have PlaceShifter, I would like to be able to watch a cable channel.
Reply With Quote
  #2  
Old 01-25-2009, 11:08 PM
jklenk jklenk is offline
Sage User
 
Join Date: Sep 2004
Posts: 24
Hmm... I'm not sure this should have been moved to "Hardware Support" from "SageTV Software" where I posted it. I think it is a bug in Sage.

I guess as long as someone reading this forum has an idea...
Reply With Quote
  #3  
Old 01-26-2009, 12:15 AM
CollinR CollinR is offline
Sage Icon
 
Join Date: Dec 2004
Location: Tulsa, OK
Posts: 1,305
If this were a bug in SageTV it would be a VERY commonly discussed problem. I mean the DCT6200 is one of the most common cable boxes out there and the USBUIRT is one of the most common IR blasters. This was moved to hardware support because it's related to your USBUIRT/cable box configuration.

Craploads have this setup running, my dad's system has 2 DCT6200s and a USBUIRT and 0 problems.

Make sure all of the cables from the USBUIRT are routed away from HV and other sources of EMI/RFI. Reboot and give it another try.

For the most part only 1 software can control the USBUIRT at a time, whichever connects to it first will have control over it. If thats SageTV thats fine but if it's anything else most likely SageTV will no long be able to comunicate with it.
Reply With Quote
  #4  
Old 01-26-2009, 01:19 AM
jklenk jklenk is offline
Sage User
 
Join Date: Sep 2004
Posts: 24
As I mentioned, I did reboot, and no other programs are using the USB-UIRT. The only program I've ever used the USB-UIRT with is Sage (other than the quick test I did with Girder to make sure that the USB-UIRT was receiving the remote code).

The USB-UIRT cable is actually by itself, other than where it connects to the back of the computer.

And it works in Girder, yet Sage registers *nothing*, and Sage even makes the USB-UIRT indicator light turn off during the learning process.
Reply With Quote
  #5  
Old 01-26-2009, 09:05 AM
btrcp2000 btrcp2000 is offline
Sage Fanatic
 
Join Date: Aug 2007
Posts: 888
I have a dct6200, but sage never worked well with that setting. Try switching to the dct2000 option within sage. That has worked for me for a long time except for the last few weeks, because I think my uirt is dying.

EDIT: upon rereading, it sounds like you have done this already. I think something is up with usbuirts in general. On their forum, there are a number of complaints about the sudden unreliability, but unfortunately it looks like the owner hasn't posted at all since May. I may be swithcing to firewire if I can't get mine working.
__________________
[size=1]Current Server:V9 UNRAID Docker, SuperMicro x9dri-LNF4+, 32 GB ECC, 2x Xeon e5-2660v2, storage array 6TB, 2 Dish r5000HD tuners, 1 HDHomerun Quatro, 1 HDHomerun Extend
4 Nvidia Shield TVs with Miniclient

Last edited by btrcp2000; 01-26-2009 at 09:07 AM.
Reply With Quote
  #6  
Old 01-27-2009, 02:04 AM
jklenk jklenk is offline
Sage User
 
Join Date: Sep 2004
Posts: 24
Thanks... but I actually don't have the DCT2000 option anymore (I removed it at some point in trying to get a fresh start - though at the time I didn't realize it was a stock profile, and probably thought I had made it myself).
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HD200 remote codes queequeg99 SageTV Media Extender 1 01-11-2009 08:02 PM
Faster Channel Change with USB UIRT tedson Hardware Support 2 12-24-2008 08:07 AM
Haupppauge 45 remote and device address codes tvmaster2 Hardware Support 5 09-17-2008 01:53 PM
IR Blaster USB UIRT not waking STB up 2FarGone Hardware Support 4 06-11-2007 08:11 AM
Using a Phillips MCE remote with sage chorscroft Hardware Support 3 04-12-2007 11:38 AM


All times are GMT -6. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.