SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #161  
Old 04-06-2019, 06:16 PM
SteveW's Avatar
SteveW SteveW is offline
Sage Aficionado
 
Join Date: Oct 2008
Location: Fall River, Nova Scotia, Canada
Posts: 337
Quote:
Originally Posted by tmiranda View Post
See of the attached fixes this issue. You will need to stop Sage and replace the existing darksky.jar with the one attached.

Tried it. Looks good here!
__________________
Server: Win 10 Pro 64 Bit, Intel i5, 8 GB, Samsung EVO 850 500 GB for OS, WD Black 4 TB + WD Black 1 TB for Recordings, WD Green 2 TB x 1 and WD Red 6 TB x 2 for DVD/Bluray Rips, Music, Home Movies, etc., Sage 9.1.8.770, HDPVR x 2, BellTV 6131 Receiver x 2, USB-UIRT with 56 KHz Receiver

Clients: PC Client x 2, HD-300 x 4 (1 Using Netgear MoCA Coax Bridges), Placeshifter x 1
Reply With Quote
  #162  
Old 04-13-2019, 09:39 AM
Lov'nSagetv Lov'nSagetv is offline
Sage User
 
Join Date: Aug 2017
Location: Canada
Posts: 7
Quote:
Originally Posted by tmiranda View Post
This upcoming weekend I plan on releasing the first non-beta version of this. (I have fixed all of the bugs that were reported other than those that did not provide any logfiles.)

If you see other issues please let me know.
Hi all...
Background info:

I am still using sagetv 7, because I still use mc2xml plugin, which I believe t.ziu adjusted it to work in Sagetv 9, as per: https://forums.sagetv.com/forums/sho...hlight=zap2xml

however, since I only have 5 OTA channels, and I am on a strict budget these past few years, I'd rather not pay for Schedules Direct.

Is there any hope that someone might...

a) Upgrade mc2xml plugin for Sagetv 9?, or possibly show/pm me how? .. Allowing me to join SageTV 9?

Thanks again to Slugger on creating mc2xml for Sagetv7: https://forums.sagetv.com/forums/sho...ghlight=mc2xml
PS, mc2xml, zap2xml, and www.zap2it.com, have been very stable for the past 1.5 years, without any issues, and I am very happy with it's performance.

OR
b) downgrade this weather plugin, so I can resume with having weather indicated within sagetv? OR pm me how?

PS, I have an IT background (oracle stuff), but have not tinkered in Linux much, nor have I attempted to review/open anything about SageTV.

Thank you in advance.
D.
Reply With Quote
  #163  
Old 04-14-2019, 05:52 PM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Quote:
Originally Posted by Lov'nSagetv View Post
Hi all...
Background info:

I am still using sagetv 7, because I still use mc2xml plugin, which I believe t.ziu adjusted it to work in Sagetv 9, as per: https://forums.sagetv.com/forums/sho...hlight=zap2xml

however, since I only have 5 OTA channels, and I am on a strict budget these past few years, I'd rather not pay for Schedules Direct.

Is there any hope that someone might...

a) Upgrade mc2xml plugin for Sagetv 9?, or possibly show/pm me how? .. Allowing me to join SageTV 9?

Thanks again to Slugger on creating mc2xml for Sagetv7: https://forums.sagetv.com/forums/sho...ghlight=mc2xml
PS, mc2xml, zap2xml, and www.zap2it.com, have been very stable for the past 1.5 years, without any issues, and I am very happy with it's performance.

OR
b) downgrade this weather plugin, so I can resume with having weather indicated within sagetv? OR pm me how?

PS, I have an IT background (oracle stuff), but have not tinkered in Linux much, nor have I attempted to review/open anything about SageTV.

Thank you in advance.
D.
I can't help with getting your guide up and running. As for weather, you can't downgrade and have it work. The service that SageTV relied on was abandoned.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #164  
Old 04-16-2019, 11:51 AM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
Has anyone tried this with a UK source? Can't make it work other than US zipcodes.

Does it work properly with Gemstone? I only see Location input, not name.

Edit: I have the API key installed.
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #165  
Old 04-16-2019, 02:15 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,176
Quote:
Originally Posted by rickgillyon View Post
Has anyone tried this with a UK source? Can't make it work other than US zipcodes.

Does it work properly with Gemstone? I only see Location input, not name.

Edit: I have the API key installed.
Gemstone has Darksky built in now and in theory should work for uk postal codes. In testing i did use Paris France by mistake when i was testing Paris Ontario so i would think UK should work too.

tmiranda's solution uses darksky too but we built these separately. I doubt it would work under gemstone.

k
Reply With Quote
  #166  
Old 04-16-2019, 02:23 PM
rickgillyon's Avatar
rickgillyon rickgillyon is offline
Sage Icon
 
Join Date: Sep 2005
Location: Whitley Bay, England
Posts: 1,944
I've probably bust it by installing the plugin then.
__________________
unRAID Server: Intel Core i5 7600K, 16GB DDR4, 2x512GB PCIe M.2 Cache Pool, 2x4TB SATA3 Parity Drive, 2x3TB + 1x4TB SATA Array, 1x TBS 6284 PCIe DVB-T2 Quad, 2x TBS 6205 PCIe DVB-T Quad, Cable TV from TBS2603 sat/IP, IPTV via Telly & node-ffmpeg-mpegts-proxy, unRAID 6.6.6, TVheadend for recording back end, OpenDCT, SDEPG, SageTV 9
Clients: 3 Nvidia Shields, 2 Android Miniclients (Amlogic S905X), 3 Win10 Pro PC Clients
Reply With Quote
  #167  
Old 04-19-2019, 05:42 PM
LHuisingh LHuisingh is offline
Sage User
 
Join Date: Feb 2011
Location: Kennewick, WA, USA
Posts: 21
I just installed 0.18 and it works fine on my PC/server. I used my zip code and it was able to retrieve weather data. Awesome job!

I then went to my HD300 to set it up. I could enter my zip code but when I pressed the OK button on my remote nothing happened. It behaved as if it wasn't trying to connect anywhere. The UI was back at the Weather screen as if I hadn't tried to enter a locale.

If I am supposed to send a log file, what file is that? Do I need to do anything to enable a log file?
Reply With Quote
  #168  
Old 04-21-2019, 05:27 AM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Quote:
Originally Posted by LHuisingh View Post
I just installed 0.18 and it works fine on my PC/server. I used my zip code and it was able to retrieve weather data. Awesome job!

I then went to my HD300 to set it up. I could enter my zip code but when I pressed the OK button on my remote nothing happened. It behaved as if it wasn't trying to connect anywhere. The UI was back at the Weather screen as if I hadn't tried to enter a locale.

If I am supposed to send a log file, what file is that? Do I need to do anything to enable a log file?
No logfile needed. I thought I fixed that problem Back to the drawing board.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #169  
Old 06-13-2019, 07:03 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
I searched and found this thread after getting tired of my SageTV title bar reporting a temperature of 25F in the summer! Thanks for providing the update!

I followed the instructions and put SageTVPluginsDev.xml in the program folder.
I was able to find the Plugin in Setup / SageTV Plugins and installed it.
There were no settings, but I found the "Change Configuration" on the Online / Weather menu, and entered my ZIP code. I did not enter a city name because that seems to replace the ZIP code.

I tried clicking "Update Data" and nothing happened.
I tried "Hourly Forecast" and the UI blanks out for a moment then displays:
Current Conditions. Daily Forecast. Updating....
The "Updating..." remains for many minutes. I can back out, but I don't see any weather data anywhere. There is nothing in the title bar where there used to be 25 degrees.

What did I miss?

Edit: regarding the duplicate Jackson JAR files. I see these in the JARs folder:
jackson-annotations-2.9.8.jar
jackson-core-2.9.8.jar
jackson-databind-2.9.8.jar
jackson-datatype-jsr310-2.9.8.jar

They are all Jackson, but otherwise different, so I'm assuming that is not an issue.
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.

Last edited by timg11; 06-14-2019 at 10:10 AM.
Reply With Quote
  #170  
Old 06-14-2019, 10:17 AM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
From the Log:

Code:
Fri 6/14 4:48:50.398 [SageTV@144311c] LOADED PLUGINS=[SageTVPlugin[googleweather state=Failed name=Google Weather version=2.0.3 type=Library desc=A weather support library that is used by SageTV's updated weather system to retrieve weather information from Weather Underground. author=Opus4 screenshots=null videos=null modified=7/1/2015 installed=6/13/2019 resPath= webpages=null implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=null packages=null], SageTVPlugin[nwsweather state=Failed name=Weather Using NWS and Darksky version=0.18 type=STVI desc=Weather for SageTV. Uses the National Weather Service and Darksky. author=tmiranda screenshots=null videos=null modified=1/26/2019 installed=6/13/2019 resPath= webpages=null implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=[PluginDependency[darksky-forecast-api minVer=1.3.1 type=Plugin], PluginDependency[sagex-api type=Plugin]] packages=null], SageTVPlugin[gxt state=Failed name=Ext GWT Library version=2.1.1.1 type=Library desc=Ext GWT UI framework for GWT apps - dependency only author=Slugger screenshots=null videos=null modified=8/24/2010 installed=4/8/2011 resPath=plugins/gxt webpages=[http://www.sencha.com/products/gwt/] implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=[PluginDependency[gwt-servlet minVer=2.0.4 type=Plugin], PluginDependency[Java minVer=1.5.0 type=JVM]] packages=null], SageTVPlugin[sagealert-common state=Failed name=SageAlert (common) version=2.0.2.1550 type=Library desc=Common classes required for SageAlert and for other plugins to add passive SageAlert support. (Dependency only, most users should not directly install this plugin.) author=Slugger screenshots=null videos=null modified=6/14/2011 installed=7/1/2017 resPath=plugins/sagealert-common webpages=[http://sagetv-addons.googlecode.com] implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=[PluginDependency[Java minVer=1.5.0 type=JVM]] packages=null], SageTVPlugin[mina-core state=Failed name=Apache Mina Core version=1.1.7 type=Library desc=SageTV Dependency JAR Plugin for Apache Mina Core (mina-core-1.1.7.jar) - no need to download directly author=shadeBlue.com screenshots=null videos=null modified=7/4/2010 installed=2/28/2011 resPath= webpages=null implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=null packages=null], SageTVPlugin[gwt-servlet state=Failed name=GWT Servlet Jar version=2.0.4 type=Library desc=GWT servlet jar - dependency only author=Slugger screenshots=null videos=null modified=8/24/2010 installed=4/8/2011 resPath=plugins/gwt-servlet webpages=[http://code.google.com/webtoolkit/] implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=[PluginDependency[Java minVer=1.5.0 type=JVM]] packages=null], SageTVPlugin[libgrowl state=Failed name=libgrowl version=0.1.1.1 type=Library desc=Java implementation of GNTP - dependency only author=Slugger screenshots=null videos=null modified=5/30/2010 installed=4/8/2011 resPath=plugins/libgrowl webpages=[http://libgrowl.sf.net] implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=null packages=null], SageTVPlugin[jetty state=Enabled name=Jetty Web Server version=2.3.0.17 type=Standard desc=Provides a platform for SageTV web application plugins.


Key section?

SageTVPlugin[nwsweather state=Failed name=Weather Using NWS and Darksky version=0.18 type=STVI desc=Weather for SageTV. Uses the National Weather Service and Darksky. author=tmiranda screenshots=null videos=null modified=1/26/2019 installed=6/13/2019 resPath= webpages=null implementation= desktopOnly=false serverOnly=false OS=Win,Linux,Mac dependencies=[PluginDependency[darksky-forecast-api minVer=1.3.1 type=Plugin], PluginDependency[sagex-api type=Plugin]] packages=null],

Can anyone interpret why it failed?
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.

Last edited by timg11; 06-14-2019 at 03:25 PM.
Reply With Quote
  #171  
Old 06-14-2019, 01:32 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
I saw the dependency on Java 8 in the first post. I update to Java 1.8.0_211

After restarting the computer and SageTV, still no weather data. Same results as above.

This is with SageTV V9.1.10.783 on Windows 7 6.1

Edit: I noticed the sagex-api plugin had an update available, so I updated it. It is now at 9.1.7.0. No change in behavior of Weather - still "Updating..." forever.

This is what I get:


Edit 2: The behavior from the HD-300 is slightly different. When I enter the page from Menu: Online / Weather, it displays a screen titled Weather Report Configuration. Configure your location. Not Configured. I click on Enter Zip Code, and enter my zip code. When I press enter, the screen goes back to "Not Configured". The Zip code I entered is not displayed. Continue is highlighted, but I cannot continue since it reloads the same screen.
From the UI on the SageTV server the Zip code is saved, shows the Zip code when I select "Change Configuration".
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.

Last edited by timg11; 06-14-2019 at 05:59 PM.
Reply With Quote
  #172  
Old 06-15-2019, 07:51 AM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
Still trying to figure out why the plugin doesn't work. Here's the section from sage.properties:

Code:
sagetv_core_plugins/darksky-forecast-api/author=tmiranda
sagetv_core_plugins/darksky-forecast-api/beta=false
sagetv_core_plugins/darksky-forecast-api/date=1548482400000
sagetv_core_plugins/darksky-forecast-api/demovideos=
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-annotations/maxversion=
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-annotations/minversion=2.9.8
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-annotations/type=Plugin
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-core/maxversion=
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-core/minversion=2.9.8
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-core/type=Plugin
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-databind/maxversion=
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-databind/minversion=2.9.8
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-databind/type=Plugin
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-datatype-jsr310/maxversion=
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-datatype-jsr310/minversion=2.9.8
sagetv_core_plugins/darksky-forecast-api/dependency/jackson-datatype-jsr310/type=Plugin
sagetv_core_plugins/darksky-forecast-api/dependency/json/maxversion=
sagetv_core_plugins/darksky-forecast-api/dependency/json/minversion=
sagetv_core_plugins/darksky-forecast-api/dependency/json/type=Plugin
sagetv_core_plugins/darksky-forecast-api/desc=Philipp Plogmann's Darksky Java API repackaged as a SageTV PlugIn.
sagetv_core_plugins/darksky-forecast-api/desktop=false
sagetv_core_plugins/darksky-forecast-api/enabled=true
sagetv_core_plugins/darksky-forecast-api/impl=
sagetv_core_plugins/darksky-forecast-api/installdate=1560473277734
sagetv_core_plugins/darksky-forecast-api/installindex=94
sagetv_core_plugins/darksky-forecast-api/name=Darksky Forecast API
sagetv_core_plugins/darksky-forecast-api/relnotes=
sagetv_core_plugins/darksky-forecast-api/respath=
sagetv_core_plugins/darksky-forecast-api/screenshots=
sagetv_core_plugins/darksky-forecast-api/server=false
sagetv_core_plugins/darksky-forecast-api/stvimports=
sagetv_core_plugins/darksky-forecast-api/type=Library
sagetv_core_plugins/darksky-forecast-api/version=1.3.1
sagetv_core_plugins/darksky-forecast-api/webpages=https\://github.com/200Puls/darksky-forecast-api
Does anything look wrong?
Could somebody who has this working post your properties for this plugin?
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.
Reply With Quote
  #173  
Old 06-15-2019, 07:58 AM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
I thought since I had Java 7 when I first installed, that maybe the plugin had not been properly installed.

I uninstalled the plugin
I restarted SageTV (as requested)
I installed the plugin
I restarted the UI (as requested)

No change - exactly the same behavior as before.
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.

Last edited by timg11; 06-15-2019 at 08:02 AM.
Reply With Quote
  #174  
Old 06-21-2019, 11:59 AM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Sorry for the delay in responding. I'm on vacation and don't have access to much of anything at the moment. I'll look at this as soon as I get home in a few days.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #175  
Old 06-21-2019, 02:08 PM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Quote:
Originally Posted by timg11 View Post
I thought since I had Java 7 when I first installed, that maybe the plugin had not been properly installed.

I uninstalled the plugin
I restarted SageTV (as requested)
I installed the plugin
I restarted the UI (as requested)

No change - exactly the same behavior as before.
The duplicate Jackson jars are an issue, you need to remove the older versions of the duplicate jars.

I'd recommend the following:
- Uninstall the plugin AND all of jackson JARs. (You may have to uninstall other plugins to remove all of the jackson plugins.)
- Reinstall.
- Note that there is an updated darksky.jar in a post dated 4/6. Once you get the plugin working you may want to update that JAR manually.

If the plugin state is "failed" it will not work. You need to fix that issue first, and I think my recommendation above is the best starting place.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #176  
Old 06-24-2019, 03:45 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
Quote:
Originally Posted by tmiranda View Post
The duplicate Jackson jars are an issue, you need to remove the older versions of the duplicate jars.
Thank you for the reply!
So you are saying these jars (annotations, core, databind, and datatype) could conflict?

jackson-annotations-2.9.8.jar
jackson-core-2.9.8.jar
jackson-databind-2.9.8.jar
jackson-datatype-jsr310-2.9.8.jar

If I'm not planning to use DarkSky, do I still need the 4/6 update?

I uninstalled the Weather plugin and re-started SageTV. Then I uninstalled all the Jackson plugins and re-started SageTV. It took several cycles to get all the Jacksons uninstalled.

Then I reinstalled Weather, and restarted the UI as prompted.

The four jackson plugins above are also re-installed with the same version numbers.

Under Main Menu / Online / Weather / Change Configuration, my ZIP code is still remembered.

I get the same results as described above when I click Extended Forecast or Hourly Forecast

PS - is there a way I can get a list of my installed plugins, other than screen-captures?
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.
Reply With Quote
  #177  
Old 06-24-2019, 08:38 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 398
Since this plugin works for others, but not for me, maybe I have an incompatible plugin?

Sorry, I don't know any way to generate a list of installed plugins, other than screen captures:

plugin1Capture.JPG

plugin2Capture.JPG


plugin3Capture.JPG

plugin4Capture.JPG


plugin5Capture.JPG

plugin6Capture.JPG
__________________
HD300 extender with SageTV V9.1.10 (service mode), Running on Windows 7 (32 bit), E8400 3GHz dual core CPU, 4G RAM, Gigabyte GA-P35-DS3L motherboard. NVidia 8600GT; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun tuner, HD-PVR Rev E1. HD-PVR 2 connected to Google Fiber GFHD200.

Last edited by timg11; 06-24-2019 at 08:42 PM.
Reply With Quote
  #178  
Old 06-26-2019, 05:32 AM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Quote:
Originally Posted by timg11 View Post
Thank you for the reply!
So you are saying these jars (annotations, core, databind, and datatype) could conflict?

jackson-annotations-2.9.8.jar
jackson-core-2.9.8.jar
jackson-databind-2.9.8.jar
jackson-datatype-jsr310-2.9.8.jar

If I'm not planning to use DarkSky, do I still need the 4/6 update?

I uninstalled the Weather plugin and re-started SageTV. Then I uninstalled all the Jackson plugins and re-started SageTV. It took several cycles to get all the Jacksons uninstalled.

Then I reinstalled Weather, and restarted the UI as prompted.

The four jackson plugins above are also re-installed with the same version numbers.

Under Main Menu / Online / Weather / Change Configuration, my ZIP code is still remembered.

I get the same results as described above when I click Extended Forecast or Hourly Forecast

PS - is there a way I can get a list of my installed plugins, other than screen-captures?
The reason I asked to uninstall all of the Jackson libs is because there was an error in one of the other plugin manifests (which has been corrected) that caused the wrong jackson libs to be installed. Uninstalling and reinstalling fixes that particular issue.

Are any of the plugins in the "failed" state or are they now all properly installed? Are there any duplicate jackson JARs that differ only by version number? (If there are, this is a problem.)

Please reproduce the error and post your sagetv_0.txt logfile. That will tell me more.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #179  
Old 07-01-2019, 09:26 AM
SteveW's Avatar
SteveW SteveW is offline
Sage Aficionado
 
Join Date: Oct 2008
Location: Fall River, Nova Scotia, Canada
Posts: 337
Weather and Java Heap

I don't know if anyone else has run across this. Sometime after switching to the released 64 bit Sage Server, I've had ongoing problems with running out of Java heap. After 2 or 3 days, it gets to the point I have to restart the server because the systems becomes so slow and unusable I have 3 extenders, but only 1 is used daily. Even with just the one extender my java stats have been hitting 1909/1909/1909 on the server. Restarting the SageTV 64 bit server resolves the problem for about 2 or 3 days, and then I have to restart again due to full java heap, and so on. Usually within a day the java starts maxing out. I run the stock interface with a few plugins like comskip, web server, infopopup, and Phoenix/BMT.

The only difference I could think of was that I had installed the NWS/Darksky plugin for weather. I'm in Canada so I'm using DarkSky. Since I disabled the weather plugin on my server, my java heap issues have stopped. My system has been up for over 8 days and my current java stats are at 759/968/1909.

Any ideas what might be going on here?

Tnx
-Steve
__________________
Server: Win 10 Pro 64 Bit, Intel i5, 8 GB, Samsung EVO 850 500 GB for OS, WD Black 4 TB + WD Black 1 TB for Recordings, WD Green 2 TB x 1 and WD Red 6 TB x 2 for DVD/Bluray Rips, Music, Home Movies, etc., Sage 9.1.8.770, HDPVR x 2, BellTV 6131 Receiver x 2, USB-UIRT with 56 KHz Receiver

Clients: PC Client x 2, HD-300 x 4 (1 Using Netgear MoCA Coax Bridges), Placeshifter x 1

Last edited by SteveW; 07-01-2019 at 09:30 AM.
Reply With Quote
  #180  
Old 07-02-2019, 05:21 AM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,818
Quote:
Originally Posted by SteveW View Post
I don't know if anyone else has run across this. Sometime after switching to the released 64 bit Sage Server, I've had ongoing problems with running out of Java heap. After 2 or 3 days, it gets to the point I have to restart the server because the systems becomes so slow and unusable I have 3 extenders, but only 1 is used daily. Even with just the one extender my java stats have been hitting 1909/1909/1909 on the server. Restarting the SageTV 64 bit server resolves the problem for about 2 or 3 days, and then I have to restart again due to full java heap, and so on. Usually within a day the java starts maxing out. I run the stock interface with a few plugins like comskip, web server, infopopup, and Phoenix/BMT.

The only difference I could think of was that I had installed the NWS/Darksky plugin for weather. I'm in Canada so I'm using DarkSky. Since I disabled the weather plugin on my server, my java heap issues have stopped. My system has been up for over 8 days and my current java stats are at 759/968/1909.

Any ideas what might be going on here?

Tnx
-Steve
I'm using it on a 64 bit linux server without heap issues. I have not tried it on the Windows server.

Does it grow steadily or jump all at once?

I'll go back and look at the code with an eye towards memory leakage.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird weather on Weather Underground sacrament055 Gemstone for v7 13 05-27-2013 10:13 AM
The Weather Channel eliminating free weather data feed iolaus SageTV Software 69 08-26-2012 11:17 AM
Downloaded Google Weather Update, No weather? symgryph SageTV v7 Customizations 3 11-18-2011 08:55 AM
Using Weather Network as a feed for Canadian Weather Fastrack SageTV Customizations 2 03-22-2009 09:47 PM
weather.com weather extractor for mlbdude2 1.8.7 (v1.0.1 / July 6) nielm SageTV Customizations 105 10-08-2004 06:54 AM


All times are GMT -6. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.