SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-08-2021, 06:43 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 456
How to prevent Sage Server from entering sleep with active HD-300 client?

I've rebuilt my server on a Win 10 64 bit machine.
It is not really a server, it is an HTPC form factor, and is able to sleep between recordings. I don't want to set the computer to run 24/7.

With my last computer (Win7 / 32 bit) I had it configured to sleep when truly idle, but it would not enter sleep while the HD300 was active and paused.

Can anyone point me to the setting that controls that? It is not the Windows sleep settings, because I may never physically touch the server computer while watching TV, so if it only counts mouse/keyboard activity, it will sleep incorrectly. I want the Sage Service to prevent sleep while there is an active HD-300 client session,

Thanks!
__________________
HD300 extender with (2020 New Build) SageTV 64 bit V9.2.2 (service mode), Running on Windows 10 (64 bit), Intel Core i7-10700K CPU, 16G RAM, GIGABYTE Z490 UD motherboard. NVidia GTX1650 Super; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun HDHR5-4US tuner, Hauppauge 1512 HD-PVR2 connected to Google Fiber TV GFHD200, tuned with USB-UIRT.
Reply With Quote
  #2  
Old 01-08-2021, 10:26 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,415
Maybe “extender_power_keeps_server_out_of_standby=true”

https://github.com/google/sagetv/blo...ement.java#L42

Reading update note 4 here (https://forums.sagetv.com/forums/showthread.php?t=49177) it seems like it would be too drastic for what you want. Furthermore, that note says when media is streaming it shouldn’t be sleeping anyway.
__________________
Windows Installer

Last edited by wnjj; 01-08-2021 at 10:30 PM.
Reply With Quote
  #3  
Old 01-09-2021, 07:57 AM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,482
It's a strange issue. During the period of time in the past where I had the SageTV server successfully sleep, I never had it attempt to sleep WHILE an HD300 was playing video, or even on menus for that matter. Furthermore, when the server was sleeping, the HD300 would send packets to wake it.
Reply With Quote
  #4  
Old 01-10-2021, 01:51 PM
timg11's Avatar
timg11 timg11 is offline
Sage Aficionado
 
Join Date: Sep 2008
Posts: 456
Quote:
Originally Posted by wnjj View Post
Maybe “extender_power_keeps_server_out_of_standby=true”

https://github.com/google/sagetv/blo...ement.java#L42
I'm not sure how I would apply that setting. In Sage.properties?

The issue is when pausing playback. The server did not sleep while playing video, but if it was paused, the server would sleep after a short time, leaving the HD-300 in a non-functional state requiring power cycle. It won't re-send the wake-on-LAN if the HD-300 receives a remote button command but the server is sleeping.

I found a setting in Setup / Customize / Power Management Settings / Idle Timeout. "Enter how long SageTV can be idle with no user input or video playback before allowing the OS standby settings to take over".

It defaulted to 2 minutes. I changed it to 30 minutes. So far so good.
__________________
HD300 extender with (2020 New Build) SageTV 64 bit V9.2.2 (service mode), Running on Windows 10 (64 bit), Intel Core i7-10700K CPU, 16G RAM, GIGABYTE Z490 UD motherboard. NVidia GTX1650 Super; Viewsonic LCD on one output and Mitsubishi WD57734 HDTV via DVI/HDMI on other output. HDHomeRun HDHR5-4US tuner, Hauppauge 1512 HD-PVR2 connected to Google Fiber TV GFHD200, tuned with USB-UIRT.

Last edited by timg11; 01-10-2021 at 01:54 PM.
Reply With Quote
  #5  
Old 01-10-2021, 04:38 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,415
Yes, in sage.properties. There could be a GUI setting that controls that but I don’t know where.

Looking through the power management code I see detection for videos playing to keep the severe awake, but not for paused. It seems like what you had was considered normal and that setting you found will work.

The one I suggested keeps the server awake continuously if a phone extender ism”connected” which I assume to mean powered up at all. If you power your extenders off when not in use then that setting may serve you well if you find the timeout setting too restrictive.
__________________
Windows Installer
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sage 6 Client: When HTPC wakes from sleep, restore Sage to full screen? sjrx0213 SageTV Software 2 12-21-2010 01:07 PM
Prevent sage server from mounting external disks DylanHall SageTV Linux 7 03-04-2010 05:43 AM
Sage Server, RAID and S3 sleep valnar Hardware Support 3 12-05-2009 11:07 AM
Any way for SageTV gui to prevent sleep? rooobosmith SageTV Software 1 05-21-2009 06:02 PM
Prevent Client users from changing settings on Server? eehtpc SageTV Software 2 11-09-2007 09:43 PM


All times are GMT -6. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.