SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-10-2021, 03:31 PM
CptKirk CptKirk is offline
Sage Advanced User
 
Join Date: Sep 2010
Posts: 234
Strange behavior with video file

I rip all my DVDs to MP4 files using Handbrake. I also create .properties and .jpg files for the video. Been doing that for years with no problems.

But the last one I just did this week is acting strange.

When I start it up the timeline at the bottom shows 0:00:00 to 0:00:00 and the play triangle is all the way to the right side of the timeline showing 0:00 (see attached image).

It will play all the way through ok, but if I touch the FF/RW/Skip buttons it just jumps back to the beginning of the movie.

I've removed the video from my video folder, rescanned media, check SageTV and see it is gone, copied it back to my video folder, rescanned media, it is now back.

But it still keeps doing the same thing.

Is there a way to reset/fix this?

Thanks
Attached Images
File Type: jpg 000.jpg (49.6 KB, 47 views)
__________________
SageTV running on: Win7 SP1 64 Pro
SageTV 9.2.6.976 (32 bit)
Java 1.8.0 311 (32 bit)
OpenDCT 0.5.32 (32 bit) (Comcast Music channels set to FFmpeg)
Clients: HD300 (x2)
HDHR3-CC Prime 20210624 (Comcast CableCard) - 3 Tuners
Hauppauge 1950 STB SD (USB-UIRT Zone 1)
Hauppauge 1950 STB SD (USB-UIRT Zone 2)
Reply With Quote
  #2  
Old 08-10-2021, 03:51 PM
NetworkGuy NetworkGuy is offline
Sage Fanatic
 
Join Date: Dec 2009
Location: Central NJ
Posts: 868
When I had a problem with the video length of a video, I used the web UI to set the correct length. If this is the only video, it is a quick fix.
__________________
Hardware: Intel Core i5-3330 CPU; 8GB (2 x 4GB); 2-4TB WD Blue SATA 6.0Gb/s HDD; Windows 7
Servers: ChannelsDVR, Plex, AnyStream, PlayOn,
Tuner: HDHomeRun Connect Quatro
Tuner: HDHomeRun Connect Duo
Sources: OTA, Sling Blue, Prime, Disney+,
Clients: ShieldTV (2), Fire TV Stick 4K (4)
Reply With Quote
  #3  
Old 08-28-2021, 07:53 PM
CptKirk CptKirk is offline
Sage Advanced User
 
Join Date: Sep 2010
Posts: 234
Media Format Parser Plugin processing problem?

Hoping Josh can see/take a look at this...

Dug into this a bit more today after ripping two more DVDs and seeing the same problem.

I just did one more and immediately afterward grabbed the sage log files.

I noticed that all my rips and imports of .mp4 files before 7/6/21 are good. The four now after that have the 0:00:00 problem.

I update my system on 6/30/21 with:

- SageTV x32 9.1.9 to SageTV x32 9.2.5
- OpenDCT 0.5.29 to OpenDCT 0.5.32

I then updated my system on 7/16/21 with:

- SageTVTranscoder Plugin x64 1.0.5 (2021-04-30)
- Media Format Parser Plugin Windows x32 0.7 (2021-03-30)

I did a rip/import on 7/6/21 that went ok with no problems.

So I'm thinking something is happening during detection.

After I dropped the Equalizer (2014).mp4 file into my DVD directory I went to sagetv and did a Setup-Scan Imported Media. This is what the log file showed happened, with an error in MediaFormatParserPlugin.

Quote:
Sat 8/28 20:17:14.924 [LibraryImporter@1a461f3] Starting to scan lib import root: \\KJCUBED4\Videos\Videos
Sat 8/28 20:17:15.289 [LibraryImporter@1a461f3] testFile=Equalizer (2014).mp4
Sat 8/28 20:17:15.293 [LibraryImporter@1a461f3] Using the format detector plugin
Sat 8/28 20:17:15.293 [LibraryImporter@1a461f3] MediaFormatParserPlugin processing: \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] There was an unhandled exception processing the file: Equalizer (2014).mp4 Error opening file. ffmpeg error code: -22
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] java.lang.RuntimeException: Error opening file. ffmpeg error code: -22
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] at jvl.FFmpeg.jni.AVFormatContext.buildAVFormatInputContext(AVFormatContext.java:40)
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] at jvl.mediaformat.MediaFormatParserPlugin.parseFormat(MediaFormatParserPlugin.java:150)
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] at sage.media.format.FormatParser.getFileFormat(FormatParser.java:200)
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] at sage.Wizard.addMediaFile(Wizard.java:3560)
Sat 8/28 20:17:15.294 [LibraryImporter@1a461f3] at sage.Seeker.importLibraryFiles(Seeker.java:1570)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] at sage.Seeker.importLibraryFiles(Seeker.java:1496)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] at sage.Seeker.importLibraryFiles(Seeker.java:1259)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] at sage.Seeker.access$700(Seeker.java:51)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] at sage.Seeker$1.run(Seeker.java:962)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] at sage.Pooler$PooledThread.run(Pooler.java:254)
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] MediaFormatParserPlugin processing complete: \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4
Sat 8/28 20:17:15.295 [LibraryImporter@1a461f3] Now using external format detector for: \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4
Sat 8/28 20:17:17.133 [ErrorStreamConsumer@13c2c4e] NOTICE: Forcibly terminating spawned process due to runaway memory detection!
Sat 8/28 20:17:17.149 [LibraryImporter@1a461f3] File Format Parsed \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4=Quicktime 0:00:00 0 kbps [{Description=A man who believes he has put his mysterious past behind him cannot stand idly by when he meets a young girl under the control of ultra-violent Russian gangsters., Year=2014, Actor=Denzel Washington, Marton Csokas, Chloe Grace Moretz, Rated=R, Genre=a_DVD, Adventure, Drama, Mystery, Sci-Fi, Thriller, MyMoviesFile=true, Title=Equalizer, Director=Antoine Fuqua, RunningTime=7920000}]
Sat 8/28 20:17:17.153 [LibraryImporter@1a461f3] Added:MediaFile[id=43052967 A[43052971,43052969,"Equalizer",0@0828.19:27,0,V] mask=V host=HTPC encodedBy= format=Quicktime 0:00:00 0 kbps [{Actor=Denzel Washington, Marton Csokas, Chloe Grace Moretz, MyMoviesFile=true, Director=Antoine Fuqua}] \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4, Seg0[Sat 8/28 19:27:15.173-Sat 8/28 19:27:15.174]] num=24234
Sat 8/28 20:17:17.154 [LibraryImporter@1a461f3] New Library File MediaFile[id=43052967 A[43052971,43052969,"Equalizer",0@0828.19:27,0,V] mask=V host=HTPC encodedBy= format=Quicktime 0:00:00 0 kbps [{Actor=Denzel Washington, Marton Csokas, Chloe Grace Moretz, MyMoviesFile=true, Director=Antoine Fuqua}] \\KJCUBED4\Videos\Videos\DVD\Equalizer (2014).mp4, Seg0[Sat 8/28 19:27:15.173-Sat 8/28 19:27:15.174]]
I add two pictures I took inside SageTV.

Good format detection.jpg: You will see at the bottom in the Format section it shows Quicktime and a whole bunch of details.

Bad format detection.jpg: You will see at the bottom in the Format section it just shows Quicktime, and nothing else.

All four that have the 0:00:00 mess up are like the Bad format detection.jpg.
Attached Images
File Type: jpg Good format detection.jpg (79.0 KB, 35 views)
File Type: jpg Bad format detection.jpg (79.8 KB, 35 views)
__________________
SageTV running on: Win7 SP1 64 Pro
SageTV 9.2.6.976 (32 bit)
Java 1.8.0 311 (32 bit)
OpenDCT 0.5.32 (32 bit) (Comcast Music channels set to FFmpeg)
Clients: HD300 (x2)
HDHR3-CC Prime 20210624 (Comcast CableCard) - 3 Tuners
Hauppauge 1950 STB SD (USB-UIRT Zone 1)
Hauppauge 1950 STB SD (USB-UIRT Zone 2)
Reply With Quote
  #4  
Old 09-09-2021, 11:02 PM
xjim1's Avatar
xjim1 xjim1 is offline
Sage Advanced User
 
Join Date: Sep 2010
Location: colorado
Posts: 212
Nice to see someone else has finally seen this.

https://forums.sagetv.com/forums/showthread.php?t=66516

It cleared up for me and haven't seen the symptom until about a week ago. Restarted Sage and it went away. If it comes back I'll post any errors I see.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Mouse Behavior RRRitchey Hardware Support 0 07-05-2013 03:30 PM
Strange behavior pjpjpjpj SageTV Software 3 11-04-2009 04:16 PM
Strange V4 behavior SprDtyF350 SageTV Software 3 11-10-2005 11:25 PM
Strange Behavior jphhughes SageTV Software 5 03-21-2005 10:34 AM
2.1 GUI has strange behavior NickSD SageTV Software 22 11-20-2004 03:17 PM


All times are GMT -6. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.